20:01:31 <redrobot> #startmeeting barbican
20:01:32 <openstack> Meeting started Mon Mar 16 20:01:31 2015 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:37 <openstack> The meeting name has been set to 'barbican'
20:01:53 <redrobot> #topic Roll Call
20:01:56 <tkelsey> o/
20:01:58 <jvrbanac> o/
20:02:00 <jvrbanac> \o
20:02:02 <bknudson> hi
20:02:07 <hockeynut> o/
20:02:13 <rellerreller> o/
20:02:16 <redrobot> ohai OSSG folk!
20:02:27 <tkelsey> hi redrobot :)
20:02:35 <chellygel> ( ꒪Д꒪)ノ
20:03:02 <arunkant> o/
20:03:04 <redrobot> chellygel that is scary
20:03:10 <redrobot> lots of barbicaneers here today!
20:03:26 <redrobot> let's get started!
20:03:31 <elmiko> i'm just hanging for a few ;)
20:03:31 <redrobot> #topic Action Items
20:03:44 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2015/barbican.2015-03-09-20.01.html
20:03:44 <jaosorior> o/
20:04:04 <redrobot> I got an email update from woodster_ who is still on vacation regarding the soft/hard deletes
20:04:36 <redrobot> He met with Jarret, and they agreed that a configuration option for soft vs hard deletes would be best
20:04:56 <redrobot> No guidance on whether soft vs hard deletes would affect things in the compliance space
20:05:05 <dave-mccowan> o/
20:05:34 <redrobot> I like the configurable approach since it lets the operator make a call
20:05:45 <redrobot> #agreed we'll add a configuration option for soft vs hard deletes
20:06:31 <redrobot> also, I've made no progress getting Castellan released, although we did land the first big patch
20:07:21 <redrobot> I'm hoping we'll get to talk about Castellan in at least one of the Security Track sessions in Vancouver, so hopefully that'll get us more contributors/users
20:07:24 <rellerreller> redrobot what is left to be done for the release?
20:07:41 <elmiko> yea, i'm curious too
20:07:48 <redrobot> excellent question
20:07:59 <elmiko> we'd really like to use it =)
20:08:22 <redrobot> I thought we had a pending CR that fixed some oslo issues
20:08:33 <redrobot> but it seems that it was abandoned
20:09:09 <redrobot> ah, yes abandoned by rellerreller
20:09:14 <redrobot> derp, rm_work, not rellerreller
20:09:21 <rellerreller> I was about to say :)
20:09:34 <rellerreller> It sounded like it was not needed anymore
20:09:54 <redrobot> hmm...
20:10:17 <redrobot> I think I would like to see oslo.log from incubator replaced with oslo_log the library
20:10:26 <rm_work> o/
20:10:40 <redrobot> mainly because we ran into some trouble at the gate with tempest/barbican because of that same issue
20:10:51 <redrobot> #help we need someone to update Castellan to use oslo_log
20:11:15 <elmiko> redrobot: i gotta run soon, but i'll hit you up later if you still need folks that can help with castellan
20:11:26 <redrobot> elmiko sounds good!
20:11:33 <rellerreller> Can the help come after freeze?
20:11:39 <elmiko> yes
20:11:43 <kfarr> rellerreller +1
20:11:48 <redrobot> yes, the only thing that is frozen is Barbican proper
20:11:53 <jaosorior> redrobot: I could do that, need an excuse to dig into Castellan anyway
20:11:56 <elmiko> oh sorry, thought rellerreller was asking
20:12:07 <redrobot> #action jaosorior to update Castellan to use oslo_log
20:13:07 <redrobot> I would be up for releasing v 0.1.0 after the oslo udpate
20:13:22 <redrobot> ok, moving on
20:13:26 <redrobot> #topic Kilo-3
20:13:27 <rellerreller> redrobot I asked the team here about that. We are good as well with the release.
20:13:42 <rellerreller> That was one of my action items.
20:13:45 <redrobot> rellerreller awesome
20:14:03 <redrobot> #link https://launchpad.net/barbican/+milestone/kilo-3
20:15:08 <redrobot> I met with Thierry last week, and since we're still in the-status-that-was-formerly-known-as-incubated then I can approve Feature Freeze Extensions (FFEs)
20:15:14 <redrobot> usually this is something that Thierry would do
20:15:17 <redrobot> sooooo
20:15:34 <redrobot> The retry BP that woodster_ is working on was granted FFE and bumped to RC1
20:16:20 <redrobot> rellerreller I saw the main content-types CR landed just a sec ago
20:16:32 <rellerreller> Oh did it!!! :)
20:16:37 <redrobot> rellerreller I'm going to change the status from "Needs Code Review" to "Implemented"
20:16:58 <redrobot> we'll address the couple of outstanding issues in follow up fixes after Kilo-3
20:16:59 <rellerreller> Awesome! I had no idea it was finally merged.
20:17:17 <redrobot> rellerreller yep!  Thanks for all the hard work!
20:17:24 <redrobot> that was definitely not an easy one
20:17:53 <arunkant> redrobot, can per_secret impl (now split into 3 patches) be considered a possible candidate for RC1..not sure if it can make usual deadline of 03/18?
20:18:14 <redrobot> arunkant yeah, I was going down the list for pending BPs
20:18:21 <redrobot> arunkant I think we can do a FFE for that feature as well.
20:18:45 <redrobot> There's a lot of code in the per-secret implementation, so we can use the extra time to review it
20:19:01 <arunkant> redrobot, what is the deadline for RC1 ?
20:19:26 <redrobot> arunkant April 9
20:19:31 <redrobot> #link https://wiki.openstack.org/wiki/Kilo_Release_Schedule
20:19:49 <arunkant> redrobot, thanks..that looks like a possibility.
20:20:32 <redrobot> alee Regarding the CA Identification BP, it looks like this CR needs to be rebased https://review.openstack.org/#/c/150070/
20:20:45 <redrobot> alee also looks like the only missing piece for that BP
20:20:53 <alee> redrobot, yes -- I plan to get to that maybe today
20:20:54 <alee> yes
20:21:01 <redrobot> alee awesome
20:21:30 <alee> redrobot, there is one more bit that needs to be fixed for which I need woodsters help
20:21:46 <alee> with those two crs, this should be finished
20:22:01 <redrobot> alee and regarding the common cert API, is there anything outstanding?  I didn't see anything in Launchpad
20:22:16 <alee> it might make 3/18, but likely will end up going beyond that
20:22:45 <alee> redrobot, couple of things on common cert api -- dave-mccowan is writing a patch to do validation stuff
20:23:00 <alee> and I am writing a CR to add functional tests
20:23:24 <alee> based on that, there will likely be a follow on cr to shake out issues
20:23:47 <redrobot> ok... I'll tentatively leave this stuff in the K-3 release...  the issue shaking can happen after the release
20:23:48 <alee> so -- not all likely to make 3/18 but probably soon after that
20:24:08 <redrobot> trying to keep FFEs down to a minimum
20:24:33 <alee> sure - lets see how the functional tests go
20:24:47 <alee> but in general common cert api is done
20:24:52 <redrobot> I'm sensing Quota might slip as well
20:24:56 <redrobot> tsv around?
20:24:59 <redrobot> nope...
20:25:23 <redrobot> #action redrobot to reach out to tsv about quota BP
20:25:31 <redrobot> I would not mind bumping this to Liberty
20:26:02 <redrobot> if we can get some eyes on https://review.openstack.org/#/c/140575/ it would be an easy BP to finish today
20:26:23 <redrobot> and lastly
20:26:44 <redrobot> rellerreller do you have any CRs up for the Asymmetric Key Support BP ?
20:26:58 <redrobot> oh yes you do
20:27:00 <rellerreller> We are currently working that.
20:27:13 <redrobot> just answered my own question... looks like WIP... I'll tentatively leave it in for K-3
20:27:32 <rellerreller> Sounds good. We will be close to the wire if we make it.
20:28:26 <redrobot> I would like to have the SHA ready for Thierry on Thursday morning, so Wed night I'm going to revisit launchpad and bump whatever needs to be bumped.
20:29:21 <redrobot> ok, moving on
20:29:26 <redrobot> #topic Functional Test Gates
20:29:35 <redrobot> lisaclark asked me to add this topic
20:29:44 <redrobot> and now I'm totally blanking on what I was supposed to talk about?
20:30:01 <jvrbanac> redrobot, adding the barbicanclient gate?
20:30:04 <hockeynut> requiring new functional tests on CRs
20:30:08 <redrobot> ^^ yes
20:30:25 <alee> redrobot, how about the dogtag gate?
20:30:38 <redrobot> ok, let's see, one at a time :)
20:30:57 <redrobot> We'd like to be a little more strict about functional tests, so please be sure to add functional tests to new BPs that land
20:31:15 <hockeynut> redrobot just BPs, or CRs in general?
20:31:28 <redrobot> 2) chellygel is working on the last bits to enable a functional gate on barbicanclient
20:31:52 <redrobot> hockeynut I thin BPs would require functional tests no matter what.  CRs in general should be done on a case-by-case basis
20:32:04 <hockeynut> redrobot gotcha
20:32:28 <redrobot> as far as dogtag gate goes
20:32:38 <hockeynut> related to that, would anyone be interested in a google hangout to go over how to write/run functional tests?
20:32:44 <redrobot> I haven't had a chance to get back to it... probably won't get to it until after Kilo-3
20:32:47 <redrobot> alee ^^
20:33:16 <alee> redrobot, ok ping me when you do
20:33:36 <alee> redrobot, as I recall you were going to try to extract more logs
20:33:47 <rellerreller> I would be interested in the functional tests
20:34:00 <redrobot> hockeynut ^^ got one taker :)
20:34:09 <hockeynut> winner winner chicken dinner
20:34:30 <redrobot> alee yep, the next step in DogTag gate is troubleshoot why installation fails in the gate, but succeeds in a regular VM
20:34:33 <hockeynut> I will schedule and publicize on #openstack-barbican
20:35:04 <redrobot> ok, any other questions/comments about functional tests
20:35:17 <redrobot> ?
20:35:25 <rellerreller> Can we go over how the gates are configured with Gerrit?
20:35:36 <rellerreller> Not now, but on the google chat.
20:35:48 <hockeynut> rellerreller sure
20:35:55 <rellerreller> I'm curious how those are setup and how you indicate which scripts to run.
20:36:00 <redrobot> rellerreller yeah, I can definitely go over that stuff... mostly involves openstack-infra/project-config
20:36:19 <rellerreller> I think a KMIP gate would be good. I just don't know how we could support equipment.
20:37:14 <redrobot> we had talked about a software kmip server before... I think that still sounds interesting
20:37:26 <redrobot> it would be leaps better than what we have now... :)
20:37:33 <rellerreller> +1
20:38:00 <jvrbanac> redrobot, did HP ever get back with us on the Atallas?
20:38:08 <redrobot> tkelsey ^^
20:38:39 <tkelsey> sorry I dont have an update on that :( its still on the radar
20:39:22 <redrobot> ok, moving on...
20:39:33 <redrobot> #topic Assert Parameter Order
20:39:40 <redrobot> this should be a fun bikeshedding session
20:39:50 <bknudson> use assertThat, then don't have to worry about it.
20:39:56 <redrobot> so I kind of rocked the boat the other day asking rellerreller to do
20:40:02 <redrobot> assertSomething(EXPECTED, ACTUAL)
20:40:11 * jvrbanac shivers
20:40:20 <redrobot> but today jvrbanac pointed out that this is backwards from the norm
20:40:40 <chellygel> jvrbanac, shivers towards which?
20:40:54 <bknudson> #link http://testtools.readthedocs.org/en/latest/api.html#testtools.TestCase.assertEquals
20:41:10 <hockeynut> looking for a needle in a haystack, or searching the haystack for the needle...
20:41:44 <redrobot> bknudson thanks for the link!
20:42:06 <alee> right - pycharm shows the order ..
20:42:13 <redrobot> seems at least testtools is on-board with having expected be first.
20:42:18 <jvrbanac> hang on
20:42:35 <jvrbanac> Pretty sure the docs don't match what's going on
20:42:47 <rellerreller> Where did jvrbanac find details on the other way?
20:43:02 <bknudson> here's a doc for using matchers and assertThat: http://testtools.readthedocs.org/en/latest/for-test-authors.html#using-matchers
20:43:32 <jvrbanac> This is how things get translated in our tests: http://paste.openstack.org/show/192724/
20:44:19 <bknudson> if you pass a dict to assertEquals I think it shows a different message.
20:45:30 <chellygel> assertThat seems to be more explicit...
20:45:36 <bknudson> Here's the matchers: https://github.com/testing-cabal/testtools/blob/master/testtools/matchers/__init__.py#L15
20:45:56 <bknudson> how desperate would you have to be to use the TarballContains matcher?
20:46:15 <jvrbanac> Interesting... I was taught that unittest assert in Python were written as spoken. Assert x is equal y
20:46:28 <jvrbanac> == self.assertEqual(x, y)
20:47:37 <redrobot> so, do we have consensus then?
20:48:07 <redrobot> assertEqual(EXPECTED, OBSERVED) going forward?
20:48:29 <redrobot> also makes for some low hanging fruit if anyone wants to go fix existing test code
20:48:53 <jvrbanac> redrobot, I still don't like this...
20:49:12 <jvrbanac> redrobot, pretty sure we've been doing this the other way since the birth of this project
20:49:19 <jvrbanac> redrobot, why the change anyway?
20:50:01 <redrobot> jvrbanac I don't think we've ever cared about the order... and since someone brought it up a while back I figured it was time to take a stance
20:50:17 <rellerreller> It is nice in the log messages when the ordering is correct because it says what was expected and what was received.
20:51:17 <redrobot> rellerreller +1
20:51:37 <chellygel> assertThat just seems more explicit
20:51:41 <chellygel> if thats the goal for what we are trying to achieve
20:52:08 <jvrbanac> rellerreller, is it showing up out of order?
20:52:31 <jvrbanac> chellygel, it's there if it makes sense to use
20:52:55 <rellerreller> jvrbanac I'm not sure anymore. I did see one out of order, but I don't remember the order in which it was written.
20:53:40 <redrobot> almost out of time for today...
20:53:47 <jvrbanac> Anyhow, if everyone wants to switch... ok. However, we have tons of stuff out there already. I don't like the idea of some things being done one way
20:53:55 <jvrbanac> and others the reverse
20:54:00 <rellerreller> So which way are we going?
20:54:14 <redrobot> rellerreller (EXPECTED, OBSERVED) as in testtools docs
20:54:22 <redrobot> we'll have to revisit stuff that is not compliant
20:54:35 <rellerreller> OK
20:54:36 <redrobot> buuuut, we are getting an intern for the summer >_<
20:54:51 * redrobot is already peparing busy work
20:55:08 <redrobot> sorry jvrbanac, we'll get to consistent eventually
20:55:08 <chellygel> i would hate to be an intern that does that o/
20:55:58 <redrobot> ok, guys, I think that's all we have time for today
20:56:03 <jvrbanac> I guess I'm the only one then that doesn't like this idea. :(
20:56:07 <redrobot> don't forget to review stuff for Kilo-3
20:56:19 <redrobot> because Wednesday night will be here before you know it!
20:56:48 <redrobot> #endmeeting