19:59:56 <redrobot> #startmeeting barbican
19:59:56 <openstack> Meeting started Mon Mar 30 19:59:56 2015 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:58 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:01 <openstack> The meeting name has been set to 'barbican'
20:00:05 <redrobot> #topic Roll Call
20:00:12 <jvrbanac> o/
20:00:14 <hockeynut> o/
20:00:16 <igueths> o/
20:00:19 <arunkant> o/
20:00:20 <jaosorior> o/
20:00:26 <dave-mccowan> o/
20:00:27 <elmiko> o/
20:00:33 <chellygel> \(・`(ェ)・)/
20:00:42 <kfarr> o/
20:00:56 <redrobot> awesome, lots of barbicaneers here!
20:01:03 <redrobot> #topic Action Items
20:01:12 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2015/barbican.2015-03-23-19.59.html
20:01:21 <redrobot> There was only one action item last week
20:01:32 <redrobot> and it was for me to reach out to tsv regarding the status of the Quota BP
20:01:43 <redrobot> I did send him an email this morning, but haven't heard back from him yet.
20:01:50 <woodster_> o.
20:01:52 <redrobot> so I'll kick the can to next time
20:01:53 <woodster_> o/
20:02:08 <redrobot> #action redrobot to update on tsv status for Quota BP
20:02:24 <reaperhulk> o/
20:02:27 <redrobot> ok, moving on to the topics for this week
20:02:42 <redrobot> #topic Kilo Deprecation
20:02:59 <redrobot> jvrbanac would you mind elaborating on this
20:03:05 <jvrbanac> redrobot, sure.
20:03:21 <jvrbanac> redrobot, so this is more of a heads up that we need to make we have everything flagged that we want to start deprecating.
20:03:59 <redrobot> I think the only things we've deprecated so far are
20:04:21 <redrobot> 1) use /payload for decryption instead of different content-types in the server
20:04:48 <redrobot> 2) don't set payload_content_type or payload_content_encoding in the client
20:05:20 <hockeynut> redrobot do we have a list anywhere of our deprecated stuff?
20:05:46 <redrobot> hockeynut other than in the chat log above, no
20:06:16 <jvrbanac> I thought we had mentioned other things during the mid-cycle
20:06:51 <hockeynut> I will suggest that we start something either in wiki or official docs to track all the deprecated things
20:07:23 <woodster_> I vote for official docs
20:07:30 <redrobot> hockeynut agreed.   I think wiki would work.
20:07:30 <jaosorior> probably the docs would be more appropriate
20:07:52 <woodster_> that should be highlighted in our API docs too
20:08:00 <redrobot> I think we certainly want to deprecate things in the docs, which we have already done.
20:08:12 <redrobot> but for a list of deprecation items, I think a wiki makes sense
20:09:32 <redrobot> tbh I don't care much either way....  anyone want to tackle compiling the list?
20:09:32 <hockeynut> usually that kind of thing goes into a change activity/history section in docs but I don't think we have such a beast
20:10:11 <hockeynut> (raises hand meekly) :-)
20:10:11 <redrobot> bueller?
20:10:37 <hockeynut> (waves hand frantically)
20:10:37 <redrobot> #action hockeynut to compile list of deprecated features in docs (or wiki)
20:11:04 <redrobot> jvrbanac were you able to dig up any other items on this topic?
20:11:51 <jvrbanac> redrobot, not of the top of my head
20:12:03 <redrobot> ok, moving on
20:12:13 <redrobot> #topic Logging in Barbican
20:12:18 <redrobot> jvrbanac this is another one of yours
20:12:22 <jvrbanac> Yep
20:12:59 <jvrbanac> Soo, as most people have realized, we need to start improving our logging
20:13:31 <jvrbanac> to start the discussion I added a simple CR here: https://review.openstack.org/#/c/168774/
20:14:10 <jvrbanac> Also, for everyone's information here is the link to the logging guidelines for openstack:
20:14:14 <jvrbanac> #link http://specs.openstack.org/openstack/openstack-specs/specs/log-guidelines.html
20:15:07 <woodster_> jvrbanac, please add localization (the u._LI(...)) stuff to info messages
20:16:24 <woodster_> are you thinking paper cuts to scrub out the prose of our logging messages?
20:17:02 <redrobot> woodster_ jvrbanac  I think there's specific guidelines on what log items get localization and which dont... not sure if this CR qualifies
20:17:29 <elmiko> i thought only debug doesn't get translated?
20:17:55 <woodster_> I think any info level needs _LI treatment so such messages can be localized
20:18:13 <elmiko> that was my impression too, aside from like variable names
20:18:35 <jvrbanac> In general, I believe we need to go through each part of Barbican, figure out what we should be logging, and figuring out how we go about closing that gap
20:19:13 <jvrbanac> Part of this is that I don't believe we're really aware of the openstack standards are for this as well.
20:19:15 <woodster_> #link http://docs.openstack.org/developer/oslo.i18n/guidelines.html#log-translation
20:19:52 <elmiko> might also want a barbican liaison to the log-wg
20:20:44 <redrobot> elmiko heh... how many liaisons are there now?
20:20:51 <elmiko> only 4 listed
20:20:56 <elmiko> https://wiki.openstack.org/wiki/CrossProjectLiaisons#Logging_Working_Group
20:21:36 <elmiko> i only suggest as i've found it useful to hangout in some of the cross project meetings, doesn't have to be some big official type thing
20:23:20 <redrobot> #help we need someone to volunteer to be our Logging Liaison
20:24:21 <redrobot> ok, any other questions/comments on this topic?
20:24:50 <jvrbanac> Just for people to toss comments on that CR
20:24:58 <jvrbanac> :D
20:25:06 <redrobot> cool
20:25:11 <redrobot> moving on
20:25:18 <redrobot> #topic Castellan Initial Release
20:25:44 <redrobot> so, all CRs that were pending last week have landed
20:25:56 <redrobot> I've also registered "castellan" in PyPI
20:26:05 <elmiko> woot
20:26:20 <redrobot> so unless there are any objections, I'll be making the initial (0.1.0) release of Castellan after this meeting.
20:27:28 <hockeynut> redrobot are functional tests required for such a release?
20:28:20 <redrobot> hockeynut I don't think so.  It's mainly just an interface now.  I wouldn't expect functional tests until kfarr gets a barbican implementation working.
20:28:48 <hockeynut> redrobot ok - just wanted to be sure they weren't required for the process.  thx!
20:30:12 <redrobot> #action redrobot to release Castellan 0.1.0
20:30:25 <redrobot> #topic Open Discussion
20:30:31 <redrobot> that's all I have on the agenda today
20:30:45 <redrobot> any other topics we would like to discuss?
20:31:06 <elmiko> quick castellan q
20:31:13 <redrobot> elmiko shoot
20:31:19 <elmiko> is the repo on github in the state it will be pushed to pypi?
20:32:04 <redrobot> elmiko I was planning to tag 5fea4ffb806fbc75c829492e5e91065a72719ebc
20:32:18 <alee> redrobot, sorry I;m late.  did you mention that acl review session on wed?
20:32:24 <elmiko> redrobot: ack, thanks!
20:32:29 <redrobot> alee I did not
20:32:41 <alee> glad I asked :)
20:32:58 <redrobot> FYI we had a Google Hangout meeting today to review woodster_ 's work on the Retry BP
20:33:13 <redrobot> it was very productive, and we were able to land the outstanding CRs
20:33:33 <redrobot> We've got another Google Hangout scheduled for this Wednesday at 11:00am PDT
20:33:44 <redrobot> I've sent an invite to all the core reviewers
20:33:58 <redrobot> ping me if you're not a core reviewer but would like an invite as well
20:34:19 <woodster_> don't wait until 30 mins before to start reviewing those CRs btw...that's a meaty feature
20:34:22 <redrobot> also invited kfarr since rellerreller is on vacation
20:34:34 <kfarr> thanks redrobot!
20:34:41 <kfarr> I was there today, just lurking
20:34:49 <redrobot> kfarr I saw!  Thanks for joining :)
20:34:49 <alee> redrobot, I believe rm_work was interested too
20:35:00 <redrobot> alee good point, I'll add him to the list
20:35:01 <rm_work> yes
20:35:41 <rm_work> yeah I was planning to re-read the spec BP and then try to make my way through all of those CRs tonight/tomorrow
20:35:42 <woodster_> Please consider adding Charles as well redrobot
20:35:50 <rm_work> it looks like basically a whole day's worth of code review T_T
20:36:22 <arunkant> redrobot, thanks for organizing acl review session. Can people add review comments on acl changes (later patches 3/4/5)..will be more useful when coming to session.
20:36:23 <alee> hopefully we'll be able to knock off most of the reviews/ issues in that section.  as folks have said though, it is meaty - so come prepared.
20:36:32 <hockeynut> those hangouts seem like a good way to get these meaty CRs thru the process
20:36:50 <hockeynut> for me the interactive review is a big plus
20:37:43 <redrobot> hockeynut I agree.  Definitely a good way to give big CRs a kick in the rear to get them moving
20:38:25 <redrobot> well, if there are no more questions/comments we can end the meeting early.
20:40:00 <redrobot> alrighty, thanks for coming guys!  See (some of) y'all in the Google Hangout on Wednesday.
20:40:05 <redrobot> #endmeeting