19:59:49 <redrobot> #startmeeting barbican
19:59:50 <openstack> Meeting started Mon Jun 22 19:59:49 2015 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
19:59:54 <openstack> The meeting name has been set to 'barbican'
20:00:04 <redrobot> #topic Roll Call
20:00:09 <jvrbanac> o/
20:00:10 <woodster_> o/
20:00:12 <dave-mccowan> o/
20:00:18 <elmiko> heyo/
20:00:20 <jaosorior> o/
20:00:22 <hockeynut> o/
20:00:24 <silos1> o/
20:00:27 <jkf> Greetings
20:00:28 <rm_work> o/
20:00:39 <redrobot> Nice!  Lots of barbicaneers here today!
20:01:02 <redrobot> As usual, the agenda for the meeting can be found here:
20:01:04 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:01:49 <redrobot> Everyone is encouraged to add agenda items ahead of time.   Otherwise we end up with meetings like today, where I make up topics as I go along :-P
20:02:06 <elmiko> hehe, was gonna say that agenda needs some love ;)
20:02:26 <redrobot> elmiko hehe indeed
20:02:27 <elmiko> i have some minor castellan and barbican/fedora updates
20:02:34 <redrobot> elmiko noted.
20:02:35 <kfarr> o/
20:02:38 <jaosorior> as long as we don't end up talking about the weather, it's alright :P
20:02:42 <elmiko> lol
20:03:05 <redrobot> #topic Action items from previous meeting
20:03:10 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2015/barbican.2015-06-15-19.59.html
20:03:37 <redrobot> First action item was for me to look into the container-acl spec for a possible Google hangout this week
20:03:55 <redrobot> But I didn't actually start reviewing until today when kfox1111 poked me about it
20:04:08 <redrobot> still half-way through, I think it would be good for others to chime in on it.
20:04:23 <redrobot> #link https://review.openstack.org/#/c/190404/3
20:04:36 <redrobot> I don't think we need a hangout just yet though
20:04:44 <redrobot> next item
20:04:50 <redrobot> was also for me to look into Kite status
20:05:07 <redrobot> I sent an email to Jamie Lennox about it, but I haven't heard back from him yet
20:05:15 <redrobot> Jamie being the main driver/contributor for Kite
20:05:26 <jaosorior> redrobot: I don't think there's much work going on regarding kite :/
20:05:32 <redrobot> but I'll update you guys when I hear back from him.
20:05:49 <redrobot> jaosorior indeed.  Last I heard he was re-tasked on something else
20:06:13 <redrobot> so that does it for the action items from last week
20:06:40 <redrobot> moving on
20:06:43 <redrobot> #topic liberty-1
20:06:49 <redrobot> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
20:06:58 <redrobot> Liberty Milestone 1 is due this week.  Preferably tomorrow.
20:07:29 <redrobot> tons of bugfixes are going into it
20:07:31 <redrobot> #link https://launchpad.net/barbican/+milestone/liberty-1
20:07:38 <redrobot> but we're a little light on blueprints
20:08:37 <redrobot> although I think one bp from jaosorior is close to landing
20:08:54 <redrobot> in any case it's just a milestone release, so it will be fine if it goes out with only the one feature
20:09:04 <jaosorior> well... in theory two bps, just need reviewers ;)
20:09:15 <redrobot> jaosorior links?
20:09:44 <redrobot> jaosorior it would be good to drop them here in case some of our awesome reviewers want to tune out of the meeting ;)
20:10:04 <jaosorior> This one has been there for a while https://review.openstack.org/#/c/178601/ ; already had 3 +2s, but decided to fix a minor issue on the last minute
20:10:19 <jaosorior> and now it's back to....not being reviewed
20:10:28 <elmiko> =(
20:10:49 <redrobot> yeah, that's been pending review for 10 weeks :(
20:11:03 <jaosorior> and these two https://review.openstack.org/#/c/194157/2 https://review.openstack.org/#/c/194283/
20:11:12 <redrobot> Also, please please please review the spec CRs
20:11:36 <redrobot> at the last Summit we made it a goal to get all the specs reviewed by l-1
20:11:44 <redrobot> and we didn't quite make it
20:12:04 <redrobot> liberty-2 is going to be a hard deadline for specs, but it would be awesome if we can get stuff landed before then.
20:13:12 <woodster_> redrobot: some of the tls blueprints are pending Ade returning from vacation to finalize them...hopefully landing next week
20:13:22 <redrobot> woodster_ thanks for the reminder
20:13:35 <redrobot> Ade asked me to shepherd his blueprints while he's on vacation
20:13:52 <redrobot> so if you have a negative vote on any of his specs, please ping me for an update
20:14:16 * redrobot makes a note to go check on Ade's blueprints for negative votes
20:14:29 <redrobot> any questions/comments about liberty-1?
20:15:20 <woodster_> Just agitating on arunkant's behalf the quota bp (just workflow needed)
20:15:23 <woodster_> #link https://review.openstack.org/#/c/159938/
20:15:58 <redrobot> ok, moving on
20:16:08 <redrobot> #topic Castellan
20:16:15 <redrobot> elmiko tag. you're it!
20:16:32 <elmiko> ok
20:16:45 <elmiko> i have drafted this bp
20:16:46 <elmiko> https://blueprints.launchpad.net/castellan/+spec/improved-configuration-options
20:16:50 <elmiko> oops
20:16:51 <elmiko> #link https://blueprints.launchpad.net/castellan/+spec/improved-configuration-options
20:17:09 <elmiko> and i have a poc working locally for it, i need to generate some docs and some tests and i think it will be ready for review
20:17:24 <elmiko> although i might make it 2-3 reviews to make it easier on the eyes.
20:17:29 <ekarlso> /buffer 25
20:17:33 <redrobot> elmiko awesome!
20:18:01 <elmiko> there are no specs yet for castellan, so i tried to be verbose in the bp. which might be a little unsusal, but i'd appreciate any feedback folks have =)
20:18:09 <woodster_> elmiko: +1 that is nice!
20:18:15 <kfarr> Thanks elmiko!
20:18:22 <redrobot> I'll have to go add a liberty series to the launchpad page, so we can track it.
20:18:27 <elmiko> =)
20:18:29 <redrobot> #action redrobot to add liberty series to castellan
20:18:45 <elmiko> that was all i had for castellan
20:18:51 <redrobot> thanks elmiko
20:19:09 <redrobot> #topic Barbican in Fedora
20:19:13 <elmiko> hehe
20:19:14 <elmiko> sooo
20:19:29 <elmiko> i've been looking at the rpm patch that xaeth has put together
20:19:40 <elmiko> and i'm working on some startup/shutdown scripts to use with systemd
20:19:52 <elmiko> sadly, i'm running into issues with the way barbican.sh does this
20:19:56 <elmiko> basically the start is fine
20:20:08 <elmiko> but the stop does a `killall uwsgi`, essentially
20:20:16 <elmiko> which is not gonna fly for a fedora package
20:20:25 <jaosorior> woodster_: I haven't +2ed arunkant's audit bp because of the lack of testing specification, that's the only reason
20:20:36 <elmiko> so, i'm looking into something with recording the pid and using that to kill the uwsgi process. but,
20:20:45 <elmiko> i'd be curious to hear if anyone else has ideas about this?
20:20:59 <elmiko> also curious if barbican upstream would want the scripts when i finish?
20:21:36 <jaosorior> elmiko: Would probably be useful, even if we keep them in the "contrib" folder or something of the sort
20:21:39 <woodster_> elmiko: I'd be all for a revamping of the barbican.sh script...as would a legion of others :)
20:21:54 <elmiko> ok, cool
20:21:58 <jkf> elmiko: I don't use barbican.sh and have my systemd unit start uwsgi directly.
20:22:09 <elmiko> i am also working on something more openstacky for the barbican.cli scripts but that's a ways out
20:22:25 <jkf> uwsgi has systemd integration, so systemd can handle it directly.
20:22:26 <elmiko> jkf: cool, i would love to talk more about that if you have time
20:22:36 <redrobot> I would be on board for a barbican.sh revamp, as well as dropping uwsgi from the rpm deps
20:22:37 <elmiko> awesome, i hadn't gotten to that point yet
20:22:43 <woodster_> elmiko: I thought we had removed uwsgi from teh barbican rpm?
20:22:50 <jkf> elmiko: sure thing.
20:23:02 <jaosorior> elmiko: at least the barbican-db-manage should be quite straight forward
20:23:13 <elmiko> woodster_: i think so, but for a standalone installation it will still need some sort of wsgi server, uwsgi/gunicorn/etc...
20:23:14 <jaosorior> to... openstack....ize
20:23:42 <redrobot> elmiko I think that the Debian folks really want httpd support
20:23:50 <elmiko> so, if i just have a fedora system, and i want to `yum install openstack-barbican`, i need a script to start it
20:23:55 <Daviey> Hey, i have a change about moving the scripts (except barbican.sh) in gerrit into the module
20:24:01 <elmiko> redrobot: so do we, for the RDO/OSP products
20:24:15 <elmiko> Daviey: awesome, link?
20:24:16 <Daviey> https://review.openstack.org/#/c/193208/
20:24:34 <Daviey> It isn't perfect, but a step in the right direction.
20:24:38 <redrobot> I would definitely +2 a change that s/uwsgi/httpd/
20:24:51 <elmiko> very cool, i'll take a look Daviey
20:24:54 <Daviey> ta
20:25:12 <jaosorior> Daviey: reviewing
20:25:20 <woodster_> Daviey: I think we've just moved to empty __init__ files now
20:25:38 <Daviey> woodster_: I thought all files had to have the header?
20:25:53 <woodster_> Daviey: otherwise this is good stuff.
20:27:15 <redrobot> elmiko anything else on the Fedora front?
20:27:38 <woodster_> Daviey: we've been using blank __init__ of late...but maybe that has changed back to header based now?
20:29:35 * redrobot thinks elmiko got distracted with a review
20:29:39 <redrobot> ok, moving on
20:29:49 <redrobot> any other topics we should talk about?
20:30:00 <redrobot> #topic Open Discussion
20:30:16 <elmiko__> sorry, had a bad net thingie
20:30:29 <redrobot> elmiko__  no worries
20:31:08 <redrobot> so now would be a good time to post links to pending reviews that need attention
20:31:13 <elmiko__> was gonna say, Daviey that patch looks good to me. my only suggestion would be to make the package named barbican.cli instead of barbican.cmd to be more explicit. otherwise, i'll give it a try locally.
20:32:31 <Daviey> elmiko: ok, i can change that
20:32:43 <jaosorior> https://review.openstack.org/#/c/178601/ well, again, I would REALLY like that people check this one out :/
20:33:04 * redrobot pinky promises to reivew jaosorior 's CR
20:33:06 <elmiko__> jaosorior: i added that to my review queue ;)
20:33:21 <woodster_> elmiko__: I think 'cmd' is how I've seen other projects handle this
20:33:57 <jaosorior> woodster_: If you have time to check the above CR, you had a +2 there before
20:34:14 <elmiko__> woodster_: lol, i've seen cli as well
20:34:21 <jaosorior> aaaand this one only needs a workflow :D https://review.openstack.org/#/c/194157/2
20:34:56 <elmiko__> woodster_: either way though, it's not a -1 for me. just a stylistic thing
20:35:03 <redrobot> looks like kfarr already reviewed that last one... maybe she can just +W right away?
20:35:14 <jaosorior> woodster_, Daviey, elmiko__: Well... keystone has cmd... honestly I don't think that folder namingg is a big deal
20:35:18 <kfarr> My first workflow!
20:35:33 <redrobot> kfarr \o/
20:35:42 <elmiko__> yay!
20:35:45 <woodster_> kfarr: nice!
20:36:05 <woodster_> jaosorior: done
20:36:07 <elmiko__> jaosorior: agreed, not a big deal. i was just adding my $0.02
20:36:09 <elmiko__> =)
20:36:21 <jaosorior> kfarr: http://funny-pics.co/wp-content/uploads/HighFiveLikeABoss.jpg
20:36:43 <woodster_> elmiko__: I still have memories from the incubation process...don't like to stray too far from the openstack fold :)
20:36:53 <jaosorior> woodster_: Thanks dude! :D
20:37:16 <elmiko__> woodster_: i hear ya, i don't think its a big deal, i just think cli is more clear
20:38:09 * redrobot agrees with elmiko__
20:38:25 <jkf> I've got a quick update on the symantec ca plugin.
20:38:38 <redrobot> #topic Symantec CA
20:38:42 <redrobot> jkf go ahead
20:39:31 <jkf> I'm not sure how the conversation went outside of my pervue, but a scope document its way to the product manager of the trust services group at Symantec.
20:39:54 <redrobot> jkf progress is good!
20:40:16 <jkf> and based on the work in the scope doc, we're looking to get a developer from that org to do the development of the plugin.
20:40:50 <jkf> Based on those estimates, I don't have nearly the time to do the work myself on a community basis, but they want to look at doing it as part of the product development.
20:41:12 <jkf> So they're still trying to identify who can do so, and I've offered my assistance to get them up to speed once they do.
20:41:43 <jkf> Unfortunately, with my deployment being my top priority, its meant I haven't had a whole lot of time to put into the plugin yet. :(
20:42:25 <jkf> So, that's where we stand with the ca plugin at the moment.
20:43:32 <redrobot> jkf awesome, thanks for the udpate
20:43:40 <redrobot> update even
20:43:54 <redrobot> anything else y'all?
20:43:57 <silos1> I proposed a new spec today: https://review.openstack.org/#/c/194298/ Really interested in seeing what people think about it.
20:44:00 <redrobot> if not we can have our 15 min back.
20:44:28 <redrobot> ah yes, I think kfarr and rellerreller will be interested in that one silos1
20:44:55 <silos1> redrobot: cool
20:44:57 <kfarr> silos1 cool, adding it to my queue
20:45:15 <silos1> kfarr: :) thx
20:46:20 <redrobot> alrighty...  seems like we're done early today.
20:46:24 <redrobot> thanks everyone for coming!
20:46:33 <elmiko> thanks redrobot
20:46:38 <redrobot> Don't forget to add topics to the wiki for next week!
20:46:50 <redrobot> #endmeeting