20:00:04 <redrobot> #startmeeting barbican
20:00:05 <openstack> Meeting started Mon Jul 27 20:00:04 2015 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:09 <openstack> The meeting name has been set to 'barbican'
20:00:14 <redrobot> #topic Roll Call
20:00:17 <chellygel> ٩(。•ω•。)و
20:00:17 <jaosorior> o/
20:00:18 <jvrbanac> o/
20:00:18 <igueths> o/
20:00:21 <elmiko> heyo/
20:00:22 <kfarr> o/
20:00:23 <silos> o/
20:00:24 <dave-mccowan> o/
20:00:26 <alee> o/
20:00:28 <jkf> Greetings
20:00:32 <woodster_> o/
20:00:49 <redrobot> chellygel always has the Ctrl+V ready to go :D
20:01:01 <elmiko> seriously...
20:01:03 <rellerreller> o/
20:01:05 * elmiko is impressed
20:01:05 <chellygel> cmd+v ;)
20:01:15 <redrobot> Woot!  Lots of barbicaneers here today.
20:01:46 <redrobot> Sorry if I'm a little out of it today guys...  I was at OSCON last week, and I'm still trying to catch up on everything...
20:02:04 <redrobot> Let's get this party started
20:02:13 <redrobot> #topic Action Items from previous meeting
20:02:48 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2015/barbican.2015-07-20-20.00.html
20:02:53 <redrobot> which it looks like there was none
20:03:02 <redrobot> but I do remember one action item from last last meeting
20:03:13 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2015/barbican.2015-07-13-20.01.html
20:03:28 <redrobot> jaosorior  to backport the DogTag gate fixes into stable/kilo
20:03:30 <redrobot> jaosorior any updates on that?
20:03:37 <jaosorior> yeah, the backport is on-going
20:03:44 <jaosorior> BUT, the tests in stable/kilo fail
20:03:51 <jaosorior> for reasons unrelated to the backporting
20:03:59 <redrobot> ugh, lame
20:04:00 <jaosorior> which is the reason that I asked redrobot for help
20:04:05 <redrobot> ok, so we should sort out the failures first
20:04:17 <redrobot> #action redrobot and jaosorior to fix the stable/kilo gate failures
20:04:21 <jaosorior> This is the first commit in the backport series https://review.openstack.org/#/c/205059/
20:04:28 <redrobot> and i'll punt on the other one to next week
20:04:37 <redrobot> #action jaosorior to backport the DogTag gate fixes into stable/kilo
20:05:03 <redrobot> and now that I think about it, I had promised kfarr a Castellan release, and then totally dropped the ball
20:05:09 * redrobot would make a good politician
20:05:19 <kfarr> it's ok redrobot :)
20:05:45 <redrobot> but it seems there's a lot of patches pending....  do we want to release now, or wait until we go through the current Castellan patch queue?
20:05:50 <elmiko> i have a question, or two, about castellan releases. maybe we could circle back around later?
20:06:00 <redrobot> ok, I'll add it to the agenda
20:06:21 <redrobot> which can be found here:
20:06:28 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:06:49 <redrobot> ok, let's move on to the agenda topics for today
20:06:58 <redrobot> #topic Blueprint Deadline this Friday
20:07:07 <arunkant> 0o/
20:07:08 <redrobot> #link https://wiki.openstack.org/wiki/Liberty_Release_Schedule
20:07:21 <redrobot> Liberty Milestone 2 is due this week
20:07:43 <redrobot> I'm sure the release managers would like to cut it tomorrow, but I may be able to push until Thursday if there's stuff in the queue that we want to land before then.
20:07:55 <redrobot> #action redrobot to do some Launchpad grooming for Liberty-2
20:08:16 <redrobot> which means that this week is the deadline for Liberty milestones
20:08:24 <redrobot> #link https://review.openstack.org/#/q/status:open+project:openstack/barbican-specs,n,z
20:08:31 <redrobot> we still have a lot of pending specs
20:08:36 <redrobot> most of them have -1 votes on them
20:10:12 <redrobot> Any questions/comments about the next milestone, or the Blueprint freeze?
20:10:41 <silos> If we don't get a bp approved by Thursday is it gone forever?
20:10:51 <redrobot> silos nope, you have to re-submit for M
20:11:02 <redrobot> silos just won't land on Liberty
20:11:10 <silos> ok. understood.
20:11:40 <redrobot> I'll probably be pinging people for reviews throughout the week.
20:12:00 <redrobot> Both for spec reviews, and also to get status updates on approved specs
20:12:57 <redrobot> ok, moving on
20:13:02 <redrobot> #topic Barbican Mid-Cycle
20:13:17 <redrobot> I just noticed we're listed on this fancy new events page:
20:13:19 <redrobot> #link https://www.openstack.org/community/events/#mid-cycle_sprints
20:13:37 <redrobot> hopefully everyone has booked flights/hotels etc
20:13:49 <redrobot> but if you still need the details, you can find them here:
20:13:52 <redrobot> #link https://wiki.openstack.org/wiki/Sprints/BarbicanLibertySprint
20:14:07 <redrobot> looking forward to visiting JHU next week :)
20:14:17 <rellerreller> woot!
20:14:19 <redrobot> any questions/comments about the mid-cycle?
20:14:29 <rellerreller> What do I need to do?
20:14:47 <rellerreller> You can let me know offline, but I want to make sure I have everything ready.
20:15:16 <rellerreller> I figure seating and some food, but did not know if I need to do anything else.
20:15:47 <kfarr> Projector?  The rooms should already have those
20:16:01 <dave-mccowan> are there instructions somewhere about where to go and how to check in once we get to the address?  not sure if there will be guards and gates, etc.
20:16:11 <woodster_> rellerreller: do you need a final list of folks going for your security folks?
20:16:36 <rellerreller> So we will be outside the perimeter, so no need to checkin or anything.
20:16:58 <rellerreller> We have a night school center where people can earn masters degrees. We will be in there.
20:17:08 <kfarr> Here: http://www.jhuapl.edu/ourwork/facilities/kossiakoff.asp
20:17:09 <woodster_> rellerreller: ha, I'd never seen that link before...I see the eventbrite registration
20:17:30 <rellerreller> We can post a map and other instructions on etherpad. Is one setup?
20:17:52 <kfarr> We should put this link on the etherpad, it's got a map for parking: https://ep.jhu.edu/about-us/locations/applied-physics-laboratory
20:18:15 <dave-mccowan> is there a room number?
20:18:25 <redrobot> rellerreller yep, let me get the link
20:18:28 <redrobot> #link https://etherpad.openstack.org/p/barbican-liberty-midcycle
20:18:34 <rellerreller> kfarr let's get some cardboard signs and hang them up!
20:18:59 <kfarr> rellerreller Yeah!
20:19:04 <rellerreller> dave-mccowan we will post signs and let you know where to go.
20:19:06 <elmiko> balloons?
20:19:44 <woodster_> who's bringing licorice liquor?
20:19:48 <rellerreller> elmiko that would be awesome. We can have them drop from the ceiling when you enter.
20:20:05 <elmiko> rellerreller: haha, now i wish i could attend
20:20:26 <rellerreller> woodster_ that brings up a good point. We have a pretty strict no alcohol policy :(
20:20:54 <redrobot> womp womp...
20:20:58 <elmiko> lol
20:21:01 <rellerreller> I was reminded by my superiors about that today :(
20:21:05 <jaosorior> well, I can't make it to this mid-cycle :/
20:21:17 <redrobot> but maybe we'll be extra productive without the Finnish liquor
20:21:23 <jvrbanac> jaosorior, :(
20:21:31 <jaosorior> so your livers will take it easy... this time O_O
20:21:32 <woodster_> well, it's not too late to have the midcycle over here :)
20:21:36 <jaosorior> or...easier :P
20:21:37 <redrobot> jaosorior I'll drink extra in your honor
20:21:51 <jaosorior> redrobot: haha hell yeah
20:22:12 <woodster_> midcycle with no Ozz???
20:23:19 <jaosorior> woodster_: unfortunately
20:23:50 <woodster_> jaosorior: maybe we can video you in...middle of the night for you, could be scary/entertaining
20:24:25 <alee> redrobot, I have to say that the licorice liquor was intrumental in heading off a heated argument about content types and/or castelan certificates -- so we may end up being less productive ..
20:24:40 <elmiko> haha!
20:24:53 <alee> woodster_, jaosorior -- and yeah, its Oz's turn as the wizard of Oz ..
20:24:57 <jaosorior> next time I see you guys, I'll make sure to be well stocked with liquor :P
20:24:59 <redrobot> alee lol, that's true...  but I don't think rm_work is going to make it so we may be safe
20:25:48 <alee> ie. disembodied green head at the centre of everything ..
20:26:00 <rm_work> yeah but i will try to call in
20:26:06 <rm_work> unless there are.... "network complications" :P
20:26:41 <redrobot> ok, so, we'll be looking for the cardboard signs once we get on campus...
20:26:43 <alee> whats that -- I thougt I heard rm_work say something .. oh well, must be a glitch ..
20:26:59 <redrobot> we'll have another chance for an update next week before everyone flies out.
20:27:15 <redrobot> moving on...
20:27:17 <woodster_> ha!
20:27:28 <redrobot> #topic V2 and Orders
20:27:34 <redrobot> jvrbanac you have the floor
20:27:42 <jvrbanac> So I don't really want discuss V2 and Orders today, but rather I just wanted to get people to start thinking about it. During the midcycle I want have a discussion about a v2 api and talk through some ideas I have around it. I know a bunch of us probably won't make it to Tokyo, so I would like to use the midcycle for some face-to-face time on this subject. Again, not really a subject for today, but something to
20:27:42 <jvrbanac> start thinking about.
20:28:30 <rellerreller> jvrbanac what kinds of things are you thinking about?
20:28:46 <rellerreller> New types of orders? Is there an etherpad page?
20:29:06 <redrobot> Yeah... definitely want to take time to think through the pain points in V1, so we can fix a lot of them in a future V2
20:29:38 <jvrbanac> rellerreller, not really. I have a bunch of ideas that have come out of trying to deploy barbican. It would really go way past the time in the meeting
20:29:41 <redrobot> rellerreller first thing that comes to mind for me is renaming "payload_content_encoding" to "transport_encoding"
20:29:53 <jvrbanac> rellerreller, hense why I wanted to bring this up during the mid-cycle
20:30:09 <redrobot> jvrbanac agreed... lots of room for bikeshedding :)
20:30:33 <redrobot> it would also be good to start adding link sections to our responses
20:30:53 <fnaval> 2015-07-27 15:29:00,083: INFO: root: MIGRATION DOWNTIME VALUES: last_success_old_host=1438028825.27, first_failure=1438028826.23, last_failure=1438028940.07, first_success_new_host=1438028826.55, DOWNTIME<=1.28269696236s
20:30:57 <fnaval> typo
20:31:04 <redrobot> { ... "links" { "self": "http://reference_to_myslef" } }  ... etc
20:31:26 <alee> jvrbanac, redrobot sounds like a design page/ etherpad needed to collect all these ideas  ..
20:31:34 <jvrbanac> Yeah, I have a bunch of ideas around this subject, but I also want to hear from other folks on the pains they've had using barbican in a prod type setting
20:32:03 <elmiko> probably want to consider microversions for a next gen api as well
20:33:25 <jvrbanac> elmiko, is that something other projects are adopting?
20:33:56 <elmiko> jvrbanac: starting to, i'm not sure how widespread it is but i am pushing this for sahara v2, and i think nova is moving forward with it as well
20:34:05 <redrobot> jvrbanac yeah, nova is using microversions now
20:34:14 <elmiko> i also saw neutron discussing this as well
20:34:49 <jvrbanac> interesting ok.
20:35:05 <elmiko> i think it really depends on how much the team expects to iterate on the api, it's really nice when you want to add many changes, some of which might not be backward compat.
20:36:14 <jvrbanac> Sounds like a good discussion to have
20:37:08 <jvrbanac> redrobot, that's all I had that agenda item. Just something for people to think about and bring to the midcycle
20:37:25 <jvrbanac> ^bring ideas to the midcycle
20:38:48 <jvrbanac> redrobot, did you die?
20:39:00 <redrobot> jvrbanac lol, not yet
20:39:09 <redrobot> ok moving on
20:39:20 <redrobot> #topic stable/kilo tests are failing
20:39:30 <redrobot> jaosorior you want to talk about this some more?
20:39:52 <jaosorior> Nah, just to raise awareness for people
20:40:10 <redrobot> jaosorior cool
20:40:12 <jaosorior> I didn't expect it to get mentioned int he beginning of the meeting. So yeah, that one's done
20:40:23 <redrobot> we did add the action item earlier in the meeting, so we'll be looking into that.
20:40:34 <redrobot> ok moving on
20:40:42 <redrobot> #topic Barbican Openstack CLI plugin
20:40:47 <redrobot> jaosorior also yours
20:41:18 <jaosorior> yup
20:41:21 <jaosorior> the CR is up https://review.openstack.org/#/c/198732/
20:42:02 <jaosorior> At the moment the plugin has some limitations
20:42:09 <redrobot> jaosorior Haven't really dug into it, but what's the deal with the command names?
20:42:22 <redrobot> would it make sense for them to be key-manager like the Governance repo change?
20:42:38 <jaosorior> redrobot: Well, I also intended there to be some discussion around those
20:42:59 <jaosorior> thing is, "container create" and such is taken
20:43:22 <jaosorior> and on the other hand, doing "orders" and operations with containers doesn't really make sense in the context of the openstack CLI
20:43:57 <jaosorior> so I intended that tto be more explicit by renaming it to something such as "secret order [create|delete...]"
20:44:34 <redrobot> hmm... would the secret abstractions make sense, you think?
20:44:47 <redrobot> or maybe something that is more akin to using openssl on the command linke
20:44:49 <redrobot> *line
20:44:53 <jaosorior> we also talked with the openstack-sdks fellows about the naming, and the discussion went around, using the project name prepended to the commands is not ideal
20:44:58 <redrobot> openstack key-gen rsa 2048
20:45:39 <jaosorior> well, if there are better suggestions, lets add them to that CR
20:46:00 <jaosorior> some people were ok with prepending "secret" to orders and containers, but if there are better ideas, they are very welcome
20:46:16 <redrobot> how closely does the CLI follow the other project abstractions, I wonder?
20:46:24 <jaosorior> what do you mean?
20:47:08 <redrobot> like, is there a 1:1 mapping of API resource to CLI command?
20:47:25 <alee> jaosorior, whats the suggestion for things like certificate orders?  not sure we would want "secret order ..." in this case.
20:47:29 <redrobot> or can we approach this from a "what would a CLI user want to do" point of view?
20:47:49 <elmiko> i think it's good to approach from the use-case point of view
20:47:55 <jaosorior> redrobot: IMO I would rather have it as "what would a CLI user want to do"
20:48:34 <jaosorior> redrobot: this is what exists at the moment http://pastebin.com/WWTmLa9w
20:49:15 <rm_work> ^^ that list does not include non-core projects like congress though, right?
20:49:28 <rm_work> which do things ... differently?
20:49:33 <jaosorior> rm_work: that is handled as plugins
20:49:42 <rm_work> this discussion was last week, way outside of my short-term memory :P
20:49:43 <jaosorior> so to enable a plugin you basically do a normal installation
20:49:49 <jaosorior> python setup.py install
20:49:54 <redrobot> the existing container is for Swift containers?
20:49:54 <rm_work> jaosorior: right, but as far as current usage examples
20:49:58 <jaosorior> and it is handled by the entrypoints that you set up in setup.cfg
20:49:58 <rm_work> and how other projects did their naming
20:50:25 <rm_work> IIRC one of their examples was "look how congress did their naming"
20:50:34 <jaosorior> redrobot, rm_work: By the way, that list has the barbican operations with the dash... because I had that installed in that virtual environment. The current CR doesn't have that dash
20:51:16 <jaosorior> rm_work: if you remember the conversation we had with the openstack-sdks folks, adding the project name before the commands was not very recommended, and we figured it wouldn't really be that appropriate usability wise
20:51:25 <elmiko> might we talk about castellan breifly, since we are short on time?
20:51:32 <jaosorior> alee: currently you have to add --request type if you would do a secret order create
20:51:33 <alee> jaosorior, huh ? so its "secret container create" instead of "secret-container create" ?
20:51:38 <kfarr> elmiko +1
20:51:41 <jaosorior> alee: yes
20:51:56 <alee> jaosorior, I like secret-container better
20:52:11 <jaosorior> alee: It breaks uniformity, that's why I had to switch it back to using spaces
20:52:14 <redrobot> elmiko yeah, let's move on to castellan
20:52:20 <jaosorior> we had that discussion with the openstack-sdks folks
20:52:25 <rm_work> yeah there are consistency issues
20:52:28 <rm_work> but +1 castellan
20:52:28 <redrobot> I don't think we're going to figure out the CLI stuff now
20:52:38 <redrobot> ok, moving on
20:52:41 <redrobot> #topic Castellan
20:52:48 <jaosorior> alee: But if it has a very different workflow and it would improve usability, we could do a command specifically for certificates, so we wouldn't need be adding all those extra params to the order create
20:53:00 <kfarr> On a side note about Castellan, there's a bunch of merge requests out there that could use some reviews
20:53:06 <elmiko> +1
20:53:06 <jaosorior> anyway, please give feedback in this CR https://review.openstack.org/#/c/198732/
20:53:13 <alee> jaosorior, yes
20:53:29 <rm_work> #link http://eavesdrop.openstack.org/irclogs/%23openstack-sdks/%23openstack-sdks.2015-07-23.log.html#t2015-07-23T14:38:59
20:53:34 <elmiko> i'm also very curious about the release schedule for castellan
20:53:41 <rm_work> ^^ discussion with openstack-sdk people
20:53:46 <woodster_> I don't see other projects using the dash in that list
20:53:48 <rm_work> useful to review so we don't go in circles
20:54:01 <elmiko> there are some features i've been waiting for before we interate with sahara, and i'd like to get them in for L3 so we can move our secrets out of sahara
20:54:03 <jaosorior> woodster_ No other project is, which is why we switched to using spaces instead of dashes
20:54:14 <jaosorior> I gotta go, talk to you guys tomorrow
20:54:15 <redrobot> elmiko release schedule is whenever kfarr or anyone else bugs me for a release :)
20:54:19 <elmiko> i'm curious if there will be a castellan release in the L3 timeframe?
20:54:23 <rm_work> redrobot: we need to merge some stuff first
20:54:26 <woodster_> jaosorior: oh got it
20:54:27 <elmiko> redrobot: ok, awesome.
20:54:37 <rm_work> there are about 3-4 CRs for Castellan that just need +A
20:54:39 <elmiko> rm_work: yes please =)
20:54:43 <redrobot> elmiko the release management team decided not to take ownership of Castellan
20:54:49 <redrobot> elmiko so I still own the release for that
20:54:51 <rm_work> and then a few more than need to be double-checked for merge conflicts and also merged
20:55:00 <elmiko> redrobot: cool, and release means push to pypi as well?
20:55:02 <rm_work> *that need
20:55:27 <redrobot> elmiko yes.  it's pretty easy actually.  Just use GPG to sign a git tag, and push it to the repo
20:55:39 <elmiko> i agree with kfarr and rm_work, maybe we could get a review sprint on this week, and talk about release dates sometime soon?
20:55:40 <redrobot> elmiko automation picks up the tag, verifies it, and then pushes the bundle to PyPI
20:55:48 <elmiko> redrobot: kickass
20:56:19 <redrobot> yeah... we can probably release next week during the mid-cycle
20:56:35 <elmiko> we should really merge some of these patches first though
20:56:44 <elmiko> and resolve whatever conflicts arise
20:56:53 <redrobot> elmiko agreed... I'll spend some time on those today hopefully.
20:56:58 <elmiko> \o/
20:57:03 <kfarr> thanks redrobot!
20:57:14 <rm_work> yeah most are ready to go
20:57:24 <redrobot> ok, that's all we have time for today.  See y'all next week, same time, same channel. :)
20:57:34 <redrobot> #endmeeting