20:00:19 <redrobot> #startmeeting barbican
20:00:20 <openstack> Meeting started Mon Oct 12 20:00:19 2015 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:23 <openstack> The meeting name has been set to 'barbican'
20:00:29 <redrobot> #topic Roll Call
20:00:38 <redrobot> As usual the meeting agenda can be found here:
20:00:42 <arunkant> o/
20:00:43 <kfarr> o/
20:00:46 <hockeynut> \o/
20:00:47 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:00:53 <silos> o/
20:00:56 <diazjf> o/
20:01:02 <tdink> o/
20:01:05 <jkf> o/
20:01:13 <dave-mccowan> o/
20:01:23 <edtubill> o/
20:01:38 <elmiko> o/
20:01:40 <redrobot> woot!  lots of barbicaneers here today
20:01:48 <redrobot> let's get started!
20:01:52 <woodster_> o/
20:01:52 <hockeynut> its a murder of barbicaneers
20:01:55 <redrobot> #topic Tokyo Summit
20:02:04 <redrobot> #link https://etherpad.openstack.org/p/barbican-m-design-sessions
20:02:24 <redrobot> A few items here
20:02:30 <rellerreller> o/
20:02:38 <redrobot> First, I added the topics for the fishbowls to the etherpad
20:02:58 <redrobot> unless someone really needs them to be flipped, I will go ahead and update the description on Sched to match.
20:03:11 <redrobot> Fishbowl 1: Wednesday, 12:05pm - Barbican Roadmap and Integration Status
20:03:17 <redrobot> Fishbowl 2: Wednesday, 2:00pm - Barbican Key Federation
20:03:40 <spotz> o?
20:04:07 <redrobot> spotz I think you really are here! ;)
20:04:18 <spotz> hehehe
20:04:28 <alee> o/
20:05:12 <lisaclark1> o/
20:05:13 <redrobot> I'm going to guess by the silence that everyone is on-board with the fishbowl topics
20:05:39 <rellerreller> I'm good +1
20:05:47 <hockeynut> good with me
20:05:52 <spotz> +1
20:05:54 <dave-mccowan> +1
20:06:12 <redrobot> I've also added a section to the etherpad to hopefully identify some Cross-project liaisons for the Summit
20:06:40 <redrobot> these would be folks who are interested in attending other project's design sessions to talk about possible Barbican integrations
20:07:18 <redrobot> For example hockeynut is our official QA (QE?) Cross-project liaison, so he'll probably be spending a lot of time with the QE folks
20:07:53 <redrobot> It would be good to identify someone to attend Magnum design sessions
20:07:54 <rellerreller> Do we have anyone familiar with Swift?
20:08:00 <hockeynut> redrobot I tried to do 50/50 @ Vancouver, will do the same in NRT
20:08:00 <alee> redrobot, sorry - whats the etherpad link again?
20:08:14 <rellerreller> https://etherpad.openstack.org/p/barbican-m-design-sessions
20:08:20 <rellerreller> alee ^
20:08:21 <redrobot> alee https://etherpad.openstack.org/p/barbican-m-design-sessions
20:08:23 <alee> thanks
20:08:26 <redrobot> rellerreller jinx!
20:09:08 <alee> redrobot, I'll go to the magnum sessions
20:09:08 <diazjf> rellerreller, I know some swift
20:09:19 <redrobot> alee awesome, thanks!
20:09:24 <rellerreller> diazjf are you attending the summit?
20:09:37 <diazjf> rellerreller, yeah I'll be there
20:09:45 <rellerreller> diazjf awesome!
20:10:13 <rellerreller> diazjf I know they have a spec out for a KeyMaster, which is almost identical to Castellan's KeyManager.
20:10:29 <alee> redrobot, I'll probably go talk with the Manila guys too
20:11:04 <hockeynut> redrobot I will sneak into some Neutron as well.
20:11:32 <diazjf> rellerreller, I have actually been working on that. jrichli on our team owns it.
20:11:56 <rellerreller> diazjf I thought you knew them. I thought you mentioned that at the mid-cycle.
20:12:12 <rellerreller> I would like to discuss that at some point.
20:12:36 <diazjf> rellerreller, yup a new version is in the works involving Castellan. Yes that would be great
20:13:16 <rellerreller> I wrote it on my white board under "Tokyo agenda" so it's official now.
20:13:35 <diazjf> ^rellerreller, awesome
20:14:37 <rellerreller> I may need to stop by Nova and Cinder. I'm not sure where we are with that yet.
20:14:49 <redrobot> alee hockeynut diazjf  feel free to add to the etherpad with the project's you'll also be working with.
20:14:54 <rellerreller> I don't know if they have the latest KeyManager from Castellan yet.
20:15:03 <hockeynut> ack
20:15:33 <alee> redrobot, rm_work whats the status of neutron/octavia with barbican?
20:15:55 <redrobot> #info Please vote on the etherpad by adding a +1 to topics you're interested in
20:16:08 <diazjf> redrobot, I'll add it under New Topics
20:16:18 <redrobot> The plan is to do the usual etherpad-driven design discussions from the last summit/mid-cycle
20:16:45 <redrobot> with the "big tent" our design time is a lot shorter than previous summits
20:16:56 <redrobot> so I want to focus on stuff that's important to everyone
20:17:21 <redrobot> #info notify redrobot if you think we need dedicated design sessions
20:17:22 <lisaclark1> redrobot: why did "big tent" shorten our design times?
20:17:24 <rellerreller> Do we vote on new topics and punted ones as well?
20:17:38 <redrobot> lisaclark1 lots more projects under the big tent now, not as much space to go around for everyone.
20:17:40 <rellerreller> I was not sure if punted items are still under consideration.
20:18:25 <redrobot> rellerreller that's why I think we should +1 individual topics
20:18:40 <redrobot> rellerreller we should be able to shake out what's still important from previous design topics
20:18:57 <rellerreller> What's the deadline for the voting?
20:19:16 <redrobot> Does next Monday's meeting sound reasonable?
20:19:29 <rellerreller> Is there a max number of votes or anything?
20:19:39 <rellerreller> Next Monday sounds reasonable to me.
20:20:04 <redrobot> rellerreller nah, i don't think we need to limit the amount of votes
20:20:24 <redrobot> just limit to one +1 per person per topic
20:21:15 <rellerreller> And these are votes for design session talks?
20:21:33 <rellerreller> There are things on here that interest me, but not necessarily enough to warrant a design session.
20:21:38 <redrobot> rellerreller yeah... well to get an idea of priorities for design session time
20:21:54 <rellerreller> OK, sorry for all of the questions.
20:22:08 <redrobot> rellerreller I don't want to limit to one topic per session because we only have a handful of them.
20:22:56 <redrobot> but I will definitely consider full session requests
20:23:12 <dave-mccowan> redrobot did you notice that you're on a panel at the same time as one of our design sessions?
20:23:23 <redrobot> last summit, for example, we had a full session dedicated to CA PLugins specifically to meet with Symantec folks that were unavailable at other times.
20:23:42 <redrobot> dave-mccowan have not noticed that...
20:24:02 <redrobot> dave-mccowan they're usually pretty good about not having conflicts... I may need to dust off my cloning machine :-\
20:25:46 <redrobot> Any other questions/comments about the summit, or planning before the summit?
20:26:46 <diazjf> meetups and parties^^ :)
20:26:50 <kfarr> Are there options to attend remotely?
20:26:58 <hockeynut> + oo diazjf
20:27:03 <kfarr> If one is willing to stay up for the time change, taht is
20:27:07 <kfarr> that
20:27:57 <lisaclark1> kfarr: we tried to do a remote vidyo session for some of our rackers during the vancouver summit and ran into challenges
20:27:58 <redrobot> kfarr I'm not sure what the rooms will be like... we can definitely plan to do a google hangout if there's interest
20:28:16 <kfarr> Ok!
20:28:28 <silos> I'd like to be a part of that as well!
20:29:03 <lisaclark1> kfarr, silos: if we get a google hangout going we can add the details on the design session etherpad
20:29:19 <kfarr> sounds good, thanks lisaclark1!
20:29:20 <redrobot> kfarr silos  ok, we'll plan for it... although as lisaclark1 pointed out, it wasn't an optimal way to get remote folks participating
20:29:39 <silos> ok.
20:29:50 <silos> thanks!
20:31:19 <redrobot> ok, moving on
20:31:28 <redrobot> #topic py34 update
20:31:41 <redrobot> dave-mccowan would you mind updating?
20:31:53 <dave-mccowan> as we all have noticed, there have been about 20 CRs over the last couple of months with weird byte vs. string patches
20:32:04 <dave-mccowan> victor and pradeep have done most of them
20:32:41 <dave-mccowan> the last few they got in the weeds with some of our our plugin code.  it's hard enough keeping base64 vs. text straight, and now bytes vs strings too.
20:32:51 <dave-mccowan> so, i did a big patch to finish up the rest of the tests.
20:32:53 <dave-mccowan> https://review.openstack.org/233633
20:33:19 <dave-mccowan> it has all the tests running, but requires oslo.serialization 1.10 which is not in global-requirements yet.
20:33:36 <dave-mccowan> but, please review mercilessly... especially the kmip stuff.
20:33:50 <dave-mccowan> after this, the PY34 CRs will stop.
20:34:07 <dave-mccowan> :-)  that's all.  any questions?
20:35:20 <dave-mccowan> i have a question... the goal per openstack now is to just get the code to be compatible.... not actually work.  right?  anyone know?
20:35:33 <kfarr> Thanks dave-mccowan!  Will take a look, and will look at the kmip changes in particular
20:35:55 <kfarr> Are they making changes that break things?
20:36:13 <dave-mccowan> python3 breaks All the Things
20:36:24 <redrobot> dave-mccowan hehe, I think the goal is to get the service to where deployers can run it on py3 if they choose to.
20:37:27 <dave-mccowan> i'd be really surprised if our functional tests worked with python3.  i'm not sure if it's worth trying.  i'd be curious to know if other projects have done more than unit tests.
20:39:37 <redrobot> dave-mccowan interesting... definitely a good challenge for someone wanting to get it running on py3
20:39:50 <redrobot> ok, moving on
20:39:58 <redrobot> #topic Liberty release notes
20:40:00 <redrobot> arunkant ping
20:40:13 <arunkant> redrobot: yes
20:40:26 <redrobot> #link http://lists.openstack.org/pipermail/openstack-dev/2015-October/076012.html
20:40:33 <redrobot> arunkant since you were asking about release notes
20:40:44 <redrobot> there was an ask on the mailing list to get those written up on the wiki
20:40:56 * hockeynut has to pick son up now.  <EOF>
20:40:56 <redrobot> I was wondering if you would want to write them arunkant ?
20:41:34 <arunkant> redrobot: let me check the mail.thanks for looking into this.
20:42:24 <redrobot> Lana Brindley messaged me about them over the weekend.  She said the doc team is willing to proofread, but they would like to have the wiki updated today...
20:42:27 <redrobot> well by EOB today anyway.
20:43:04 * rellerreller has to leave now
20:43:21 <arunkant> ok..let me check what is needed.
20:43:30 <redrobot> awesome, thanks arunkant
20:43:42 <redrobot> #action arunkant to write Liberty release notes in OpenStack wiki
20:44:30 <arunkant> redrobot: will ping  you if have questions
20:44:31 <redrobot> arunkant I know it's not a whole lot of time, so just let me know when you can get to it.
20:44:34 <redrobot> arunkant thanks!
20:45:13 <arunkant> redrobot: will look into this in next hour or so.
20:45:25 <redrobot> #topic Naughty project list
20:45:30 <redrobot> #link http://lists.openstack.org/pipermail/openstack-dev/2015-October/076559.html
20:46:18 <redrobot> we're on a list of projects that may break with an upcoming devstack change
20:47:19 <redrobot> it would be good to get things fixed up before it becomes a problem
20:47:35 <redrobot> I also noticed we were on another list of clients that may break, but I can't find the mail link right now
20:49:38 <redrobot> ... If I find it, i'll post it to our irc channel
20:49:55 <redrobot> anyone have time/interest into fixing the devstack issue?
20:51:37 <redrobot> #help we need someone to fix the devstack issue mentioned in http://lists.openstack.org/pipermail/openstack-dev/2015-October/076559.html
20:51:47 <redrobot> ok, that's all I have on the agenda for today
20:52:00 <redrobot> got a few minutes left
20:52:05 <redrobot> #topic Open Discussion
20:54:10 <silos> Is there a reason why the Orders Resource doesn't have an API page? I was going to create one unless there's a reason it didn't survive the migration from the old wiki to the new one.
20:55:30 <redrobot> silos I think it still needs to be moved/rewritten
20:55:42 <silos> redrobot: gotcha.
20:56:17 <redrobot> silos http://git.openstack.org/cgit/openstack/barbican/tree/doc/source/api.rst has some info on it
20:56:23 <redrobot> silos that page is an orphan though
20:56:30 <redrobot> silos so it's not getting built into the html site
20:56:59 <silos> redrobot: Ah I see. thanks for the link. I'll see what I can do.
20:57:00 <dave-mccowan> redrobot i don't think barbican is on the naughty anymore. http://goo.gl/6p8lvn
20:57:46 <dave-mccowan> silos certificates.rst  has some info too, but a full on orders doc would be awesome.
20:58:29 <silos> dave-mccowan: I noticed that. I'll reference certificates as an example. Some good examples in there.
21:01:42 <redrobot> alright y'all
21:01:44 <redrobot> we're out of time
21:01:50 <redrobot> thanks for coming!
21:01:53 <redrobot> #endmeeting