#openstack-meeting-alt: barbican

Meeting started by redrobot at 20:00:24 UTC (full logs).

Meeting summary

  1. Roll Call (redrobot, 20:00:37)
    1. https://wiki.openstack.org/wiki/Meetings/Barbican (redrobot, 20:01:30)

  2. Action Items from last meeting (redrobot, 20:02:13)
    1. http://eavesdrop.openstack.org/meetings/barbican/2015/barbican.2015-11-09-20.00.html (redrobot, 20:02:23)
    2. kfarr will be handling the Mitaka-1 release (redrobot, 20:05:05)
    3. ACTION: redrobot to review updated Federation usecases https://etherpad.openstack.org/p/barbican-federation-use-cases (redrobot, 20:07:49)

  3. Barbican Federation Use-Cases Detailed Overview (redrobot, 20:09:04)
    1. https://etherpad.openstack.org/p/barbican-federation-use-cases (redrobot, 20:09:25)
    2. everyone please review the federation use cases (redrobot, 20:12:55)

  4. Castellan Authentication compatibility for Swift (redrobot, 20:13:17)
    1. https://etherpad.openstack.org/p/swifjt-keymaster-with-castellan (diazjf, 20:13:37)
    2. https://etherpad.openstack.org/p/swifjt-keymaster-with-castellan (redrobot, 20:13:56)
    3. ACTION: diazjf to write blueprint to better define Context in Castellan (redrobot, 20:45:32)
    4. ACTION: diazjf to write a non-keystone auth middleware for Barbican (redrobot, 20:45:46)

  5. Barbican Garbage Collector (redrobot, 20:46:30)
    1. https://review.openstack.org/#/c/243806/ (edtubill, 20:46:54)
    2. https://blueprints.launchpad.net/barbican/+spec/barbican-cron-job-garbage-collector-for-database (edtubill, 20:46:54)

  6. Creating a castellan-specs repo (redrobot, 20:53:23)
    1. VOTE: Voted on "Should Castellan specs be tracked in barbican-specs or not?" Results are (redrobot, 20:58:21)


Meeting ended at 21:00:29 UTC (full logs).

Action items

  1. redrobot to review updated Federation usecases https://etherpad.openstack.org/p/barbican-federation-use-cases
  2. diazjf to write blueprint to better define Context in Castellan
  3. diazjf to write a non-keystone auth middleware for Barbican


Action items, by person

  1. diazjf
    1. diazjf to write blueprint to better define Context in Castellan
    2. diazjf to write a non-keystone auth middleware for Barbican
  2. openstack
    1. redrobot to review updated Federation usecases https://etherpad.openstack.org/p/barbican-federation-use-cases
  3. redrobot
    1. redrobot to review updated Federation usecases https://etherpad.openstack.org/p/barbican-federation-use-cases


People present (lines said)

  1. redrobot (94)
  2. rellerreller (45)
  3. notmyname (25)
  4. diazjf (20)
  5. kfarr (13)
  6. edtubill (12)
  7. woodster_ (9)
  8. elmiko (9)
  9. openstack (6)
  10. silos1 (5)
  11. arunkant (4)
  12. alee (4)
  13. jrichli (3)
  14. jvrbanac (3)
  15. spotz (1)
  16. jmckind (1)
  17. jkf (1)


Generated by MeetBot 0.1.4.