20:00:49 <rellerreller> #startmeeting barbican
20:00:50 <openstack> Meeting started Mon Nov 23 20:00:49 2015 UTC and is due to finish in 60 minutes.  The chair is rellerreller. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:53 <openstack> The meeting name has been set to 'barbican'
20:01:06 <rellerreller> #topic Roll Call
20:01:14 <kfarr> \o/
20:01:17 <diazjf> o/
20:01:18 <rellerreller> o/
20:01:21 <edtubill> o/
20:01:22 <jkf> o/
20:01:23 <arunkant> o/
20:01:26 <silos> \o/
20:01:28 <alee> o/
20:02:06 <rellerreller> as usual, the agenda can be found here:
20:02:13 <rellerreller> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:02:38 <rellerreller> a good amount of barbicaneers here! :)
20:03:46 <rellerreller> We can go ahead and get started.
20:03:50 <elmiko> o/
20:03:52 <spotz> o/ - late:)
20:04:07 <rellerreller> #topic Action Items from last meeting
20:04:18 <rellerreller> http://eavesdrop.openstack.org/meetings/barbican/2015/barbican.2015-11-16-20.00.log.html
20:04:36 <rellerreller> redrobot to review updated Federation usecases https://etherpad.openstack.org/p/barbican-federation-use-cases
20:04:43 <rellerreller> redrobot is not here today.
20:04:59 <rellerreller> This was a general action item for all those interested to review the use case.
20:05:11 <rellerreller> diazjf has there been any progress on this?
20:05:25 <rellerreller> I know that I forgot to do this :(
20:06:02 <diazjf> rellerreller not currently, redrobot was going to send it to someone at rackspace
20:06:19 <rellerreller> I think he wanted to send it to Joe
20:06:45 <rellerreller> I think we can keep this action item open.
20:07:08 <diazjf> correct, we will wait for Joe to take a look, but other than that any feedback in the etherpad would be great.
20:07:12 <rellerreller> #action everyone review the federation use cases https://etherpad.openstack.org/p/barbican-federation-use-cases
20:07:35 <rellerreller> Any other comments on this action item?
20:08:18 <rellerreller> OK, there was another action item from last week.
20:08:22 <rellerreller> diazjf to write blueprint to better define Context in Castellan
20:08:41 <rellerreller> diazjf any update on this?
20:09:00 <diazjf> rellereller, None yet, I will schedule a hangout with elmiko so we can go over our ideas.
20:09:30 <rellerreller> Can you post the date/time for this?
20:09:31 <elmiko> =)
20:09:41 <rellerreller> This way others may attend as well.
20:09:57 <diazjf> elmiko, should we do it tomorrow or after the holidays?
20:10:11 <diazjf> I'm free anytime tomorrow
20:10:18 <elmiko> diazjf: i could do it tomorrow
20:10:28 * elmiko checks calendar
20:10:34 <rellerreller> kfarr do you have time tomorrow?
20:10:51 <elmiko> i'm free most of the day (eastern u.s. time)
20:10:58 <kfarr> Yes, except for 11-noon (eastern time)
20:11:01 <rellerreller> kfarr I would like for one of us to attend if possible.
20:11:20 <diazjf> 2:00PM eastern sound good?
20:11:28 <elmiko> sounds good to me
20:11:31 <kfarr> sure!
20:12:02 <rellerreller> #info meeting at 2:00 PM ET to discuss to Castellan context objects
20:12:16 <elmiko> should we just meet on irc and go from there?
20:12:19 <diazjf> Perfect, I'll post the link to the hangout on IRC tomorrow 5 min till 2:00PM
20:12:26 <elmiko> cool. thanks diazjf !
20:12:49 <rellerreller> #info diazjf will post the link to the hangout on IRC tomorrow 5 min till 2:00PM
20:13:19 <rellerreller> There was one last action item from last week.
20:13:21 <rellerreller> diazjf to write a non-keystone auth middleware for Barbican
20:13:37 <alee> diazjf, rellerreller  I'm interested so I'll probably lurk a bit
20:13:56 <diazjf> rellerreller, that will also be discussed in the hangout
20:14:10 <rellerreller> I feel like that is probably not going to be done, and we should probably remove this as an open action item.
20:14:10 <diazjf> alee, awesome your more than welcome to join
20:15:06 <rellerreller> alee sounds good. The more people the better.
20:15:24 <rellerreller> That's it for action items unless there is anything else?
20:15:35 <rellerreller> #topic Mitaka-1 milestone
20:15:44 <rellerreller> kfarr will be handling the release.
20:15:53 <rellerreller> kfarr do you have everything you need for this? Are you comfortable with this?
20:16:03 <mixos> I will be there as well. have question for why castellan ctxt is not using session. :- )
20:16:45 <kfarr> rellerreller, yes I was looking into it.  It is do-able.
20:17:23 <rellerreller> Excellent. Do you have any questions or anything else that we need to discuss?
20:17:44 <rellerreller> I don't know who added this action item, so I'm not sure what to cover.
20:17:57 <kfarr> rellerreller, I think that must have been redrobot
20:18:12 <kfarr> I think elmiko was wanting to talk about Castellan!
20:18:16 <rellerreller> I was thinking the same thing.
20:18:43 <elmiko> i had questions for last meeting, but i think they will be answered in the hangout
20:19:21 <rellerreller> I only had one more minor topic.
20:19:24 <rellerreller> #topic Cinder volume encryption blog post
20:19:24 <kfarr> elmiko, sounds good
20:19:38 <rellerreller> dave-mccowan or alee I thought I heard this morning that you will be posting a blog post on this. Is that true?
20:19:47 <rellerreller> Could you provide more details?
20:19:53 <lisaclark1> o/
20:21:06 <alee> rellerreller, thats one of the things I'm working on right now
20:21:39 <rellerreller> Cool. Can you post a link when that is done?
20:21:44 <alee> rellerreller, I just finished testing out / getting the latest liberty barbcuian packages working for RDO
20:21:46 <rellerreller> I would like to read it.
20:22:00 <rellerreller> alee +1
20:22:27 <alee> and so am writing some blogs on how to work with them, how to set up baarbican with ipa, and how to set up volume encryption
20:22:47 <alee> in particular you want to set it up the barbican behind https
20:22:57 <elmiko> nice
20:22:59 <rellerreller> Is there some explanation of how RDO works?
20:23:06 <alee> I had it all working for my demo in tokyo , so this is a writeup on all that
20:23:31 <rellerreller> Sounds very cool.
20:23:40 <alee> some - rdo is just the upstream release of red hat openstack
20:24:22 <alee> so it will be red hat/fedora focused in that sense. - but yeah , I'll post link
20:24:28 <rellerreller> I used it once before. It worked for a single node deployment for me. I was curious as to how it worked and how to configure it.
20:24:43 <alee> and make sure folks can get to it
20:25:00 <rellerreller> #action alee to post blog post on testing Cinder volume encryption with Barbican and RDO
20:25:25 <alee> rellerreller, well I'm not going to go into rdo director and what not -- the work to integrate barbican/ipa into that - esp fr volume encryption is actively being worked on
20:25:34 <alee> by me and jaosorior
20:25:58 <rellerreller> alee ok
20:26:48 <rellerreller> That was every thing on the agenda for today.
20:26:56 <rellerreller> #topic open discussion
20:27:17 <rellerreller> Is there anything else that anyone wants to discuss?
20:27:40 <arunkant> i have nova patch for https://bugs.launchpad.net/nova/+bug/1505930 ..can some barbicaneer review and provide their blessings?
20:27:40 <openstack> Launchpad bug 1505930 in OpenStack Compute (nova) "Fix key manager service endpoints in devstack Nova ephemeral" [Undecided,In progress] - Assigned to Arun Kant (arunkant-uws)
20:28:20 <arunkant> the issue is around nova keymgr usage for ephermeral encryption..
20:28:53 <alee> rellerreller, kfarr sounds like something you guys should look into ..
20:29:11 <rellerreller> Yes, I definitely want to look into this.
20:29:19 <alee> arunkant, I'm curious - so I'll look too.
20:29:31 <kfarr> alee, arunkant, yes, I had taken a look at it
20:29:43 <rellerreller> #action kfarr to investigate Nova key manager bug https://bugs.launchpad.net/nova/+bug/1505930
20:29:43 <openstack> Launchpad bug 1505930 in OpenStack Compute (nova) "Fix key manager service endpoints in devstack Nova ephemeral" [Undecided,In progress] - Assigned to Arun Kant (arunkant-uws)
20:29:43 <arunkant> thanks alee, rellerreller ..
20:30:05 <lisaclark1> rellerreller: i wanted to chat about the January midcycle
20:30:12 <kfarr> I think it would be solved by replacing the keymgr with Castellan -- if not, then maybe the bug fix should go into Castellan
20:30:28 <rellerreller> lisaclark1 sounds good. We can discuss next.
20:30:32 <alee> rellerreller, in case anyone missed the conversation rellerreller and I had with redrobot on irc -- the midcycle is going to be in Jan in San Antonio.
20:30:48 <alee> but lisaclark1 -- go ahead :)
20:30:53 <rellerreller> #topic Barbican mid-cycle
20:30:58 <lisaclark1> thanks alee :-)
20:31:33 <lisaclark1> yes, midcycle in Jan in San Antonio.  Rackspace has also committed to the OSSP group to support an overlapping midcycle in the San Antonio location
20:32:20 <alee> cool beans -- are there hotels in which Rackspace has a preferred rate?
20:32:24 <lisaclark1> rellerreller, alee: has an etherpad or eventbrite been started to capture date/time/location details and signup?
20:32:40 <alee> lisaclark1, not that I know of
20:32:47 <lisaclark1> alee: i can work on pulling together a few hotel recommendations.
20:32:48 <rellerreller> I don't think so.
20:33:09 <arunkant> kfarr: yes castellan seems to have the same issue. It will be good to have this fix in current impl as it will allow this change to backport (internal, not on openstack side) in liberty.
20:33:22 <alee> lisaclark1, sounds like a good thing to add to the eventbrite page
20:33:28 <rellerreller> #action lisaclark1 to pull together a few hotel recommendations
20:34:19 <rellerreller> lisaclark1 what are the official dates?
20:34:33 <lisaclark1> dates for barbican midcycle will be Jan 11-13, OSSP midcycle Jan 12-15
20:35:28 <rellerreller> #info Barbican mid-cycle in San Antonio, TX January 11-13 and OSSG mid-cycle January 12-15
20:35:46 <lisaclark1> there will be an overlap and we're evaluating rooms that will allow for easy dropins between the 2 groups.  i would recommend though that any barbicaneers wanting to participate in the non-overlapping OSSP days, to please signup on the OSSP etherpad
20:35:57 * rellerreller enjoys using the info and action item hash tags :)
20:36:13 <lisaclark1> lolz
20:36:25 <alee> lisaclark1, where is that etherpad?
20:37:02 <rellerreller> lisaclark1 will be in the same place where it was the last time we met in San Antonio?
20:37:30 <alee> lisaclark1, it may be worthwhile seeing if there should be some joint sessions .. seeing as we all in the same place.
20:37:32 <lisaclark1> rellerreller: we're trying to secure spaces at the Rackspace Castle location
20:38:17 <lisaclark1> rellerreller: the previous San Antonio location was at Geekdom
20:38:29 <rellerreller> lisaclark1 I would think that the Barbican area of the Castle would always be available to us.
20:38:52 <alee> rellerreller, have to get by the castellan first ..
20:39:00 <spotz> heheh
20:39:13 <lisaclark1> alee: i think there's definitely opportunities for joint sessions
20:39:33 * alee gotta run .. have fun storming the castle!
20:40:58 <rellerreller> Anything else on this topic?
20:41:24 <arunkant> one thing..can someone triage this barbican bug.. https://bugs.launchpad.net/barbican/+bug/1518510
20:41:24 <openstack> Launchpad bug 1518510 in Barbican "Barbican config values not available via oslo_config.cfg.CONF handle" [Undecided,New]
20:42:06 <lisaclark1> please set an action item for me to provide an eventbrite link, and I'll include important details for the upcoming midcycle there.
20:42:33 <rellerreller> #action lisaclark1 to provide an eventbrite link
20:43:29 <rellerreller> Last chance to bring up any other topics.
20:44:00 <silos> old patch, needs some love: https://review.openstack.org/#/c/236123/2
20:44:57 <edtubill> can I get somepeople to review this spec for garbage collection: https://review.openstack.org/#/c/243806/
20:45:20 <rellerreller> #topic patches that need review
20:45:47 <rellerreller> silos has https://review.openstack.org/#/c/236123/
20:46:00 <rellerreller> edtubill has https://review.openstack.org/#/c/243806/
20:46:10 <rellerreller> Anything else that is blocking anyone's progress?
20:47:11 <elmiko> i'm curious in general about when the next castellan release will be pressed?
20:47:12 <rellerreller> diazjf has one for user metadata https://review.openstack.org/#/c/229995/
20:47:46 <rellerreller> #topic Castellan release schedule
20:47:50 <elmiko> \o/
20:48:03 <rellerreller> elmiko I don't know what the release schedule is for Castellan.
20:48:24 <rellerreller> I believe the last time we cut a release was because we needed a new feature to be integrated with other libraries.
20:48:25 <kfarr> elmiko, a schedule hasn't really been sorted out.  I suppose it could align with the openstack releases, meaning the next one could be next week
20:48:27 <elmiko> i kinda thought it was whenever kfarr felt like there was enough to do a release =)
20:48:33 <rellerreller> Is there a feature that you need?
20:48:47 <kfarr> haha elmiko, yes, is there a feature you need?
20:48:50 <elmiko> the updated fix to options.set_defaults is nice
20:48:55 <elmiko> adding the auth_url in
20:49:21 <elmiko> would be nice to get that out, and then bump the global-reqs
20:49:43 <kfarr> elmiko, got it, I can work on it
20:49:50 <elmiko> kfarr: thanks!
20:50:01 <rellerreller> #action kfarr to work on next release of Castellan
20:50:23 <elmiko> it might be nice to have castellan released around the same time as openstack releases, or even a little before so that the global-requirements can be updated.
20:50:36 <rellerreller> +1
20:50:48 <elmiko> i'm not super-knowledgeable on the release side of things though, so i'd be curious to hear someone from infra's thoughts on this.
20:51:28 <kfarr> elmiko, good point
20:51:44 <rellerreller> I usually just ask redrobot. I have no idea how all of that works.
20:52:18 <elmiko> no worries, i'm just thinking about issues i'm running into as a consumer of castellan
20:53:41 <rellerreller> elmiko I agree.
20:54:04 <rellerreller> I would like to see Castellan be managed in a more pragmatic way, so others know what to expect.
20:54:29 <rellerreller> We are starting to get some traction with other projects, and I think we need to be more systematic.
20:54:32 <elmiko> definitely, i see this as a growth process for castellan
20:54:40 <elmiko> rellerreller: +1
20:54:41 <kfarr> rellerreller, yes, that's fair
20:55:09 <rellerreller> Sounds like a great topic for the mid-cycle
20:56:13 <rellerreller> OK, we only have a few minutes left here.
20:56:27 <rellerreller> Is there anything else?
20:56:52 <elmiko> nothing from me
20:57:12 <rellerreller> OK, let's call it a meeting.
20:57:18 <rellerreller> Have a good day everyone.
20:57:28 <rellerreller> Enjoy your Thanksgiving!
20:57:45 <rellerreller> #endmeeting