20:00:49 <redrobot> #startmeeting barbican
20:00:50 <openstack> Meeting started Mon Jan 25 20:00:49 2016 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:54 <openstack> The meeting name has been set to 'barbican'
20:00:57 <redrobot> #topic Roll Call
20:01:00 <woodster_> o/
20:01:03 <silos> \o/
20:01:04 <jhfeng> o/
20:01:10 <kfarr> o/
20:01:14 <elmiko> heyo/
20:01:17 <edtubill> o/
20:02:05 <maxabidi> o/
20:02:09 <redrobot> good to see al the IBMers show up on time :)
20:02:10 <alee> o/
20:02:17 <silos> hehe
20:02:59 <hockeynut> o/
20:03:00 <redrobot> alrighty... a little litght on barbicaneers today
20:03:00 <jhfeng> except fernando who is on vacation
20:03:01 <mp1> o /
20:03:14 <redrobot> but that's ok.
20:03:19 <redrobot> let
20:03:24 <redrobot> let's get this started
20:03:27 <redrobot> #topic Action Items
20:03:33 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2016/barbican.2016-01-18-20.00.html
20:03:40 <redrobot> All action items were mine,
20:03:54 <redrobot> I did sync up with Anne Gentle IRL
20:04:14 <redrobot> the docs team would like us to publish the User Guide to docs.openstack.org
20:04:59 <spotz> o/
20:05:10 <redrobot> probably end up here somehwere: http://docs.openstack.org/user-guide/
20:05:17 <elmiko> neat
20:05:29 <redrobot> They sent me a link to the Nova patches that got their piece of the user-guide there
20:05:29 <arunkant> o/
20:05:51 <redrobot> I don't have much time to look into it now, but if anyone is interested I could give you more details offline
20:06:15 <redrobot> I did not have time to look into the security bugs, so I'm punting on those
20:06:19 <redrobot> #action redrobot to check on status of reported security bug
20:06:23 <pdesai> redrobot, i will be interested, can you please forward me the details
20:06:28 <redrobot> #action redrobot to ping ccneill about the nova+cinder security bug
20:06:49 <diazjf_in_miami> O/
20:06:49 <redrobot> hi pdesai !  I'll shoot you an email with the details of what needs to be done.
20:06:52 <panatl> o/
20:06:53 <jmckind> o/
20:06:56 <pdesai> sure thanks
20:07:12 <redrobot> #action redrobot to send pdesai details about publishing the user-guide
20:07:31 <redrobot> ok, that's it for Action items, let's move on...
20:07:38 <redrobot> #topic Liaison Updates
20:07:59 <redrobot> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
20:08:13 <redrobot> Oslo - no updates from me
20:08:24 * redrobot did not really pay much attention at the oslo meeting today :-\
20:08:46 <redrobot> Release Management - (also mine) - Barbican Mitaka-2 was released last week
20:09:07 <redrobot> it was a bugfix release again, since we just recently started merging blueprints
20:09:15 <kfarr> \o/
20:09:19 <redrobot> QA - hockeynut - any updates?
20:09:41 <hockeynut> redrobot the tailgaters group is no more - been consumed by other QA groups (Rally, etc)
20:09:54 <hockeynut> redrobot other than that, just keepin' on keepin' on
20:10:03 <redrobot> awesome, thanks for the update hockeynut
20:10:10 * redrobot has no idea what the tailgaters are
20:10:32 <redrobot> alee any updates from Magnum?
20:10:35 <hockeynut> was a group looking at more complete openstak cloud testing (beyond just gate, tempest, etc)
20:10:52 <alee> redrobot, no sorry -- missed their meeting last week
20:10:58 <redrobot> no worries
20:11:05 <redrobot> ok, that's it for cross-project liaisons
20:11:08 <redrobot> let's move on
20:11:19 <redrobot> #topic BYOK Spec
20:11:27 <redrobot> #link https://review.openstack.org/#/c/271517/
20:11:34 <redrobot> diazjf_in_miami taking a vacation break to talk about this?
20:12:02 <diazjf_in_miami> Redrobot yup
20:12:11 <diazjf_in_miami> On my cellphone lol
20:12:31 <elmiko> hehe
20:12:40 <elmiko> that's dedication ;)
20:13:01 <diazjf_in_miami> I just wanted everyone to check it out. I need to add the listed projects as well. Thanks elmiko :)
20:13:12 <redrobot> I'm picturing diazjf_in_miami sitting in the middle of Miami beach squinting to try to see the phone through the sun glare... ;)
20:13:23 <elmiko> haha, redrobot++
20:13:35 <diazjf_in_miami> Redrobot you're not wrong ;)
20:14:12 <redrobot> ok, well let's get some eyes on that spec
20:14:24 <diazjf_in_miami> Also I wanna know the process of getting a fish bowl together for the summit
20:14:37 <diazjf_in_miami> Thanks!
20:14:40 <redrobot> diazjf_in_miami I'm guessing you'll be getting the security folks to review as well?
20:14:51 <diazjf_in_miami> Redrobot for sure
20:15:01 <redrobot> diazjf_in_miami awesome, thanks for the update
20:15:22 <redrobot> ok, moving on
20:15:35 <redrobot> #topic Blueprint: Multiple-backends
20:15:45 <redrobot> #link https://review.openstack.org/#/c/263972/
20:16:00 <woodster_> diazjf_in_miami:  the spec would need a security flag on it for a formal security review I think
20:16:00 <redrobot> looks like woodster_ and rellerreller have been giving feedback on there
20:16:19 <redrobot> woodster_  it's in the security-specs repo, so I imagine they'll be looking at it anyways
20:16:25 <diazjf_in_miami> Woodster_ security flag?
20:16:39 <redrobot> diazjf_in_miami SecurityImpact
20:16:44 <redrobot> ...
20:16:51 <redrobot> back to the current topic... :-P
20:17:03 <diazjf_in_miami> Woodster_ redrobot gotcha thanks
20:17:11 <redrobot> looks like we're making progress addressing the outstanding concerns
20:17:27 <redrobot> I'm concerned that this may not land in time for Mitaka
20:17:40 <redrobot> arunkant please take a look at the recent reviews
20:17:54 <arunkant> redrobot: Did not get time to look into spec and address remaining questions..will add updated version this week..to keep it going
20:17:57 <redrobot> this is a pretty big change, and I don't want to rush it ...
20:18:10 <redrobot> so we'll play it by ear and check up next week.
20:18:14 <redrobot> arunkant thanks
20:18:19 <redrobot> ok, moving on
20:18:22 <redrobot> #topic Blueprint Reviews
20:18:28 <redrobot> https://review.openstack.org/#/q/project:openstack/barbican-specs+status:open
20:18:49 <redrobot> there's a few that already have +2s... hoping we can land those in the next day or two
20:19:45 <redrobot> silos did you ever get a chance to prioritize the Launchpad BPs?
20:20:02 * redrobot looks
20:20:08 <redrobot> nope doesn't look like it
20:20:08 <silos> redrobo: no sorry, got caught up with other things
20:20:15 <redrobot> silos no worries
20:20:37 <redrobot> I just wanted to point out that we do still have a launchpad page to track blueprint priorities
20:20:39 <redrobot> #link https://blueprints.launchpad.net/barbican
20:20:55 <redrobot> although they're not quite accurate right now, silos and I will be updating the priority on those
20:21:36 <redrobot> that's all I have on the agenda for today
20:21:50 <redrobot> #topic Open Discussion
20:21:58 <redrobot> any other topics we should talk about while we're here?
20:22:16 <elmiko> yea, i wanted to pass on a thanks to the barbican/castellan teams
20:22:29 <elmiko> as of M2, sahara has full barbican integration =)
20:22:36 <kfarr> Hooray!
20:22:38 <redrobot> woot!  that's awesome news elmiko !
20:22:48 <hockeynut> woot woot!
20:22:50 <woodster_> \o/
20:22:51 <diazjf_in_miami> Great news!!
20:22:59 <elmiko> so yea, good job all, and many thanks for all the help!
20:23:07 <redrobot> diazjf_in_miami we need to add that to our Barbican slides! :D
20:23:11 <silos> awesome!
20:23:20 * redrobot cheers all around
20:23:38 <diazjf_in_miami> Redrobot, for sure! I'll help you out in San Antonio March or April!
20:24:40 <alee> that reminds me -- I'm curious what talks folks are proposing for the summit in austin?
20:24:58 <alee> redrobot, do we have a list of them anywhere?
20:25:04 <redrobot> alee  not yet
20:25:11 <redrobot> alee do you want to start an etherpad to track them?
20:25:22 <diazjf_in_miami> Alee we need something in before Feb 1! Pretty close deadline
20:25:36 <alee> right
20:25:49 <redrobot> I don't have any planned, but an engineer from Mirantis asked me to sit in a talk about OpenStack security... not entirely sure what he wants me to talk about.
20:26:20 <elmiko> security!
20:26:23 <elmiko> ;)
20:26:23 <alee> redrobot, I dont have any planned yet either - but I can set up an etherpad
20:26:48 <alee> redrobot, we should try to get at least some barbican related talks though ..
20:26:52 <redrobot> elmiko lol... I figured
20:27:19 <redrobot> I want to buy one of those new Yubikeys... they have PCKS#11 support now, so maybe we can use them as a backend to Barbican....
20:28:02 <redrobot> if I could get that to work, I could do a talk like "Ghetto Barbican" or something like that ;)
20:28:35 <alee> redrobot, any feedback from the designate folks?
20:28:49 <redrobot> alee  none yet
20:29:01 <redrobot> #action redrobot to touch base with Designate folks
20:29:07 <redrobot> alee  I'll try to make it to their meeting this week.
20:29:25 <elmiko> redrobot: +1 for ghetto barbican, you could even have a container with a preconfig'd barbican lol
20:31:02 <redrobot> elmiko ... put like 8 yubikeys in a USB hub, and then run the containers on that same host...  on-demand-ghetto-barbican! lol
20:31:10 <elmiko> haha, love it!
20:31:24 <elmiko> "yes, yes it scales."
20:31:29 <redrobot> lol
20:32:02 <redrobot> hehe... anyway...  if you do submit a talk let us know in the channel so we can help, or at least upvote it.
20:32:26 <redrobot> anything else before we call it an early day?
20:33:05 <silos> I got an old patch that's been sitting around ready for a workflow: https://review.openstack.org/#/c/240339/
20:33:18 <silos> If people have some free time.
20:33:39 <redrobot> silos  I may possibly have some free cycles if we end this meeting early :)
20:33:47 <elmiko> redrobot: gotta combine the yubkey with this https://www-ssl.intel.com/content/www/us/en/compute-stick/intel-compute-stick.html perfect portable barbican
20:34:14 <redrobot> elmiko ooooh!  ... I wonder if it has any usb ports?
20:34:19 <elmiko> it does
20:34:28 <elmiko> i think the new one has 2 or maybe 3 ports
20:34:48 <redrobot> elmiko oh man!  I think I might actually try to make this talk a reality
20:34:58 <redrobot> also it would give me an excuse to get some new toys
20:34:59 <elmiko> yuss =)
20:35:57 <elmiko> "Dude where's my key? Barbican on the go." ?
20:35:58 <alee> redrobot, https://etherpad.openstack.org/p/barbican-austin-summit-talks
20:36:15 <redrobot> haha, thanks alee
20:37:05 <diazjf_in_miami> Title a talk "keep Openstack weird" may work since we'll all be in Austin!
20:37:54 <elmiko> haha, yes!
20:38:25 <alee> it would be nice to have some talks on actual barbican deloyments / performance testing ..
20:39:11 <redrobot> alee I don't think we'll have enough Rackspace data for a talk this summit... definitely something we want to talk about in the fall summit though.
20:39:11 <jhfeng> alee: we're planning proposal one
20:39:12 <elmiko> alee: +1
20:39:18 <jhfeng> still working on details
20:39:44 <alee> jhfeng, excellent -- please add to wiki when its there :)
20:40:11 <jhfeng> redrobot: right, getting per data is a hard part right now
20:40:21 <woodster_> redrobot:  you're not saving the good talks for the Nov summit are you? :)
20:40:28 <jhfeng> s/per/perf
20:40:31 <redrobot> woodster_ totally am
20:42:34 <redrobot> alrighty y'all seems like we're out of things to talk about
20:42:40 <redrobot> thanks for coming, everyone!
20:42:43 <redrobot> #endmeeting