20:00:53 <redrobot> #startmeeting barbican
20:00:54 <openstack> Meeting started Mon Feb  1 20:00:53 2016 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:57 <openstack> The meeting name has been set to 'barbican'
20:01:11 <redrobot> #topic Roll Call
20:01:15 <kfarr> o/
20:01:15 <jmckind> o/
20:01:21 <woodster_> o/
20:01:24 <silos> \o/
20:01:27 <pdesai> o/
20:01:27 <jhfeng> o/
20:01:36 <diazjf> o/
20:01:41 <mp1> o /
20:01:46 <edtubill> o/
20:02:20 <redrobot> #topic Action Items
20:02:35 <redrobot> I've totally been slacking on these.  I did manage to complete 1/4
20:02:49 <maxabidi> 0/
20:02:52 <maxabidi> o/
20:03:20 <redrobot> I sent pdesai some details regarding the doc team ask of publishing our API guide on docs.openstack.org/api-guide
20:03:34 <redrobot> but I'll have to punt on the other thee action items
20:03:41 <redrobot> #action edrobot to check on status of reported security bug
20:03:50 <redrobot> #undo
20:03:51 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0x9377c10>
20:04:04 <redrobot> #action redrobot to check on status of reported security bug
20:04:10 <redrobot> #action redrobot to ping ccneill about the nova+cinder security bug
20:04:20 <redrobot> #action redrobot to touch base with Designate folks
20:04:30 <redrobot> clear
20:04:40 * redrobot needs some coffee
20:04:45 <rellerreller> o/
20:04:45 <redrobot> ok, moving on
20:04:53 <redrobot> #topic Liaison Updates
20:05:16 <redrobot> I don't have anything to report today...  any of our other liaisons have anything to update on?
20:05:33 <pdesai> yup i received your email redrobot, we need two patches for it, before we get started with those patches, it will be great to have this merged: https://review.openstack.org/#/c/236123/11 (userguide on orders)
20:05:54 <alee> o/
20:06:13 <redrobot> pdesai agreed
20:06:15 <redrobot> hi alee !
20:06:21 <redrobot> alee any updates from Magnum?
20:06:45 <alee> no updates
20:07:02 <redrobot> alrighty
20:07:10 <redrobot> moving on to today's agenda
20:07:14 <elmiko> o/
20:07:15 <alee> sorry - I've been focused on getting ready for conferenrce this week
20:07:22 <redrobot> alee  no worries
20:07:31 <redrobot> #topics Castellan Object Patches
20:07:44 <redrobot> #topic Castellan Object Patches
20:07:54 <redrobot> diazjf o/
20:08:20 <diazjf> So rellerreller and kfarr have provided excellent feedback. I was concerned on wether we should limit the parameters or include all possible keystone parameters for auth
20:08:55 <diazjf> See comments in https://review.openstack.org/#/c/270602/
20:08:55 <arunkant> o/
20:09:27 <diazjf> https://review.openstack.org/#/c/270602/2/castellan/common/credentials/keystone_password.py
20:09:55 <diazjf> I agree with rellerreller and will update the patch tonight
20:10:26 <redrobot> diazjf awesome
20:10:27 <rellerreller> :)
20:10:36 <redrobot> #topic Google Hangouts
20:10:39 <redrobot> diazjf another one of yours
20:10:44 <diazjf> yup :)
20:10:57 <diazjf> ok so I wanted to setup 2 google hangout sessions this week
20:11:03 <diazjf> 1 to go over BYOK
20:11:10 <jkf> o/
20:11:12 <diazjf> 2 to help alee with puppet
20:11:36 <diazjf> Just wanted to see if there was any interest in going over these topics this week
20:11:46 <rellerreller> +1 for BYOK
20:12:04 <alee> diazjf, I'd love to set up a session but I'll bve travelling/ in conference for most of the week.
20:12:15 <kfarr> diazjf +1 BYOK
20:12:30 <diazjf> rellerreller, kfarr, how do you feel about Tuesday or Wednesday?
20:12:46 <diazjf> alee, we'll talk then when you get back
20:12:57 <rellerreller> Tuesday is better for me
20:13:10 <kfarr> either works for me, afternoons are better
20:13:24 <rellerreller> 3:00 PM ET Tuesday?
20:13:30 <alee> diazjf, if you like , we can talk a bit after this meeting.
20:13:40 <diazjf> rellerreller, perfect
20:13:50 <diazjf> alee, sure we can talk a little about it
20:13:50 <rellerreller> kfarr ?
20:14:01 <alee> diazjf, ok - lets do that
20:14:02 <kfarr> rellerreller, diazjf +1 for 3
20:15:29 <diazjf> awesome, so I have nothing else
20:15:43 <redrobot> diazjf awesome, thanks
20:15:50 <redrobot> ok, moving on
20:15:54 <redrobot> #topic Blueprints
20:16:05 <redrobot> we still have a lot of blueprints in review
20:16:12 <redrobot> and there's only 4 weeks of development time left
20:16:22 <redrobot> before the feature freeze release
20:16:50 <silos> I updated the ones on launchpad in barbican that had the 'mitaka' release target
20:17:02 <redrobot> silos awesome!  you da man!
20:17:18 <silos> redrobot: thx!
20:17:20 <redrobot> #link https://blueprints.launchpad.net/barbican
20:18:52 <redrobot> Also please take a look at the open specs for review
20:18:55 <redrobot> #link https://review.openstack.org/#/q/project:openstack/barbican-specs+status:open
20:19:10 <redrobot> that's all we had on the agenda for today
20:19:16 <redrobot> #topi Open Discussion
20:19:31 <redrobot> are there any other topics we should talk about while we're here?
20:19:33 <woodster_> Please review this CR, as it adds missing contraint/defaults when setting up database via alembic: https://review.openstack.org/#/c/274276/
20:20:10 <rellerreller> Any proposed talks for Austin?
20:20:40 <jkf> I'd like to get some more eyes on the pkcs11 padding bug fix I submitted, so it can get merged... https://review.openstack.org/#/c/270572
20:20:41 <redrobot> rellerreller good question
20:20:44 <redrobot> #link https://etherpad.openstack.org/p/barbican-austin-summit-talks
20:20:50 <hockeynut> o/ better late than never!
20:20:54 <redrobot> rellerreller ^^ we have an etherpad to track those
20:21:20 <redrobot> today is the last day to propose talks, so if you have something in mind, today would be the day to put an abstract in!
20:21:38 <panatl> o/
20:21:44 <arunkant> redrobot: can core reviewer look into audit patch https://review.openstack.org/#/c/217523/ ..has been pending for a while.
20:22:02 <hockeynut> rellerreller noooooo!
20:22:17 * hockeynut is looking for the attendance etherpad
20:22:19 <rellerreller> hockeynut ?
20:23:49 <arunkant> _wooster: Can you please look into this again (sqlaclhemy connection leak) : https://review.openstack.org/#/c/263358/
20:24:03 <arunkant> s/_wooste/_woodster
20:24:14 <jhfeng> redrobot: we submitted one. I'll add it into the etherpad
20:26:26 <woodster_> arunkant:  will do
20:27:23 <redrobot> any other topics we should talk about?
20:27:28 <arunkant> thanks woodster_
20:27:30 <redrobot> if not we can be done with the meeting early today.
20:28:05 <arunkant> redrobot: I did update the https://review.openstack.org/#/c/263972/
20:28:25 <redrobot> arunkant awesome
20:28:39 <redrobot> woodster_ rellerreller can you guys please re-review arunkant 's BP
20:29:00 <arunkant> redrobot: looks like most of rellerreller questions/concerns were answered in previous patch discussion.
20:29:00 <redrobot> I'm concerned that it probably won't land for mitaka since it's such a big change.
20:29:28 <rellerreller> I would not say that all of my concerns are gone.
20:29:59 <arunkant> redrobot: It depends on how soon this is approved.
20:29:59 <rellerreller> One feature that is common to PKCS11 and KMIP is key wrapping. I think that needs to be worked out before agreeing to this.
20:30:58 <arunkant> rellerreller: Please mention the details of issue in patch. As per earlier comments, transport key should not be a concern.
20:31:01 <rellerreller> I think this should be discussed in Austin.
20:32:11 <arunkant> rellerreller: summit is over 2 months away..will be good to have some progress before that.
20:32:23 <redrobot> rellerreller +1 ...  I think it should be good to iterate on the Blueprint before then though.
20:32:44 <rellerreller> redrobot +1
20:33:37 <redrobot> ok y'all
20:33:45 <redrobot> seems like we're out of topics for today
20:34:00 <redrobot> so we all get 25 min of our day back. :)
20:34:04 <elmiko> \o/
20:34:07 <redrobot> don't forget to review!
20:34:12 <redrobot> #endmeeting