20:01:20 <redrobot> #startmeeting barbican
20:01:21 <openstack> Meeting started Mon Feb 29 20:01:20 2016 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:22 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:25 <openstack> The meeting name has been set to 'barbican'
20:01:30 <woodster_> redrobot's true identity is revealed
20:01:31 <redrobot> better
20:01:34 <redrobot> haha
20:01:40 <redrobot> #topic Roll Call
20:01:48 <rellerreller> o/
20:01:48 <kfarr> o/
20:01:51 <woodster_> o/
20:01:51 <diazjf> o/
20:01:52 <jmckind> o/
20:01:56 <elmiko> o/ (sorta)
20:02:01 <jkf> o/
20:02:24 <edtubill> o/
20:02:34 <redrobot> Lots of barbicaneers here today
20:02:41 <redrobot> as usual our agenda can be found here:
20:02:45 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican#Agenda
20:02:53 <redrobot> and anyone is allowed to add topics
20:03:02 <redrobot> and it looks like a couple of you did!
20:03:40 <alee> o/
20:03:46 <dave-mccowan> o/
20:03:52 <silos> o/
20:04:16 <redrobot> #topic Action Items from last meeting
20:04:23 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2016/barbican.2016-02-22-20.00.html
20:04:39 <redrobot> Looks like there was just one unassigned action item.
20:04:51 <redrobot> which should probably be a #help item, not an #action item.
20:04:53 <redrobot> so
20:05:32 <redrobot> #help We need someone to take over Adam Harwell's CR
20:05:41 <redrobot> #link https://review.openstack.org/#/c/251168/
20:06:06 <panatl> 0/
20:06:08 <panatl> o/
20:06:25 <woodster_> I thought someone did offer to take it over last week?
20:06:56 <redrobot> woodster_ I didn't see anyone assigned to the action item... but I was also only here for like 5 min last week
20:07:10 <redrobot> diazjf did anyone volunteer to pick up Adam's CR?
20:07:27 <diazjf> I believe mp1
20:07:33 <diazjf> wanted to take a look at it
20:07:46 <diazjf> I'll ask him to join
20:07:52 <panatl> me . for https://review.openstack.org/#/c/251168/
20:07:59 <panatl> i did .. please assigned to me
20:08:15 <panatl> please assing to me ... https://review.openstack.org/#/c/251168/
20:08:28 <panatl> will catch up with rm_work .. if have any questions
20:08:28 <redrobot> hi panatl !  I don't think I've met you before.  Would you mind introducing yourself?
20:08:46 <panatl> we did ... in San antonio
20:08:47 <panatl> :)
20:08:50 * redrobot is terrible with names... and even worse with IRC handles
20:08:52 <panatl> was with Arun
20:08:53 <mp1> o/
20:08:56 <mp1> super late sorry
20:09:03 <redrobot> hi mp1
20:09:20 <panatl> redrobot: we met .. i am Pankaj Khandar from HPE
20:09:32 <redrobot> mp1 we were just wondering if you signed up to work on https://review.openstack.org/#/c/251168/ ?
20:09:54 <redrobot> panatl I do remember you!  ...  just didn't know your handle :)
20:10:06 <panatl> cheers from silos :)
20:10:20 <redrobot> mp1 if not panatl was willing to work on it
20:10:22 <mp1> I did, but it looks like panatl volunteered to work on it in the meeting last week?
20:10:50 <mp1> I'm busy with https://review.openstack.org/#/c/282059/
20:11:01 <redrobot> mp1 ok, sounds good
20:11:20 <redrobot> #action panatl will take over rm_work's CR https://review.openstack.org/#/c/251168/
20:11:31 <redrobot> ok, moving on
20:11:40 <redrobot> #topic Liaison Updates
20:11:41 <panatl> thanks!
20:11:56 <redrobot> #link http://wiki.openstack.org/wiki/CrossProjectLiaisons
20:12:19 <redrobot> I missed the oslo meeting this morning (shame on me)
20:12:50 <redrobot> hockeynut_afk any news from QE/QA?
20:12:56 <redrobot> guess not since afk
20:13:09 <hockeynut_afk> redrobot nosiree
20:13:34 <redrobot> pdesai1 ping
20:13:41 <pdesai1> hey
20:14:05 <redrobot> hi pdesai1 !  I noticed our Doc liaison is outdated, and it reminded me that you're doing a ton of doc work
20:14:17 <pdesai1> yup i am working on it
20:14:19 <redrobot> pdesai1 just wondering if you had an update on the api-guide work?
20:14:31 <pdesai1> have two patches ready for review
20:14:40 <pdesai1> https://review.openstack.org/#/c/285519/1
20:14:51 <pdesai1> working on Andreas comment
20:15:00 <pdesai1> https://review.openstack.org/#/c/284368/
20:15:04 <pdesai1> is ready for review
20:15:24 <pdesai1> there are lot of reference and doc changes as the location of .rst files have changed
20:15:34 <pdesai1> under userguide
20:15:34 <redrobot> pdesai1 awesome, thanks!
20:15:37 <pdesai1> sure
20:16:41 <diazjf> pdesai1 I'll help review those as well
20:16:52 <pdesai1> thanks diazjf
20:17:20 <redrobot> ok, moving on to the actual agenda
20:17:25 <redrobot> #topic  Code Freeze, burr!
20:17:34 <redrobot> #link https://etherpad.openstack.org/p/barbican-m-spec-crs
20:17:55 <redrobot> So diazjf was nice enough to put the etherpad together with links to outstanding blueprint work
20:18:03 <redrobot> we should try to get these landed no later than Wednesday
20:18:12 <redrobot> I want to be able to cut RC1 this Thursday
20:18:19 <redrobot> or M3 I guess
20:18:35 <diazjf> redrobot perfect.
20:18:46 <redrobot> #link http://releases.openstack.org/mitaka/schedule.html
20:19:11 <redrobot> we should probably aim to release a Mitaka python-barbicanclient as well
20:19:33 <redrobot> I already have a CR in review for a python-barbicanclient release
20:19:38 <redrobot> but it still needs a bit more work
20:19:51 <redrobot> also there's been a couple of bugs reported that we may want to fix before then...
20:21:11 <silos> redrobot: I've been looking at some of the bugs. We should start the discussion for the v2 client as soon as possible because some are very hard to fix without revamping the client.
20:21:45 <redrobot> silos yeah... one of the reasons we slacked on releasing the client was that I didn't really want to commit to supporting the openstack-client bits right off the bat
20:21:59 <redrobot> but I think we can call those "beta" this release and then change them without too much trouble.
20:22:29 <silos> redrobot: OK. sounds good.
20:23:11 <redrobot> any questions about M3 or the Code Freeze?
20:23:13 <alee> redrobot, is the alternate auth stuff going to make it in castellan?
20:23:26 <alee> redrobot, is there going to be a castellan release?
20:24:05 <kfarr> alee redrobot, that's the next thing on the agenda!
20:24:24 <alee> kfarr, awesome
20:24:39 <diazjf> redrobot, so everything needs to be merged by Wednesday? hopefully :)
20:25:50 <redrobot> diazjf yes, hopefully by Wednesday EOB.  I'll be focusing on reviews today and probably Wednesday as well.
20:25:59 <redrobot> alee kfarr yeah, I'll cover that next.
20:26:11 <diazjf> redrobot, awesome thanks
20:26:19 <redrobot> ok, moving on
20:26:24 <redrobot> #topic Castellan releases
20:26:37 <redrobot> So the first thing I should point out is that Castellan is not managed by the release team:
20:26:40 <redrobot> #link Castellan releases
20:26:43 <redrobot> #undo
20:26:44 <openstack> Removing item from minutes: <ircmeeting.items.Link object at 0x9e175d0>
20:26:52 <redrobot> #link http://git.openstack.org/cgit/openstack/governance/tree/reference/projects.yaml#n41
20:27:05 <kfarr> Yes, and I had cut a few Castellan releases in the past
20:27:14 <redrobot> Note that only the Barbican Service and python-barbicanclient are managed by the release team.
20:27:35 <redrobot> so in theory we should be able to release Castellan whenever we feel like we need a release.
20:28:29 <diazjf> redrobot, kfarr, alee, rellerreller, after the secret metadata stuff gets merged I'll be 100% in finishing the castellan auth stuff
20:28:38 <kfarr> The reason I put Castellan releases on the meeting minutes was because I wanted to cut a Castellan release now
20:28:52 <kfarr> and wanted to ask the community if anyone wanted me to wait
20:29:06 <diazjf> kfarr, would next week be possible
20:29:19 <rellerreller> kfarr do you need it released for any dependent patches in other projects?
20:29:25 <diazjf> I just need tests for the castellan auth stuff to be done
20:29:36 <redrobot> That said... I'm not sure how the dependency management for Mitaka affects Castellan
20:29:39 <rellerreller> kfarr or do you want to wait for the auth stuff?
20:30:02 <kfarr> How soon do we think the auth stuff will be finished?
20:30:24 <diazjf> kfarr, if no problems on the user metadata stuff, I'd say Friday
20:32:40 <kfarr> Ok, that's fine.  I don't need it immediately, but it would be nice soon
20:32:53 <kfarr> alee, was there a reason you were interested in a new release?
20:32:57 <redrobot> kfarr do you need this new release to be used by other projects in the Mitaka release?
20:33:18 <alee> kfarr, no - just curious as to status
20:33:29 <kfarr> I do need it eventually, but right now I'm working around not having it
20:33:52 <alee> kfarr, I plan to use it for some cinder work later on
20:33:59 <redrobot> kfarr we may want to look into the version ceiling for Mitaka... I think the upper constraints are going to be set soon.
20:34:59 <redrobot> kfarr not a huge deal since we can always backport into a branch that meets the version requirements for the upper constraints, but it's definitely easier if the upper constraints include the new release.
20:35:30 <kfarr> redrobot ok yeah, I don't know how project-specific version ceilings get set
20:36:00 <redrobot> kfarr it's part of openstack/requirements ... but I'm not 100% sure on when they get locked down for the final cycle release.
20:36:44 <diazjf> kfarr, I'll see if I can get the tests ready for review by Wednesday
20:36:53 <redrobot> #action redrobot to look into upper constraints for Castellan across projects in the Mitaka release
20:37:01 <redrobot> kfarr I'll ping you when I find out what the deal is
20:37:11 <kfarr> redrobot ok cool!
20:37:42 <redrobot> anything else on Castellan releases?
20:37:54 <kfarr> That's it for me!
20:38:02 <redrobot> ok, moving on
20:38:06 <redrobot> #topic Open Discussion
20:38:13 <redrobot> Any other topics/questions we should talk about?
20:38:18 <rellerreller> Any news on design session?
20:38:26 <redrobot> rellerreller oh yes!  Thanks
20:38:40 <redrobot> The organizers pinged me last week to ask about space requirements.
20:39:44 <redrobot> let's start an etherpad to capture design session topics for the Summit
20:39:49 <redrobot> #link https://etherpad.openstack.org/p/newton-barbican-design-sessions
20:40:20 <redrobot> If we can get topics in there in the next day or two that'll give me a good idea of what our space requirements look like.
20:41:54 <redrobot> Also, to avoid the time-suck of the CMS split discussions that happend in Tokyo
20:42:15 <redrobot> let's try to only add topics that we know we are willing to work on for the cycle.
20:42:38 <redrobot> also avoid content-type talks
20:42:45 <redrobot> unless it's v2 content-types ;)
20:43:24 <diazjf> no CMS, no content-types, this is gonna be a weird summit ;-)
20:43:33 <redrobot> lolol
20:43:37 <redrobot> we can talk CMS
20:43:43 <redrobot> but only if someone is ready to do the work
20:44:17 <rellerreller> How do the cross-project topics work?
20:44:48 <rellerreller> Do we still propose under Barbican and indicate that it is a cross-project, or is there a cross-project submission forum or something?
20:44:52 <redrobot> rellerreller there's usually an email that goes out with a link to an openstack-hosted service where topics get proposed
20:45:37 <redrobot> rellerreller those submissions get reviewed by the tc, and then the top X talks get chosen for the cross-project track
20:45:44 <redrobot> which usually happens a day before the regular design sessions
20:45:54 <diazjf> reminder BYOK -> https://review.openstack.org/#/c/271517/
20:46:23 <rellerreller> diazjf That's exactly what I was thinking. BYOK seems to be quite popular.
20:47:22 <diazjf> rellerreller, yeah I think os-security will be involved in that as well
20:47:50 <redrobot> There's a party at the summit, and it's BYOK
20:48:16 <rellerreller> I'm expecting a lot of interested parties there. Plus add in the fact that every service will need to have API changes to support it, and it sounds like a long, tedious process.
20:48:43 <rellerreller> I love BYOK parties!
20:49:29 <redrobot> any other topics we should talk about?
20:49:38 <redrobot> if not we could all get 10 min of our day back
20:49:50 <rellerreller> Is anyone familiar with Keystone policy resources?
20:50:25 <elmiko> what do you mean exactly?
20:50:35 <rellerreller> I saw that in the API and was wondering if any other projects are using it.
20:50:45 <elmiko> ah, gotcha. not sure
20:50:50 <rellerreller> What kinds of policy are being stored there?
20:51:01 <pdesai1> that API is for creating new policies
20:51:05 <pdesai1> nothing is stored by default
20:51:32 <rellerreller> It gets stored and then you can retrieve it according to the API.
20:51:38 <pdesai1> the idea is to convert the policy.json file and store policies from there into db
20:52:25 <pdesai1> yup as a deployer you can create whatever policy is appropriate for your deployment and retrieve it back
20:52:40 <rellerreller> Awesome opossum!
20:52:51 <pdesai1> db takes higher precedence over policy.json which is configurable
20:53:32 <rellerreller> Thanks pdesai1 !
20:53:45 <pdesai1> sure rellerreller
20:53:59 <elmiko> pdesai1++
20:54:03 <pdesai1> :)
20:54:29 <rellerreller> That's all I had.
20:54:46 <redrobot> woot!  finished with 5 min to spare
20:54:50 <mp1> this patch is ready for review: https://review.openstack.org/#/c/282059/ if anyone has spare cycles to take a look at it
20:54:50 <redrobot> thanks for coming everyone!
20:54:50 <elmiko> hehe
20:55:09 <redrobot> in the nick of time mp1
20:55:11 <redrobot> #endmeeting