20:00:08 <redrobot> #startmeeting barbican
20:00:09 <openstack> Meeting started Mon Mar  7 20:00:08 2016 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:12 <openstack> The meeting name has been set to 'barbican'
20:00:19 <redrobot> #topic Roll Call
20:00:24 <hockeynut> o/
20:00:27 <mp1> o/
20:00:29 <edtubill> o/
20:00:30 <diazjf> o/
20:00:33 <randallburt> o/
20:00:34 <arunkant> o/
20:00:36 <maxabidi> o/
20:00:36 <silos> \o/
20:00:40 <jhfeng> o/
20:00:48 <woodster_> o/
20:01:34 <redrobot> alright, lots of barbicaneers here today
20:01:41 <rellerreller> o/
20:01:42 <redrobot> #topic Action Items from last meeting
20:01:44 <kfarr> o/
20:02:32 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2016/barbican.2016-02-29-20.01.html
20:02:50 <redrobot> redrobot to look into upper constraints for Castellan across projects in the Mitaka release
20:02:53 <redrobot> which I did
20:03:46 * redrobot is digging for link
20:03:53 <jkf> o/
20:04:19 <redrobot> #link https://github.com/openstack/requirements/blob/master/upper-constraints.txt#L83
20:04:31 <redrobot> ^^ is where the upper constraints for castellan are defined
20:05:42 <redrobot> ok, moving on
20:05:58 <redrobot> #topic Liaison Updates
20:06:06 <redrobot> #link https://wiki.openstack.org/wiki/CrossProjectLiaisons
20:06:27 <redrobot> Unfortunately I missed the oslo meeting this morning. :(
20:06:43 <redrobot> I'll read the logs later and find out if anything interesting happened.
20:06:52 <redrobot> any updates from other liaisons?
20:06:55 <redrobot> hockeynut QE?
20:06:58 <hockeynut> nosiree
20:07:09 <panatl> o/
20:07:12 <redrobot> ok, moving on then.
20:07:29 <hockeynut> is that a question from panatl ?
20:07:29 <redrobot> #topic Mitaka-3
20:08:49 <redrobot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/088409.html
20:08:54 * redrobot is slow with the links today
20:09:01 <redrobot> Mitaka-3 was released
20:09:13 <redrobot> the linked ML message has the link to the tarball
20:09:36 <redrobot> we had to move the configurable-soft-delete blueprint to FFE since it didn't merge before the release was tagged.
20:09:45 <redrobot> I think that should be our only FFE for this cycle.
20:10:36 <redrobot> any questions/comments about Mitaka-3 milestone?
20:10:42 <redrobot> or code freeze?
20:11:37 * redrobot hears crickets
20:11:39 <redrobot> ok moving on
20:11:44 <randallburt> chirp chirp
20:12:00 <redrobot> #topic OpenStack Bug Squash
20:12:45 <redrobot> There's a global bug-smashing event happening soon
20:12:54 <randallburt> its today, isn't it?
20:12:55 <hockeynut> soon=now
20:12:56 <redrobot> oh hey, it's actually today
20:13:04 <redrobot> #link https://www.eventbrite.com/e/global-openstack-bug-smash-san-antonio-tickets-20926594006
20:13:36 <redrobot> I should've checked the dates on that way sooner than today.
20:13:48 <redrobot> I was going to invite our Austin friends to come down to the Castle for this
20:14:14 <redrobot> but it would have been better to plan this in advance.
20:14:22 <redrobot> everyone is still welcomed to come down I guess?
20:14:27 <diazjf> redrobot, edtubill and I are down :)
20:14:45 <redrobot> diazjf that would be awesome!
20:15:06 <redrobot> it's a distributed thing too, so anyone can participate remotely as well
20:15:28 <redrobot> and since we're in code freeze now, it's the perfect time to squash some bugs!
20:16:57 <kfarr> redrobot do you have any advice for cores for reviewing and merging code?
20:16:58 <redrobot> ok, moving on
20:17:10 <kfarr> should only bug fixes be merged at this point?
20:17:23 <redrobot> kfarr yes, only bugfixes for the next few weeks.
20:17:26 <jmckind_> 0/
20:17:46 <kfarr> got it
20:18:12 <redrobot> kfarr probably worth discussing in its own topic
20:18:19 <redrobot> #topic Mitaka RC1
20:18:21 <redrobot> #link http://releases.openstack.org/mitaka/schedule.html
20:18:42 <redrobot> the target release date for Mitaka RC1 is the week of March 14-18
20:18:52 <redrobot> so from now until then we should only merge bugfxies
20:18:56 <redrobot> *bugfixes
20:19:05 <randallburt> plus the FFE, yes?
20:19:15 <redrobot> randallburt yes, but I think the FFE is complete now
20:19:16 <randallburt> assuming its approved or whatever the process is
20:19:21 <randallburt> ah, cool
20:19:35 <redrobot> randallburt BP was already complete... there was a patch in review that didn't merge before M-2
20:19:41 <randallburt> cool
20:19:42 <redrobot> *M-3
20:20:30 <redrobot> once RC1 is tagged sometime next week, then master will become Newton and we can start merging new BPs
20:20:52 <redrobot> which is a nice segway into
20:20:57 <redrobot> #topic Newton Blueprints
20:21:51 <redrobot> In the spirit of having more time to review BPs, and merging them early so we can start working on implementations with plenty of time before the first N milestone, we should start proposing BPs for N now
20:22:14 <redrobot> I've got the ball rolling on the first one:
20:22:16 <redrobot> #link https://review.openstack.org/#/c/286318/
20:22:33 <redrobot> it's a BP that was approved for L but did not get implemented
20:22:57 <redrobot> per our policy I'm submitting it for re-review for the new cycle, to make sure it still makes sense
20:24:34 <redrobot> Any questions about Mitaka RC1 or Newton Blueprints?
20:25:13 <rellerreller> redrobot are you going to -2 all of the other bps?
20:25:31 <rellerreller> Should the authors of those bps abandon them?
20:25:36 <redrobot> rellerreller yeah, we should probably do that
20:25:46 <redrobot> rellerreller not abandon, just edit to target newton instead of mitaka
20:26:20 <rellerreller> It's just that there are so many old specs now.
20:26:48 <rellerreller> About 14/20 are from 2015.
20:26:59 <randallburt> we could say that if they aren't adopted for N and are older than X they'll be administratively abandoned.
20:27:01 <redrobot> rellerreller hmm...  I suppose we can abandon the really old ones.
20:27:10 <randallburt> give a deadline of N1 or something
20:27:13 <redrobot> randallburt +1
20:27:45 <redrobot> #action redrobot to -2 pending CRs with a note to resubmit for N and a deadline to mark them as abandoned.
20:29:13 <redrobot> ok, moving on
20:29:22 <arunkant> redrobot: Please do not abandon https://review.openstack.org/#/c/263972/ (Multiple backend) ..I will move to Newton.
20:29:37 <redrobot> arunkant no problem.
20:29:49 <redrobot> arunkant we probably won't mark any as abandoned until n-1
20:30:37 <redrobot> #topic Space Requirements for Austin Design Summit
20:30:41 <redrobot> #link https://etherpad.openstack.org/p/newton-barbican-design-sessions
20:31:06 <redrobot> As I mentioned last week, we have an etherpad to record design session items in Austin
20:31:50 <redrobot> it's pretty small so far
20:32:13 <redrobot> and I'm using it to gauge how much space we'll need
20:32:17 <redrobot> including fish-bowls if any
20:32:40 <rellerreller> How will some of these work if other projects have the same proposal?
20:32:42 <redrobot> diazjf do you know if the security folks are going to do a fishbowl for the BYOK stuff?  Or should we plan to have a fish-bowl about it?
20:32:55 <rellerreller> For instance byok is proposed here and likely by security project.
20:33:18 <redrobot> rellerreller hopefully we can plan to avoid doubling up on sessions
20:33:25 <diazjf> redrobot, I'm not sure, I can email Robert later today
20:33:44 <redrobot> rellerreller we ask the OpenStack overlords for space... but we may not get all the space we ask for
20:33:44 <rellerreller> redrobot or maybe double our time to have a lot of discussion :)
20:34:08 <redrobot> rellerreller yeah, I think for sure we'll want to have the contributors meetup 1/2 day
20:34:19 <redrobot> rellerreller and maybe 10ish design sessions
20:34:24 <redrobot> I wasn't sure about fishbowls though
20:34:43 <redrobot> rellerreller kfarr do we want to fish-bowl any castellan features?
20:35:00 <kfarr> for upcoming features?
20:35:18 <kfarr> I feel like most of the upcoming work will be with integration into other projects
20:35:23 <rellerreller> I'm not sure if any are cross-project.
20:35:41 <rellerreller> The key manager/project configuration is kind of cross-project.
20:36:09 <redrobot> Maybe we should do a fish-bowl on the new auth features with some code samples on how to use them?
20:36:21 <rellerreller> Basically what the code will look like in each of the services, but I'm not sure how much discussion outside of our community would be needed.
20:36:46 <rellerreller> redrobot that's cool with me.
20:37:00 <kfarr> redrobot, rellerreller, +1
20:37:04 <rellerreller> redrobot I say combine that with per project key manager. They are related.
20:37:33 <redrobot> rellerreller think a single fish-bowl for both will be enough?
20:37:43 <redrobot> or should we ask fro 2 ?
20:37:58 <rellerreller> redrobot Right now I think 1 should be enough.
20:38:12 <redrobot> rellerreller ok, sounds good
20:38:16 <rellerreller> redrobot I can provide more details on etherpad for a possible agenda.
20:38:19 <diazjf> kfarr, rellerreller, redrobot, I will help you out wuth the auth_stuff
20:38:30 <redrobot> diazjf awesome!
20:38:31 <rellerreller> Then we can discuss more to see if one or two sessions.
20:38:39 <rellerreller> diazjf +1
20:38:55 <diazjf> I'll start preparing slide sometime this week
20:40:19 <arunkant> rellerreller: about keymanager/project configuration ..is this something proposed on castellan side or barbican server side ?
20:40:34 <rellerreller> castellan
20:41:05 <arunkant> okay..was looking if this in lines of multiple backend..thanks
20:41:09 <rellerreller> arunkant same problem space as yours, but I want to move it up a level.
20:41:55 <rellerreller> We have similar problem, and I believe if we solve it at castellan level then both of us are happy.
20:42:20 <arunkant> rellerreller: is there any doc for this proposal available?
20:42:35 <rellerreller> arunkant not yet
20:42:46 <rellerreller> arunkant I'm working on documentation.
20:43:06 <rellerreller> arunkant it will take a little bit of time to get through prepub.
20:44:36 <redrobot> ok, I think I can get a space request out now
20:44:40 <redrobot> thanks rellerreller
20:44:52 <redrobot> that's all I had on the agenda today
20:44:56 <redrobot> #topic Open Discussion
20:45:07 <redrobot> Anything else we should talk about?  CRs to review?
20:45:20 <rellerreller> redrobot are there abstracts or design session desriptions needed?
20:45:46 <rellerreller> redrobot or will you tell OpenStack this is our space request and here are the session titles?
20:46:00 <redrobot> I'll ask for 1-2 fishbowls.  We'll need abstracts for those since they go to the main schedule
20:46:02 <rellerreller> redrobot I'm wondering what I need to get through prepub.
20:46:13 <diazjf> If anyone has free cycles they can checkout https://review.openstack.org/#/c/262684/
20:46:19 <redrobot> the workroom sessions don't need descriptions
20:46:22 <diazjf> ^ Just Barbican validation
20:46:26 <redrobot> neither does the 1/2 meetup
20:46:34 <rellerreller> redrobot I'll work on some session descriptions.
20:46:42 <redrobot> awesome, thanks rellerreller
20:46:56 <redrobot> #action rellerreller to work on fish bowl descriptions
20:48:34 <redrobot> diazjf will look at it in a bit
20:48:57 <diazjf> redrobot gracias
20:49:09 <redrobot> anything else?  If not we can get 10 minutes of our day back...
20:49:21 <diazjf> redrobot, I'll let you know by the end of the day if we can go to the bug squashing event
20:50:06 <redrobot> diazjf cool... I have a few meetings tomorrow, but I could probably sneak out for a while.  Definitely going to try to be there most of Wednesday.
20:50:29 <diazjf> redrobot, awesome
20:50:43 <redrobot> ok, then, thanks for coming everyone!
20:50:48 <redrobot> #endmeeting