20:02:33 <redrobot> #startmeeting barbican
20:02:35 <openstack> Meeting started Mon Mar 14 20:02:33 2016 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:02:36 <fungi> though reading further in scrollback, is the question just whether it's acceptable to make the e-mail addresses of refstack data submitters public knowledge? as long as they know up front that's happening, i don't see why it would be a concern. for example every one of our thousands of developers ahs their e-mail addresses published in git commit messages
20:02:39 <openstack> The meeting name has been set to 'barbican'
20:02:45 <redrobot> #topic Roll Call
20:02:48 <edtubill> o/
20:02:48 <jmckind_> o/
20:02:49 <elmiko> o/
20:02:50 <panatl> o/
20:02:54 <kfarr> o/
20:02:57 <diazjf> o/
20:03:00 <woodster_> o/
20:03:10 <redrobot> As usual the agenda can be found here:
20:03:12 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican#Agenda
20:03:21 <silos> o/
20:03:26 <mp1> o/
20:03:26 <redrobot> Lots of barbicaneers here today!
20:04:12 <maxabidi> \o
20:04:18 <redrobot> #topic Action Items from last meeting
20:04:21 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2016/barbican.2016-03-07-20.00.html
20:04:30 <arunkant> o/
20:04:33 <redrobot> First action item was for me to -2 pending CRs.
20:04:59 <redrobot> no progress to report, so I'm punting to next week
20:05:04 <randallburt> o/ late
20:05:08 <redrobot> #action redrobot to -2 pending CRs with a note to resubmit for N and a deadline to mark them as abandoned
20:05:22 <redrobot> Looks like rellerreller isn't here
20:05:31 <redrobot> so we'll punt on his action item as well.
20:05:42 <redrobot> #action rellerreller to work on fish bowl descriptions
20:05:51 <redrobot> ok, on to the actual agenda
20:06:15 <redrobot> #topic Critical fixes for python-barbicanclient in Mitaka
20:06:33 <kfarr> redrobot he is working on the fish bowl descriptions
20:06:46 <redrobot> kfarr awesome, thanks for the update
20:07:10 <redrobot> for this topic
20:07:29 <redrobot> Doug Hellman is fixin' to create stable branches for mitaka for the clients
20:07:30 <redrobot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/088853.html
20:07:51 <redrobot> Currently we have a 4.0.0 tag that could be used as the stable branch in Mitaka
20:08:09 <redrobot> unless we have critical fixes that need to land for use by other projects in Mitaka
20:08:30 <redrobot> If we do create the stable branch, then we will have to backport future fixes
20:08:51 <redrobot> Questions/comments?  Any bugs we absolutely need to fix in a 4.0.X ?
20:09:29 <silos> So what does this mean for outstanding patches? Like could we still merge outstanding CR's today cause it looks like some are waiting to be merged.
20:09:53 <alee_> o/
20:10:17 <redrobot> silos so, if we want to include those patches in Mitaka, then we need to do another release after they land
20:10:27 <silos> ah k.
20:12:21 <redrobot> going once ...
20:12:44 <redrobot> lots of shy barbicaneers here today ;)
20:13:16 <elmiko> sorry, no strong barbican opinions from me today ;)
20:13:22 <redrobot> #topic Design Session topics for Austin Summit
20:13:23 <randallburt> silence is consent
20:13:29 <elmiko> haha, nice
20:13:58 <redrobot> Just a reminder that we have an etherpad to track design session topics
20:13:58 <redrobot> #link https://etherpad.openstack.org/p/newton-barbican-design-sessions
20:14:23 <redrobot> Any questions/comments?
20:14:58 <jmckind_> good list so far
20:14:58 <diazjf> redrobot, kfarr, any word on BYOK. I wont be available tomorrow so I was wondering if you can check for me during the security meeting.
20:15:09 <alee_> redrobot, how many sessions do we have?
20:15:44 <redrobot> alee_ they're still sorting that out.  I requested 2 fishbowls, 8 Design Sessions, 1 Meetup
20:15:52 <kfarr> diazjf, redrobot we hope to get the description through internal review soon, hopefully this week
20:16:08 <redrobot> I'll let y'all know when I hear what the official allocation is
20:16:20 <diazjf> kfarr, awesome. I'll be collaborating with you and rellerreller then :)
20:18:36 <redrobot> any other questions?
20:19:54 <redrobot> ok then, movin gon
20:19:56 <redrobot> *moving on
20:20:03 <redrobot> #topic Open Discussion
20:20:08 <redrobot> that's all I had on the agenda for today.
20:20:15 <redrobot> Any other topics we should talk about?
20:20:22 <redrobot> Pending reviews?
20:20:23 <redrobot> oh yeah
20:20:29 <redrobot> #topic RC1 due this week
20:20:46 <redrobot> We fixed some bugs last week during the bugsquash
20:21:13 <redrobot> I fixed one bug that I'm hoping I can land in the next couple of days
20:21:34 <redrobot> silos diazjf any other reviews pending form the bugsquash?
20:22:05 <silos> I have one for alembic. Let me get the link.
20:22:05 <diazjf> redrobot, yuppo
20:22:18 <diazjf> all minor
20:22:20 <silos> https://review.openstack.org/#/c/292523/
20:22:28 <silos> If it gets merged we can use alembic in the gate :D
20:22:34 <diazjf> https://review.openstack.org/#/c/290765/
20:22:52 <diazjf> https://review.openstack.org/#/c/291454/
20:23:02 <diazjf> https://review.openstack.org/#/c/287523/
20:23:16 <diazjf> and https://review.openstack.org/#/c/284368/
20:23:20 <diazjf> are all the bugs I see
20:23:26 <diazjf> and silos
20:23:56 <redrobot> diazjf silos thanks
20:24:07 <diazjf> no prob
20:24:07 <redrobot> core reviewers, please take a look at those
20:24:13 <silos> np
20:24:29 <diazjf> redrobot, also do we want to make sure the Barbican API Guide gets published to the site
20:24:55 <redrobot> diazjf doc publication isn't tied to the release, so we don't need it to release RC1
20:25:02 <diazjf> redrobot, gotcha
20:26:10 <redrobot> any other topics?
20:27:04 <diazjf> **cricket cricket**
20:27:15 <silos> diazjf beat me to it.
20:27:33 <redrobot> ok, seems like we've got ourselves an extra 30 min of workday
20:27:39 <elmiko> \o/
20:27:40 <redrobot> thanks for coming everyone!
20:27:45 <redrobot> #endmeeting