20:00:35 <redrobot> #startmeeting barbican
20:00:36 <openstack> Meeting started Mon Mar 21 20:00:35 2016 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:41 <openstack> The meeting name has been set to 'barbican'
20:01:15 <redrobot> #topic Roll Call
20:01:19 <hockeynut> o/
20:01:20 <mp1> o/
20:01:20 <elmiko> o/
20:01:21 <maxabidi> \o
20:01:28 <kfarr> o/
20:01:28 <silos> \o/
20:01:32 <diazjf> o/ here
20:01:34 <arunkant> o/
20:02:00 <panatl> o/
20:02:17 <redrobot> lots of barbicaneers here today!
20:02:32 <redrobot> as usual the agenda can be found here:
20:02:41 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican#Agenda
20:02:46 <fredyx101> o/ here
20:03:07 <jmckind_> 0/
20:03:09 <redrobot> and since nobody added agenda item, I'm just going to make some up as we go
20:03:25 <redrobot> *items
20:03:43 <redrobot> #topic Action Items from last week
20:03:53 <redrobot> I still have to go comment on all the open blueprints
20:04:01 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2016/barbican.2016-03-14-20.02.html
20:04:04 <redrobot> so
20:04:13 <redrobot> #action redrobot to -2 pending CRs with a note to resubmit for N and a deadline to mark them as abandoned
20:04:51 <redrobot> for the other action, rellerreller mentioned towards the end of that meeting that the fishbowl descriptions are coming along
20:05:11 <redrobot> #topic Mitaka Release Candidate 1
20:05:13 <diazjf> awesome news
20:05:28 <redrobot> I'm hoping we can cut RC1 tomorrow.
20:05:51 <redrobot> Anything critical still pending that we absolutely must have before RC1?
20:06:45 <redrobot> I would like to get some eyes on the release notes
20:06:49 <redrobot> #link https://review.openstack.org/#/c/294222/
20:06:53 <redrobot> for example.
20:07:01 <redrobot> also, feel free to add any release notes I may have missed.
20:07:27 <kfarr> redrobot, do all release notes need to go in before RC1?
20:07:37 <redrobot> kfarr yeah, I think so
20:08:08 <redrobot> kfarr I'm assuming there's autmation around the publishing of the release notes that requires them to be in the repo when the release is made?
20:09:48 <kfarr> redrobot, I believe they are already published as you merge them, but I am looking to double check that now
20:10:38 <redrobot> kfarr interesting...
20:10:50 <redrobot> kfarr do we have to make a /mitaka page for them?
20:10:56 <woodster_> o/
20:11:06 * redrobot is not sure how the release notes move out of "current" release
20:11:54 <dave-mccowan> o/
20:13:36 <redrobot> Another thing I noticed while looking at the release notes is that our KEK Signature migration script doesn't have a barbican-manage command to run it.
20:14:23 <redrobot> I tried to add it but ran into a weird issue where the subcommand was listed as valid, but gave an error when you tried to run it. :-\
20:15:20 <redrobot> ...
20:15:38 <redrobot> ok, I'll take that as a no on critical fixes needed before RC1
20:15:54 <redrobot> as soon as the release notes land I'll ask the release team to make the RC1 release.
20:16:01 <redrobot> that'll mark the start of the N cycle
20:16:11 <redrobot> #topic Newton Design Sessions
20:16:26 <redrobot> #link https://etherpad.openstack.org/p/newton-barbican-design-sessions
20:16:45 <redrobot> just a reminder that we have an etherpad to capture topics for the design summit
20:18:24 <redrobot> In case you missed it, the slot allocation was announced on the mailing list
20:18:26 <redrobot> #link http://lists.openstack.org/pipermail/openstack-dev/2016-March/089467.html
20:18:38 <redrobot> Barbican: 2fb, 6wr, cm:half
20:19:05 <redrobot> 2 fishbowls - I was thinking 1 for mutiple-backend, the other for castellan
20:19:23 <redrobot> 6 working rooms - regular design sessions for topics from etherpad
20:19:42 <redrobot> cm:half is the 1/2 day contributors meetup
20:19:50 <redrobot> like we had in Tokyo
20:20:13 <redrobot> Any questions/comments about the sessions?
20:20:52 <arunkant> redrobot: Is 1/2 day meet-up going to be on Friday afternoon ?
20:21:30 <redrobot> arunkant the exact schedule hasn't been announced yet, so there's a 50% chance that it'll be Friday morning.
20:21:36 <arunkant> redrobot: Can this done be in morning or some other day ?
20:21:44 <arunkant> redrobot: okay thanks
20:21:59 <redrobot> I'll let y'all know once the final schedule is out
20:22:58 <redrobot> #topic Open Discussion
20:23:07 <dave-mccowan> There is a new question on the openstack-dev mail list asking about how to deploy Barbican with HA.
20:23:11 <redrobot> That's all I can think of from the top of my head
20:23:24 <diazjf> redrobot http://docs.openstack.org/developer/barbican/api/index.html
20:23:30 <diazjf> the user guide 404s
20:23:46 <redrobot> dave-mccowan oh yeah, I was meaning reploy to that thread
20:24:16 <rellerreller> o/
20:24:38 <kfarr> redrobot, release notes auto-publish to http://docs.openstack.org/releasenotes/barbican/liberty.html (for liberty)
20:24:39 <redrobot> diazjf seems the move to api-guide is not quite there yet
20:24:50 <redrobot> diazjf someone is looking into fixing it though: https://review.openstack.org/#/c/295472/
20:24:50 <kfarr> not sure why mitaka isn't publishing yet: http://docs.openstack.org/releasenotes/barbican/mitaka.html
20:25:52 <redrobot> kfarr maybe we need a mitaka.rst ? http://git.openstack.org/cgit/openstack/barbican/tree/releasenotes/source
20:26:05 <kfarr> redrobot, yup, that would do it
20:26:52 <redrobot> kfarr do you know if the reno tool has a workflow for taking "unreleased" notes and putting them together in a release page?
20:28:24 <kfarr> redrobot, good question, looking into it
20:29:54 <dave-mccowan> an item that we could start tracking is the "maturity index" of barbican. https://www.openstack.org/software/releases/liberty/components/barbican    there's a couple items that are low hanging fruit that could give us another point or two.
20:29:58 <kfarr> redrobot, maybe this? http://docs.openstack.org/developer/reno/usage.html#generating-a-report
20:31:14 <redrobot> kfarr hmm... maybe
20:31:29 <redrobot> kfarr I'll ask around in the release channel
20:31:38 <redrobot> dave-mccowan +1
20:32:48 <kfarr> dave-mccowan +1 +1 +1
20:35:29 <redrobot> well... looks like we're out of topics for today?
20:35:32 <silos> On the topic of the releasenotes. Do we need to mention the changes to the db? I think we've added a few new revisions. like for user_metadata.
20:35:55 <redrobot> silos I made a note in one of the patches I submitted last week
20:36:07 <silos> redrobot: cool.
20:36:27 <woodster_> dave-mccowan: interesting list...offline upgrade and rolling upgrade capability are interesting
20:36:38 <rellerreller> redrobot I completed my action item for the topic discussion descriptions.
20:37:29 <dave-mccowan> i believe we follow standard deprecation, we just aren't tagged for it.
20:37:41 <redrobot> rellerreller no worries... do you have an update?
20:38:34 <woodster_> I'd suggest adding discussion of dave-mccowan link to the summit discussion wiki
20:39:05 <dave-mccowan> another example: we have an install guide, but it is not in the right repo to earn the "point".
20:39:18 <rellerreller_> redrobot sorry I was just kicked off for some reason. Did you respond to my question?
20:39:40 <rellerreller_> redrobot ^ the one about where to post the descriptions? Email or etherpad or other?
20:39:44 <redrobot> rellerreller yes.  [15:37:40]  <redrobot>	rellerreller no worries... do you have an update?
20:40:16 <rellerreller_> redrobot I think my question about where to post was lost.
20:40:21 <redrobot> rellerreller_ you can add descriptions to the newton etherpad if you want?
20:40:36 <woodster_> dave-mccowan:  I think we need to add grenade testing for the offline upgrade check
20:41:27 <redrobot> rellerreller_ eventually we'll need to add them to the design summit schedule
20:41:37 <rellerreller_> redrobot do you have the link for that? I don't think I bookmarked that one.
20:42:15 <woodster_> dave-mccowan: I think rolling upgrades are addressed in some projects via use of oslo_db and versioned objects
20:42:24 <redrobot> rellerreller_ not sure if it's out yet... for previous summits they sent a link to the ML for us to add the description.
20:42:59 <kfarr> dave-mccowan, do you know if the recent change to move docs to the api-guide will address the install guide item?  or is that a separate web page?
20:43:09 <rellerreller_> redrobot you are talking about the Newton etherpad page?
20:43:28 <redrobot> rellerreller_ yeah, or a new one.  whatever works best for you.
20:44:23 <redrobot> kfarr I think we would have to be listed here: http://docs.openstack.org/liberty/install-guide-ubuntu/
20:44:26 <dave-mccowan> kfarr, i don't know for sure, but the way i read the requirement is that "key management service" would be part of one or more of the 3 install guides at http://docs.openstack.org/
20:45:06 <dave-mccowan> Barbican is in the debian repo and in EPEL for the rpm installs, so it should be easy to do.
20:45:20 <kfarr> redrobot, dave-mccowan oh hmm
20:45:49 <rellerreller_> redrobot https://etherpad.openstack.org/p/barbican-n-design-sessions
20:46:13 <redrobot> rellerreller_ thanks
20:49:08 <redrobot> looks like someone already added the maturity index topic to the design sessions
20:49:10 <redrobot> +1
20:49:29 <redrobot> alrighty, looks like we're just about done, unless there's a last minute topic?
20:49:36 <woodster_> redrobot: that was me :)
20:49:46 <redrobot> thanks woodster_
20:50:42 <redrobot> thanks for coming eveyone!
20:50:45 <redrobot> #endmeeting