20:01:27 <redrobot> #startmeeting barbican
20:01:28 <openstack> Meeting started Mon May 23 20:01:27 2016 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:01:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:01:31 <openstack> The meeting name has been set to 'barbican'
20:01:36 <redrobot> #topic Roll Call
20:01:40 <kfarr> o/
20:01:46 <diazjf> o/
20:01:58 <jmckind_> o/
20:02:07 <arunkant> o/
20:02:45 <redrobot> few barbicaneers here today...
20:02:58 <redrobot> no matter, we'll still have an awesome time! :D
20:03:11 <jmckind_> for sure!
20:03:17 <redrobot> as usual the agenda can be found here:
20:03:19 <redrobot> #link https://wiki.openstack.org/wiki/Meetings/Barbican#Agenda
20:03:31 <diazjf> The waters be clearrrr
20:03:42 <redrobot> #topic Action Items from last meeting
20:03:45 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2016/barbican.2016-05-16-20.00.html
20:04:11 <woodster_> o/
20:04:27 <redrobot> So I was going to look into the installation doc skeleton
20:04:41 <redrobot> turns out the doc team is in transition right now with regards to the installation documentation
20:05:17 <redrobot> next step is to go to the install doc meeting and ask for direction there
20:05:28 <redrobot> #action redrobot to join the next installation doc meeting
20:05:45 <redrobot> that's it for action item updates
20:05:55 <redrobot> #topic Blueprint Reviews
20:06:11 <redrobot> #link https://review.openstack.org/#/c/286318/
20:06:31 <redrobot> ^^ I wrote up the changes to make generic containers mutable.  It's what was agreed on during the summit
20:06:42 <diazjf> redrobot, my IOU still stands. I should have some more time this week
20:06:57 <redrobot> diazjf \o/
20:07:12 <redrobot> maybe woodster_ could sneak in a review?
20:07:21 <redrobot> anyone one else have BPs that need reviewing?
20:07:31 <redrobot> #link https://review.openstack.org/#/q/project:openstack/barbican-specs+status:open
20:07:47 <woodster_> redrobot: I'll try to get that in today
20:08:26 <redrobot> thanks woodster_ !
20:10:26 <redrobot> #link PKCS#11 error handling
20:10:30 <redrobot> derp
20:10:41 <redrobot> #topic PKCS#11 error handling
20:10:46 <redrobot> #link https://review.openstack.org/#/c/319940/
20:11:33 <redrobot> so jmckind_ has been working on fixing the issue where CKR_TOKEN_ERROR thrown by a PKCS#11 devices results in Barbican being stuck in an error state.
20:11:40 <redrobot> I think the CR is ready for reviews
20:11:42 <jmckind_> diazjf, I was looking at your comments and like your suggestions. I'll try to get those updated today/tomorrow.
20:12:12 <diazjf> jmckind_ awesome, thanks for working on this! Really useful.
20:12:53 <redrobot> #topic Open Discussion
20:12:59 <redrobot> Anything else that we should talk about?
20:13:09 <diazjf> redrobot, midcycle?
20:13:14 <redrobot> the wiki agenda was empty, and I ran out of things off the top of my head
20:13:20 <redrobot> diazjf ah yeah, good topic
20:13:26 <redrobot> diazjf got any updates for us?
20:14:17 <diazjf> So the more and more people I talk to the less likely I think we'll be able to host the event here just because of our teams budget. I'll get back to you by next monday and I'll let you know if its possible. We may just have to do it at Starbucks lol
20:14:26 <redrobot> lol
20:14:27 <fredyx10> hey I've been working in a cleanup process that run before the functional tests, it basically delete any secret and container for the tests users before the functionals run
20:14:57 <redrobot> fredyx10 awesome... do you have a CR yet?
20:14:58 <fredyx10> ooops I'll let diazjf finish his stuff first
20:15:20 <fredyx10> ohhh ok he's done
20:15:25 <diazjf> redrobot, I'll make sure to let the Security team know as well. fredyx10 no worries.
20:15:32 <redrobot> diazjf I think we may be able to find space at one of the Rackspace offices SA/Austin if need be
20:15:58 <diazjf> redrobot, lets talk later in the week and see what we can do
20:16:19 <fredyx10> well hockeynut put a CR that was merged more than a month ago… so I started working with that, but the way that works, delete the resources before every test run… since we have a parallel execution in place some of the tests fail
20:16:37 <fredyx10> so I'm trying to put the cleanup process together
20:16:48 <fredyx10> but not completely sure of where it should be located
20:17:05 <fredyx10> if it should be in the test utilities
20:17:26 <fredyx10> or if it should be an option in the CMD to clean resources for a given user
20:18:12 <diazjf> #link https://review.openstack.org/#/c/319424/
20:18:13 <fredyx10> right now and it's the way I submitted the CR is in the SetUp of the test_secrets and test_containers
20:18:32 <fredyx10> thank you diazjf
20:18:36 <fredyx10> that's the one
20:18:54 <fredyx10> so I tested it locally, everything passed since I dont have parallel execution locally
20:19:36 <fredyx10> upstream we do have parallel execution so I guess the cleaning up before every test is raining the parade of some tests while they run
20:19:49 <fredyx10> this clean should run only once
20:20:01 <fredyx10> before the entire functional suite
20:20:12 <fredyx10> but I'm not completely sure of where to put it
20:20:22 * redrobot needs to brush up on functional tests
20:20:57 <redrobot> I'm not really sure what the best thing would be? ... maybe add it to the gate itself?
20:21:08 <fredyx10> I could place is it in the functional test as an utility but also this could be reused by someone
20:21:08 <diazjf> fredyx10, I'm thinking it should be in the test utilities. We don't want a manual command to do the cleanup. you can use a setUpClass to perform the function once per class
20:21:24 * hockeynut drops in
20:21:53 <fredyx10> diazfj that still will be execute multiple times right?
20:21:56 <jmckind_> yeah, as long as there is no reason to leave the old data around for some reason. Since it's for the functional run, can't see why one would want that.
20:22:19 <diazjf> fredyx10 should only be executed once per class unlike the regular setup
20:22:24 <diazjf> ^ https://docs.python.org/2/library/unittest.html#setupclass-and-teardownclass
20:22:34 <redrobot> so, I guess the gate has a brand new DB every time... and this is only an issue on DBs that must be reused across test runs
20:24:12 <redrobot> maybe we don't need to run it at the gate at all?
20:25:10 <fredyx10> ok thanks diazjf!
20:25:26 <redrobot> diazjf that might work too
20:25:41 <fredyx10> yeah that could also work
20:26:20 <redrobot> cool, well, it looks like you can keep making progress fredyx10
20:26:22 <hockeynut> fredyx10 tdink_afk and I spoke about this earlier today.  Doesn't really apply to gate - its more for dev/test environments where folks may have used the functional test users for other things and could have leftover data
20:28:16 <fredyx10> yes, thank you redrobot, diazjf
20:28:21 <redrobot> any other topics before we call it a day?
20:28:31 <fredyx10> I'll gitve it another try with that approach and see
20:29:02 <fredyx10> gitve == give (my spanish brain fights my english hands)
20:29:54 * redrobot twiddles thumbs
20:30:23 <redrobot> alright, let's cal it a day.  Thanks for coming everyone!
20:30:28 <diazjf> thank everyone!
20:30:31 <jmckind_> thanks!
20:30:39 <redrobot> #endmeeting