20:00:04 <diazjf> #startmeeting barbican
20:00:05 <openstack> Meeting started Mon Jul 25 20:00:04 2016 UTC and is due to finish in 60 minutes.  The chair is diazjf. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:09 <openstack> The meeting name has been set to 'barbican'
20:00:36 <woodster_> o/
20:00:46 <diazjf> #topic Roll Call
20:01:04 <kfarr> o/
20:02:06 <diazjf> Very low attendance today :(
20:02:38 <diazjf> I'll start from last meetings items #link http://eavesdrop.openstack.org/meetings/barbican/2016/barbican.2016-07-18-20.01.txt
20:02:55 <diazjf> Only action item is me chairing
20:03:01 <diazjf> so we can move on
20:03:05 <woodster_> o/
20:03:22 <diazjf> Barbican agenda can be found here #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:03:37 <diazjf> no new topics, so I will make some up
20:03:42 <diazjf> #topic midcycle
20:03:54 <diazjf> #link https://etherpad.openstack.org/p/barbican-security-midcycle-N
20:04:20 <diazjf> It has been confirmed that the midcycle will be at IBM Austin, please make sure to update the topics in the upcoming weeks.
20:04:56 <diazjf> Dates are Aug 15 - 17 Barbican and Aug 17- 19 Security
20:05:29 <diazjf> I will update the midcycle etherpad with hotels and events we can do when everyone is here
20:05:36 <diazjf> Any Questions
20:06:00 <diazjf> ok moving on
20:06:10 <diazjf> #topic barbican talks
20:06:41 <diazjf> Sometime tomorrow the OpenStack Presentations will be available to vote on.
20:06:57 <diazjf> I'll make sure everyone gets an email with links to the Barbican presentations :)
20:07:07 <diazjf> Any questions on this?
20:07:23 <woodster_> diazjf: nice! How may presentations are there?
20:07:33 * woodster_ barbican-wise that is?
20:08:13 <diazjf> woodster_ so far I think we have 2 presentations which involve Barbican. I'm hoping we will find some random ones out there as well :)
20:09:00 <diazjf> woodster_ will you be coming to Austin for the midcycle?
20:09:01 <kfarr> I have one about KMIP!
20:09:12 <diazjf> kfarr, awesome! that makes 3
20:09:19 <woodster_> diazjf: At least for one of the days I believe so
20:09:30 <diazjf> woodster_ awesome!
20:10:08 <diazjf> ok moving on
20:10:16 <diazjf> #topic open discussion
20:10:48 <diazjf> btw I'm chairing today since redrobot it up in Alaska! Hope he's having fun
20:11:48 <woodster_> diazjf: do you know the status of things barbican client? There is a contributor interested in coding for one of the blueprints you had put in a while back...
20:11:52 * woodster_ looking for link
20:12:46 <woodster_> #link https://blueprints.launchpad.net/python-barbicanclient/+spec/add-user-metadata
20:12:50 <woodster_> catintheroof: ^^^^
20:13:17 <catintheroof> woodster_, diazjf the thing is that i had the knowledge to code the retrieval of user metadata, but i dont seem to have the knowledge to well-code the setter
20:13:47 <diazjf> woodster_ catintheroof let me take a look
20:13:57 <diazjf> seems like launchpad is down
20:14:09 <woodster_> catintheroof: barbican has friendly sherpas to help with things like that :)
20:14:38 <alee> o/
20:14:54 <woodster_> diazjf: are you ok with folks helping out with the client code? are you actively working on that code? If not, then only Oz is I think
20:15:27 <diazjf> catinroof, woodster_ I'd be happy if you could pick that up. In the midcycle we should probably discuss the future of the Barbican Client, there seems to be alot that needs to be changed. I haven't been actively working with the client.
20:15:45 <diazjf> btw catintheroof is a real cool name :)
20:16:09 <woodster_> diazjf: yeah, and I don't know the status of the barbican client vs openstack one
20:16:58 <diazjf> #action diazjf to add barbican-client discussion topic to midcycle
20:17:27 <catintheroof> diazjf, you are just being nice hahahaah well , i can do the getter git review
20:17:44 <catintheroof> diazjf, woodster_ and the try to do something with the setter
20:18:06 <woodster_> catintheroof: I'm thinking there are example setters in the client code you could take a look at
20:18:37 <catintheroof> diazjf, woodster_ there are ... but my problem is ... i dont understand them ^_^
20:19:04 <catintheroof> diazjf, woodster_ buttttt .... i can use the first free sherpa mile
20:20:00 <diazjf> catinroof, I'd be happy to do some reviews once the code is up. I'd start by taking a look at https://github.com/openstack/python-barbicanclient/blob/master/barbicanclient/secrets.py since the secretmeta will be pretty similar
20:22:17 <diazjf> catinroof you would essential map the secret meta api requests to client functions
20:22:25 <diazjf> catinroof will you attend the midcycle?
20:22:50 <diazjf> Maybe we can plan some hackathon type to actively help out with the barbican client
20:23:13 <diazjf> openstack client still uses the functions from python-barbicanclient
20:24:02 <diazjf> Anymore questions anyone?
20:25:04 <woodster_> diazjf: thanks for the clarification
20:26:03 <diazjf> woodster_ catintheroof feel free to ping me with anymore question! Hope everyone has a good week!
20:26:10 <diazjf> See everyone soon
20:26:12 <diazjf> #endmeeting