20:00:41 <dave-mccowan> #startmeeting barbican
20:00:42 <openstack> Meeting started Mon Jan 30 20:00:41 2017 UTC and is due to finish in 60 minutes.  The chair is dave-mccowan. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:45 <openstack> The meeting name has been set to 'barbican'
20:00:50 <dave-mccowan> #topic roll call
20:00:56 <diazjf> o/
20:01:08 <dave-mccowan> o/
20:01:22 <kfarr> o/
20:02:10 <dave-mccowan> hello barbicaneers!
20:02:34 <dave-mccowan> it might be just us today.  i haven't see redrobot, and alee said he had to miss today
20:03:01 <dave-mccowan> as usual, the agenda is here:
20:03:09 <dave-mccowan> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:03:20 <dave-mccowan> #topic Barbican Container Fixes
20:03:32 <dave-mccowan> diazjf?
20:03:51 <diazjf> Was recently looking over the container docs and saw some errors. Opened up bugs and add fixes all around.
20:04:01 <diazjf> Just want some quick reviews whenever anyone gets time
20:04:33 <dave-mccowan> \o/  thanks diazjf
20:04:39 <dave-mccowan> i see the review links are in the agenda
20:04:49 <diazjf> There are 3 patches which 1.) Update docs, 2.) Add unit tests, 3.) Fix a bug when filtering thru consumers. Thanks dave!!!
20:05:12 <dave-mccowan> anything else?  let's try to get those merged early this week to make Ocata.
20:05:25 <diazjf> thanks, thats all for me.
20:05:36 <dave-mccowan> #status gate status
20:05:46 <dave-mccowan> we've just been talking about this in the main channel.
20:06:15 <dave-mccowan> look like the feature to add the id field has co-requisite changes that need to be made to barbican client that haven't been finished yet.
20:06:43 <kfarr> I was the 3rd person to +2, does that count as broad agreement?
20:06:50 <kfarr> +2 the revert MR
20:06:58 <dave-mccowan> i think we're in unanimous agreement that we need to revert the id patch.  :-(
20:07:26 <dave-mccowan> the good news is that it should open up the gate again.
20:07:50 <dave-mccowan> kfarr do you have a goal in mind for the next castellan release?
20:08:04 <kfarr> dave-mccowan, I was hoping to get in the list feature
20:08:33 <kfarr> but that was dependent on a python-barbicanclient patch
20:08:45 <kfarr> that didn't make it in before you tagged the release last week
20:09:18 <dave-mccowan> bummer.
20:10:12 <dave-mccowan> we'll have to try to get all of the patches with cross-repo dependencies in early in Pike, so we don't end up in the time crunch.
20:11:09 <dave-mccowan> i think we're out of time on Ocata, and I don't think the release group will let me re-tag the python-barbicanclient, especially since the deadline has now passed.
20:11:33 <dave-mccowan> which leads us to...
20:11:40 <dave-mccowan> #topic Ocata Status
20:12:33 <dave-mccowan> so, last week was the deadline for libraries (python-barbicanclient) and I tagged what we had finished then.  unfortunately, we missed a couple features we wanted.
20:13:39 <dave-mccowan> this week our goal is to tag a Release Candidate for Barbican.  we need prioritize urgent fixes that want to go in, but also only low risk commits.
20:14:37 <dave-mccowan> if anyone has any patches in particular to merge this week, post the links in the channel.  i'll ping people this week before tagging the release to make sure we've finished what we can.
20:15:01 <dave-mccowan> by the end of next week Ocata will be out the door and we'll be on to Pike
20:15:13 <dave-mccowan> any questions or comments on the schedule?
20:16:33 <dave-mccowan> kfarr we need to think through castellan releases, especially if we start having version dependencies with other projects.
20:16:48 <dave-mccowan> for example with Nova Ocata need a different Castellan than Nova Pike?
20:17:16 <kfarr> Wouldn't we just bump the minimum requirement in that case?
20:18:40 <dave-mccowan> yes.  this is why the release deadline for client libraries is two weeks before the services, so they can fix on a stable branched version.  does castellan have stable branches?
20:19:45 <kfarr> dave-mccowan, no
20:20:11 <dave-mccowan> we can talk about it at the PTG.  we might need to start doing that.
20:20:33 <dave-mccowan> #topic Tempest Testing
20:20:45 <kfarr> okk
20:20:48 <dave-mccowan> kfarr did peter give you an update?
20:21:32 <kfarr> There are patches out for the secret-metadata client tests and order client tests
20:22:06 <kfarr> https://review.openstack.org/#/c/424817/ and https://review.openstack.org/#/c/423346/
20:22:33 <dave-mccowan> thanks!
20:22:33 <kfarr> also, I made a gate for the barbican-tempest-plugin project that runs the tempest plugin tests
20:22:51 <kfarr> maybe one day we'll want that running for each commit to barbican, too?
20:23:04 <dave-mccowan> cool!
20:23:39 <diazjf> awesome, I'll add them to my review queue
20:23:49 <dave-mccowan> yes, i think that'd be good.  btw, alee brought up the idea: why doesn't barbicanclient or castellan tests run with each commit to barbican?
20:23:58 <dave-mccowan> that'd help catch some issues earlier.
20:24:44 <dave-mccowan> #topic Top Three
20:25:13 <dave-mccowan> the openstack foundation puts together a slide deck with each release that includes a "top 3" list for each project.
20:25:26 <dave-mccowan> does anyone have input on what our Top 3 is for Ocata?
20:26:10 <diazjf> dace-mccowan, I don't think we've had any real big features other than the one we are reverting :(
20:26:29 <kfarr> Top 3 new features?
20:26:39 <dave-mccowan> diazjf yep :(
20:26:51 <dave-mccowan> top 3 anything.   we need to put on our marketing hats. :-)
20:27:06 <diazjf> 1.) Update with global requirements lol
20:27:16 <dave-mccowan> Ocata was a short cycle, so it's ok if our list is light.
20:27:20 <kfarr> diazjf lolz
20:27:27 <kfarr> tempest plugin?
20:27:28 <dave-mccowan> hooray for openstack proposal bot
20:27:33 <dave-mccowan> kfarr +1
20:28:33 <dave-mccowan> maybe general quality improvements... we must have fixed a bug or two.
20:28:45 <dave-mccowan> #topic PTG
20:28:48 <diazjf> dave-mccowan maybe improved testing, the new gates like Postgre etc
20:28:59 <dave-mccowan> diazjf +1
20:29:07 <dave-mccowan> #link https://etherpad.openstack.org/p/ptg-barbican-pike
20:29:40 <dave-mccowan> just a reminder to add any ideas for Pike or other discussion to the PTG etherpad.
20:30:03 <dave-mccowan> hopefully we'll be able to find a way to connect remote folks too.
20:30:08 <kfarr> Ooh, if we got any new maturity points, we could include those
20:30:18 <diazjf> kfarr, awesome!
20:30:39 <diazjf> hopefully we did, but I think the install guide needs more work
20:30:57 <diazjf> that was the easiest point to get
20:30:58 <dave-mccowan> kfarr yes!  we've got two new ones so far (vmt managed and number or distros).  two more still in works (stable branch and standard deprecation)
20:32:33 <dave-mccowan> #action dave-mccowan follow up on addition maturity points items
20:32:35 <dave-mccowan> #topic Barbican Mascot
20:32:58 <dave-mccowan> and now the big news.  we've gotten a draft of our barbican mascot.
20:33:36 <dave-mccowan> as you'll recall we voted on what animal we wanted and "anything with barbs" was the going choice.  the artists couldn't draw a sea urchin, so we went with porcupine.
20:34:00 <dave-mccowan> they'll have laptop stickers and whatnot at the PTG
20:34:08 <dave-mccowan> #link http://imgur.com/a/RBn39
20:34:29 <diazjf> sweet I like it!!!
20:34:51 <diazjf> hopefully you can snag a few and I'll give you and address to send them too
20:34:59 <dave-mccowan> diazjf definitely
20:35:10 <diazjf> dave-mccowan thanks!! :)
20:35:26 <kfarr> that's really cool
20:36:02 <dave-mccowan> yep.  it'll be fun to see how they use all the drawings.  have you guys seen any of the others?
20:36:54 <dave-mccowan> #topic any other topics?
20:38:15 <dave-mccowan> thanks kfarr and diazjf!
20:38:23 <diazjf> thanks dave
20:38:33 <dave-mccowan> see you later
20:38:35 <dave-mccowan> #endmeeting