20:00:28 <dave-mccowan> #startmeeting Barbican
20:00:29 <openstack> Meeting started Mon Mar  6 20:00:28 2017 UTC and is due to finish in 60 minutes.  The chair is dave-mccowan. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:30 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:32 <openstack> The meeting name has been set to 'barbican'
20:00:39 <dave-mccowan> #topic Roll Call
20:00:41 <kfarr> \o/
20:00:43 <diazjf-yeah> o/
20:00:52 * dave-mccowan waves
20:02:31 <dave-mccowan> hello barbicaneers, our agenda is here
20:02:33 <dave-mccowan> #link https://wiki.openstack.org/wiki/Meetings/Barbican
20:02:35 <redrobot> o/
20:03:00 <dave-mccowan> #topic Pike Status
20:03:08 <dave-mccowan> I started a new etherpad to track us through Pike
20:03:18 <dave-mccowan> #link https://etherpad.openstack.org/p/barbican-tracker-pike
20:03:39 <dave-mccowan> please add any features I may have missed from the first pass of the list
20:04:13 <dave-mccowan> redrobot, i have your name by the first three on this list.  do you have an update for this week?
20:04:35 <redrobot> dave-mccowan no updates this week
20:04:43 <redrobot> dave-mccowan other than, yes, I'm working on that stuff
20:04:50 <dave-mccowan> :-)
20:05:08 <dave-mccowan> alee i've got your name by two
20:05:10 <diazjf-yeah> redrobot, reviewed your Simple Crypto Upgrade SPec
20:06:26 <dave-mccowan> i think we have a good plan for Pike.
20:06:56 <dave-mccowan> Anyone have anything else to bring up on topic of Pike deliverables?
20:07:28 <diazjf-yeah> dave-mccowan added the container renaming. Not sure if that is to be included in Pike
20:07:46 <alee> o/
20:08:02 <redrobot> diazjf-yeah awesome, thanks.
20:08:54 <dave-mccowan> renaming container will need to be part of creating a V2 API.  I don't think we have a plan for that in Pike at this point.
20:09:31 <dave-mccowan> alee notice on https://etherpad.openstack.org/p/barbican-tracker-pike I have your name by two features. :-)
20:09:58 <redrobot> dave-mccowan hmm...  well, I think the last time we were talking about the ID change we agreed on implementing as a microversion
20:09:59 <alee> dave-mccowan, egad .. fleeing meeting now ..
20:10:22 <redrobot> If I understand microversions correctly, then implementing microversions negates the need for new major versions of the API?
20:10:43 <redrobot> ie, if we land microversions to implement the entity-ID spec, then we will likely never create a v2
20:10:52 <alee> dave-mccowan, yeah - and I added one more ..
20:10:55 <dave-mccowan> redrobot yes.  i don't think we can rename "containers" without a major, right?
20:11:09 <redrobot> dave-mccowan we can rename containers in a new microversion
20:11:18 <redrobot> dave-mccowan we will never have a v2 if we implement microversions
20:11:26 <dave-mccowan> redrobot oh... cool.  got it.
20:11:55 <redrobot> but there's also a pretty good chance that I don't know what I'm talking about ;)
20:12:01 * redrobot is no microversion expert
20:12:04 <dave-mccowan> what's our next step on figuring out microversions?
20:12:33 <dave-mccowan> i guess we need an API WG consultation?
20:12:56 <redrobot> I think we start with the client
20:13:07 <redrobot> the client needs to be able to specify which microversion it is using?
20:13:15 <dave-mccowan> #action dave-mccowan Get an API WG consultation on microversions
20:13:21 <redrobot> yeah, wouldn't hurt to hear it straight from the horse's mouth
20:14:06 <dave-mccowan> #topic Backlog Review
20:14:31 <dave-mccowan> we made great progress on our bug back log during the PTG.  we're at 47 (down from 72).
20:15:04 <dave-mccowan> is there anything we can do to help coordinate reviews to reduce this?
20:15:31 <dave-mccowan> i can set up an etherpad, or something, if that will help.  or i can just remind us all each week. :-)
20:16:02 <kfarr> To coordinate reviewing the bug backlog or to coordinate reviewing the merge request backlog?
20:16:04 <kfarr> or both?
20:16:38 <dave-mccowan> kfarr both/either.   i'd like to see both backlogs shrink.
20:17:44 <dave-mccowan> would a regular google hangout to review as a group help?
20:18:17 <redrobot> I think we already do a good job of asking for reviews during these meetings
20:18:43 <kfarr> I still have a hard time getting reviews on my patches :(
20:18:46 <redrobot> I think a google hangout every couple of weeks to triage bugs woud be awesome
20:18:59 <diazjf-yeah> redrobot, I like that idea
20:19:03 <redrobot> good job of asking for reviews != good job of doing reviews :-\
20:20:14 <dave-mccowan> OK, i'll look to set something up in a week or so.  in the meantime, everyone please check the queues.
20:20:21 <dave-mccowan> #topic tempest testing
20:21:07 <kfarr> The image signing scenario almost went in: https://review.openstack.org/431241
20:21:30 <kfarr> but something updated versions, and now the gate is broken
20:21:35 <kfarr> so.. we're working on that
20:21:51 <kfarr> And there's a patch up for the volume encryption scenario tests: https://review.openstack.org/439182
20:21:53 <dave-mccowan> doh!
20:23:14 <dave-mccowan> when multiple scenarios are in, do the all run under the same gate job?
20:23:41 <kfarr> Yes, they should
20:24:07 <kfarr> There's one gate job that runs devstack with barbican (and the encryption features enabled)
20:24:29 <kfarr> and runs the barbican api tests along with any scenario that are being added
20:24:44 <kfarr> the image signature verification one was the first one
20:25:52 <dave-mccowan> cool
20:26:06 <dave-mccowan> #topic Operators / OSIC
20:26:20 <dave-mccowan> anything new from the operators or OSIC?
20:27:20 <dave-mccowan> #topic any other business
20:28:04 <dave-mccowan> i have lots of extra Porcupine stickers from the PTG.  PM me with your address and how many you want and I'll get them out to you.
20:28:27 <diazjf-yeah> dave-mccowan will email you tonight. Thanks dude
20:28:51 <dave-mccowan> please pass them on to Barbican alums around you
20:29:47 <dave-mccowan> we can use remaining time for triaging and reviews. :-)
20:30:11 <dave-mccowan> post links to any that you think are high priority or needs discussion.
20:32:01 <kfarr> Here's an easy one: https://review.openstack.org/#/c/437056/
20:32:38 <kfarr> Here's a new Castellan feature that might require discussion: https://review.openstack.org/412558
20:33:14 <kfarr> Here's one that adds some new functional tests (easy): https://review.openstack.org/#/c/436244/
20:33:36 <diazjf-yeah> kfarr, I'll get to all those tonight. Its been a while since I last reviewed some.
20:33:47 <kfarr> This one updates the sample local.conf.example file (easy): https://review.openstack.org/#/c/437170/
20:34:12 <kfarr> I got the KMIP gate working (!!!) would be nice to get this in: https://review.openstack.org/#/c/437747/
20:38:58 <dave-mccowan> thanks kfarr!  we'll get on those. :-)
20:40:40 <dave-mccowan> Thanks everyone.  See you later.
20:40:43 <dave-mccowan> #endmeeting