20:00:30 <dave-mccowan> #startmeeting barbican
20:00:31 <openstack> Meeting started Mon Mar 13 20:00:30 2017 UTC and is due to finish in 60 minutes.  The chair is dave-mccowan. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:34 <openstack> The meeting name has been set to 'barbican'
20:00:34 <dave-mccowan> #topic roll call
20:02:19 <kfarr> \o/
20:02:28 <dave-mccowan> hi kfarr
20:02:56 <alee> o/  and here I was thinking I missed it
20:03:21 <dave-mccowan> hi alee.   we're an hour later now due to DST
20:03:44 <alee> dave-mccowan, yeah - seems the rest of the world doesn't change when we do
20:03:58 <alee> mighty inconvenient, that ..
20:04:32 <alee> :/
20:05:02 <dave-mccowan> yep.  i figure congress owes me a new VCR due to that change.  except, i don't use VCR anymore. :-)
20:05:57 <dave-mccowan> small group.... we'll blame it on congress. ;-)
20:05:59 <dave-mccowan> here's the agenda: https://wiki.openstack.org/wiki/Meetings/Barbican#Agenda
20:05:59 <dave-mccowan> #topic backlog review
20:06:12 <dave-mccowan> we're doing a great job whittling down the open reviews for patches
20:06:40 <dave-mccowan> the bug count is still pretty high.  down from 72, but still half of the remaining 49 are in "new" state.
20:07:26 <dave-mccowan> just a reminder to help out when you can.  when more folks are round i'll set up a time to get together to triage together again.
20:07:36 <dave-mccowan> #topic Pike status
20:07:50 <dave-mccowan> 4 weeks until Milestone 1.
20:08:00 <dave-mccowan> https://launchpad.net/barbican/+milestone/pike-1
20:08:37 <kfarr> I sent an email to the ML about oslo.keymanager
20:08:38 <kfarr> http://lists.openstack.org/pipermail/openstack-dev/2017-March/113863.html
20:08:53 <kfarr> already has some replies
20:09:07 <dave-mccowan> kfarr thanks!  i missed that.
20:09:16 <kfarr> it was just an hour ago or so
20:09:21 <kfarr> so no worries :)
20:10:49 <dave-mccowan> ah... that's why.  cool.  a good discussion started already.
20:11:11 <dave-mccowan> alee are you going to do the httpd and devstack changes for pike-1?
20:11:43 <alee> dave-mccowan, I'm going to try -- on some dogtag proiorities right now
20:12:04 <alee> dave-mccowan, if not, definitely by pkie-2
20:12:17 <dave-mccowan> alee sounds good.  i'll try to keep an appropriate level of nagging in the meantime. :-)
20:12:32 <alee> sure :)
20:12:55 <dave-mccowan> a new contributor, namnh, want to help us with getting our "supported:upgrades" tag.  he asked us to look at:
20:13:05 <dave-mccowan> https://bugs.launchpad.net/barbican/+bug/1670946
20:13:05 <openstack> Launchpad bug 1670946 in Barbican "[RFE] Support rolling upgrade in Barbican" [High,In progress] - Assigned to Nam (namnh)
20:14:13 <dave-mccowan> hi namnh
20:14:45 <dave-mccowan> we just got to your agenda item on rolling upgrade support.  did you have anything to mention in particular?
20:14:59 <namnh> hi dave-mccowan, I am so sorry for late
20:15:31 <namnh> yes,
20:15:40 <dave-mccowan> namnh thanks for waking up early (or staying up late) to talk with us
20:15:49 <namnh> First, I think we should add worker to devstack plugin. this path is to do this: https://review.openstack.org/#/c/444190/
20:16:21 <namnh> :) thanks for your understanding
20:16:30 <dave-mccowan> that patch looks good to me.  what do you think alee?
20:16:48 <kfarr> I wish I understood better about what barbican-worker is doing
20:17:03 <kfarr> does just adding it like that automatically make all the requests pass through the worker?
20:17:15 <kfarr> I wish there were a way to check that it is doing what we think it is doing
20:17:31 <alee> dave-mccowan, patch looks ok to me ..
20:18:50 <alee> not sure what this has to do with rolling upgrades ..
20:19:13 <namnh> kfarr: I am new member in barbican, I will try to make clear this service
20:19:20 <dave-mccowan> my guess is that workers runs, but is not used unless settings are made in the [queue] section
20:19:36 <dave-mccowan> alee right.  devstack and workers  are separate from ugrades.
20:20:04 <alee> dave-mccowan, ok - just wanted to make sure I wasn't missing some context
20:20:22 <namnh> alee: I think yes, becasue I am writting automation test and it's related to all service in barbican
20:20:50 <kfarr> dave-mccowan, do you know what the difference is between barbican-retry and barbican-worker?
20:20:55 <alee> namnh, fairt enough.  Its a good idea for something to test the worker code
20:21:36 <namnh> alee, dave-mccowan, kfarr: I have a plan to support upgrade
20:21:45 <namnh> Testing upgrade from newton to ocata and ocata to master to verify that there're not any problems
20:21:51 <namnh> developing to support automation test with grenade, then making a document for operators
20:22:03 <namnh> how do you think about this?
20:22:36 <kfarr> yes, that sounds like a good plan~
20:23:15 <dave-mccowan> namnh thanks, that sounds great.
20:24:46 <dave-mccowan> anything else on this topic?
20:24:54 <namnh> dave-mccowan, alee, kfarr: I am preparing souce code link this link: https://github.com/NguyenHoaiNam/barbican/tree/devstack_db/devstack/upgrade
20:25:15 <namnh> is that right way what you are thinking?
20:27:29 <dave-mccowan> namnh i see you're using grenade.  that's good.  what example did you follow?  i assume you plan to merge this to the barbican repository...
20:30:08 <kfarr> namnh maybe we could make an experimental gate first, modeled off another project (maybe ironic since they also have a devstack plugin?)
20:30:33 <kfarr> then if you committed your changes to barbican, they could be tested in the experimental grenade gate?
20:30:46 <namnh> dave-mccowan: I think barbican is missing a "upgrade" folder that it can support grenade running automation test. I am just preparing, I will push my patch after testing
20:32:13 <dave-mccowan> kfarr do you want to add an empty experimental gate job to help get that started?
20:32:34 <kfarr> dave-mccowan, I could take a look, sure
20:32:42 <namnh> as you can see: https://github.com/NguyenHoaiNam/barbican/blob/devstack_db/devstack/upgrade/shutdown.sh#L31. it has worker, that reason why I would like ask your dicision about this service
20:33:18 <namnh> whether it has in devstack or not.
20:33:36 <dave-mccowan> namnh sounds good.  i think we reached agreement to merge your devstack change.  thanks for finding and fixing this.
20:34:39 <namnh> dave-mccowan: for this patch set: https://review.openstack.org/#/c/444190/
20:35:50 <dave-mccowan> namnh yes, i've given it +2 now.  maybe alee or kfarr can finish their review soon and merge.
20:36:01 <kfarr> I'm still unsure!  I don't have any hard objections
20:36:09 <kfarr> I just don't know enough
20:36:26 <kfarr> like, what's the difference between barbican-retry and barbican-worker
20:36:32 <kfarr> and do we need both in devstack
20:38:31 <namnh> kfarr: I understand, maybe I should research worker more detail :)
20:38:48 <dave-mccowan> on the old wiki, there is a description of workers.  under [queue] in the config, you specify enable=True and the number of workers and that gives parallel processing.  recommendation is # of workers == the # of CPUs.  in the default config with devstack, it doesn't matter if a worker is started or not... it's not used, unless [queue] is enabled.
20:39:24 <alee> kfarr, I'm not answering because I'ma little fuzzy myself.  I think we need to look to see whats realyy needed
20:39:29 <dave-mccowan> let's pick redrobot's or woodster's brain on this
20:40:00 <dave-mccowan> thanks namnh we'll work more on this and let you know through comments on the review
20:40:12 <alee> dave-mccowan, yes -because I think we need barbican-worker and not retry or visa versa
20:41:18 <kfarr> Another question, if we change the installation to install the worker, then should we change the default config to have one worker enabled?
20:42:06 <kfarr> probably for woodster or redrobot ^^
20:42:10 <alee> kfarr, dave-mccowan lets take an actuaon item to try to understand what we need here - in consultation with redrobot and woodster
20:42:52 <dave-mccowan> #action check with redrobot or woodster about retry and worker processes and devstack defaults
20:43:19 <dave-mccowan> moving on...
20:43:29 <dave-mccowan> #topic tempest testing
20:43:47 <dave-mccowan> i notice that octavia added barbican/octavia scenario testing that now runs in our gate
20:44:03 <dave-mccowan> anything else new here kfarr?
20:45:14 <kfarr> not too much
20:45:43 <kfarr> volume encryption scenario tests: https://review.openstack.org/#/c/439182/
20:46:03 <kfarr> that's it!
20:46:09 <dave-mccowan> thanks!
20:46:15 <dave-mccowan> #topic summit
20:46:39 <dave-mccowan> Barbicaneers got a lot of session approved!
20:47:41 <alee> including the superpopular workshop!
20:48:18 <alee> on the workshop, we should be able to get Thales involved again in providing us with an HSM
20:48:48 <dave-mccowan> We also will need volunteers to staff an "onboarding room" for new contributors to drop by.  It will be part of the Forum, scheduled for 90 minutes.  they say we don't need to prepare something, but maybe having something hands-on would be good to recruit contributors.
20:49:40 <alee> dave-mccowan, I should probably be able to volumteer for part of that
20:49:57 <dave-mccowan> Also for the Forum (i guess Design-session-lite), there are two etherpads to collect topics
20:50:03 <dave-mccowan> To propose cross project topics:  https://etherpad.openstack.org/p/BOS-TC-brainstorming
20:50:21 <dave-mccowan> To propose Barbican topics:  https://etherpad.openstack.org/p/BOS-Barbican-brainstorming
20:51:19 <dave-mccowan> We can propose a continuation of the Key Manager adoption topic that we started at PTG
20:51:47 <dave-mccowan> The
20:52:03 <dave-mccowan> The forum should have operators and developers present.
20:52:21 <dave-mccowan> any other comments on Summit?
20:53:29 <dave-mccowan> #topic any other business
20:54:31 <dave-mccowan> thanks for joining namnh.  usually we have a few more people joining.
20:56:07 <namnh> dave-mccowan: I am glad to discuss with all of you in a weekly meeting :)
20:56:55 <dave-mccowan> thanks everyone
20:56:59 <dave-mccowan> #endmeeting