20:00:13 <dave-mccowan> #startmeeting barbican
20:00:14 <openstack> Meeting started Mon Mar 20 20:00:13 2017 UTC and is due to finish in 60 minutes.  The chair is dave-mccowan. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:15 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:17 <openstack> The meeting name has been set to 'barbican'
20:00:18 <dave-mccowan> #topic roll call
20:00:22 <diazjf> o/
20:00:26 <namnh> hi
20:00:33 <dave-mccowan> hi namnh
20:00:39 <dave-mccowan> hi diazjf
20:00:54 <diazjf> hey dave-mccowan!
20:01:11 <namnh> hi dave-mccowan
20:01:26 <kfarr> \o/
20:02:08 <redrobot> o/
20:02:48 <dave-mccowan> hi redrobot!
20:03:10 <dave-mccowan> Alrighty... the gang's all here.  The agenda is here: https://wiki.openstack.org/wiki/Meetings/Barbican
20:03:18 <dave-mccowan> #topic backlog review
20:03:32 <dave-mccowan> we're looking a lot better on patches \o/
20:03:48 <dave-mccowan> redrobot there's a few outstanding on the stable branches.  can you take a look at those?
20:04:13 <redrobot> dave-mccowan yes, I can review those
20:04:18 <redrobot> I'll try to get to them today
20:04:27 <dave-mccowan> redrobot thanks!
20:04:42 <dave-mccowan> our un-triaged bug count is still pretty high.
20:06:14 <dave-mccowan> shall we have a hangout this week to group-triage the bugs?  that worked out well during the PTG.
20:06:34 <kfarr> Sure, that works for me
20:07:13 <dave-mccowan> redrobot is there a day/time that works best for you?
20:07:40 <redrobot> dave-mccowan pretty flexible on time
20:08:35 <dave-mccowan> tomorrow at 2pm EDT, 1pm CDT ?
20:08:59 <redrobot> dave-mccowan I think that would work for me
20:09:07 <kfarr> I could do the hour after that
20:09:11 * redrobot double checks
20:09:46 <redrobot> 3pm EDT, 2pm CDT works for me too
20:09:50 <Arkady_Kanevsky> no meeting today after mid-cycle last week
20:09:59 <dave-mccowan> +1 for me
20:10:03 <kfarr> +2
20:10:07 <kfarr> * + 1
20:10:16 <dave-mccowan> \o/
20:10:26 <dave-mccowan> #agreed hangout tomorrow at 3pm EDT to triage bugs
20:10:36 <dave-mccowan> moving on...
20:10:45 <dave-mccowan> #topic Pike Status
20:11:04 <dave-mccowan> 3 weeks until Milestone 1
20:11:31 <dave-mccowan> at the PTG, we schedule a bunch of stuff for this milestone:
20:11:32 <dave-mccowan> https://launchpad.net/barbican/+milestone/pike-1
20:12:04 <dave-mccowan> does anyone have an update on their work items?
20:12:50 <namnh> For my task related to support-upgrade
20:13:10 <namnh> I tested to upgrade from N to O and O to P(master), there are not any problems with this
20:13:24 <namnh> and I pushed a patch for this and I am testing the patch. Then I will find how to setup a new gate (like gate-grenade-dsvm-) because I don't have experience in openstack-infra
20:13:43 <namnh> Here is my patch set: https://review.openstack.org/#/c/446282/
20:15:22 <dave-mcc_> kfarr do you want to give an update from the mail list?
20:15:51 <kfarr> Oh sure thing
20:16:17 <kfarr> I posted on the mailing list last week
20:16:36 <kfarr> I proposed that Castellan be renamed to oslo.keymanager (link here: http://lists.openstack.org/pipermail/openstack-dev/2017-March/113863.html)
20:17:22 <kfarr> It seemed like by the end of the comments on the thread, the consensus was to not rename Castellan, but move it under oslo's umbrella of ownership
20:18:24 <kfarr> and hopefully oslo's blessing will validate Castellan and improve adoption
20:18:39 <redrobot> sounds good to me...
20:19:16 <kfarr> I saw dave-mccowan's email at the end about next steps
20:19:22 <dave-mcc_> castellan-core will = oslo-core + barbican-core, per the last message on the thread
20:19:27 <kfarr> Should we turn those into action items?
20:20:01 <dave-mcc_> i'm not sure if we can do that, or if we need someone with super-gerrit permission to do that.
20:20:25 <dave-mcc_> i was hoping some oslo friends would join us today to discuss.
20:20:44 <dave-mcc_> #action update core and driver teams for castellan
20:20:54 <dave-mcc_> hrm... i lost chair
20:21:48 <dave-mcc_> oh well...  anything else on Castellan's promotion?
20:22:00 <kfarr> Nope, that's it from me!
20:22:17 <dave-mcc_> #topic code reviews
20:23:08 <dave-mcc_> jeremy has a big patch out for refactor of barbicanclient.  he added a blueprint at our request.  can we decide on if we want to go that direction?
20:23:44 <dave-mcc_> https://review.openstack.org/403604
20:25:32 <dave-mcc_> maybe too big a question for this meeting?
20:26:01 <dave-mcc_> namnh has 4 patches.  thanks!  do you want to discuss any of your patches?
20:27:47 <namnh> Yes, who can I add to review this patch set: https://review.openstack.org/#/c/446282/4
20:29:37 <dave-mcc_> hrmmm... IRC is flakey today
20:30:44 <dave-mcc_> redrobot i was hoping you could help us out of a couple of his too.  there is one about barbican-workers, and also one about the barbican-api script that you wrote.
20:31:21 <redrobot> ack
20:33:16 <dave-mcc_> thanks redrobot and namnh
20:33:18 <dave-mcc_> #topic any other business?
20:33:27 <namnh> thanks dave-mcc_ redrobot
20:33:53 <dave-mccowan> #topic any other business
20:33:54 <diazjf> dave-mcc_ we have a talk for Boston
20:34:06 <dave-mccowan> #topic summit
20:34:18 <dave-mccowan> yes... lots of barbican team presentation this time!
20:34:20 <diazjf> dave-mccowan, kfarr, redrobot, alee, our Barbican Workshop was selected for the Boston Summit
20:34:30 <kfarr> Yeah!
20:35:27 <redrobot> \o/
20:35:40 * redrobot has fingers crossed that work will send him to Boston
20:36:19 <diazjf> \o/ We can have some hangouts setup as the Summit gets closer and closer
20:36:34 <diazjf> we should still have most of the material just a few things to cleanup
20:37:52 <dave-mccowan> yea... also we'll need to make a "Barbican Project Status" presentation.   The foundation will be providing a template for projects to follow.
20:38:38 <dave-mccowan> also we'll be hosting an "Onboarding room".  there's some mix messages on whether we're supposed to make it a presentation, or an open-house drop-in kind of thing.
20:39:05 <dave-mccowan> the idea is to meet and welcome new contributors and give them info to help them get up to speed and contributing to barbican.
20:40:08 <dave-mccowan> we've still got a few weeks to get ready.  we'll talk more.
20:40:14 <dave-mccowan> anything else for today?
20:41:34 <kfarr> My KMIP patch is passing!
20:41:38 <kfarr> Would appreciate reviews
20:41:46 <kfarr> https://review.openstack.org/#/c/437747/
20:41:50 <dave-mccowan> \o/
20:44:27 <dave-mccowan> Thanks everyone!  See ya later. :-)
20:44:34 <dave-mccowan> #endmeeting