20:00:01 <dave-mccowan> #startmeeting barbican
20:00:01 <openstack> Meeting started Mon Apr 17 20:00:01 2017 UTC and is due to finish in 60 minutes.  The chair is dave-mccowan. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:06 <openstack> The meeting name has been set to 'barbican'
20:01:44 <kfarr> \o/
20:01:53 <dave-mccowan> hi kfarr!
20:02:02 <kfarr> hey dave-mccowan !
20:02:06 <dave-mccowan> thanks for chairing last week
20:02:12 <kfarr> no problem
20:02:21 <dave-mccowan> #topic roll call
20:02:26 <kfarr> o/
20:02:29 <dave-mccowan> i'm out of practice
20:04:01 <dave-mccowan> small group so far.  hopefully more will join soon.
20:04:06 <dave-mccowan> the agenda: https://wiki.openstack.org/wiki/Meetings/Barbican#Agenda
20:04:48 <dave-mccowan> #topic pike status
20:04:52 <diazjf> o/
20:04:59 <dave-mccowan> hi diazjf!
20:05:19 <diazjf> hey dave-mccowan! It's been a busy day!
20:05:35 <dave-mccowan> let's skip to tempest testing with py3.5, while we wait for anyone else joining soon.
20:05:56 <dave-mccowan> kfarr i added a py35 version of the tempest testing and a few tests fail.
20:06:12 <kfarr> dave-mccowan ohhh
20:06:24 <dave-mccowan> do you think any APLers would be able to take a look?
20:06:47 <kfarr> Probably!  It's just an experimental gate for now?
20:07:20 <dave-mccowan> yes
20:07:32 <dave-mccowan> probably pretty straight forward fixes... adding b'' in a few places
20:07:41 <alee> o/
20:07:47 <dave-mccowan> hi alee!
20:07:54 <alee> dave-mccowan, hey there
20:08:10 <dave-mccowan> let's look the pike tracker: https://etherpad.openstack.org/p/barbican-tracker-pike
20:08:42 <dave-mccowan> we're 1/3 through Pike now.  we fixed a good number of bugs in milestone 1, but haven't made much progress on our blueprints
20:09:26 <dave-mccowan> alee do you have any predictions of the future for WSGI deployment or IPA vault?
20:10:03 <alee> dave-mccowan, no - no predictions.
20:10:33 <alee> dave-mccowan, I've been tied up on other things, but I may get freed up for at least some time
20:10:49 <alee> dave-mccowan, more liekly than noy, ipa vault will be deferred
20:11:32 <alee> dave-mccowan, whats the wgsi deployemnt thing?
20:12:10 <dave-mccowan> it's a community goal, and something said that OOO needed too.  i guess deploy behind httpd is the most popular way to do it.
20:12:31 <dave-mccowan> we want to make it the default for devstack
20:12:50 <alee> dave-mccowan, oh ok - yeah we do
20:12:58 <alee> (we already do in triple-o
20:13:12 <dave-mccowan> sweet.  easy cut-n-paste then. :-)
20:13:34 <alee> dave-mccowan, so yeah its still doable. just gotta find time to do it
20:14:22 <dave-mccowan> cool.  still plenty of time, but it'll go fast with summit in the middle of the release.
20:14:42 <dave-mccowan> kfarr what about list filters?  i know you have a bunch of patches out for this.  do they need reviews?
20:14:57 <kfarr> Yes!
20:15:23 <kfarr> redrobot already implemented the backend feature
20:15:41 <kfarr> It just needs to be exposed in python-barbicanclient (and castellan)
20:15:49 <kfarr> Here's python-barbicanclient: https://review.openstack.org/#/c/400370/
20:16:10 <kfarr> and castellan (dependent on the above patch): https://review.openstack.org/#/c/418019/
20:16:23 <dave-mccowan> is all the code done for it then?  just waiting on reviews and merges?
20:16:43 <kfarr> Yup!
20:16:50 <dave-mccowan> cool!
20:17:23 <dave-mccowan> for Python 3.5, the community goal is to have functional and tempest gate jobs running with py35.
20:17:46 <dave-mccowan> i have most of the functional tests running.  just about 20 failing tests left to fix.
20:18:07 <dave-mccowan> there's also an experimental gate job for tempest that has a few failures too.
20:18:22 <dave-mccowan> hopefully we'll get all of those cleared up soon
20:18:34 <dave-mccowan> diazjf what's up with deprecation?
20:19:21 <diazjf> dave-mccowan, I'm setting up some time to get it done this week
20:19:32 <dave-mccowan> great!
20:20:10 <diazjf> #action diazjf to submit patches to remove certificates api.
20:20:25 <dave-mccowan> if anyone has an item schedule for pike-1, please update it to p2, p3, or future based on your plans.
20:20:33 <dave-mccowan> #action diazjf to submit patches to remove certificates api.
20:21:00 <dave-mccowan> any database gurus here?
20:21:37 <dave-mccowan> jeremy has a weird db issue where it's working differently with centos than for ubuntu.
20:21:48 <dave-mccowan> https://bugs.launchpad.net/barbican/+bug/1681988
20:21:49 <openstack> Launchpad bug 1681988 in Barbican "py27 UT fails on centos7.2.1511" [Undecided,New]
20:22:20 <dave-mccowan> that's all i have for Pike
20:22:24 <dave-mccowan> moving on....
20:22:40 <dave-mccowan> #topic Summit
20:23:01 <dave-mccowan> alee i saw you had some updates last week for the workshop
20:23:23 <dave-mccowan> anything else new, or urgent?
20:23:27 <alee> dave-mccowan, yeah - I'd like to get a meeting scheduled for the workshop presenters this week
20:23:45 <alee> kfarr, and I were thinking tommorow morning perhaps?
20:23:49 <alee> 11 am EST?
20:23:55 <dave-mccowan> +1 for me
20:23:59 <kfarr> +1
20:24:15 <alee> redrobot, diazjf , dave-mccowan ?
20:24:24 <redrobot> o/
20:24:37 <dave-mccowan> redrobot \o/
20:25:16 <diazjf> alee, redrobot, wotks for me.
20:25:21 <redrobot> sorry I'm late guys
20:25:33 <redrobot> It's been a fun few days at the rack
20:25:36 <alee> redrobot, can you meet tomorow at 11 am EST?
20:25:46 <alee> for the workshop ..
20:25:51 <redrobot> alee yes, should be good.
20:25:56 <alee> dave-mccowan, ??
20:26:02 <dave-mccowan> yes for me
20:26:14 <alee> excellent -- kfarr can you set it up?
20:26:22 <kfarr> Ah yes
20:26:30 <kfarr> Meeting invite ?
20:26:35 <alee> yup
20:26:39 <alee> google hangout
20:27:03 <alee> we can do updates then
20:27:44 <dave-mccowan> redrobot we should set another time to start planning the vault presentation
20:28:20 <dave-mccowan> https://etherpad.openstack.org/p/barbican-pike-summit
20:29:21 <dave-mccowan> barbicaneers are busy this summit.  feel free to add anything you to share to that etherpad
20:29:33 <dave-mccowan> anything else for summit?
20:30:18 <dave-mccowan> #topic pike status revist
20:30:32 <dave-mccowan> redrobot do you have an update for any pike blueprint items?
20:30:40 <dave-mccowan> (do you need help or review or anything?)
20:30:49 <dave-mccowan> https://etherpad.openstack.org/p/barbican-tracker-pike
20:31:21 <dave-mccowan> you signed up for 4 at the PTG.
20:32:47 <redrobot> well, not sure if y'all saw the news already but OSIC was cancelled
20:32:56 <redrobot> so no Intel folks will be joining
20:33:08 <dave-mccowan> :-(
20:33:16 <kfarr> yeah :(
20:33:19 <diazjf> :(
20:33:21 <redrobot> and I'm only working on Barbican for this week and next, and hopefully find a new job shortly after that.
20:33:28 <kfarr> !!
20:33:29 <openstack> kfarr: Error: "!" is not a valid command.
20:33:43 <redrobot> I'm still going to Boston on my own dime
20:33:52 <redrobot> and will definitely work on the presentations
20:34:33 <kfarr> :( :(
20:34:41 <dave-mccowan> redrobot I hope everything works out.  definitely apply for travel assistance.
20:34:43 <redrobot> also if anyone is hiring, let me know!  I've got a freshly updated resume I can send your way :)
20:35:08 <redrobot> dave-mccowan yep, I've been frantically email lots of folks, and I still have speaker support on my list of to-dos
20:35:18 <redrobot> *emailing
20:35:28 <diazjf> redrobot, good luck my dude!
20:35:52 <redrobot> diazjf thanks m8
20:36:05 <redrobot> dave-mccowan yeah, let's sync up some time tomorrow for the Vault talk
20:36:45 <dave-mccowan> redrobot tomorrow is good for me.
20:36:50 <dave-mccowan> #topic any other business
20:38:16 <dave-mccowan> thanks everyone!  we'll talk tomorrow on summit prep!
20:38:22 <dave-mccowan> #endmeeting