#openstack-barbican: barbican

Meeting started by redrobot at 13:01:41 UTC (full logs).

Meeting summary

  1. Roll Call (redrobot, 13:03:41)
  2. Review action items from last week (redrobot, 13:04:47)
    1. ACTION: redrobot to update the Barbican Wiki page (redrobot, 13:06:09)
    2. ACTION: redrobot to ask alee about submitting the Barbican workshop to the next Summit (redrobot, 13:07:07)

  3. Successfully tested regression fix patch for SafeNet HSM (redrobot, 13:09:52)
    1. https://review.openstack.org/#/c/629294/ (redrobot, 13:10:04)

  4. Bug "ERROR: _get_master_key() takes exactly 3 arguments (2 given)" when executing `barbican-manage hsm rewrap_pkek` (Luzi, graeb) (redrobot, 13:12:58)
    1. ACTION: Luzi to add a new story to the Barbican Storyboard for the _get_master_key() error (redrobot, 13:18:08)

  5. Why do we SHA256 HMAC over a wrapped PKEK? (redrobot, 13:19:46)
    1. ACTION: graeb to add story for making HMAC Key Wrap mechanism configurable (redrobot, 13:32:20)

  6. Failing Gates (redrobot, 13:32:42)
    1. https://review.openstack.org/#/c/628667/ (redrobot, 13:33:22)
    2. ACTION: redrobot to add stories for permanent fixes to the gate workarounds (redrobot, 13:36:07)


Meeting ended at 13:40:49 UTC (full logs).

Action items

  1. redrobot to update the Barbican Wiki page
  2. redrobot to ask alee about submitting the Barbican workshop to the next Summit
  3. Luzi to add a new story to the Barbican Storyboard for the _get_master_key() error
  4. graeb to add story for making HMAC Key Wrap mechanism configurable
  5. redrobot to add stories for permanent fixes to the gate workarounds


Action items, by person

  1. graeb
    1. graeb to add story for making HMAC Key Wrap mechanism configurable
  2. Luzi
    1. Luzi to add a new story to the Barbican Storyboard for the _get_master_key() error
  3. redrobot
    1. redrobot to update the Barbican Wiki page
    2. redrobot to ask alee about submitting the Barbican workshop to the next Summit
    3. redrobot to add stories for permanent fixes to the gate workarounds


People present (lines said)

  1. redrobot (62)
  2. graeb (18)
  3. Luzi (4)
  4. openstack (3)
  5. moguimar (2)
  6. mhen (2)
  7. jaosorior (1)
  8. openstackgerrit (1)
  9. raildo (1)


Generated by MeetBot 0.1.4.