13:01:18 <redrobot> #startmeeting barbican
13:01:19 <openstack> Meeting started Tue Jul 30 13:01:18 2019 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:20 <redrobot> Is the meetbot asleep?
13:01:22 <openstack> The meeting name has been set to 'barbican'
13:01:24 <redrobot> there we go
13:01:24 <moguimar> o/
13:01:30 <redrobot> #topic Roll Call
13:01:44 <redrobot> Courtesy ping for ade_lee hrybacki jamespage Luzi lxkong raildo rm_work xek
13:01:52 <rm_work> o/
13:01:54 <redrobot> As usual our agenda can be found here:
13:01:56 <Luzi> o/
13:02:10 <redrobot> #link https://etherpad.openstack.org/p/barbican-weekly-meeting
13:02:58 <redrobot> #topic Review Past Meeting Action Items
13:03:22 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2019/barbican.2019-07-23-13.02.html
13:04:11 <redrobot> First action item: tedrobot to look into the key_manager implementation of openstacksdk to determine feature gap
13:04:19 <redrobot> *redrobot not tedrobot
13:04:26 <redrobot> I did this!
13:04:34 <redrobot> openstacksdk is pretty barebones
13:05:19 <redrobot> there's only support for secrets, containers and orders
13:06:57 <redrobot> so it's going to need quite a bit of work to get it up to speed
13:07:08 <redrobot> which begs the question: Why on earth are we maintaining two clients?
13:08:14 <redrobot> Luzi, you said Nova absolutely must use openstacksdk?
13:08:15 <Luzi> redrobot, i have no idea, it was that way, when I started working on openstack :D
13:09:53 <Luzi> as far as i understand this, it is their goal to somewhen only use openstacksdk...
13:09:56 <rm_work> so, in octavia we maintain python-octaviaclient as a programming interface only, and import it to the SDK for our CLI support
13:10:07 <rm_work> which I believe has been working well
13:10:25 <redrobot> rm_work, openstackclient or openstacksdk ?
13:10:32 <redrobot> rm_work, we plug into openstackclient for cli
13:10:36 <rm_work> err yeah sorry
13:10:40 <rm_work> SDK is what Horizon uses
13:10:41 <rm_work> so UI
13:10:48 <rm_work> though you don't have a UI yet...
13:11:15 <redrobot> I think I'll just poke the hornets nest and send a message to the ML about WTF the goal is with openstackclient
13:11:21 <redrobot> err SDK
13:12:05 <rm_work> nm i lied i guess we don't use our pythonclient in there O_o
13:12:08 <redrobot> #action redrobot to poke ML to understand the goal of openstacksdk
13:12:20 <rm_work> johnsom did all the work on this, I thought i followed it but apparently not close enough lol
13:12:27 <redrobot> haha
13:12:29 <rm_work> but he would know the answer to what the idea behind the whole thing is
13:12:35 <redrobot> yeah, I have no idea who worked on the Barbican stuff
13:13:20 <redrobot> cool
13:13:29 * redrobot tries to avoid double work as much as possible
13:13:32 <rm_work> looks like Monty and ... Brian Curtain? don't know him
13:13:44 <redrobot> He was a Racker back in the day
13:14:12 <rm_work> looks like most of the work was 2-3 years ago
13:14:16 <redrobot> ok, moving on to the next action item
13:14:19 <rm_work> so this may be out of date
13:14:35 <redrobot> rm_work, yeah, definitely old
13:14:49 <redrobot> and no support for quotas or consumers or nothin'
13:15:35 <redrobot> ok, second action item from last week:
13:15:36 <redrobot> redrobot to talk to hrybacki about unified roles
13:15:55 <redrobot> I did not do this, but I did leave a message for hrybacki on our trello board about it.
13:16:22 <redrobot> There's a role bug in ooo we need to fix, and we may look into the unified roles while we're at it.
13:16:30 <redrobot> #action redrobot to talk to hrybacki about unified roles (2)
13:16:40 <redrobot> ok, that's it for the action items
13:16:45 <redrobot> let's move on to other things
13:17:00 <redrobot> #topic Shanghai Talks
13:17:07 <redrobot> Is voting still open?
13:18:41 <Luzi> no
13:19:00 <Luzi> we are already choosing the final presentations
13:19:40 <redrobot> Nice
13:19:50 * redrobot keeps his fingers crossed for the Barbican Workshop
13:20:18 <redrobot> ok, moving on
13:20:27 <redrobot> #topic Shanghai PTG Space
13:20:43 <redrobot> I got an email asking if we'll need space dedicated to Barbican at the PTG
13:21:00 <redrobot> Anyone @here know if you're going?
13:21:10 <redrobot> I hope I get to go
13:21:20 <Luzi> maybe - depends on boss
13:21:21 <redrobot> but I don't want to ask for space if I'll be sitting in there by myself, lol.
13:21:32 <ade_lee__> I hope to get to go too ,,
13:22:02 <redrobot> I think I have a little over a week to respond
13:22:14 <redrobot> so, I'll ask again next week and keep my fingers crossed, heh
13:22:19 <moguimar> I'm not going
13:22:38 <moguimar> not this time China...
13:24:14 <redrobot> ok, moving on
13:24:18 <redrobot> #topic Open Discussion
13:24:22 <redrobot> Anything else on your minds?
13:25:05 <moguimar> nope
13:25:50 <Luzi> nothing from my side
13:26:00 <redrobot> cool beans
13:26:14 <redrobot> let's wrap up for the day, then.
13:26:21 <redrobot> Thanks for coming everyone!
13:26:23 <redrobot> #endmeeting