13:00:43 <redrobot> #startmeeting barbican
13:00:43 <openstack> Meeting started Tue Aug 6 13:00:43 2019 UTC and is due to finish in 60 minutes. The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:46 <openstack> The meeting name has been set to 'barbican'
13:00:53 <moguimar> o/
13:01:19 <redrobot> #topic Roll Call
13:01:38 <redrobot> Courtesy ping for ade_lee hrybacki jamespage Luzi lxkong raildo rm_work xe
13:01:44 <raildo> o/
13:01:50 <Luzi> o/
13:02:13 <rm_work> o/
13:02:33 <redrobot> As usual our agenda can be found here:
13:02:41 <redrobot> #link https://etherpad.openstack.org/p/barbican-weekly-meeting
13:02:55 <redrobot> Ok, let's get started
13:03:05 <redrobot> #topic Review Past Meeting Action Items
13:03:40 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2019/barbican.2019-07-30-13.01.html
13:03:43 <redrobot> First action item
13:03:59 <redrobot> redrobot to poke ML to understand the goal of openstacksdk
13:04:04 <redrobot> I kind-of did this but not exactly
13:04:09 <redrobot> I didn't email the mailing list
13:04:18 <redrobot> but I did look into it and added a topic for this meeting
13:04:22 <redrobot> so we'll get to it in a bit
13:04:36 <redrobot> Moving on
13:04:41 <redrobot> Next action item:
13:04:43 <redrobot> redrobot to talk to hrybacki about unified roles
13:04:51 <redrobot> I did not do this again. :(
13:04:59 <redrobot> I'll try to do it before next week for sure
13:05:04 <redrobot> #action redrobot to talk to hrybacki about unified roles (3)
13:05:10 <redrobot> Ok, moving on
13:05:21 <redrobot> #topic Liaison Updates
13:05:28 <redrobot> moguimar, anything we should be aware of in osloland?
13:07:33 <redrobot> I think moguimar fell asleep. Going to assume no news from osloland
13:07:37 <redrobot> ok, moving on
13:07:48 <redrobot> #topic OpenstackSDK
13:08:00 <moguimar> bah... screen was not scrolling
13:08:14 <moguimar> osloland is fine
13:08:22 <redrobot> moguimar, no worries. :)
13:08:42 <redrobot> Right, so OpenStack SDK.
13:08:58 <redrobot> When I was looking for a roadmap I ran into this Nova blueprint:
13:09:17 <redrobot> #link https://blueprints.launchpad.net/nova/+spec/openstacksdk-in-nova
13:10:01 <redrobot> So, with Nova no longer using python-XXXclients
13:10:09 <redrobot> I think we should consider deprecating ours
13:10:16 <redrobot> so that we're not maintaining 4 clients
13:10:27 <redrobot> Four clients?!?! Yep, that's right
13:10:29 <redrobot> 1. Castellan
13:10:35 <redrobot> 2. python-barbicanclient
13:10:43 <redrobot> 3. openstacksdk
13:10:58 <redrobot> 4. the "behavior" layer of barbican api functional tests
13:11:23 <redrobot> So, what I was thinking is that we should deprecate python-barbicanclient this cycle
13:11:29 <redrobot> and not implement any new features there
13:11:40 <redrobot> instead focus our energy on openstacksdk
13:11:56 <Luzi> so there is something in openstacksdk already?
13:12:08 <redrobot> Yes, but it's minimal
13:12:31 <Luzi> i see
13:12:33 <redrobot> I think a good exercise would be to re-write Castellan->Barbican using openstacksdk
13:12:59 <redrobot> Also implement the secret consumers feature in openstacksdk
13:14:28 <redrobot> Any thoughts on that?
13:14:42 <redrobot> Anyone getting heartburn because python-barbicanclient would go away?
13:15:25 <Luzi> maybe thats a good question to ask on the ml
13:15:37 <ade_lee> redrobot, I'm ok with it going away -- but maybe we need to have more feature parity between it and openstacksdk before we deprecate it
13:16:00 <ade_lee> at this point, I'm not even sure what the gaps are
13:16:08 <redrobot> ade_lee, that's fair.
13:16:15 <ade_lee> and how long they will take to address
13:16:37 <rm_work> i don't think that octavia planned to get rid of python-octaviaclient due to supporting openstacksdk, but i wonder if it's something we should consider
13:16:43 <redrobot> ade_lee, I've been looking into openstacksdk. There's not much there. I don't have a good estimate for implementation though.
13:17:08 <ade_lee> there is not much of a gap -- or there is not much already implemented?
13:17:11 <redrobot> rm_work, seems like redundant effort.
13:17:18 <rm_work> yeah... it does somewhat
13:17:19 <redrobot> ade_lee, not much implemented haha
13:17:27 <rm_work> but i think we'd also need to rewrite openstackclient to use the SDK then
13:17:38 <rm_work> because the python-xxx clients are used in that
13:18:32 <redrobot> rm_work, looks like openstacksdk is already a part of openstackclient https://opendev.org/openstack/python-openstackclient/src/branch/master/requirements.txt#L10
13:18:40 <ade_lee> redrobot, yeah - then I'd suggest some kind of analysis of what is needed and time for implementation before we consider deprecating python-barbicanclient
13:18:53 <rm_work> hmm
13:19:10 <redrobot> ade_lee, cool, I can look into documenting that
13:19:11 <rm_work> yeah it'd still need implementation work tho
13:19:20 <rm_work> it definitely uses the python-xxxclient right now
13:19:32 <redrobot> #action redrobot to document the feature gap between python-barbicanclient and openstacksdk
13:20:00 <ade_lee> ack sounds like a series of stories/sub-stories ..
13:20:03 <rm_work> i'm very interested in the client folks' take on this
13:20:19 <redrobot> rm_work, yeah, I'd think deprecating python-XXXclient would be a 2-3 cycle process.
13:20:53 <rm_work> specifically Dean
13:21:12 <rm_work> I think he was diving into a lot of these issues somewhat deeply
13:22:25 <redrobot> rm_work, what is the client channeL?
13:22:33 <redrobot> I can go poke them and get some of their feedback/ideas
13:22:51 <rm_work> hmmm uhhh
13:22:56 <rm_work> good question
13:23:20 <rm_work> i usually just poke people in the infra channel cause EVERYONE is always there :D and then figure out the right channel after lol
13:23:22 * rm_work is bad
13:23:25 <Luzi> #openstack.sdks
13:23:33 <Luzi> s/./-
13:23:44 <redrobot> haha
13:23:45 <rm_work> ah k
13:23:46 <redrobot> thanks, Luzi
13:24:12 <redrobot> Maybe I can start a ML discussion too
13:24:30 <redrobot> Try to figure out how many people out there are maintaining both like Octavia
13:25:09 <redrobot> #action redrobot to email ML about openstacksdk/python-xxxclient
13:27:06 <redrobot> ok, looks like we got a couple of action items for this topic
13:27:10 <redrobot> so we can probably move on
13:27:44 <redrobot> #topic KMIP gate is now experimental
13:28:02 <redrobot> Many thanks to AJaeger for whipping our gates back into shape the last couple of days.
13:28:03 <rm_work> kk, dean is in a meeting presently but his short comment was "everything is moving towards the sdk" so it sounds like at least this is the right direction
13:28:14 <redrobot> rm_work++
13:28:16 <rm_work> (in the past we took steps in the WRONG direction, toward a deprecated project, lol)
13:28:22 <redrobot> lol
13:28:53 <redrobot> So, one of the things that happened during this gate cleanup is that the KMIP gate was moved to the experimental pipeline
13:29:05 <redrobot> as you might have noticed, the KMIP gate has been failing for a while
13:29:21 <redrobot> it was marked as non-voting, so it was effectively just wasting a lot of resources
13:29:45 <redrobot> The gate is still there, and you can trigger it by commenting "experimental" (I think?) on the patch.
13:30:01 <rm_work> remind me before the meeting ends that i have a topic
13:30:18 <redrobot> #link https://review.opendev.org/#/c/674655
13:30:31 <redrobot> ^^ review with KMIP being marked as experimental if you're interested
13:30:54 <redrobot> Any questions about the KMIP or other gates?
13:31:39 <redrobot> OK, moving on.
13:31:41 <redrobot> rm_work, you're up
13:31:56 <redrobot> rm_work, what's your topic?
13:32:32 <ade_lee> redrobot, heading to office .. see you in a bit ..
13:32:39 <redrobot> ade_lee, ack
13:33:36 <ade_lee> Luzi, any news on the summit selections front , though?
13:35:05 <Luzi> we are done - should be announced soon
13:35:20 <ade_lee> Luzi, cool - thanks
13:37:53 <redrobot> I think rm_work changed his mind about adding a topic? 🤔
13:38:04 <Luzi> ade_lee, theoretically the schedule should be published "today"...
13:38:16 <rm_work> no i am here
13:38:18 <rm_work> sorry
13:38:25 <rm_work> distracted, this is why i asked you to remind me :D
13:38:27 <rm_work> #link https://review.opendev.org/#/c/666986/
13:38:38 <rm_work> we are discussing making out cross-project barbican gate voting
13:38:45 <rm_work> I am not sure if we actually want to do this
13:38:48 <rm_work> I am curious on your take
13:38:52 <redrobot> #topic Octavia-barbican gate
13:39:01 <rm_work> right now you run a cross-project gate for octavia on barbican somewhere, right?
13:39:26 <redrobot> rm_work, I _think_ so?
13:39:45 <rm_work> I am just curious whether you think it'd be a good idea for us to gate on you with a voting gate
13:40:12 <redrobot> octavia-v2-dsvm-tls-barbican
13:40:18 <redrobot> it's currently non-voting
13:40:42 <rm_work> yeah on our side it's non-voting
13:40:47 <redrobot> Just to be clear, you want to make the existing Barbican gate voting
13:40:50 <rm_work> i thought you had one on your side too but i couldn't find it
13:40:56 <rm_work> yeah, someone proposed it
13:40:58 <redrobot> or add a Barbican+Octavia gate in Octavia that is voting?
13:41:09 <redrobot> We have octavia-v2-dsvm-tls-barbican in Barbican
13:41:15 <redrobot> in the Check pipeline
13:41:35 <johnsom> Someone wants to make it voting on the Octavia side.
13:41:50 <rm_work> ah it took me a few patchsets to find it, it must not be running consistently... well anyway, yeah it looks non-voting on your side
13:42:01 <rm_work> so maybe that answers my question
13:42:06 <redrobot> #link https://opendev.org/openstack/barbican/src/branch/master/.zuul.yaml#L175-L176
13:42:09 <johnsom> Full disclosure, I voted -1 on the idea.
13:42:16 <rm_work> also it appears that since i looked at this, they abandoned the patch
13:42:26 <rm_work> yeah i also did, but i wanted to talk with folks here too :D
13:43:00 <redrobot> Have y'all had issues with it breaking often?
13:43:12 <johnsom> Not really
13:43:14 <redrobot> that'd be my main driver for making something voting
13:43:49 <rm_work> yeah, though i did just see it fail spuriously an hour ago lol
13:44:09 <rm_work> which is the main reason I was -1 ... we don't need MORE chances for random shit to break and kill merges
13:44:22 <johnsom> I just don’t like idea of blocking our patches on yet another project. We already have too many IMO.
13:44:26 <rm_work> yep
13:44:34 <rm_work> ok well this is more discussion than i really even intended
13:44:39 <rm_work> i just wanted snap opinions
13:44:51 <rm_work> and i think johnsom and I already have ours :D
13:44:56 <redrobot> Hehe
13:45:08 <rm_work> i was really just trying to see if you felt strongly that "yes, please do that"
13:45:13 <redrobot> I'm on the side of "leave it as is unless it becomes a pita"
13:45:18 <rm_work> otherwise I think our original takes will stick
13:46:03 <rm_work> because personally if you asked me, i would say "no, please run the job, but keep it non-voting so our random problems don't break you, but keep an eye on it"
13:46:11 <rm_work> which is what I intend to be our approach
13:46:32 <johnsom> +1
13:46:38 <redrobot> rm_work++
13:46:48 <redrobot> Cool, sounds like we're all in agreement :)
13:46:57 <rm_work> yepyep
13:47:03 <rm_work> went 95% longer than intended
13:47:05 <redrobot> #topic Open Discussion
13:47:15 <redrobot> Any other topics we should talk about today?
13:47:23 <moguimar> not on my end
13:49:08 <redrobot> cool cool
13:49:12 <redrobot> thanks for coming everyone!
13:49:15 <redrobot> #endmeeting