13:02:18 <redrobot> #startmeeting barbican
13:02:19 <openstack> Meeting started Tue Sep 10 13:02:18 2019 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:02:22 <openstack> The meeting name has been set to 'barbican'
13:02:39 <openstackgerrit> Moisés Guimarães proposed openstack/barbican master: Add SecretConsumerRepo repository and its tests  https://review.opendev.org/677517
13:02:39 <openstackgerrit> Moisés Guimarães proposed openstack/barbican master: add SecretConsumerMetadatum object and its tests  https://review.opendev.org/679603
13:02:40 <redrobot> #topic Roll Call
13:03:09 <Luzi> \o/
13:03:19 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage lxkong mhen moguimar raildo rm_work xek
13:03:28 <moguimar> o/
13:03:38 <redrobot> As usual our agenda can be found here:
13:03:45 <raildo> o/
13:03:50 <redrobot> #link https://etherpad.openstack.org/p/barbican-weekly-meeting
13:04:14 <redrobot> #topic Review Past Meeting Action Items
13:04:27 <mhen> o/
13:04:36 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2019/barbican.2019-09-03-13.13.html
13:04:58 <redrobot> I did not work on my action items
13:05:08 <redrobot> so I'm just going to go ahead and kick those to next week
13:05:24 <redrobot> #action redrobot to document the feature gap between python-barbicanclient and openstacksdk (6)
13:05:37 <redrobot> #action redrobot to review octavia's how-to for uploading certs (3)
13:05:54 <redrobot> #action redrobot to check if secret types can be changed after upload (3)
13:05:59 <redrobot> mhen, hello!
13:06:05 <redrobot> did you get a chance to work on:
13:06:06 <mhen> redrobot, hello!
13:06:14 <redrobot> mhen to file a bug about simple_crypto using an outdated encryption mechanism (Fernet)
13:06:21 <mhen> did that today!
13:06:39 <redrobot> Awesome!
13:06:39 <mhen> however, marked it as security-relevant, because ... well it kinda is ;)
13:06:45 <mhen> so it might not be visible to everyone
13:06:46 <redrobot> let me see if I can find the link
13:07:06 <mhen> #link https://storyboard.openstack.org/#!/story/2006524
13:07:17 <redrobot> perfect, thanks mhen!
13:07:29 <mhen> I can lift the private flag if desired
13:07:50 <openstackgerrit> Moisés Guimarães proposed openstack/barbican master: add SecretConsumerMetadatum object and its tests  https://review.opendev.org/679603
13:08:04 <redrobot> I can't seem to be able to get to it, so I probably don't have permissions.
13:08:13 <redrobot> I might work with the Security SIG to get that though
13:08:19 <redrobot> as I am interested in being able to look at security bugs
13:08:40 <redrobot> Let's keep the flag on for now mhen
13:08:48 <mhen> roger that
13:09:40 <redrobot> Cool, that's it for the action item review, moving on.
13:09:47 <redrobot> #topic Liaison Updates
13:09:56 <redrobot> moguimar, any news from Oslo we should be aware of?
13:10:01 <moguimar> nope
13:10:09 <redrobot> Cool beans.
13:10:12 <redrobot> Moving on
13:10:16 <redrobot> #topic M3
13:10:29 <redrobot> This week is Milestone-3 release week
13:10:47 <redrobot> I'm really hoping we can get the Secret Consumers feature merged before the end of the week.
13:11:03 <moguimar> working on it
13:11:28 <redrobot> moguimar, I think the delay is mostly my fault ... 😅
13:11:53 <redrobot> Just in case we need it, I'd be okay with a Feature Freeze exception to get this stuff completed for the Train release
13:12:20 * redrobot should probably look into what FF looks like nowadays just in case
13:12:59 <redrobot> Any other things we should consider for M3?
13:15:07 <redrobot> Okay, moving on.
13:15:12 <redrobot> #topic Fedora gate
13:15:47 <redrobot> The fedora gate is failing.  The nodepool was recently upgraded to F29, so the failure is related to that
13:16:09 <redrobot> we have a patch that partially fixes it, but I still have to figure out why it's throwing 500 errors:
13:16:27 <redrobot> #link https://review.opendev.org/#/c/662543/
13:17:22 <redrobot> I'm thinking that if we can't get it sorted out by this afternoon we should consider making it non-voting
13:17:25 <redrobot> to unblock the gate
13:17:35 <redrobot> because none of the Secret Consumers work can land right now.
13:17:40 <redrobot> Any concerns with that plan?
13:19:14 <moguimar> not on my end
13:19:51 <redrobot> Ok, moving on.
13:19:54 <redrobot> #topic Open Discussion
13:20:06 <redrobot> That's all I can think of for the agenda today.
13:20:16 <redrobot> Anyone else have topics they want to bring up?
13:20:27 <moguimar> I don't  have anything else either
13:20:46 <redrobot> Luzi, mhen ?
13:21:09 <Luzi> nothing today from my side
13:21:30 <mhen> me neither
13:21:55 <dave-mccowan> nothing from me... just quick Hi Y'all!  o/
13:22:09 * redrobot a wild dave-mccowan appears!
13:22:20 <redrobot> Hi dave-mccowan!!!
13:22:39 * dave-mccowan waves to redrobot
13:25:25 <redrobot> dave-mccowan, any chance you'll be joining us in Shanghai?
13:29:44 <redrobot> The wolrd may never know ...
13:29:55 <redrobot> Okay, y'all, thanks for coming!  We'll see you next week!
13:29:58 <redrobot> #endmeeting