13:01:08 <redrobot> #startmeeting barbican
13:01:09 <openstack> Meeting started Tue Sep 17 13:01:08 2019 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:12 <openstack> The meeting name has been set to 'barbican'
13:02:06 <moguimar> o/
13:02:06 <redrobot> #topic Roll Call
13:02:11 <mhen> o/
13:02:14 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek
13:02:16 <Luzi> o/
13:02:21 <moguimar> \o
13:02:24 <redrobot> As usual our agenda can be found here:
13:02:32 <nearyo> hello :)
13:02:38 <raildo> yo
13:02:42 <redrobot> #link https://etherpad.openstack.org/p/barbican-weekly-meeting
13:02:49 <redrobot> Wow, lots of folks here today!
13:02:50 <redrobot> Exciting!
13:03:19 <redrobot> Ok, let's get started
13:03:42 <redrobot> #topic Review Last Meeting's Action Items
13:03:58 <redrobot> I've mostly been trying to get the gate unblocked, which I'm almost done with
13:04:04 <redrobot> so I haven't had time to get the action items done
13:04:09 <redrobot> we'll punt to next time
13:04:11 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2019/barbican.2019-09-10-13.02.html
13:04:27 <redrobot> redrobot to document the feature gap between python-barbicanclient and openstacksdk (7)
13:04:33 <redrobot> #action redrobot to document the feature gap between python-barbicanclient and openstacksdk (7)
13:04:41 <redrobot> #action redrobot to document the feature gap between python-barbicanclient and openstacksdk (4)
13:04:51 <redrobot> #action redrobot to check if secret types can be changed after upload (4)
13:04:54 <redrobot> ok, moving on
13:04:59 <redrobot> #topic Liaison Updates
13:05:10 <redrobot> moguimar, anything from Osloland this week?
13:05:18 <moguimar> nope
13:05:35 <redrobot> no news is good news. :)
13:05:39 <redrobot> moving on
13:05:42 <redrobot> #topic Fedora gate
13:06:05 <redrobot> I've been working on a patch to get the gate back to passing:
13:06:09 <redrobot> #link https://review.opendev.org/#/c/662543/
13:06:27 <redrobot> The main issue I'm sorting out now is that the DogTag plugin was not Python 3 compatible
13:06:44 <redrobot> and the new Fedora nodes (29) no longer provide a Python 2 pki module
13:07:01 <redrobot> So I'm updating the DogTag plugin to run in Python 3
13:07:15 <redrobot> I'm expecting to wrap that up today, so we should have an unclogged gate after that
13:08:10 <redrobot> so we can get moguimar Secret Consumers work merged soon after that
13:08:25 <redrobot> (which is a nice segue into the next topic
13:08:30 <redrobot> #topic Secret Consumers
13:08:37 <redrobot> we're going to need a Feature Freeze exception for this
13:08:48 <redrobot> I don't know what all is needed off the top of my head
13:08:52 <redrobot> I should probably look into that
13:09:03 <redrobot> #action redrobot to do the needful for the Secret Consumers FF
13:09:29 <redrobot> moguimar, any other updates on Secret Consumers
13:09:30 <redrobot> ?
13:09:33 <moguimar> nope
13:10:36 <redrobot> OK, moving on
13:10:51 <redrobot> #topic Barbican dashboard extension contrib
13:11:02 <mhen> hi :)
13:11:05 <redrobot> mhen, nearyo take it away!
13:11:22 <mhen> so, a few weeks ago we had a discussion here about a missing dashboard for Barbican right?
13:11:28 <redrobot> right
13:12:16 <mhen> well we were able to recruit nearyo for this job ;)
13:12:57 <redrobot> Nice!
13:13:01 <redrobot> welcome nearyo!
13:13:03 <mhen> he would like to start on this and contribute it
13:13:16 <redrobot> Awesome!
13:13:27 <nearyo> hello :-)
13:13:36 <redrobot> I can get a repo set up with the basic cookie cutter stuff and then let nearyo take it from there
13:13:37 <Luzi> nearyo and I will also be in shanghai, if everything works out with the visa :)
13:13:57 <redrobot> Looking forward to seeing y'all over there!
13:14:03 <redrobot> (also pending visa, hehe)
13:15:04 <redrobot> #action redrobot to set up cookiecutter repo for barbican-ui
13:15:16 <mhen> redrobot, this would be great! We'd appreciate if you could help out nearyo getting this started :)
13:15:48 <redrobot> very cool
13:15:59 <nearyo> Perfect, thank you (y)
13:16:02 <redrobot> That would be so awesome if we can get an initial release for U
13:17:48 <redrobot> I'll try to get that set up later today.
13:17:58 <redrobot> nearyo, I'll ping you once I have some patches up for Infra
13:18:35 <redrobot> Okay, moving on ...
13:18:40 <redrobot> #topic Open Discussion
13:18:47 <redrobot> Any other topics y'all want to talk about?
13:20:59 <redrobot> Alrighty then, looks like we're done here for the day
13:21:04 <redrobot> thanks for coming, everyone!
13:21:07 <redrobot> #endmeeting