13:00:47 <redrobot> #startmeeting barbican
13:00:48 <openstack> Meeting started Tue Feb  4 13:00:47 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:49 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:52 <openstack> The meeting name has been set to 'barbican'
13:02:19 <redrobot> #topic Roll Call
13:02:38 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek
13:02:44 <Luzi> o/
13:02:47 <Luzi> hello :)
13:03:41 <redrobot> Hi Luzi!
13:04:11 <redrobot> Let's get started
13:04:20 <redrobot> #topic Review Past Action Items
13:04:41 <moguimar> o/
13:04:46 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2020/barbican.2020-01-28-13.05.html
13:05:32 <redrobot> OK, first one:
13:05:33 <redrobot> redrobot to add containers-undercloud as a non-voting job
13:05:49 <redrobot> Started working on this, should have a patch ready for it later today
13:05:53 <redrobot> #action redrobot to add containers-undercloud as a non-voting job
13:06:02 <redrobot> ^^ adding it again so we can talk about it again next week
13:06:10 <redrobot> Next,
13:06:11 <redrobot> redrobot to bug stable team for pending stable backports
13:06:20 <redrobot> I did not bug enough people for this
13:06:26 <redrobot> so I need to do some more buggin'
13:06:29 <redrobot> #action redrobot to bug stable team for pending stable backports
13:07:15 <redrobot> OK, moving on
13:07:39 <redrobot> #topic 4Liaison Updates
13:07:52 <redrobot> moguimar, how did it go at FOSDEM?
13:08:16 <moguimar> It was nice
13:08:50 <moguimar> after my talk some one told that my presentation was better than the oslo.config docs
13:08:59 <moguimar> guess I need to do more work to update the docs xD
13:09:18 <redrobot> Hehe, I was just about to say... it sounds like you need to do some doc work, haha.
13:09:20 <moguimar> and you can find everything here
13:09:22 <moguimar> https://fosdem.org/2020/schedule/event/security_protecting_plaintext_secrets_in_configuration_files/
13:09:30 <moguimar> including the recording
13:09:39 <moguimar> #link https://fosdem.org/2020/schedule/event/security_protecting_plaintext_secrets_in_configuration_files/
13:09:43 <redrobot> Nice!  I'll have to check it out later
13:09:51 <moguimar> 20 minutes
13:10:44 <redrobot> moguimar, any other news from oslo?
13:11:01 <moguimar> nope, Ben has been absend from the meetings for a while
13:11:13 <moguimar> I also missed the meeting yesterday, if there was actually one
13:11:29 <moguimar> but Herve is pushing things forward
13:11:53 <moguimar> We are bumping all major versions, I
13:11:59 <moguimar> I'll ask about the castellan patch
13:12:53 <moguimar> that's all on FOSDEM + oslo land
13:13:20 <redrobot> sweet, thanks moguimar
13:13:24 <redrobot> ok, moving on
13:13:43 <redrobot> #topic Manipulation of ACL data in DB
13:13:57 <redrobot> #link https://review.opendev.org/#/c/357978/13/doc/source/artifacts/barbican/newton/review-findings.rst
13:14:05 <redrobot> Luzi, have you had a chance to think about ^^
13:14:15 <Luzi> i was discussing this with mhen
13:15:25 <Luzi> signing the rows does sound like a good idea as long as the private key is not on the database host
13:16:09 <redrobot> Cool.
13:16:19 <redrobot> Yeah, I think Hashicorp Vault does something similar
13:16:38 <redrobot> I think they do authenticated encryption of everything that gets stored in the DB
13:16:53 <redrobot> We should probably work on that this cycle
13:17:03 <redrobot> Luzi, did you have any interest/time to work on this?
13:18:27 <Luzi> sadly not, as i can finally start with implementing some image encryption patches :/
13:19:14 <redrobot> Luzi, no worries.  I'll try to get some time to work on it on Upstream Fridays
13:19:30 <redrobot> That's all I have on the agenda for today
13:19:35 <redrobot> #topic Open Discussion
13:19:42 <redrobot> Anything else y'all want to talk about?
13:19:56 <moguimar> I'd like to take a look into hvac next Friday
13:20:26 <moguimar> and create some cards in the board
13:20:33 <redrobot> Nice, yeah, that'll be awesome moguimar
13:20:35 <moguimar> where do we find the link to that board redrobot ?
13:21:07 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:21:36 <moguimar> tks
13:27:40 <redrobot> Alrighty y'all
13:27:44 <redrobot> I think we're done for the day
13:27:47 <redrobot> Thanks for coming!
13:27:50 <redrobot> #endmeeting