13:00:12 <redrobot> #startmeeting barbican
13:00:13 <openstack> Meeting started Tue Mar 10 13:00:12 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:16 <openstack> The meeting name has been set to 'barbican'
13:00:26 <redrobot> #topic Roll Call
13:00:29 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek
13:00:34 <Luzi> o/
13:00:43 <redrobot> As usual our agenda can be found here:
13:00:51 <redrobot> #link https://etherpad.openstack.org/p/barbican-weekly-meeting
13:00:57 <redrobot> Hi Luzi!
13:02:46 <Luzi> hi redrobot
13:03:00 <redrobot> #topic Review Past Action Items
13:03:24 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2020/barbican.2020-03-03-13.00.html
13:03:25 <nearyo> o/
13:03:30 <redrobot> I still need to do my action item
13:03:46 <redrobot> #action redrobot to send ML message to get added to barbican-stable
13:03:50 <redrobot> ok, moving on
13:03:53 <redrobot> hi nearyo!
13:03:59 <nearyo> hey
13:04:16 <redrobot> #topic Liaison Updates
13:04:23 <redrobot> moguimar, o/
13:06:11 <moguimar> o/
13:06:16 <redrobot> hi moguimar!
13:06:19 <moguimar> hey
13:06:21 <redrobot> Any updates from oslo?
13:06:29 <moguimar> not really
13:06:36 <moguimar> I've been doing some castellan code latelly
13:06:40 <redrobot> :-O
13:06:51 <redrobot> I saw your patches, but haven't had a chance to review them yet
13:06:58 <redrobot> #topic Castellan Updates
13:07:12 <moguimar> the hvac backend is still waiting on some decisions
13:07:25 <redrobot> #link https://review.opendev.org/#/q/project:openstack/castellan+status:open
13:07:44 <moguimar> so the traditional vault backend turns the objects into dicts
13:07:45 <redrobot> Ok, I'll try to take a look soon.  For sure I'll look at it Friday at the latest.
13:07:50 <moguimar> before storing them
13:07:57 <moguimar> I wanna centralize that code somewhere
13:08:09 <moguimar> and was thinking if we don't aready have a solution or pattern for that
13:08:36 <moguimar> I looked into oslo.serialization and yesterday oslo folks recommended me to look into oslo.versionedobjects
13:08:59 <redrobot> πŸ€”πŸ€”πŸ€”
13:09:21 <moguimar> so I have that on my list for when I get back from BRA
13:10:26 <moguimar> HervΓ© is helping a lot in the reviews =D
13:10:46 <moguimar> I gotta back to him as well in the oslo.cache code
13:10:57 <moguimar> back him up*
13:11:22 <moguimar> which will also help me in other security stuff
13:11:25 <redrobot> awesome, thanks for leading the charge on the HVAC work, moguimar
13:11:50 <moguimar> I wanna have it with at least the same features as the current one has
13:12:01 <moguimar> https://review.opendev.org/#/c/706468/
13:12:07 <moguimar> this one could use some input too
13:12:15 <moguimar> just to raise a discussion
13:12:51 <moguimar> and I think at some point that could be automated
13:12:56 <moguimar> some dependabot
13:13:06 * redrobot looks
13:13:54 <redrobot> ah yes... I thought we had updated the Vault version alredy?
13:14:37 <redrobot> I'm not sure we want to always be bumping the minimum version of Vault we support, but we definitely need to do a better job of evaluating new releases
13:14:47 <moguimar> yep
13:16:07 <redrobot> Cool, anything else on Castellan?
13:16:11 <moguimar> nope
13:16:21 <redrobot> alright, moving on
13:16:27 <redrobot> #topic Barbican UI
13:16:41 <redrobot> nearyo, I'm sorry I have not had a chance to look at your patch. :(
13:16:57 <redrobot> ade_lee, was supposed to do the initial review, but I'm not sure if he's had a chance to do that
13:17:04 <redrobot> unfortunately he's out on PTO right now.
13:17:12 <redrobot> But I'll ask him about it when he gets back.
13:17:23 <redrobot> I think rm_work was also interested in Barbican UI
13:17:58 <nearyo> Hey ... okay no problem ... that was my the question
13:18:15 <rm_work> Yeah he was
13:18:40 <rm_work> But he knows literally nothing about UI code
13:18:47 <redrobot> same
13:18:50 * redrobot hangs head in shame
13:19:11 * rm_work holds head high
13:20:04 <nearyo> No problem ... maybe you can have a look at the python/server side? :)
13:21:51 <Luzi> https://review.opendev.org/#/c/702399/
13:22:07 <redrobot> For sure. :)  ... also maybe we should ping the UI folks to take a looky loo
13:22:16 <Luzi> that's the link in case someone wants to know ;)
13:22:31 <redrobot> thanks, Luzi
13:22:38 <nearyo> So maybe you can check in the first place if I used the barbican-python-client correctly? This would be great.
13:22:48 <redrobot> #help we need more reviewers for the initial Barbican UI patch
13:22:49 <nearyo> (y)
13:25:42 <redrobot> oh no! nearyo ragequit
13:25:47 <redrobot> j/k
13:25:50 <redrobot> I hope he comes back.
13:25:56 <redrobot> Ok, moving on
13:26:01 <redrobot> #topic PTG
13:26:22 <redrobot> I did not request space for Barbican at the upcoming PTG due to lack of attendees interested in Barbican.
13:26:32 <rm_work> RIP
13:26:39 <nearyo> o/
13:27:01 <rm_work> Well hopefully it even happens :)
13:27:04 <redrobot> sorry rm_work... you would have been sitting at the PTG table by yourself.
13:27:21 <rm_work> I requested space for 10 for octavia lol
13:27:59 <rm_work> How are we supposed to tear up the town if you aren't there πŸ˜”
13:28:13 <redrobot> :(
13:28:21 <redrobot> We'll have to plan to tear up Berlin instead. lol
13:28:49 <rm_work> Works for me
13:28:58 <Luzi> I will be in Berlin too :D
13:29:08 <rm_work> Noice
13:29:14 <redrobot> rm_work, I do recommend going to the Devil's Elbo for a Beer Burbon and Bacon.
13:29:20 <redrobot> *Devil's Elbow
13:29:33 <rm_work> Sold me with the bacon
13:29:55 <redrobot> Luzi, awesome!  I'm going to try to get to Berlin too. 🀞🀞
13:31:12 <redrobot> ok, moving on
13:31:26 <redrobot> #topic Open Discussion
13:31:32 <redrobot> Anything else y'all want to talk about?
13:31:41 <tosky> soooo, a review in barbican-tempest-plugin
13:31:54 <tosky> this one, part of the "drop py2" goal: https://review.opendev.org/#/c/704083/
13:32:35 <tosky> also, I noticed there is a bunch of barbican-tempest-plugin reviews which could be easily reviewed or even approved (like opendev links migration, stestr migration, etC)
13:33:27 <redrobot> tosky, looking
13:33:38 * redrobot adds barbican-tempest-plugin to his review queue
13:36:49 <tosky> thanks!
13:37:06 <redrobot> Anything else we should talk about?
13:37:36 <nearyo> Sorry guys ... BEST-WIFI (TM)For those who are interested in the barbican-ui or if someone has any questions, it's probably the easiest to write me an email to dag.dammann@cloudandheat.com
13:38:04 <redrobot> Ack, thanks again for the UI work, nearyo
13:38:38 <nearyo> my pleasure ^^
13:39:23 <redrobot> Alrighty, y'all.  I don't have anything else on the agenda.
13:39:27 <redrobot> Thanks everyone for joining!
13:39:33 <redrobot> See y'all online!
13:39:37 <redrobot> #endmeeting