13:01:23 <redrobot> #startmeeting barbican
13:01:24 <openstack> Meeting started Tue Apr 14 13:01:23 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:27 <openstack> The meeting name has been set to 'barbican'
13:02:10 <redrobot> #topic Roll Call
13:02:15 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:02:25 <moguimar> o/
13:02:47 <openstackgerrit> Merged openstack/castellan master: Update master for stable/ussuri  https://review.opendev.org/719790
13:02:56 <rm_work> o/
13:03:01 <redrobot> hi moguimar and rm_work!
13:03:18 <moguimar> hey
13:03:40 <redrobot> #topic Review Past Meeting Action Items
13:04:12 <redrobot> Let's see ..
13:04:30 <redrobot> I still need to do this
13:04:45 <redrobot> #action redrobot to send ML message to get added to barbican-stable team
13:04:57 <redrobot> and also nearyo won't be able to demo barbican-ui yet
13:05:17 <redrobot> #action nearyo to give a demo of Barbican-UI some time
13:05:31 <redrobot> #topic Liaison Updates
13:05:50 <redrobot> I made sure to attend the Oslo meeting yesterday
13:05:53 <moguimar> I was on holyday yesterday
13:05:59 <moguimar> good
13:06:19 <redrobot> I've been trying to fix our gates, and part of the issues we're seeing is that Castellan made a 3.0.0 release on 2020-03-31
13:06:25 <redrobot> that was broken
13:06:37 <redrobot> partly because functional testing is not great in Castellan
13:06:51 <moguimar> did you find the cause already?
13:07:16 <redrobot> yep
13:07:21 <rm_work> have you noticed any gate issues with sqlalchemy / sqlite?
13:07:31 <redrobot> a constant was renamed, but not all references were updated
13:07:35 <redrobot> https://bugs.launchpad.net/castellan/+bug/1872480
13:07:35 <openstack> Launchpad bug 1872480 in castellan "Castellan release 3.0.0 is broken" [Critical,Fix committed] - Assigned to Douglas Mendizábal (dougmendizabal)
13:07:50 <redrobot> #link https://review.opendev.org/#/c/718775
13:07:54 <redrobot> ^^ is the patch
13:08:24 <redrobot> and I worked with bnemec yesterday to get a 3.0.1 release
13:08:38 <redrobot> rm_work, I did notice those, but I haven't dug into it yet
13:08:48 <redrobot> I'm a bit confused, because I thought devstack used MariaDB?
13:09:18 <rm_work> at least octavia's functional suite just uses a sqlite db
13:09:20 <moguimar> guilty xD
13:09:48 <rm_work> devstack uses a real db yes
13:11:10 <redrobot> rm_work, I'll dig into that next issue soon
13:11:33 <redrobot> I'm still trying to figure out why tf devstack is still pulling in 3.0.0 instead of the newer 3.0.1
13:11:38 <rm_work> ah so you have seen issues with that?
13:12:16 <redrobot> Yeah ... well, I've seen SQLite issues in the logs while trying to fix this Castellan issue
13:12:27 <redrobot> but I'm not sure how many of the test failures are due to that
13:12:29 <rm_work> kk i will be interested to see what those are :D
13:12:54 <redrobot> cool, I'll let you know when I find out
13:13:08 <redrobot> as far as Castellan goes, I did ask for a requirements FFE
13:13:11 <redrobot> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-April/014077.html
13:14:01 <redrobot> So I'll figure out what needs to be done there
13:14:07 <redrobot> I think it's just a patch to openstack/requirements
13:14:54 <redrobot> But yeah, if anyone knows what the deal is with pip installing 3.0.0 still, I'd appreciate the help
13:15:24 <redrobot> ok, moving on
13:15:34 <redrobot> #topic barbican-ui
13:16:10 <redrobot> There was a message in the ML asking about a barbican-ui release
13:16:13 <redrobot> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-April/014084.html
13:16:31 <redrobot> but as we have not landed nearyo's work yet, I asked the release team to remove barbican-ui from Ussuri
13:16:40 <redrobot> so we'll target the initial release for next cycle.
13:16:55 <redrobot> after we've had a chance to see nearyo's demo and get all that code merged
13:21:01 <openstackgerrit> Merged openstack/castellan master: Update hacking for Python3  https://review.opendev.org/715646
13:21:02 <openstackgerrit> Merged openstack/castellan master: Add Python3 victoria unit tests  https://review.opendev.org/719791
13:22:09 <redrobot> OK, moving on
13:22:13 <redrobot> #topic Open Discussion
13:22:27 <redrobot> Any other topics y'all want to talk about moguimar, rm_work?
13:23:00 <moguimar> nope, it was holiday last friday, so I didn't have the chance for an Upstream Friday
13:23:24 <rm_work> nope, just beating my head against this sqlalchemy issue o/
13:23:41 <redrobot> barbican sqlalchemy?
13:23:46 <rm_work> no
13:23:59 <redrobot> well, then,  ...  good luck! >_<
13:24:09 <rm_work> o/
13:24:41 <redrobot> alrighty, y'all, thanks for joining!
13:24:46 <redrobot> #endmeeting