13:01:46 <redrobot> #startmeeting barbican
13:01:46 <openstack> Meeting started Tue May  5 13:01:46 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:47 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:49 <openstack> The meeting name has been set to 'barbican'
13:01:55 <redrobot> #topic Roll Call
13:01:57 <moguimar> o/
13:02:37 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:02:40 <redrobot> Hi moguimar!
13:02:44 <moguimar> hey
13:02:44 <Luzi> o/
13:03:15 <redrobot> Hi Luzi!
13:03:25 <Luzi> hi redrobot, hi moguimar :)
13:03:48 <moguimar> hi Luzi
13:03:56 <tosky> o/
13:04:04 <redrobot> Hi tosky!
13:04:08 <redrobot> Ok, let's get started
13:04:13 <redrobot> #topic Virtual PTG
13:04:18 <moguimar> looks like we have a meeting this week xD
13:04:38 <moguimar> redrobot, did you get us a room slot?
13:04:49 <redrobot> Was about to ask about that haha
13:04:59 <moguimar> #link https://ethercalc.openstack.org/126u8ek25noy
13:05:20 <redrobot> thanks!  I was just about to post that
13:06:06 <redrobot> moguimar, suggested that we could meet around this time
13:06:22 <moguimar> yeah, but the slots might be dificult now
13:06:32 <redrobot> Which works for me, but there seems to be a lot of stuff happening on Tuesday as well
13:07:48 <redrobot> Looks like Cinder is meeting on Tuesday
13:07:58 <redrobot> Luzi, are you planning on joining the Virtual PTG?
13:08:07 <moguimar> room 18/19 have slots
13:08:14 <Luzi> yeah
13:08:29 <redrobot> moguimar, yeah, there's a note about adding a room if needed, so I could look into that also
13:08:50 <moguimar> Cinder is meeting Tue and Wed
13:09:00 <moguimar> should we book another day?
13:09:05 <moguimar> I'm fine with Thursday
13:09:20 <redrobot> That'll work for me too
13:09:36 <moguimar> 2 or 3 slots?
13:09:36 <redrobot> Luzi, tosky what do y'all think about having the Barbican discussions on Thursday
13:10:00 <Luzi> I'm fine with that
13:10:25 <tosky> don't block your program on me - I will popup with some question on testing and zuulv3 (if there are open questions about that)
13:11:13 <redrobot> tosky, you can add those topics here:
13:11:16 <redrobot> #link https://etherpad.opendev.org/p/barbican-victoria-topics
13:11:52 <tosky> oh, oki
13:12:08 <redrobot> Ok, I've reserved Thursday from 1300-1700 UTC
13:12:24 <redrobot> I'll send an email to openstack-discuss after this
13:12:37 <redrobot> #action redrobot to announce Virtual PTG slot on openstack-discuss
13:13:09 <redrobot> So, yeah, please add topics to that ehterpad
13:13:41 <redrobot> I'm also going to add a topic to review last cycle's etherpad
13:13:49 <redrobot> for stuff we didn't get to that we may still want to do
13:15:54 <redrobot> Any other questions/comments about the Virtual PTG?
13:17:39 <redrobot> OK, moving on
13:17:48 <redrobot> #topic Gerrit Gates
13:18:14 <redrobot> Things are moving again, though I may have broken a few jobs by not configuring stuff correctly switching to Zuul v3
13:18:46 <tosky> do I understand it correctly that not all jobs have been ported?
13:18:47 <redrobot> Also, a shoutout to AJaeger for helping a bunch with getting our repos updated for Python 3.8
13:21:53 <redrobot> Let me know if you see anything funky going on with the gates and we'll try to get it sorted out
13:22:03 <redrobot> Any other questions/comments on the gate updates?
13:22:08 <tosky> a quick note about the grenade job: the current one is not working as expected (it does not test barbican :)
13:22:27 <redrobot> tosky, yeah, I totally messed that one up, haha.  :(
13:22:54 <tosky> I tried to address that, but it is failing https://review.opendev.org/#/c/724258/
13:22:56 <redrobot> tosky, I'll try to get to it soonish, but definitely by Friday
13:23:07 <tosky> and I'm not sure why, because the smoke tests are passing
13:23:37 <redrobot> tosky, I'll take a look at your patch as soon as I can
13:24:50 <tosky> unrelated, there is a python-barbicanclient patch (not by me) which should fix the gates there and it may get some reviews: https://review.opendev.org/#/c/721203/
13:25:18 <tosky> finally, in case of issues with the zuulv3 conversion and/or any question, I volunteered to help with that goal, so please feel free to ping me anytime/add me to the reviews
13:25:27 <tosky> and please add native-zuulv3-migration as review topic
13:25:32 <redrobot> tosky, awesome!
13:26:45 <redrobot> OK, moving on
13:26:52 <redrobot> #topic Open Discussion
13:26:58 <redrobot> Anything else y'all want to talk about?
13:27:19 <moguimar> not on my end
13:27:20 <tosky> a question I wanted to raise - which I haven't discussed with the cinder cores
13:27:41 <tosky> barbican-tempest-plugin contains tests which also touch cinder (volume encryption tests)
13:27:54 <tosky> it also has glance-related tests (image signing)
13:28:21 <tosky> in cinder, we are trying to extend our testing to also include encryption with barbican as key manager
13:28:50 <tosky> we have cinder-tempest-plugin, but technically the tempest client for barbican is in barbican-tempest-plugin
13:29:29 <tosky> so I was wondering if it would be possible to co-share the responsibility of barbican-tempest-plugin with other teams (cinder, glance, QA),
13:29:53 <redrobot> tosky, we kinda do something like that wit the Octavia folks
13:30:00 <tosky> with some kind of gentleperson agreement of not approving tests which cover other projects without an ack for the people from those other projects and/or barbican
13:30:03 <tosky> oh
13:30:29 <redrobot> For Octavia, we have jobs that check our patches against their TLS tests
13:30:56 <redrobot> And they run the same test suite on their patches ... (though I'm not super familiar with their end of things)
13:32:00 <redrobot> tosky, maybe we need a Cinder->Barbican liaison?  Someone (or a few folk) who get added to patches to barbican-tempest-plugin?
13:32:25 <tosky> redrobot: yes, something like that; I will discuss about this with the other cinder people
13:32:38 <tosky> (I'm a fresh core on cinder-tempest-plugin, but not on cinder)
13:32:46 <redrobot> Yeah, it seems wasteful to double the efforts to test that integration
13:34:00 <redrobot> tosky, cool, let me know what y'all think about it when you bring it up.
13:34:04 <tosky> thanks!
13:34:24 <tosky> (a small review about barbican-tempest-plugin is https://review.opendev.org/#/c/721979/ :)
13:34:31 <tosky> that's it from me today
13:35:02 <redrobot> Appreciate your input tosky!
13:35:09 <redrobot> OK, anything else before we call it a day?
13:37:10 <redrobot> Cool beans.
13:37:22 <redrobot> Thanks for joining everyone!  See you online!
13:37:25 <redrobot> #endmeeting