13:01:21 <redrobot> #startmeeting barbican
13:01:22 <openstack> Meeting started Tue May 19 13:01:21 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:25 <openstack> The meeting name has been set to 'barbican'
13:01:33 <redrobot> #topic Roll Call
13:01:59 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:03:25 <moguimar> o/
13:03:37 <redrobot> Good morning, moguimar!
13:03:42 <moguimar> morning
13:03:55 <redrobot> I was starting to think no one was going to show up.
13:03:59 <tkajinam> o/
13:04:13 <tkajinam> hi. let me join to bring one topic
13:04:14 <redrobot> hi tkajinam!
13:04:22 <tkajinam> redrobot, hi :-)
13:04:35 <redrobot> OK, let's get started
13:04:43 <redrobot> #topic Liaison Updates
13:04:59 <redrobot> moguimar any news from Oslo?
13:05:10 <moguimar> nope
13:06:08 <redrobot> cool
13:06:23 <redrobot> tosky around?  any news from Cinder?
13:07:09 <redrobot> OK, moving on
13:07:15 <tosky> hi! No, no news; I think there was an email to be sent?
13:07:18 <tosky> Sorry, lost trakc
13:08:17 <redrobot> Hi tosky!  No worries ...  I don't remember adding an action item for email?
13:08:22 * redrobot has not had coffee yet
13:09:06 <tosky> right, it was more "let's try if adding barbican tests, based on the barbican client provided by barbican-tempest-plugin, inside cinder-tempest-plugin and see what happens"
13:09:09 <tosky> if I read the logs correctly
13:09:36 <tosky> but I couldn't work on that yet
13:09:52 <tosky> and that's I guess my status
13:10:25 <redrobot> cool, thanks tosky!
13:10:31 <redrobot> OK, moving on
13:10:35 <redrobot> #topic Virtual PTG
13:11:17 <redrobot> Just the usual reminder that we'll be having a Virtual PTG meeting for Barbican on Thursday June 4
13:11:22 <redrobot> #link https://ethercalc.openstack.org/126u8ek25noy
13:11:45 <redrobot> We have a virtual room reserved from 1300-1700 UTC
13:12:09 <redrobot> Also, this is the etherpad where you can add topics to be discussed
13:12:11 <redrobot> #link https://etherpad.opendev.org/p/barbican-victoria-topics
13:12:11 <moguimar> cool
13:12:50 <redrobot> OK moving on ...
13:13:09 <redrobot> tkajinam ready to talk about your topic?
13:13:21 <tkajinam> redrobot, yes
13:13:55 <tkajinam> redrobot, Can we change the topic to something like open discussion ?
13:14:07 <redrobot> #topic Open Discussion
13:14:11 <tkajinam> thx
13:14:47 <tkajinam> https://review.opendev.org/#/c/721203/
13:15:01 <tkajinam> #link https://review.opendev.org/#/c/721203/
13:15:44 <tkajinam> I'd like to ask reviews about this.
13:15:55 <redrobot> I started reviewing it last week
13:16:00 <tkajinam> this is currently blocking py2 drop, so would be nice if we can land this in early stage
13:16:11 <tkajinam> I've submitted some DNM patch to test integration tests which use barbican, but didn't see any failures caused by this change at the moment
13:16:15 <redrobot> agreed.  and thank you for the patch tkajinam!
13:16:26 <tkajinam> https://review.opendev.org/#/q/topic:barbican-py3-fix
13:16:33 <tkajinam> you can find these DNM patches here... for your reference
13:16:52 <moguimar> well done tkajinam =D
13:17:06 <tkajinam> one note is that though my fix deals with test codes mostly, but have one fix regarding unexpected change caused by string type handling
13:17:09 <moguimar> you have my +1 already
13:17:15 <tkajinam> I mean str does not mean the same in py2 and py3
13:17:42 <tkajinam> and I think we should backport that part to fix behavior on py3... I'll work on that once the master patch lands
13:18:08 <tkajinam> redrobot, np. and thanks for your attention
13:18:11 <tkajinam> moguimar, thx :-)
13:18:17 <moguimar> can't +2
13:18:29 <moguimar> yet 😬
13:18:35 <redrobot> Oh yeah!
13:19:04 <tkajinam> that's all from me at the moment. I wanted to share these additional information about the patch
13:19:17 <tkajinam> let me know if you find anything unclear about the patch, on irc/gerrit/etc ...
13:19:23 <redrobot> will do tkajinam!
13:19:38 <redrobot> #topic New barbican-core nomination
13:19:45 <redrobot> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-May/014896.html
13:19:54 <redrobot> I've nominated moguimar for barbican-core
13:20:01 <redrobot> thanks ade_lee for the +1
13:20:03 <moguimar> thanks D =D
13:20:34 <tosky> \o/
13:20:47 <redrobot> we'll officially add you to the team this week
13:20:54 <redrobot> I just gotta remember how to do that
13:21:12 <redrobot> #action redrobot to officially add moguimar to barbican-core in gerrit
13:21:14 <tkajinam> nice :-)
13:21:45 <redrobot> Thank you for all the help moguimar!  You've been an awesome contributor to Barbican for a while now. :)
13:24:22 <redrobot> That's all I have for today
13:24:31 <redrobot> do y'all have any other topics we should talk about?
13:24:55 <tkajinam> nothing from my side :-)
13:25:35 <moguimar> nope
13:25:48 <redrobot> Thanks for joining, everyone!
13:25:55 <redrobot> See you online!
13:25:58 <redrobot> #endmeeting