13:01:01 <redrobot> #startmeeting barbican
13:01:01 <openstack> Meeting started Tue Jun  9 13:01:01 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:02 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:01:04 <openstack> The meeting name has been set to 'barbican'
13:01:25 <redrobot> #topic Roll Call
13:01:28 <moguimar> o/
13:01:32 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:01:54 <raildo> o/
13:01:55 <redrobot> As usual our (empty) agenda can be found here:
13:01:58 <redrobot> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
13:03:33 <redrobot> We could almost have this in the work IRC moguimar raildo 😝
13:03:54 <raildo> redrobot++
13:04:30 <moguimar> xD
13:04:30 <redrobot> OK, let's get started!
13:04:52 <redrobot> #topic Liaison Updates
13:04:58 <redrobot> moguimar, any news from Oslo?
13:05:03 <moguimar> nope
13:05:17 <moguimar> we had a quick one yesterday
13:05:59 <redrobot> moguimar, anything notable from the PTG we should be aware of?
13:06:33 <moguimar> castellan wasn't a topic at the PTG
13:06:36 <moguimar> but policy was
13:06:45 <moguimar> so maybe raildo might have some updates
13:07:24 <redrobot> What do you say raildo?  Anything we should be aware of from PTG?
13:07:30 <raildo> hell yea :) well first of all, I believe that we had a great conversation on the barbican side :)
13:08:08 <redrobot> Yeah! I have an agenda item to recap real quick in a bit.
13:08:40 <raildo> redrobot, cool, so let's wait for it
13:09:00 <raildo> I'm not a fan of spoilers anyway hehe
13:09:19 <redrobot> haha, ok, let's do it right now (we'll come back to moguimar's wayward reviews)
13:09:24 <redrobot> #topic PTG Recap
13:09:45 <redrobot> #link https://etherpad.opendev.org/p/victoria-ptg-barbican
13:10:13 <redrobot> Like raildo said, we had a great PTG
13:10:17 <redrobot> notes are on the link above
13:10:26 <redrobot> and we did record all 4 hours of the session
13:10:39 <redrobot> and as soon as the OSF gives us the video, we'll post it.
13:12:47 <redrobot> #action redrobot to make Taiga cards out of the work we planned for Victoria
13:13:00 <moguimar> I was thinking exactly about that
13:13:09 <moguimar> an action item for the Taiga board
13:13:44 <redrobot> moguimar, great minds think alike! 🤓
13:17:13 <redrobot> raildo, anything from the policy discussions we need to mention?
13:18:10 <raildo> well, we had some discussion on the oslo/keystone side most of it is summarized on the Keystone etherpad
13:18:51 <raildo> #link https://etherpad.opendev.org/p/victoria-ptg-keystone (lines 20-67 and lines 146-187)
13:19:32 <raildo> we basically got the nova's feedback on that work and planned some improvements to be done on victoria
13:20:12 <raildo> but for Barbican itself, atm, focus on what we discussed on the PTG would be enough for now
13:20:44 <redrobot> awesome, thanks raildo
13:20:55 <redrobot> #topic Secret Consumers
13:20:57 <raildo> also trying to understand a bit more about those new concepts, like system scope, we have some cool video like this one from Lance
13:20:59 <raildo> #link https://www.youtube.com/watch?v=NI4MVMG7FGw
13:21:07 <redrobot> right on!
13:21:17 * redrobot adds video to his watchlist
13:21:47 <redrobot> OK, let's see ... we talked a little bit about Secret Consumers at the Image Encryption meeting yesterday
13:22:08 <redrobot> Looks like we should focus on adding client support to python-barbicanclient
13:24:42 <redrobot> I don't think the python-$PROJECTclient libraries are going away any time soon.
13:24:58 <redrobot> So maybe ade_lee is right that we should have two test suites for python-barbicanclient and openstacksdk
13:25:19 <moguimar> strike that maybe
13:25:41 <redrobot> moguimar++
13:27:43 <redrobot> OK, moving on
13:27:50 <redrobot> #topic Wayward Reviews
13:27:59 <redrobot> #link https://tinyurl.com/yd3x48fl
13:28:43 <moguimar> I guess we could start with the top ones
13:28:43 <redrobot> that's a nice query, moguimar
13:28:59 <moguimar> that's ade_lee's work
13:29:31 <moguimar> #link https://review.opendev.org/#/c/720975/
13:29:39 <redrobot> gotcha, the only thing I would change is adding the ansible-role-*-hsm and barbican-ui repos
13:29:57 <moguimar> can do
13:30:13 <moguimar> so, this one I think is pretty straightforward
13:30:23 <moguimar> replaces mock with unittest.mock
13:30:50 <moguimar> one less requirement and Zuul is happy about it
13:30:52 <redrobot> moguimar, cool, merged
13:31:29 <moguimar> you didn't even let me link the second one xD
13:32:06 <moguimar> I also have posted this one
13:32:09 <moguimar> #link https://review.opendev.org/#/c/734175/
13:32:35 <moguimar> tiny fixes before I can get to the contributing goal
13:34:37 <redrobot> moguimar, lgtm
13:36:26 <openstackgerrit> Andreas Jaeger proposed openstack/python-barbicanclient master: Update hacking for Python3  https://review.opendev.org/715622
13:36:33 <moguimar> cool, I'll poke ade_lee later
13:36:51 <moguimar> look, a wild review apperas xD
13:37:50 <redrobot> 😆😆😆
13:38:43 <AJaeger> ;)
13:38:53 <moguimar> already gave you my +1 AJaeger
13:39:04 <moguimar> lets wait on zuul for a +2
13:39:24 <redrobot> cool, any other quick reviews we could do right now moguimar?
13:39:30 <AJaeger> sure, hope it passes now
13:39:37 <moguimar> well, we have 20 minutes, right?
13:39:44 <moguimar> I saw another from AJaeger
13:39:46 <moguimar> on pygments
13:39:54 <moguimar> with wrong commit message
13:39:59 <moguimar> how is that one comming AJaeger ?
13:40:23 <AJaeger> moguimar: which one?
13:40:35 <moguimar> ah, you -1d it
13:40:39 <moguimar> https://review.opendev.org/#/c/729500/
13:40:54 * AJaeger would love to have some guideance on updating hacking for barbican - see https://review.opendev.org/#/c/716730/
13:41:12 <moguimar> they are 3 on that same line
13:41:15 <moguimar> https://review.opendev.org/#/c/729449/
13:41:17 <AJaeger> the tests fail, and I have two DNM on top of it. Could you advise me how to move forward and what you see as proper fix, please?
13:41:27 <moguimar> https://review.opendev.org/#/c/729501/
13:41:47 <AJaeger> moguimar: let me check 729501
13:42:18 <AJaeger> 729501 can be abandoned
13:42:29 <moguimar> I added myself to that one
13:43:20 <moguimar> AJaeger, I'll take a look at 716730 later today
13:43:26 <AJaeger> moguimar: thanks!
13:44:06 <moguimar> reason to abandon 729501?
13:44:20 <moguimar> just wanna write something there
13:44:23 <moguimar> not a blank abandon
13:45:34 <AJaeger> moguimar: I would write for all three - 449, 501, 500 - "another larger change already merged that includes this one, so this is a duplicate - abandon. Thanks for your change"
13:45:48 <moguimar> ah, I see
13:45:49 <AJaeger> moguimar: agreed, blank abandon is bad
13:45:57 <moguimar> I remember seeing those changes somewhere already
13:46:08 <AJaeger> moguimar: as part of my openstackdocstheme updates
13:46:16 <moguimar> yeah
13:46:38 <moguimar> ok, 3 less reviews in the list =D
13:46:48 <redrobot> yay!
13:46:52 <openstackgerrit> Elod Illes proposed openstack/barbican stable/rocky: DNM: CI health check  https://review.opendev.org/734560
13:48:22 <moguimar> done
13:49:32 <moguimar> since we're here
13:49:35 <moguimar> #link https://review.opendev.org/#/c/729001
13:50:15 <AJaeger> \o/
13:50:36 * AJaeger finally gets his backlog smaller...
13:50:36 <redrobot> lgtm
13:51:48 <moguimar> AJaeger, bring them on
13:51:57 <moguimar> any other you want us to have a look at?
13:52:13 <moguimar> for this last 8 minutes
13:52:18 <moguimar> of awesomeness
13:52:30 <AJaeger> moguimar: sorry, no ;)
13:52:38 <moguimar> dang, ok
13:53:02 <moguimar> this wayward review felt a bit like our first Upstream Friday, right redrobot ?
13:53:11 <redrobot> moguimar, sure did!
13:53:24 <redrobot> thanks for bringing that up, moguimar
13:53:27 <moguimar> cool, lets keep it on the menu then =D
13:53:42 <redrobot> maybe we should do this on the regular meeting points
13:53:43 <moguimar> we have a similar slot at oslo meetings
13:53:45 <redrobot> jinx!
13:54:01 <AJaeger> wait, do you review barbicanclient stable branches? ussuri is broken, https://review.opendev.org/734420 is the first t ofix it
13:55:05 <redrobot> AJaeger, lgtm
13:56:05 <moguimar> this is a backport of Takashi Kajinami's patch right?
13:56:13 <AJaeger> moguimar: yes
13:56:18 <moguimar> cool
13:56:33 <moguimar> shipped
13:58:14 <AJaeger> thx. Once that's in, I'll backport the next fix to bring that one back to life ;)
13:58:28 <moguimar> cool
13:58:50 <moguimar> allright, I guess that's all folks =D
13:59:08 <redrobot> I think this is the first time we've used the whole hour in a long while.
13:59:14 <redrobot> thanks for joining everyone!
13:59:16 <moguimar> #link https://www.youtube.com/watch?v=b9434BoGkNQ
13:59:35 <redrobot> 😆😆😆
13:59:38 <redrobot> #endmeeting