13:00:06 <redrobot> #startmeeting barbican
13:00:07 <openstack> Meeting started Tue Jun 30 13:00:06 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:10 <openstack> The meeting name has been set to 'barbican'
13:00:28 <redrobot> #topic Roll Call
13:00:40 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:02:31 <moguimar> o/
13:02:47 <moguimar> dang, I'm struggling to get rid of lunch today
13:03:16 <moguimar> big bowl of garlic soup and now big bowl of salad
13:03:21 <jamespage> apologies - opendev'ing today so won't make meeting
13:03:42 <redrobot> no worries jamespage
13:03:54 <redrobot> moguimar, sounds tasty
13:04:11 <redrobot> moguimar, missing Brazil food yet?
13:04:19 <moguimar> nope
13:04:25 <redrobot> hahaha
13:04:56 <redrobot> Ok, let's get started
13:05:17 <redrobot> As usual our agenda can be found here:
13:05:26 <redrobot> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
13:05:38 <redrobot> #topic Review Past Meeting Action Items
13:05:57 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2020/barbican.2020-06-23-13.00.html
13:06:11 <redrobot> First one: moguimar to update Core Team roster in wiki
13:06:20 <redrobot> moguimar, did youg get a chance to update it?
13:06:29 <moguimar> probably not
13:06:41 <redrobot> hehe, no worries.  We'll punt to next week
13:06:41 <moguimar> I was trying to remember some action item I had signed up for
13:06:45 <redrobot> #action moguimar to update Core Team roster in wiki
13:06:50 <redrobot> Next AI
13:07:06 <redrobot> redrobot to make Taiga cards out of the work we planned for Victoria
13:07:08 <redrobot> I did do this!
13:07:32 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:07:35 <redrobot> so there it is
13:07:39 <moguimar> nice!
13:07:45 <redrobot> I assigned the HVAC task to you moguimar
13:07:54 <moguimar> working on it this morning
13:08:05 <moguimar> let me check if it is in progress
13:08:13 <redrobot> I think I'm going to make it a point to look at the kanban board at the bottom of this meeting every week
13:08:40 <moguimar> done
13:08:49 <moguimar> cool
13:09:32 <redrobot> OK, moving on
13:09:37 <redrobot> #topic Liaison Updates
13:09:44 <redrobot> moguimar, Oslo updates?
13:09:49 <moguimar> none
13:10:00 <moguimar> we had a ligning fast meeting yesterday
13:10:51 <redrobot> cool
13:11:07 <redrobot> I don't think tosky is around so we'll skip the Testing update
13:11:17 <redrobot> #topic Bug Review
13:11:49 <redrobot> moguimar, your patch for the Contributing docs made me realize I don't pay enough attention to the Storyboards for our projects
13:12:05 <redrobot> so I'm going to start reviewing them really quick during this meeting
13:12:30 <moguimar> sorry? 😅
13:13:09 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:13:10 <redrobot> :D
13:13:40 <redrobot> I added a new story because of your docs patch as well
13:13:46 <redrobot> #link https://storyboard.openstack.org/#!/story/2007852
13:14:08 <redrobot> I think there's some template somewhere that is generating a blank API docs page for Barbican
13:14:26 <redrobot> and it looks like it's wired up to use swagger (?) or something like it
13:14:39 <redrobot> so I think it would be good to look into it
13:14:56 <redrobot> and maybe start using a tool like that to automate our API docs
13:15:03 <redrobot> instead of hand-crafting them like we do now.
13:15:45 <moguimar> I've played a bit with swagger
13:16:11 <moguimar> but with some flask related stuff called connexion from shopify IIRC
13:16:12 <redrobot> sounds like you just volunteered, moguimar
13:16:17 <redrobot> XD
13:16:21 <moguimar> xD
13:16:44 <moguimar> ¯\_(ツ)_/¯
13:16:57 <redrobot> In any case, it might be something to pair up on for an Upstream Friday sometime this cycle
13:18:51 <moguimar> sure
13:19:49 <redrobot> That was the only new bug I saw
13:19:50 <tosky> I am aroung, but I don't have updates; there were a few other fires in the last days to be taken care of
13:20:08 <redrobot> #topic Wayward reviews
13:20:12 <tosky> I'm still have the "check if barbican/volume tests works if moved into cinder-tempest-plugin"
13:20:17 <redrobot> hi tosky!  no worries.
13:20:41 <redrobot> #action tosky to check if barbican/volume tests works if moved into cinder-tempest-plugin
13:24:23 <moguimar> any low hanging fruits in the review dashboard?
13:25:07 <moguimar> I approved the backport of this to ussuri
13:25:10 <moguimar> https://review.opendev.org/#/c/738398/
13:25:18 <moguimar> but I'm not sure how far back should we approve backports
13:25:48 <moguimar> there are rocky, stein and train patches open
13:25:48 <tosky> are there any news (or something I can help with) regarding the zuulv3 jobs?
13:26:08 <tosky> or at least some help to understand the failures of the patch which fixes the grenade job
13:26:35 <redrobot> tosky, I have not looked into it, tosky :(
13:27:13 <redrobot> moguimar, I'd say let's follow the official OpenStack schedule: https://releases.openstack.org/
13:28:04 <moguimar> so allow Train and Stein and request to abandon Rocky?
13:28:28 <moguimar> stein and rocky patches are failing functional-vault
13:28:57 <redrobot> yeah, let's abandon Rocky and if the contributor trying to backport complains we'll go ahead and try to merge it. :D
13:29:49 <moguimar> ok, I'll do that
13:31:23 <redrobot> cool
13:31:32 <redrobot> OK, moving on
13:31:36 <redrobot> #topic Open Discussion
13:31:42 <redrobot> anything else we should talk about?
13:31:56 <moguimar> nothing that comes to my mind
13:33:04 <redrobot> cool, let's call it a day then.
13:33:09 <redrobot> Thanks for joining, y'all!
13:33:12 <moguimar> o/
13:33:12 <redrobot> #endmeeting