13:00:26 <redrobot> #startmeeting barbican
13:00:26 <openstack> Meeting started Tue Jul  7 13:00:26 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:27 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:30 <openstack> The meeting name has been set to 'barbican'
13:00:50 <redrobot> #topic Roll Call
13:00:52 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:00:55 <Luzi> o/
13:01:04 <redrobot> Hi Luzi!
13:01:08 <Luzi> hi redrobot
13:01:38 <redrobot> As usual our agenda is over here:
13:01:40 <redrobot> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
13:02:04 <moguimar> o/
13:02:09 <redrobot> hi moguimar!
13:02:26 <moguimar> hey, sorry for the delay
13:02:32 <moguimar> I was finisshing lunch
13:03:35 <redrobot> No worries
13:03:39 <redrobot> Let's get started!
13:03:52 <redrobot> #topic Action Items from last meeting
13:04:16 <redrobot> First Action Item: moguimar to update Core Team roster in wiki
13:04:26 <redrobot> did you get a chance to update that, moguimar?
13:04:31 * redrobot looks
13:04:31 <moguimar> I guess I did not check on that
13:04:51 <moguimar> and I'm still not sure if I've done it already xD
13:04:56 <redrobot> Hehe
13:05:04 <redrobot> looks like it still needs to be done:
13:05:06 <moguimar> do you have a link?
13:05:16 <redrobot> #link https://wiki.openstack.org/wiki/Barbican
13:05:31 <moguimar> thanks
13:05:46 <redrobot> #action moguimar to update Core Team roster in wiki
13:06:12 <redrobot> tosky is not around so we'll kick their action item to next week
13:06:18 <redrobot> #action tosky to check if barbican/volume tests works if moved into cinder-tempest-plugin
13:06:35 <redrobot> #topic Liaison Updates
13:06:42 <redrobot> moguimar, any Oslo news?
13:07:08 <moguimar> I don't think we had a meeting yesterday
13:07:11 <moguimar> Ben was out
13:07:19 <moguimar> and we also had holiday in the CZ
13:08:40 <redrobot> Cool cool
13:08:47 <redrobot> Alright, moving on
13:08:48 <moguimar> ok, wiki updated
13:08:51 <redrobot> #topic Bug Review
13:09:05 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:09:15 <redrobot> looks like we did not have any new bugs
13:09:22 <redrobot> since last week
13:09:42 <tosky> ehm, no updates, sorry
13:10:01 <redrobot> hi tosky!  no worries, thanks for joining us. :D
13:10:57 <redrobot> #link https://bugs.launchpad.net/castellan/
13:11:21 <redrobot> We have a big bug backlog in Castellan ... I'll have to spend some time cleaning up the Launchpad for it
13:11:43 <redrobot> #help We need folks who can verify (try to recreate) Barbican + Castellan bugs
13:13:02 <redrobot> OK, moving on
13:13:10 <redrobot> #topic Kanban Review
13:13:14 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:14:13 <moguimar> aaaand I'm back
13:14:16 <redrobot> moguimar, yay, you're back!
13:14:17 <redrobot> haha
13:14:22 <moguimar> what did I miss?
13:14:35 <redrobot> Just the topic change to Kanban review
13:14:48 <redrobot> moguimar, want to give an update on the HVAC work you have in progress?
13:14:55 <moguimar> yep
13:14:58 <moguimar> I got a patch today
13:15:05 <moguimar> https://review.opendev.org/#/c/739698/
13:15:21 <moguimar> I guess I need some minor fixes to it
13:15:27 <redrobot> Nice!
13:15:33 <redrobot> I'll add it to my review queue
13:16:15 <moguimar> I just noticed that the previous vault backend uses binascii to encode buffers to hexadecimal
13:17:31 <moguimar> so I'll add that too
13:17:40 <moguimar> to make sure the backends are compatible with each other
13:18:45 <redrobot> Gotcha, yeah
13:19:17 <redrobot> It would be interesting to see if we can set up a test (grenade?) where screts are stored by a previous version (without HVAC) and then retrieved by the current version
13:19:41 <moguimar> ok
13:19:57 <moguimar> this also reminds me of something
13:20:41 <tosky> about grenade? :)
13:20:44 <moguimar> iurygregory mentioned barbican CI yesterday
13:21:03 <redrobot> ?
13:21:10 <moguimar> he said he could eventually send some patches
13:21:37 <moguimar> iurygregory o/
13:21:41 <iurygregory> o/
13:22:02 <moguimar> I'll need your help to set up some grenade tests
13:22:12 <iurygregory> sure =)
13:22:18 <moguimar> done =D
13:22:38 <redrobot> Haha, awesome!
13:23:08 <redrobot> OK, moving on
13:23:08 <redrobot> #topic Wayward Reviews
13:23:17 <redrobot> #link https://tinyurl.com/yd3x48fl
13:23:26 <redrobot> Any low hanging fruit we can merge right now?
13:24:18 <moguimar> I guess https://review.opendev.org/#/c/735089
13:26:15 <moguimar> also we should have a look at https://review.opendev.org/#/c/735163/
13:27:13 <redrobot> moguimar, done
13:27:46 <moguimar> how should we use the +2 backport candidate?
13:31:03 <redrobot> I have no idea
13:31:11 <redrobot> >_<
13:31:30 <moguimar> xD
13:31:36 <redrobot> I assume there's something on the ML about it that I didn't read. hehe
13:31:58 <redrobot> But the patch seems like a good backport
13:32:38 <moguimar> I guess we should put `Stable Branches` higher in that querry
13:32:45 <moguimar> and try to keep it empty
13:33:06 <redrobot> yeah, I need to work on a new version for that query
13:33:16 <redrobot> to add the ansbile-role-*-hsm repos too
13:33:33 <moguimar> ah yeah, that too
13:33:33 <redrobot> #topic Open Discussion
13:33:43 <redrobot> Anything else y'all want to talk about while we're here?
13:33:59 <moguimar> not on my end
13:37:04 <redrobot> Alrighty then, that'll do it for today
13:37:10 <redrobot> thanks for joining, everyone!
13:37:15 <redrobot> #endmeeting