13:00:14 <redrobot> #startmeeting barbican
13:00:15 <openstack> Meeting started Tue Jul 28 13:00:14 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:18 <openstack> The meeting name has been set to 'barbican'
13:00:38 <redrobot> #topic Roll Call
13:00:45 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:00:45 <Luzi> o/
13:00:53 <moguimar> o/
13:01:06 <redrobot> Good morning, y'all!
13:01:15 <redrobot> or afternoon, I suppose. :)
13:02:28 <Luzi> greetings from nearyo, he became a father a few weeks ago - i saw him yesterday
13:02:42 <redrobot> Oh wow, that's awesome!
13:03:02 <redrobot> Congratuations nearyo!  And welcome, little baby nearyo! :D
13:03:21 <Luzi> i will tell him :D
13:03:36 <redrobot> :D
13:03:39 <tosky> o/
13:03:44 <redrobot> Ok, let's get started y'all!
13:03:55 <redrobot> As usual the agenda can be found here:
13:03:57 <redrobot> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
13:04:09 <redrobot> #topic Review Past Meeting Action Items
13:04:50 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2020/barbican.2020-07-21-13.00.html
13:05:03 <redrobot> I did not get a chance to jump on an #openstack-ansible meeting
13:05:25 <redrobot> #action redrobot to look into ansible-role-thales-hsm and ansible-role-atos-hsm bug projects
13:05:31 <redrobot> so let's check again next week
13:05:38 <redrobot> moving on ..
13:05:45 <redrobot> tosky to check if barbican/volume tests works if moved into cinder-tempest-plugin
13:05:53 <tosky> I brutally tried https://review.opendev.org/#/c/743492/
13:05:53 <redrobot> have you had a chance to work on that tosky?
13:06:18 <tosky> there are some issues, some technical, other more about workflows and rules
13:06:19 <redrobot> Uh oh.. that gate is not happy
13:06:28 <tosky> the main job is happy (lvm-lio-barbican)
13:06:31 <redrobot> that's a great start, though, thanks tosky! :D
13:06:37 <tosky> issues:
13:06:49 <tosky> - I'm not sure why barbican is not found in the older branches, to be investigated
13:07:32 <redrobot> interesting ...
13:07:34 <tosky> - requirements doesn't recognize barbican-tempest-plugin as dependency, that's a bigger issue (partially discussed but iirc no final decision) on how to make tempest plugins depend on each other
13:07:41 <redrobot> is it looking for barbican?  Or barbican-tempest?
13:07:49 <tosky> - the ceph job failed most likely because barbican is not enabled there, that's easy to fix
13:08:08 <tosky> the error in the stable branches are about the service endpoints not found
13:08:32 <redrobot> I see
13:08:42 <redrobot> let us know if we can help with that patch!
13:08:49 <tosky> - finally the dependency itself on the barbican code means that some care must be kept when changing the barbican_manager file, but that can be handled somehow
13:09:07 <tosky> so first I need to dig deeper and find a plan for the less technical issues
13:09:27 <tosky> that's it for now I guess
13:09:40 <redrobot> thank you for the update tosky. :)
13:10:05 <redrobot> #topic Liaison Updates
13:10:17 <moguimar> network hickups again..
13:10:22 <moguimar> nothing from Oslo
13:10:23 <redrobot> moguimar, no worries
13:10:29 <redrobot> moguimar, do you have any news from Oslo?
13:11:00 <moguimar> nothing other than some castellan patches for later this meeting
13:11:12 <redrobot> sounds good
13:11:18 <redrobot> tosky, any other Testing updates?
13:11:24 <tosky> nothing for now
13:11:35 <redrobot> OK, moving on
13:11:40 <redrobot> #topic Kanban Review
13:11:51 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:12:12 <redrobot> moguimar, HVAC progress?
13:12:32 <moguimar> patch is ready for review
13:12:51 <moguimar> https://review.opendev.org/#/c/742169/
13:16:35 <redrobot> Awesome I'll take a look asap
13:16:43 <redrobot> OK, moving on
13:17:00 <redrobot> #topic Bug Review
13:17:06 <redrobot> StoryBoard bugs:
13:17:17 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:17:25 <redrobot> Looks like no new bugs
13:17:43 <redrobot> #link https://bugs.launchpad.net/castellan
13:18:26 <redrobot> And no new bugs for Castellan either
13:18:47 <redrobot> #topic Wayward Reviews
13:18:49 <redrobot> #link https://tinyurl.com/ya2qgkw6
13:19:08 <redrobot> I was hoping to get through June and July patches ... but I didn't get much time to review last week :(
13:19:24 <moguimar> I went through almost all of them today
13:19:49 <moguimar> the ones in Needs Approvals are almost no brainers
13:19:52 <moguimar> and small
13:20:44 <moguimar> let me know if you have any comments in any of them so I can go to the next section
13:21:32 <moguimar> in Without Negative Feedback we have only 1 to discuss
13:21:55 <moguimar> the other ones are not ready yet
13:22:36 <tosky> I was talking with iurygregory and we would really need your help to deploy with barbican locally and try to upgrade, because something weird is going on
13:22:53 <tosky> I haven't tried but in his tests even a local devstack deployment makes c-api fail
13:23:45 <redrobot> tosky, I am not sure what c-api is?
13:25:15 <tosky> cinder-api
13:25:28 <tosky> that's the name used in devstack
13:26:09 <redrobot> Oh, gotcha
13:26:27 <redrobot> Yeah we can definitely help.  What would work best to help y'all?
13:27:30 <moguimar> redrobot, I got iurygregory a machine for devstack testing
13:27:49 <redrobot> moguimar, awesome
13:30:05 <redrobot> #topic Open Discussion
13:30:10 <redrobot> Anything else we should talk about?
13:30:30 <moguimar> https://review.opendev.org/#/c/728740/
13:31:05 <moguimar> nevermind, just add that one to your list redrobot
13:32:31 <redrobot> moguimar, interesting ... Yeah, will have to think about that one.  We'll probably want some functional test around it as well.
13:37:37 <redrobot> Thanks for joining everyone!
13:37:41 <moguimar> I guess that's all
13:37:46 <redrobot> See y'all online! :)
13:37:51 <redrobot> #endmeeting