13:00:08 <redrobot> #startmeeting barbican
13:00:09 <openstack> Meeting started Tue Aug 11 13:00:08 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:12 <openstack> The meeting name has been set to 'barbican'
13:00:39 <redrobot> #topic Roll Call
13:00:40 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:00:42 <moguimar> o/
13:01:07 <redrobot> Hi moguimar!
13:01:13 <tosky> o/
13:01:14 <moguimar> hey hey
13:02:08 <redrobot> Hi tosky!
13:02:21 <redrobot> As usual our agenda can be found here:
13:02:29 <redrobot> https://etherpad.opendev.org/p/barbican-weekly-meeting
13:02:57 <redrobot> #topic Review Last Meeting Action Items
13:03:00 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2020/barbican.2020-08-04-13.00.html
13:03:10 <redrobot> First one
13:03:12 <redrobot> redrobot to look into ansible-role-thales-hsm and ansible-role-atos-hsm bug projects
13:03:29 <redrobot> I'm going to try to catch the #openstack-ansible meeting in a couple of hours to talk about this
13:03:33 <redrobot> #action redrobot to look into ansible-role-thales-hsm and ansible-role-atos-hsm bug projects
13:04:40 <redrobot> and the next one we'll talk about during the Kanban Review
13:04:50 <redrobot> #topic Liaison Updates
13:04:54 <redrobot> moguimar, anything from Oslo?
13:05:02 <moguimar> nope
13:05:41 <redrobot> cool beans
13:05:51 <redrobot> tosky, any news from the Testing side of things?
13:07:38 <tosky> nothing on testing (I still have to analyse some results from the attempted import of barbican tests inside cinder-tempest-plugins)
13:07:52 <tosky> I do have news about the jobs, but I guess we will talk about it later
13:07:52 <redrobot> cool, thanks tosky
13:08:07 <redrobot> okay!
13:08:18 <redrobot> #topic Kanban Review
13:08:32 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:09:38 <redrobot> I added a card to track Secret Consumers as per our action item last week.
13:10:16 <redrobot> For that I have a couple of WIP patches, and I was able to Depends-On: a patch in python-barbicanclient to use in the functional test gate for barbican.
13:10:27 <moguimar> and I realized that the hvac driver is not quite there yet
13:10:44 <moguimar> been working on it since this morning
13:10:50 <redrobot> moguimar, :-O
13:11:22 <moguimar> also in some stuff that makes me furious about constructors using conf
13:12:24 <redrobot> gotcha
13:12:30 <redrobot> cool, let me know if I can help
13:12:34 <redrobot> ok, moving on
13:12:53 <redrobot> #topic Bug Review
13:13:05 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:13:11 <redrobot> Look like no new bugs
13:13:48 <redrobot> #link https://bugs.launchpad.net/castellan
13:13:54 <redrobot> and no new bugs on Castellan either
13:14:13 <redrobot> #topic Gate Jobs
13:14:21 <redrobot> tosky, your turn. :)
13:15:19 <tosky> I think the following two reviews should be a proper port of the last legacy jobs: https://review.opendev.org/745321 + https://review.opendev.org/745326
13:16:28 <redrobot> oh yeah, I saw those
13:16:52 <redrobot> I wanted to ask why you had to rename from *-simple-crypto-* to *-simply-crypto-* ?
13:17:17 <tosky> because I mistyped it
13:17:37 <redrobot> oops
13:17:45 <openstackgerrit> Luigi Toscano proposed openstack/barbican-tempest-plugin master: zuul: migrate and clean the tempest native jobs  https://review.opendev.org/745321
13:18:06 <openstackgerrit> Luigi Toscano proposed openstack/barbican master: zuul: switch to the new tempest native jobs  https://review.opendev.org/745326
13:18:12 <tosky> it should be fixed now
13:18:28 <redrobot> awesome, we'll get it merged as soon as the zuul gives it the +1
13:18:38 <redrobot> Thanks again for all the help with those!
13:19:15 <tosky> I will propose patches for the various users (castellan & co) to switch to the new names as well, but that can wait
13:20:53 <redrobot> tosky, sounds good
13:22:49 <tosky> btw, various projects depends on cursive (glance, and I think nova has a job) but it's kind of out of openstack right now; shouldn't be adopted by some project, if it's a dependency?
13:22:52 <tosky> maybe a question for glance
13:23:21 * redrobot googles cursive, only finds handwriting
13:23:39 <tosky> https://opendev.org/x/cursive
13:24:12 <tosky> one of the jobs installs it from source: https://review.opendev.org/#/c/745321/3/.zuul.yaml
13:24:40 <tosky> and https://review.opendev.org/#/c/745326/2/.zuul.yaml
13:24:57 <tosky> it is really not called right now in barbican - maybe it should be dropped (?)
13:25:42 <redrobot> tosky, yeah, if we're not using it in barbican code, it doesn't make sense to install it.
13:25:59 <tosky> it is indirectly used by glance
13:26:34 <tosky> I think that was the reason to test with the master version of a crypto-related library when running image tests, but I haven't dug into the history
13:31:05 <redrobot> Yeah, sounds like maybe they wanted to test new cursive changes?
13:31:15 <redrobot> Anything else you want to talk about now tosky ?
13:31:33 <tosky> nothing else, it's all about the reviews
13:32:43 <redrobot> cool... and speaking of reviews
13:32:47 <redrobot> #topic Wayward Reviews
13:32:57 <redrobot> #link https://bugs.launchpad.net/castellan
13:33:01 <redrobot> #undo
13:33:01 <openstack> Removing item from minutes: #link https://bugs.launchpad.net/castellan
13:33:10 <redrobot> #link https://tinyurl.com/ya2qgkw6
13:33:12 <tosky> btw, the link to the dashboard for Wayward Reviews doesn't include barbican-tempest-plugin
13:33:38 <redrobot> moguimar is the dashboard wizard
13:33:42 <moguimar> ack
13:33:44 <moguimar> I
13:33:46 <moguimar> I'll fix that
13:33:51 <redrobot> thanks moguimar!
13:38:02 <redrobot> moguimar, can you +2 backports? https://review.opendev.org/#/c/744147/
13:38:54 <moguimar> done
13:40:09 <redrobot> moguimar, thanks!
13:40:32 <redrobot> I don't see any other obvious low hanging fruit
13:40:46 <redrobot> so ...
13:40:50 <redrobot> #topic Open Discussion
13:40:56 <redrobot> anything else y'all want to talk about?
13:41:33 <moguimar> not on my end
13:42:04 <redrobot> Cool, thanks for joining, y'all!
13:42:10 <redrobot> #endmeeting