13:00:19 <redrobot> #startmeeting barbican
13:00:20 <openstack> Meeting started Tue Aug 25 13:00:19 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:23 <openstack> The meeting name has been set to 'barbican'
13:00:34 <redrobot> #topic Roll Call
13:00:38 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:00:49 <redrobot> As usual our agenda can be found here:
13:00:55 <redrobot> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
13:00:58 <raildo> o/
13:01:00 <moguimar> o/
13:01:14 <moguimar> guess who updated the review dashboard?
13:01:55 <redrobot> That guy??? → moguimar
13:02:23 <moguimar> you will see when we get there
13:02:28 <Luzi> o/
13:02:40 <redrobot> Haha, ok
13:02:43 <redrobot> let's get started!
13:02:44 <tosky> hi
13:02:48 <redrobot> #topic Review Past Meeting Action Items
13:03:01 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2020/barbican.2020-08-18-13.00.html
13:03:16 <redrobot> I did not work on my AI 😓
13:03:36 <redrobot> #action redrobot to submit a governance patch for the HSM repos
13:03:50 <redrobot> #topic Liaison Updates
13:03:58 <redrobot> moguimar, Oslo news?
13:04:17 <moguimar> yes
13:04:25 <moguimar> we're approaching feature freeze on Oslo
13:04:36 <redrobot> Uh oh ...
13:04:38 <moguimar> this week I think
13:04:50 <moguimar> so, starting from next week, only FFEs
13:05:13 <redrobot> Do we need to land the HVAC stuff this week,then?
13:05:40 <moguimar> I'm not sharp on the patch
13:05:55 <moguimar> I guess it needs more love before merging
13:06:14 <redrobot> Gotcha ... no worries, I don't think we absolutely need it for V
13:07:37 <redrobot> tosky, any news from Testing?
13:08:24 <tosky> no news this week
13:08:36 <tosky> I still have a pending task to fix the grenade job (help still appreciated :)
13:08:39 <redrobot> Cool beans.
13:10:07 <redrobot> #link https://review.opendev.org/#/c/724258/
13:10:21 <redrobot> This one right, tosky?
13:10:32 <tosky> yes, correct
13:10:50 <redrobot> K, hoping to get some time this week to look at it
13:10:51 <tosky> iurygregory tried a fix, but it didn't work; the job still fails on some cinder operation
13:11:20 <tosky> thanks; I'm going to rebase and recheck to have updated logs
13:11:22 <iurygregory> yeah =(
13:12:27 <redrobot> OK, moving on to the next topic
13:12:32 <redrobot> #topic Kanban Review
13:12:42 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:13:24 <redrobot> moguimar, anything else on HVAC we have not mentioned yet?
13:13:24 <openstackgerrit> Luigi Toscano proposed openstack/barbican master: zuul: fix the grenade job to actually test barbican  https://review.opendev.org/724258
13:13:37 <moguimar> nope
13:15:03 <redrobot> For Secret Consumers:  I took a few days off and just got back today.  Did not make as much progress as I would have liked.  Going to push hard on that this week.
13:16:04 <redrobot> Moving on ...
13:16:08 <redrobot> #topic Bug Review
13:16:17 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:16:26 <redrobot> Looks like no new stories for barbican projects
13:16:56 <redrobot> #link https://bugs.launchpad.net/castellan/+bugs?orderby=-id&start=0
13:17:05 <redrobot> And no new bugs in Castellan either.
13:17:24 <redrobot> #topic Wayward Reviews
13:17:27 <redrobot> #link https://tinyurl.com/y3ydwmkl
13:17:48 <redrobot> I see barbican-tempest-plugin in there now :D
13:17:53 <tosky> \o/
13:18:09 <moguimar> and I put a 3 items on the top
13:18:22 <moguimar> that have been not updated for more than 14 days
13:18:43 <moguimar> I was going with 7, but then I thought that we would hit the same 3 items almost every week
13:18:55 <redrobot> Nice!
13:19:00 <redrobot> I really like that, thanks moguimar!
13:19:07 <tosky> a few things I've noticed:
13:19:08 <moguimar> and 3 is a good count that we could go through in this meeting
13:19:08 <tosky> - this review https://review.opendev.org/#/c/745455/ fixes the functional tests a bit more; still failing, but in a later stage
13:19:42 <tosky> - ussuri is broken (https://review.opendev.org/#/q/project:openstack/barbican+branch:stable/ussuri) and if I read the comments in https://review.opendev.org/#/c/724138/ correctly, a "gate fixing" patch is needed
13:20:14 <tosky> (and yes, now please remember barbican-tempest-plugin!)
13:21:17 <redrobot> tosky, ugh, broken gates are no bueno
13:21:23 <redrobot> I'll take a look at that last patch
13:23:47 <redrobot> #topic Open Discussion
13:23:56 <redrobot> anything else y'
13:23:59 <moguimar> yep
13:24:00 <redrobot> all want to talk about?
13:24:23 <moguimar> won 't we go through the 3 items in 14 Days Without Feedback?
13:24:37 <redrobot> moguimar, sure, let's do it!
13:24:43 <moguimar> first one
13:24:48 <moguimar> https://review.opendev.org/#/c/745303/
13:24:59 <moguimar> looks like gate didn't trigger
13:25:16 <moguimar> is it just a recheck?
13:25:23 <redrobot> moguimar, no, it's waiting for https://review.opendev.org/#/c/745302/ to merge first
13:25:32 <moguimar> ah
13:26:01 <moguimar> so let's dig into that one then
13:27:26 <redrobot> moguimar, lgtm.
13:27:31 <moguimar> yup
13:27:35 <moguimar> 2nd
13:27:40 <moguimar> https://review.opendev.org/#/c/744213/
13:28:21 <moguimar> and 3rd
13:28:22 <moguimar> https://review.opendev.org/#/c/745408/2
13:28:22 <redrobot> WIP still.
13:28:24 <moguimar> both are wips
13:28:32 <moguimar> lets add wip comments to both of them
13:28:37 <moguimar> so next week we get 3 new items
13:29:25 <moguimar> good
13:29:31 <moguimar> we already can see the next 3 items
13:29:36 <redrobot> looks like the new items are for stable/ussuri
13:29:37 <moguimar> but let's not overdo it
13:29:45 <redrobot> which we'll need to dig into
13:29:46 <redrobot> cool
13:30:27 <redrobot> Anything else y'all want to talk about?
13:30:43 <moguimar> I'll drop another recheck there, maybe is a tox-doc fix that needs to be backported
13:30:52 <moguimar> I'm not sure if we did that here.
13:31:03 <moguimar> not on my end I guess
13:31:21 <redrobot> cool beans
13:31:30 <redrobot> tosky, Luzi, anything else y'all want to talk about?
13:32:57 <Luzi> nothing from my side
13:33:06 <raildo> I have a quick topic, if we have some free time haha
13:33:16 <redrobot> sure thing raildo
13:34:17 <raildo> so, I'm trying to get a student in a mentoring project to work with the default policy work on Barbican
13:34:25 <raildo> #link https://docs.google.com/document/d/1QkRf1ioP42VKcqR5dugczE92pN3WahHKvJwuxSqHYAo/edit
13:34:41 <raildo> redrobot, will be a co-mentor with me on that adventure haha
13:34:53 <redrobot> raildo++
13:35:20 <raildo> so, we do have a kind of WIP spreadsheet describing what needs to be changed on the wiki page
13:35:23 <raildo> #link https://wiki.openstack.org/wiki/Barbican/Policy
13:35:47 <raildo> but would be nice to confirm that everything looks fine on it, so we can have it ready to be implemented once we get someone to work on it
13:37:05 <redrobot> raildo, let's get together this week to go over that wiki page
13:37:11 <redrobot> we can probably take out that "Tag" column
13:37:14 <tosky> nothing from me
13:37:24 <raildo> redrobot, sounds good to me
13:38:46 <redrobot> raildo, Upstream Friday maybe?
13:38:59 <raildo> works for me
13:39:09 <redrobot> Sweet!
13:39:12 <redrobot> Let's do it!
13:39:29 <redrobot> Sounds like we're all done for the day now.
13:39:47 <redrobot> Thanks for joining, everyone!  See y'all online.
13:39:56 <redrobot> #endmeeting