13:00:19 <redrobot> #startmeeting barbican
13:00:20 <openstack> Meeting started Tue Sep  1 13:00:19 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:21 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:23 <openstack> The meeting name has been set to 'barbican'
13:00:39 <redrobot> #topic Roll Call
13:00:40 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:00:48 <Luzi> o/
13:00:53 <redrobot> Hi Luzi!
13:01:01 <Luzi> hi redrobot
13:01:05 <tosky> o/
13:01:26 <redrobot> Hi tosky!
13:01:55 <redrobot> OK, let's get started
13:02:06 <redrobot> #topic Review Past Meeting Action Items
13:02:09 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2020/barbican.2020-08-25-13.00.html
13:02:52 <redrobot> First one: redrobot to submit a governance patch for the HSM repos
13:02:56 <redrobot> I did do this! :D
13:03:07 <redrobot> I submitted two patches
13:03:12 <redrobot> first one is to governance:
13:03:14 <redrobot> #link https://review.opendev.org/#/c/748027/
13:03:15 <moguimar> o/
13:03:45 <redrobot> It moves the other two ansible-role-*-hsm roles under their own deliverables in the Barbican project
13:04:06 <redrobot> and the other patch is to configure Storyboard to add projects for both of those
13:04:14 <redrobot> #link https://review.opendev.org/#/c/748028/
13:05:10 <redrobot> I'll keep an eye out for those
13:05:15 <redrobot> feel free to +1 if you want
13:05:23 <redrobot> OK, moving on
13:05:28 <redrobot> #topic Liaison Updates
13:05:34 <redrobot> moguimar, any news from Oslo?
13:05:42 <moguimar> yep
13:05:51 <moguimar> we are officially in Feature Freeze
13:06:15 <redrobot> cool beans
13:06:23 <redrobot> that's good to know
13:07:04 <redrobot> tosky, any news from testing?
13:07:06 <tosky> no news from me
13:07:19 <redrobot> tosky, cool beans
13:07:26 <redrobot> tosky, did you see this message in the ML?
13:07:29 <redrobot> #link http://lists.openstack.org/pipermail/openstack-discuss/2020-August/016839.html
13:08:19 <tosky> oh, right, but I didn't check what was going on
13:08:42 <redrobot> yeah, I haven't had a chance to look into it yet either
13:09:04 <redrobot> I'll add an action item so we don't forget about it
13:09:28 <redrobot> #action redrobot, tosky: Look into tempest failure from ML message
13:10:11 <redrobot> OK, moving on
13:10:15 <redrobot> #topic Kanban Review
13:10:17 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:10:30 <redrobot> moguimar, any updates on the HVAC work?
13:10:36 <moguimar> no progress there
13:11:11 <redrobot> Not much progress on microversions+secret consumers from me either
13:11:39 <redrobot> and like I mentioned, we do have those two patches for review to move the ansible-hsm roles around
13:11:47 <redrobot> OK, moving on
13:12:00 <redrobot> #topic Bug Review
13:12:11 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:12:15 <redrobot> no new bugs in Storyboard
13:12:51 <redrobot> #link https://bugs.launchpad.net/castellan/+bugs?orderby=-id&start=0
13:12:56 <redrobot> and no new bugs on Castellan either
13:13:17 <redrobot> #topic Wayward Reviews
13:13:19 <redrobot> #link https://tinyurl.com/y3ydwmkl
13:13:49 <openstackgerrit> Douglas Mendizábal proposed openstack/barbican master: Fix dogtag functional job  https://review.opendev.org/745455
13:13:51 <moguimar> lets start with our 3 items of the day?
13:13:56 <redrobot> moguimar, sure
13:13:58 <moguimar> https://review.opendev.org/#/c/739311/
13:14:10 <moguimar> migrate testing to ubuntu focal
13:14:58 <redrobot> Looks like the patch needs more work still
13:15:15 <moguimar> yep
13:15:23 <moguimar> removed my -1 so it should be updated
13:15:25 <moguimar> next
13:15:38 <moguimar> https://review.opendev.org/#/c/731281/
13:17:42 <moguimar> and https://review.opendev.org/#/c/746281/
13:18:17 <redrobot> I'm going to need to put my thinking cap on for these alembic changes
13:19:30 <tosky> I'd just like to remind about the stable/ussuri branch (which still misses its .gitignore, a few changes were needed)
13:19:58 <tosky> and two small barbican-tempest-plugin reviews, https://review.opendev.org/#/c/715514/ and https://review.opendev.org/#/c/721979/
13:20:36 <redrobot> I think it'll be easier to look at those than try to do alembic reviews righ tnow
13:20:39 <redrobot> *right now
13:20:43 <redrobot> #link https://review.opendev.org/#/q/status:open+project:openstack/barbican+branch:stable/ussuri
13:21:04 <moguimar> yep
13:28:17 <redrobot> OK, looking at https://review.opendev.org/#/c/715514/ first
13:28:36 <redrobot> According to https://packaging.python.org/guides/dropping-older-python-versions/
13:28:44 <redrobot> > The way to set those values is within the call to setup within your setup.py script. This will insert the Requires-Python metadata values based on the argument you provide in python_requires.
13:29:18 <redrobot> If I understand this correcty, passing python_requires to setup() will generate the Requires-Python: specifiers?
13:29:46 <redrobot> s/specifiers/clasifiers
13:30:15 <redrobot> setup.cfg values get passed to the setup() function right?
13:30:24 <moguimar> yep
13:30:34 <redrobot> if so, then I think the patch is wrong, as it should be python_requires instead of python-requires
13:30:42 <redrobot> ie. underscore instead of dash
13:30:57 <tosky> uhm
13:31:55 <redrobot> or am I missing something? 🤔
13:32:41 <tosky> I really don't know :)
13:37:02 <redrobot> I'm going to -1 for now and dig into it later
13:37:45 <redrobot> merged the second one
13:37:56 <redrobot> And I'm going to have to dig into the ussuri branch
13:40:16 <redrobot> I think we can move on
13:40:21 <redrobot> #topic Open Discussion
13:40:22 <moguimar> ack
13:40:25 <redrobot> anything else y'all want to talk about?
13:40:40 <tosky> nothing from me
13:40:52 <Luzi> yes
13:41:11 <Luzi> will there be a Barbican event at the vPTG?
13:41:22 <moguimar> yep
13:41:31 <moguimar> redrobot just got the reservations
13:41:53 <Luzi> should I ask nearyo to give a presentation of the Barbican UI stuff he did?
13:42:07 <Luzi> at the ptg?
13:42:07 <redrobot> Luzi, that would be awesome
13:42:20 <Luzi> okay, I will ask him :)
13:42:25 <redrobot> Luzi, let me know if the times I scheduled will work?
13:42:29 <redrobot> It's around this time, I think
13:42:33 <redrobot> on Tues and Thurs
13:42:37 <Luzi> ah were can i see the times?
13:43:14 <redrobot> #link https://ethercalc.openstack.org/7xp2pcbh1ncb
13:43:25 <Luzi> thank you :)
13:43:48 <redrobot> I don't think they're finalized yet, so we can still move things around if needed.
13:43:55 <Luzi> i will have a chat with nearyo and give an answer to you next week - just thought it would be a good idea :D
13:44:15 <redrobot> #action Luzi to check PTG times to make sure they work for her and nearyo
13:44:27 <Luzi> times should be okay for me at least :D
13:44:41 <redrobot> Awesome
13:45:03 <redrobot> If there's nothing else, I think we're done. :D
13:45:29 <redrobot> Thanks for joining, everyone!
13:45:32 <redrobot> #endmeeting