13:00:34 <redrobot> #startmeeting barbican
13:00:35 <openstack> Meeting started Tue Sep  8 13:00:34 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:39 <openstack> The meeting name has been set to 'barbican'
13:00:52 <redrobot> #topic Roll Call
13:00:54 <Luzi> o/
13:00:59 * tosky around, but not much around
13:00:59 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:01:07 <redrobot> Hi Luzi and tosky!
13:01:21 <redrobot> I wonder if moguimar is around?
13:01:36 <moguimar> o/
13:01:38 <moguimar> yeah
13:01:39 <moguimar> here
13:01:41 <redrobot> :D
13:01:47 <redrobot> As usual our agenda can be found here:
13:01:50 <redrobot> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
13:02:16 <redrobot> OK, let's get started!
13:02:29 <redrobot> #topic Review Past Meeting Action Items
13:02:36 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2020/barbican.2020-09-01-13.00.html
13:02:46 <redrobot> First one
13:02:55 <redrobot> Luzi to check PTG times to make sure they work for her and nearyo
13:03:05 <redrobot> Luzi, did you get a chance to check with nearyo?
13:03:28 <Luzi> yes, he thinks it will be possible for him to give a demo at the PTG :)
13:03:37 <redrobot> Excellent!
13:04:26 <redrobot> Next,
13:04:34 <Luzi> is there already an etherpad for the PTG themes?
13:04:38 <redrobot> * redrobot, tosky: Look into tempest failure from ML message
13:04:45 <redrobot> Luzi, not yet, but we can make one real quick
13:04:51 <Luzi> okay :)
13:05:10 <redrobot> What's the new code name? W____?
13:05:27 <moguimar> wallaby?
13:05:32 <moguimar> or something like that
13:06:13 <redrobot> #link https://etherpad.opendev.org/p/wallaby-ptg-barbican
13:06:22 <redrobot> Luzi, ^^^
13:06:38 <Luzi> thank you :)
13:07:02 <redrobot> tosky, I did not get a chance to look into the tempest failure
13:07:20 <redrobot> tosky, I think I'll add it as a story to the tempest bug tracker so we don't forget
13:07:47 <redrobot> #action redrobot to add story for tempest bug in ML
13:07:54 <redrobot> OK, that's it for the action items
13:08:17 <redrobot> #topic Liaison Updates
13:08:20 <redrobot> moguimar, any news from Oslo?
13:08:29 <moguimar> Feature Freeze on
13:08:41 <moguimar> since last Friday
13:09:08 <redrobot> Cool beans
13:09:39 <redrobot> tosky, any news from the testing side of things?
13:11:31 <redrobot> I think we may have asked in the 1/2 where tosky's not paying attention. :-P
13:11:34 <redrobot> Let's move on.
13:11:39 <redrobot> #topic Kanban Review
13:11:48 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:12:15 <redrobot> moguimar, assuming we'll need to hold off on the HVAC work until Castellan is branched?
13:12:23 <moguimar> yep
13:13:29 <redrobot> On my part, I'm moving the "Move ansible-role-*-hsm" repos" card
13:13:40 <redrobot> Both the governance patch and the infra patch merged
13:13:51 <redrobot> we should have Storyboard projects for all the HSM roles now
13:14:15 <redrobot> and we're also able to release versions of each repo individually, so that's awesome
13:14:30 <redrobot> For Secret Consumers
13:14:51 <redrobot> I was working on the microversions patch last week.  One thing I'm not sure about is whether we should change the response to the root controller
13:14:52 <raildo> o/
13:15:02 <redrobot> to match the Versions response specified by the API-WG
13:15:17 <redrobot> #link https://specs.openstack.org/openstack/api-wg/guidelines/microversion_specification.html
13:15:59 <redrobot> The API-WG guidance is to return {"versions": [ { ... versions here } ]}
13:16:25 <redrobot> but we currently return {"versions": {"values": [ { ... versions here ... } ]}
13:19:38 <redrobot> Maybe we should only return the new format if the X-OpenStack-API-Version header is set?
13:22:18 <redrobot> Anyway, something to think about
13:22:33 <redrobot> ...
13:22:53 <redrobot> Moving on
13:22:56 <redrobot> #topic Bug Review
13:23:04 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:23:13 <redrobot> I did report a new bug last week:
13:23:25 <redrobot> #link https://storyboard.openstack.org/#!/story/2008103
13:23:51 <redrobot> It's a bit of a low priority, I think, because it only happens when you're using the unauthenticated context
13:24:02 <redrobot> but basically we're not processing Accept headers correctly
13:24:16 <redrobot> Accept: */* is defaulting to replying with an HTML response
13:24:22 <redrobot> which is bad for a JSON API
13:25:10 <raildo> redrobot, I'm creating a list of low-hanging-fruit bugs as suggestion for some students for the University where I live. They want to start to contributing to open source/barbican...
13:25:19 <raildo> redrobot, I added this one as a good candidate
13:25:39 <redrobot> raildo, sounds good!
13:25:41 <raildo> redrobot, but if you have any other bugs, that you think that will be easy to have it fixed, and it's not a high priority, just let me know
13:25:50 <redrobot> raildo, okay!
13:26:51 <redrobot> #link https://bugs.launchpad.net/castellan/+bugs?orderby=-id&start=0
13:26:56 <redrobot> looks like no new bugs in Castellan
13:27:12 <redrobot> #topic Wayward Reviews
13:27:15 <redrobot> #link https://tinyurl.com/y3ydwmkl
13:28:31 <moguimar> one out of the 3 14+ days patches seems to be about actually something
13:28:39 <moguimar> https://review.opendev.org/#/c/687817/
13:29:20 <moguimar> and we can almost have a cake to this one
13:29:26 <moguimar> will be 1yr old next month
13:29:40 <redrobot> oof
13:29:59 <redrobot> I think we just need to remove the default text in the releasenote and merge it
13:30:27 <redrobot> moguimar, do you want to update the patch?
13:30:45 <moguimar> yeah, we didn't give him any feedback in 3 months
13:30:59 <moguimar> I can rebase it and put it on my list to investigate
13:31:13 <openstackgerrit> Moisés Guimarães proposed openstack/barbican master: Set db_auto_create default to False  https://review.opendev.org/687817
13:32:31 <moguimar> lets go to needs approval
13:32:33 <moguimar> https://review.opendev.org/#/c/745455/
13:33:29 <redrobot> moguimar, lgtm, next
13:33:38 <moguimar> I'd like to go back to https://review.opendev.org/#/c/715514/
13:33:48 <tosky> (sorry) I couldn't check that tempest failures either, and fine to add as a story; no other testing updates for now
13:34:00 <redrobot> thanks tosky!
13:34:03 <moguimar> I've seen many projects in the oslo side already with that proposed fix
13:34:39 <moguimar> so do you have any other concerns on that patch redrobot? or do we go with you changing the -1 to +2?
13:35:00 <moguimar> the dash is also correct, no need to be _
13:35:28 <redrobot> moguimar, hmm... I'm still not convinced. :-P
13:35:39 <redrobot> Let me look into it today and I'll update it if needed.
13:35:47 <moguimar> ok
13:36:24 <moguimar> I don't have anything else that catches the eye for now
13:36:33 <redrobot> Cool beans.
13:36:37 <redrobot> #topic Open Discussion
13:36:42 <redrobot> anything else y'all want to talk about?
13:41:51 <redrobot> I'll take that as a no.
13:41:57 <redrobot> Thanks for joining everyone! :D
13:42:00 <redrobot> #endmeeting