13:00:07 <redrobot> #startmeeting barbican
13:00:08 <openstack> Meeting started Tue Oct 13 13:00:07 2020 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:11 <openstack> The meeting name has been set to 'barbican'
13:00:20 <redrobot> #topic Roll Call
13:00:35 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:00:42 <redrobot> As usual the agenda etherpad is here:
13:00:45 <raildo> o/
13:00:49 <redrobot> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
13:00:54 <moguimar> o/
13:02:52 <redrobot> There were no action items last week
13:03:01 <redrobot> so let's go straight into the liaison updates
13:03:05 <redrobot> #topic Liaison Updates
13:03:08 <redrobot> moguimar, any news from Oslo?
13:03:39 <moguimar> yep
13:03:51 <moguimar> we have a DPL governance mode now
13:04:07 <moguimar> which is composed of 5 people so far
13:05:08 <redrobot> coolness
13:05:15 <moguimar> you can check it our here
13:05:19 <moguimar> #link https://wiki.openstack.org/wiki/Oslo#Project_Leadership_Liaisons
13:05:30 <redrobot> still watiing until after PTG for the oslo.utils release?
13:06:54 <moguimar> yep
13:07:34 <redrobot> cool
13:07:39 <redrobot> tosky, around?  any news from testing?
13:08:13 <tosky> nothing on my side
13:08:40 <redrobot> Cool, moving on.
13:09:13 <redrobot> #topic Kanban Review
13:09:16 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:09:39 <redrobot> No progress in the microversions patches (blocker for moguimar's Secret Consumers work)
13:09:45 <redrobot> moguimar, any updates on HVAC?
13:09:49 <moguimar> nope
13:10:29 <redrobot> raildo, any updates on the Policy work?
13:10:48 <raildo> redrobot, yeah, we do have some updates
13:11:17 <raildo> we have a bit more organized patches, https://review.opendev.org/#/c/755163/ this is the first one
13:11:37 <raildo> where we're defining the new roles/scopes that will be used on all of the APIs changes
13:12:11 <raildo> and here is the first example of usage of it https://review.opendev.org/#/c/755875/2 on the TransportKey, still need to have the unit tests fixed, but I'm working on it
13:12:35 <redrobot> Awesome!
13:12:50 <raildo> so would be nice to have a feedback on the new roles definition, also if we want to deprecate some of of the older roles, we can add a deprecation note later
13:13:12 <raildo> and any suggestion on which API calls would be nice to be implementing the default roles support next?
13:14:08 <redrobot> probably some of the less used ones, like secret stores or quotas
13:14:26 <raildo> redrobot, cool, I'll add those APIs to the todo list
13:15:11 <raildo> that's all that I have for now
13:16:05 <redrobot> cool, moving on
13:16:08 <redrobot> #topic Bug Review
13:16:12 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:16:48 <redrobot> Looks like we did get a new Story in Storyboard:
13:16:49 <redrobot> #link https://storyboard.openstack.org/#!/story/2008238
13:16:59 <redrobot> >  Typo in cp command in contributor/dev doc
13:17:09 <redrobot> Anyone want to volunteer to triage that one?
13:17:32 <redrobot> seems like low hanging fruit for sure
13:18:19 <moguimar> I can champion it
13:18:27 <moguimar> I have someone in mind to fix it =D
13:18:33 <redrobot> Haha, nice!
13:18:41 <redrobot> thanks moguimar!
13:19:02 <redrobot> And it looks like no new bugs for Castellan
13:19:03 <redrobot> #link https://bugs.launchpad.net/castellan/+bugs?orderby=-id&start=0
13:19:37 <redrobot> #topic Wayward Reviews
13:19:40 <redrobot> #link https://tinyurl.com/y3ydwmkl
13:20:25 <redrobot> looks like our 14 day patches are for stable branches
13:20:47 <moguimar> I did a lot of patch petting yesterday
13:20:51 <redrobot> I'm planning on spending some time this week to make sure our stable branches are in good shape
13:20:55 <redrobot> nice moguimar!
13:20:58 <redrobot> I'
13:21:05 <moguimar> actually thought it was Tuesday xD
13:21:18 <redrobot> haha
13:21:56 <moguimar> but yeah, there are good number of patches that need a 2nd core to look at them
13:22:25 <moguimar> and kudos to aj for putting the bandit patch together
13:23:35 <tosky> I've seen a rechecks on the old reviews on stable/queens - I guess it was to refresh the logs
13:24:45 <redrobot> #action redrobot to check stable branches for health
13:24:47 <tosky> the current status is still fully described by one of the last comments in https://review.opendev.org/#/c/699186/ (which combines https://review.opendev.org/#/c/697210/ and https://review.opendev.org/#/c/695327/)
13:26:06 <tosky> most likely a few additional fixes need to be squashed inside https://review.opendev.org/#/c/699186/ (for sure the fix for the tests using an "expired" date)
13:26:32 <redrobot> Ah yes, the expired dates ...  5 years seemd like such a long time back then. :-P
13:28:06 <moguimar> gotta always check for the release lifespan
13:29:15 <tosky> couldn't those expiration dates be moved even forward in time? Like 2038, which is going to be problematic anyway? (but probably not for 64 bit systems)
13:30:02 <redrobot> Yeah, that would work
13:30:08 <moguimar> does 2039 breaks for 64 bits? xD
13:31:54 <tosky> I think 64 bit time will roll-over when it won't be a problem for the humanity anymore :D
13:32:11 <moguimar> ah good
13:32:20 <redrobot> 🤣🤣🤣
13:32:37 <moguimar> I was thinking about "just put a date that we all will be retired at that time"
13:33:31 <moguimar> "boom has been planted" Counter Strike feelings
13:34:26 <redrobot> #topic Open Discussion
13:34:34 <redrobot> Anything else y'all want to talk about?
13:34:57 <moguimar> not with you xD
13:35:13 <redrobot> haha, jerk
13:35:16 <moguimar> I'd like to ask tosky a few questions after the meeting
13:35:26 <redrobot> 😝
13:35:31 <tosky> sure
13:35:31 <redrobot> cool, sounds like it's a wrap
13:35:36 <redrobot> thanks for joining everyone!
13:35:38 <moguimar> but it is oslo's business
13:35:40 <redrobot> #endmeeting