13:00:15 <redrobot> #startmeeting barbican
13:00:16 <openstack> Meeting started Tue Jan 19 13:00:15 2021 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:19 <openstack> The meeting name has been set to 'barbican'
13:01:18 <redrobot> #topic Roll Call
13:01:32 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work xek nearyo
13:01:32 <moguimar> o/
13:01:39 <redrobot> Hi moguimar!
13:01:45 <moguimar> hey hey
13:01:50 <rajivmucheli> Hi
13:01:57 <moguimar> hey rajiv
13:02:01 <Luzi> o/
13:02:19 <tosky> hello
13:02:26 <redrobot> Yay, lots of folks here today! :D
13:02:33 <redrobot> As usual the agenda is over here:
13:02:36 <redrobot> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
13:03:02 <redrobot> Let's get started
13:03:10 <redrobot> #topic Review Past Meeting Action Items
13:03:24 <redrobot> #link http://eavesdrop.openstack.org/meetings/barbican/2021/barbican.2021-01-12-13.00.html
13:03:38 <redrobot> We only had one  Action Item for moguimar
13:03:48 <redrobot> > moguimar to use his gerrit-foo to make us a new dashboard link that includes Cursive reviews
13:03:51 <moguimar> did we? xD
13:03:55 <moguimar> ah
13:04:17 <moguimar> now... did we save that new link somewhere? xD
13:04:20 <redrobot> And here is the new link for everyone to bookmark
13:04:24 <redrobot> #link https://tinyurl.com/y3zto3ad
13:04:56 <redrobot> I got you moguimar ;)
13:05:17 <redrobot> OK, moving on
13:05:23 <redrobot> #topic Liaison Updates
13:05:37 <tosky> no updates, sorry
13:05:43 <redrobot> no worries tosky
13:05:55 <redrobot> any new Oslo updates moguimar?
13:06:05 <moguimar> yep
13:06:20 <moguimar> we were asked about barbican-ui in the mailing list
13:06:26 <moguimar> actually that was from the release team
13:07:43 <Luzi> is there a link? (i cannot find the mail right now)
13:08:16 <moguimar> [barbican][release] Barbican deliverables questions
13:08:27 <moguimar> I'm terrible with links
13:08:31 <moguimar> can you find that one redrobot ?
13:08:43 <redrobot> #link http://lists.openstack.org/pipermail/openstack-discuss/2021-January/019845.html
13:08:52 <redrobot> That one? moguimar
13:09:07 <moguimar> can you find that one redrobot ?yep
13:09:11 <moguimar> oops
13:09:22 <moguimar> yeah, that one
13:09:24 <redrobot> hehe
13:09:25 <Luzi> i'll forward this to nearyo and our boss...
13:09:32 <redrobot> Thanks Luzi
13:10:13 <redrobot> I think I will try to deploy Nearyo's patch in a VM and if things aren't broken I think we should consider merging it to get a release
13:10:19 <redrobot> I know for sure we don't want to abandon it
13:10:43 <redrobot> as we (Red Hat) are also interested in barbican-ui but it's still a little ways out in our roadmanp
13:10:52 <redrobot> *roadmap
13:11:33 <redrobot> I think we do also want to release the HSM ansible roles
13:13:30 <redrobot> any other thoughts/comments on the ML message?
13:14:09 <redrobot> #action redrobot to reply to Hervé in ML about releases
13:14:19 <redrobot> OK, moving on
13:14:42 <redrobot> #topic Kanban Review
13:14:44 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:14:50 <redrobot> No updates from me today
13:15:11 <redrobot> moguimar any updates on HVAC?  Have you had a chance to look at it this year?
13:15:23 <moguimar> not really
13:15:44 <moguimar> I have been terrible about upstream fridays
13:16:18 <redrobot> Haha, no worries.  I'm trying to get better at them too.
13:16:28 <redrobot> I'll try to remind you about it this Friday
13:16:55 <redrobot> #topic Bug Review
13:17:13 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:17:21 <redrobot> Looks like no new barbican stories
13:17:38 <redrobot> #link https://bugs.launchpad.net/castellan/+bugs?orderby=-id&start=0
13:17:43 <redrobot> and no new bugs in Castellan
13:18:05 <redrobot> moguimar where do Cursive bugs/stories get tracked?
13:18:20 <redrobot> maybe we should add them to our list of bug pages to check?
13:18:38 <moguimar> lets AI that for next week
13:18:50 <moguimar> or maybe look at the readme now
13:19:05 <redrobot> #action moguimar to look into where Cursive bugs are tracked
13:19:09 <moguimar> lauchpad
13:19:15 <moguimar> https://bugs.launchpad.net/cursive
13:19:46 <redrobot> #undo
13:19:46 <openstack> Removing item from minutes: #link https://bugs.launchpad.net/cursive
13:19:51 <redrobot> #undo
13:19:52 <openstack> Removing item from minutes: #action moguimar to look into where Cursive bugs are tracked
13:19:58 <redrobot> #link https://bugs.launchpad.net/cursive/+bugs?orderby=-id&start=0
13:20:10 <redrobot> Looks like there's a couple of ancient bugs there
13:20:21 <moguimar> yeah
13:20:34 <moguimar> we can pair on a bug review next Fri
13:20:40 <redrobot> sounds good
13:21:01 <redrobot> OK, moving on
13:21:06 <redrobot> #topic Wayward Reviews
13:21:17 <redrobot> #link https://tinyurl.com/y3zto3ad
13:21:51 <redrobot> One easy merge for you moguimar
13:21:53 <redrobot> https://review.opendev.org/c/openstack/barbican/+/768512
13:22:21 <redrobot> Another easy README update
13:22:22 <redrobot> https://review.opendev.org/c/openstack/ansible-role-thales-hsm/+/770168
13:24:04 <moguimar> done
13:28:10 <redrobot> I need to sit down and try to grok that mokeypatch patch at some point
13:28:31 <redrobot> Also, I am not sure we want to remove 3.7 from barbicanclient
13:28:33 <redrobot> https://review.opendev.org/c/openstack/python-barbicanclient/+/768977
13:28:57 <moguimar> well, we don't
13:29:02 <moguimar> that was agreed already in the ML
13:29:08 <moguimar> those patches should be abandoned
13:29:15 <redrobot> Cool
13:29:16 <moguimar> we test lower and upper bounds
13:29:21 <moguimar> 36 and 38
13:29:36 <moguimar> but we can keep classifiers for intermediary versions
13:29:51 <redrobot> cool
13:30:03 <redrobot> I'll look for that ML link and add it to the review
13:30:43 <redrobot> I think that's it for easy patches
13:30:50 <redrobot> #topic Open Discussion
13:31:14 <tosky> in the meantime, I've managed to update the cursive zuul patch (https://review.opendev.org/c/x/cursive/+/746584), which requires some cleanup in project-config (https://review.opendev.org/c/openstack/project-config/+/771443)
13:31:34 <rajivmucheli> Hi, is the alembic_version for Openstack Barbican on Victoria release 0f8c192a061f ?
13:31:34 <rajivmucheli> https://github.com/openstack/barbican/blob/stable/victoria/barbican/model/migration/alembic_migrations/versions/0f8c192a061f_add_secret_consumers.py#L18
13:32:35 <rajivmucheli> which hasnt changed from ussuri release ?
13:33:30 <redrobot> tosky I'll take a look at those
13:33:45 <openstackgerrit> Merged openstack/barbican master: [doc] Fix hmac/mkek generation commands  https://review.opendev.org/c/openstack/barbican/+/768512
13:34:20 <redrobot> rajivmucheli that sounds about right... I don't think the database had any changes in Victoria
13:35:04 <rajivmucheli> okay, in the victoria release notes, its mentioned about  https://docs.openstack.org/releasenotes/barbican/victoria.html#upgrade-notes
13:35:42 <rajivmucheli> i am little confused if i need to enable this prior to a upgrade ? i have a migration script which executes barbican-manage --upgrade
13:35:42 <redrobot> Ah yes, that is a change to the API behavior, not the database.
13:36:23 <redrobot> No, auto migrate means the API will run migration, but it sounds like you have a script that does it first.
13:36:42 <redrobot> Just make sure you run your script once before starting the API
13:37:33 <rajivmucheli> yes, unless the migration completes the execution of barbican-manage db upgrade, the api pods doesnt start as i have dependancy check.
13:38:15 <rajivmucheli> are there any other checks to be performed prior to the upgrade ?
13:38:48 <redrobot> 🤔 I can't think of anything off the top of my head.
13:39:01 <rajivmucheli> okay, thanks!
13:39:38 <redrobot> You're welcome! 😁
13:39:53 <redrobot> Anything else y'all want to talk about?
13:41:57 <redrobot> Sounds like we're done for the day.
13:42:03 <redrobot> Thanks for joining everyone!
13:42:09 <redrobot> #endmeeting