13:00:35 <redrobot> #startmeeting barbican
13:00:35 <opendevmeet> Meeting started Tue Jun 15 13:00:35 2021 UTC and is due to finish in 60 minutes.  The chair is redrobot. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:35 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
13:00:35 <opendevmeet> The meeting name has been set to 'barbican'
13:00:42 <redrobot> #topic Roll Call
13:00:51 <redrobot> Courtesy ping for ade_lee dave-mccowan hrybacki jamespage Luzi lxkong mhen moguimar raildo rm_work tosky xek nearyo oleksandry
13:01:02 <rosmaita> o/
13:01:09 <redrobot> Hi rosmaita
13:01:23 <rosmaita> hello
13:01:23 <redrobot> As usual the agenda can be found here:
13:01:31 <redrobot> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
13:02:32 <Luzi> o/
13:03:10 <rosmaita> redrobot: https://review.opendev.org/c/openstack/barbican/+/796284 has finally passed zuul, if you could look when you have time, it's blocking some of the cinder gates
13:03:29 <rosmaita> took 3 rechecks, but looks like that was due to mirroring problems for dependencies where the jobs landed
13:03:38 <redrobot> #topic Barbican Gates
13:03:49 <redrobot> Thanks for working ont hat patch rosmaita.
13:04:02 <rosmaita> that was all Gorka, i am just following up
13:04:07 <redrobot> gotcha
13:04:19 <redrobot> Yeah, I'm not sure how so much SQLAlchemy broke all at once
13:04:36 <rosmaita> well, the "major" projects got advance notice a few months ago
13:04:47 <redrobot> heh
13:04:54 <rosmaita> i left a comment on the patch that more projects should be notified, but it got lost
13:05:12 <rosmaita> anyway, 1.4 intentionally introduced some backward incompatibilities
13:05:16 <rosmaita> to prepare for 2.0
13:05:33 <redrobot> I'll take a look at the patch right after this meeting and try to catch ade_lee for a second review when he comes online
13:05:39 <rosmaita> cool, ty
13:06:06 <rosmaita> i have one more "none of my business, but" comment (or i can wait for open discussion later)
13:06:17 <redrobot> shoot
13:06:43 <rosmaita> i noticed that there's a place in the barbican code where you have deleted=1 in a sqlalchemy query
13:06:52 <rosmaita> 'deleted' is boolean in the model, though
13:07:08 <rosmaita> i believe it's not a problem for mysql/mariadb
13:07:21 <rosmaita> but might be worth using boolean to be consistent
13:07:32 <rosmaita> (since db use is kind of important for barbican)
13:07:40 <redrobot> Ah yeah, that's a good catch
13:07:54 <tosky> hi
13:08:04 <redrobot> hi tosky
13:08:05 <rosmaita> we got burned once by that in glance when someone was using postgresql
13:08:08 <tosky> I see the main topic I was going to raise has been taken care of already
13:08:14 <rosmaita> :)
13:08:17 <tosky> (i.e. broken gates for everyone!)
13:08:39 <redrobot> 😅😅😅
13:08:52 <redrobot> I'm hoping we can get everything back online in the next couple of hours
13:09:51 <rosmaita> i wonder whether we should propose that the cinder-tempest-plugin tests be run in the requirements gate -- currently it's just unit tests for select projects
13:10:00 <rosmaita> that way barbican would get a workout
13:10:33 <rosmaita> i was going to propose that barbican unit tests should be added, but that wouldn't have caught this event
13:11:02 <rosmaita> anyway, something to think about ... i will be happy to help push this if you think it's a good idea
13:11:15 <redrobot> More testing is always good IMO
13:11:53 <rosmaita> and actually, i am wrong about the barbican UTs not catching a problem, so maybe those would be sufficient
13:12:23 <redrobot> let's propose a patch and see what the requirements folks have to say abou tit
13:13:56 <rosmaita> sounds good
13:14:15 <redrobot> OK, moving on ...
13:14:20 <redrobot> #topic Liaison Updates
13:14:26 <redrobot> tosky anything else you want to talk about?
13:17:40 <tosky> nothing else (usual stuff about grenade still pending)
13:18:34 <redrobot> cool, thanks tosky
13:18:40 <redrobot> #topic Kanban Review
13:18:50 <redrobot> #link https://tree.taiga.io/project/dmend-openstack-barbican/kanban
13:19:23 <redrobot> I have a WIP patch to fix the unicode error when using the Vault backend: https://review.opendev.org/c/openstack/barbican/+/796065
13:20:08 <redrobot> the patch works for a new deployment, but I still need to add the logic to handle inconsistent encodings for existing deployments
13:21:21 <redrobot> #topic Bug Review
13:21:34 <redrobot> #link https://storyboard.openstack.org/#!/project_group/barbican
13:22:09 <redrobot> We have one new bug for the db migration that was broken by sqlachemy https://storyboard.openstack.org/#!/story/2008967
13:22:37 <redrobot> #link https://bugs.launchpad.net/castellan/+bugs?orderby=-id&start=0
13:22:43 <redrobot> No new Castellan bugs
13:22:54 <redrobot> #link https://bugs.launchpad.net/cursive/+bugs?orderby=-id&start=0
13:23:00 <redrobot> And no new Cusrvie bugs
13:23:22 <redrobot> #topic Wayward Reviews
13:23:52 <redrobot> usually me and moguimar would look at reviews now, but he won't be around very much anymore :(
13:24:13 <redrobot> That said, if anyone here is interested in being a core reviewer let me know and we can work on a plan to get you there. ;)
13:24:33 <redrobot> #topic Open Discussion
13:24:41 <redrobot> Anything else y'all want to talk about?
13:28:12 <rosmaita> redrobot: will you propose a patch to add barbican UTs to the requirements check?
13:28:30 <redrobot> rosmaita yeah, I can do that
13:28:44 <redrobot> #action redrobot to propose patch for requirements check to include barbican unit tests
13:28:47 <rosmaita> cool, ping me in #openstack-cinder and I will leave a comment on it
13:29:11 <rosmaita> i will talk offline with tosky about the advisibility of proposing cinder-tempest-plugin jobs for requirements
13:29:34 <rosmaita> if we put up a patch, i will ping you
13:29:42 <redrobot> ack, sounds good
13:29:49 <rosmaita> excellent, thank you
13:32:00 <redrobot> Thanks for joining, everyone!
13:32:03 <redrobot> #endmeeting