12:15:34 <dmendiza[m]> #startmeeting barbican
12:15:34 <opendevmeet> Meeting started Tue Jun 20 12:15:34 2023 UTC and is due to finish in 60 minutes.  The chair is dmendiza[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:15:34 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
12:15:34 <opendevmeet> The meeting name has been set to 'barbican'
12:16:06 <dmendiza[m]> #topic Roll Call
12:16:43 <dmendiza[m]> I need a coffee ☕
12:17:08 <dmendiza[m]> It's @xek who should be running this, not d34dh0r53
12:17:52 <dmendiza[m]> rajiv , mharley @_oftc_mharley:matrix.org: still around?
12:18:04 <mharley> I'm here.
12:18:06 <Luzi> o/
12:18:17 <rajiv> yes
12:20:06 <rajiv> i havent cleaned up db past 3 years, i am planning to introduce a cron job for every 3hrs.
12:20:35 <rajiv> i couldnt find the barbican-manage output details, apart in models.py file
12:20:52 <dmendiza[m]> rajiv: OK, i'll add that to the agenda
12:21:07 <rajiv> is there any docu ?
12:21:17 <dmendiza[m]> As usual the agenda is over here:
12:21:25 <dmendiza[m]> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
12:21:35 <dmendiza[m]> #topic Review Past Meeting Action Items
12:22:13 <dmendiza[m]> Looks like the last weekly meeting was this one:
12:22:15 <dmendiza[m]> #link https://meetings.opendev.org/meetings/barbican/2023/barbican.2023-06-06-12.00.html
12:22:31 <dmendiza[m]> and there were no action items
12:22:38 <dmendiza[m]> moving on
12:22:55 <dmendiza[m]> #topic Liaison Updates
12:23:01 <dmendiza[m]> tosky: around?
12:23:08 <tosky> hi!
12:23:20 <tosky> no updates from me
12:23:29 <dmendiza[m]> sounds good, thanks!
12:23:38 <tosky> I haven't even checked if anything related happened on the PTG
12:23:44 <dmendiza[m]> I just came back from PTO so I don't have any updates either
12:23:47 <tosky> (which I didn't attend)
12:24:08 <dmendiza[m]> same, I was out on vacation while a few other folks went up to Vancouver
12:24:30 <dmendiza[m]> I'm assuming d34dh0r53 is still not around for VMT updates
12:24:38 <dmendiza[m]> moving on
12:24:54 <dmendiza[m]> #topic DB cleaning
12:25:04 <dmendiza[m]> rajiv: this is your topic
12:25:57 <rajiv> thanks, i get the below output in qa, anything i need to lookout for ?
12:26:08 <rajiv> is there a better to share code here ?
12:26:18 <rajiv> 2023-06-15 08:38:36,052 26 INFO barbican.model.clean [-] Cleaned up 784 entries for Order with no children in OrderRetryTask
12:26:23 <rajiv> 2023-06-15 08:38:36,920 26 INFO barbican.model.clean [-] Cleaned up 99671 entries for EncryptedDatum
12:26:28 <rajiv> 2023-06-15 08:38:36,925 26 INFO barbican.model.clean [-] Cleaned up 786 entries for SecretUserMetadatum
12:26:32 <rajiv> 2023-06-15 08:38:38,051 26 INFO barbican.model.clean [-] Cleaned up 199354 entries for SecretStoreMetadatum
12:27:08 <rajiv> i cannot understand SecretStoreMetadatum in models.py, is there better documentation to understand what has been cleaned up ?
12:27:53 <rajiv> i also presume, once db is cleaned up, there isnt a way to restore ? apart taking a snapshot prior cleaning ?
12:30:27 <dmendiza[m]> rajiv: paste of a few lines is fine.  For longer output use https://paste.opendev.org/
12:31:11 <dmendiza[m]> this is the only docs I'm aware of:
12:31:13 <dmendiza[m]> #link https://docs.openstack.org/barbican/latest/admin/database_cleaning.html
12:31:19 <rajiv> https://paste.opendev.org/show/bdZFMnIZrjiHocD2S3a4/
12:31:54 <dmendiza[m]> > what has been cleaned up ?
12:32:08 <dmendiza[m]> By default, everything in Barbican is soft-deleted
12:32:20 <rajiv> yes, i referred this page, but i dont understand whats SecretStoreMetadatum, EncryptedDatum, etc, i presume these are table names, correct ?
12:32:35 <dmendiza[m]> Theyre python object names
12:32:50 <rajiv> i have shared the barbican-manage db command output in the above paste link
12:33:02 <dmendiza[m]> #link https://opendev.org/openstack/barbican/src/branch/master/barbican/model/models.py#L386
12:33:17 <dmendiza[m]> #link https://opendev.org/openstack/barbican/src/branch/master/barbican/model/models.py#L453
12:33:59 <dmendiza[m]> rajiv: by default, "db clean" takes everything that was "soft-deleted" and deltes it for real
12:34:08 <dmendiza[m]> ie, actually purges the data from the DB
12:34:26 <dmendiza[m]> > there isnt a way to restore ? apart taking a snapshot prior cleaning ?
12:34:26 <dmendiza[m]> this is correct.
12:35:11 <dmendiza[m]> Objects that are soft-delted have a "deleted" column that is set to 1, and don't show up in API queries
12:35:15 <rajiv> okay, i wanted to understand the cleaning logic in detail
12:35:27 <dmendiza[m]> db clean looks for those objects and deletes them from the db
12:35:28 <rajiv> oh ok
12:36:01 <dmendiza[m]> 100% agree that the output of the cli tool could be better
12:36:32 <rajiv> so from the output i shared in the paste link, everything looks expected ? i wanted to confirm before rolling out the change to production!
12:37:31 <dmendiza[m]> Yes, I don't see anything out of the ordinary there
12:37:48 <rajiv> cool, thanks
12:37:49 <dmendiza[m]> but definitely be sure you have a DB backup strategy before you start running db clean regularly
12:39:28 <rajiv> sure, db backups are taken every 15mins or if there is any change
12:39:44 <rajiv> maybe to start with, i will set the cron job for once a day
12:39:44 <dmendiza[m]> Awesome, yeah you should be good to go then.
12:40:32 <rajiv> :)
12:42:35 <dmendiza[m]> Great
12:42:39 <dmendiza[m]> any other questions on this topic?
12:48:13 <dmendiza[m]> I'll take that as a no
12:48:15 <dmendiza[m]> moving on
12:48:24 <dmendiza[m]> #topic Open Discussion
12:48:32 <dmendiza[m]> Anything else y'all want to talk about?
12:50:55 <dmendiza[m]> OK, moving on
12:50:59 <dmendiza[m]> #topic Bug Review
12:51:21 <dmendiza[m]> #link https://bugs.launchpad.net/barbican/+bugs?orderby=-id&start=0
12:52:39 <dmendiza[m]> Looks like there are no new bugs in Launchpad for Barbican
12:52:51 <dmendiza[m]> #link https://bugs.launchpad.net/python-barbicanclient/+bugs?orderby=-id&start=0
12:53:32 <dmendiza[m]> Looks like no new bugs in python-barbicanclient either
12:53:38 <dmendiza[m]> but we do need to update the description
12:53:53 <dmendiza[m]> the link preview in Matrix is showing me a message about migrating to Storyboard
12:53:58 <dmendiza[m]> which is no longer true
12:54:13 <dmendiza[m]> #action dmendiza to update python-barbicanclient launchpad to update Storyboard redirect
12:54:43 <dmendiza[m]> #link https://bugs.launchpad.net/castellan/+bugs?orderby=-id&start=0
12:54:50 <dmendiza[m]> And no new Castellan bugs
12:54:59 <dmendiza[m]> #link https://bugs.launchpad.net/cursive/+bugs?orderby=-id&start=0
12:55:03 <dmendiza[m]> and also no new Cursive bugs
12:55:14 <dmendiza[m]> that's all I have for today.  Thanks for joining, y'all
12:55:17 <dmendiza[m]> #endmeeting