15:02:16 <dmendiza[m]> #startmeeting barbican
15:02:16 <opendevmeet> Meeting started Mon May 12 15:02:16 2025 UTC and is due to finish in 60 minutes.  The chair is dmendiza[m]. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:16 <opendevmeet> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:02:16 <opendevmeet> The meeting name has been set to 'barbican'
15:03:36 <dmendiza[m]> #topic Roll Call
15:03:44 <dmendiza[m]> Courtesy ping for dmendiza[m] ade_lee d34dh0r53 Luzi tosky tobias-urdin jjung mharley lpiwowar
15:03:55 <xek> o/
15:03:57 <dmendiza[m]> I guess I don't really need to ping myself, haha
15:04:14 <xek> I'll add myself to the list
15:04:50 <dmendiza[m]> As usual, the agenda is here:
15:04:53 <dmendiza[m]> #link https://etherpad.opendev.org/p/barbican-weekly-meeting
15:04:59 <dmendiza[m]> Let's get started
15:05:06 <dmendiza[m]> #topic Review Past Meeting Action Items
15:05:24 <dmendiza[m]> #link https://meetings.opendev.org/meetings/barbican/2025/barbican.2025-04-28-15.03.html
15:05:28 <dmendiza[m]> There were non
15:05:32 <dmendiza[m]> *none
15:06:09 <dmendiza[m]> #topic Liaison Updates
15:06:42 <dmendiza[m]> From the Release side of things, I did see a patch for Flamingo-1 come through
15:06:47 <dmendiza[m]> I think we're good to merge that
15:06:54 <mauricioharley[m]> o/
15:06:58 <dmendiza[m]> unless someone here objects?
15:07:33 <dmendiza[m]> Ohai mauricioharley !  I didn't think you'd be available so I decided to chair the meeting
15:07:43 <dmendiza[m]> mauricioharley: I can hand it back to you if you want?
15:07:57 <mauricioharley[m]> Thanks, dmendiza . I' using the phone today.
15:08:06 <mauricioharley[m]> No, feel free to run the show today. ;-)
15:08:12 <dmendiza[m]> You go tit
15:08:14 <dmendiza[m]> *got it
15:08:21 <mauricioharley[m]> * . I'm using
15:08:38 <dmendiza[m]> lpiwowar: around?  Any QE updates?
15:09:13 <dmendiza[m]> I guess they're not around.  Moving on
15:09:15 <xek> no updates from VMT
15:09:21 <dmendiza[m]> ack, thanks Grzegorz Grasza
15:09:44 <mauricioharley[m]> rajiv: did you manage to fix the Zuul errors on your patch?
15:09:52 <xek> lpiwowarhasn't attended the meeting for a while
15:10:04 <dmendiza[m]> OK, moving on ...
15:10:05 <rajiv> mauricioharley[m]: yes, for the blueprint
15:10:23 <dmendiza[m]> Grzegorz Grasza: I see, maybe we need a new QE liaison?
15:10:35 <rajiv> it was fixed 2 weeks back, i was waiting for a review
15:10:46 <dmendiza[m]> #topic Barbican Specs (Blueprints)
15:10:50 <dmendiza[m]> #link https://review.opendev.org/q/project:openstack/barbican-specs+status:open
15:11:04 <dmendiza[m]> rajiv: apologies, I have been mostly out on PTO the last two weeks.
15:11:22 <dmendiza[m]> I am back now, though, so I'll review your spec this week (probably for Upstream Friday)
15:11:23 <rajiv> np!
15:11:50 <rajiv> cool :) based on the feedback, i will fix the commit : https://review.opendev.org/c/openstack/barbican/+/947118
15:12:36 <dmendiza[m]> Looks like rajiv 's spec is the only recent one ... the others are ancient
15:13:22 <dmendiza[m]> We should consider abandoning old CRs.
15:13:29 <rajiv> https://review.opendev.org/c/openstack/barbican/+/947118 was submitted last month
15:14:58 <dmendiza[m]> rajiv: ack, I'll take a look at the implementation patch too, but we probably won't merge it until after the spec itself is merged.
15:15:11 <rajiv> roger that Captain!!!
15:15:40 <dmendiza[m]> OK, moving on
15:15:49 <dmendiza[m]> #topic KMIP Client Library
15:16:03 <dmendiza[m]> Good thing you're here, rajiv because I have questions for you
15:16:28 <rajiv> nice!
15:16:40 <dmendiza[m]> We (Red Hat) plan to fix up KMIP so that it is fully supported again in Barbican
15:16:54 <dmendiza[m]> but there are some challenges to get to a state that we would consider healthy
15:17:07 <dmendiza[m]> The main hurdle now is that OpenKMIP/PyKMIP seems to be abandoned
15:17:19 <dmendiza[m]> #link https://github.com/OpenKMIP/PyKMIP/
15:17:45 <rajiv> yep, i tagged the owner over Twitter as well but had no response :(
15:17:50 <dmendiza[m]> The last commit was almost a year ago, the last release was over 5 years ago
15:18:10 <dmendiza[m]> rajiv: same.  I met Peter Hamilton a long time ago and reached out to him directly but never heard back
15:18:43 <dmendiza[m]> rajiv:  mauricioharley made me aware of the fork you've been working on:
15:18:45 <dmendiza[m]> #link https://github.com/sapcc/PyKMIP
15:18:54 <rajiv> yes
15:19:01 <rajiv> how can i help ?
15:19:10 <dmendiza[m]> And I have some questions about it to see if we could possibly use it as a replacement for OpenKMIP/PyKMIP
15:19:31 <dmendiza[m]> I summarized most of my questions in this Issue:
15:19:36 <dmendiza[m]> #link https://github.com/sapcc/PyKMIP/issues/28
15:20:03 <dmendiza[m]> to summarize here:
15:20:31 <dmendiza[m]> * Will you be publishing docs to readthedocs?
15:20:31 <rajiv> my bad, on missing this, wonder why i dint receive any notifications
15:21:06 <dmendiza[m]> * Will you be making regular releases.  i.e. Tags in GitHub and uploads to PyPI?
15:21:40 <dmendiza[m]> * Will you have a dedicated community discussion forum i.e. IRC/Matrix chat, or mailing list?
15:21:53 <rajiv> we will definitely maintaining the fork but it will be customised for our requirements!
15:22:10 <rajiv> are there any requirements to meet ?
15:22:24 <dmendiza[m]> I think it will be useful for Barbican as long as the Client side of it conforms to the KMIP spec
15:23:00 <mharley[m]> rajiv: where can you know more what are your requirements?
15:23:08 <dmendiza[m]> rajiv: any plans to rename the fork?  `pykmip` is taken in PyPI by OpenKMIP/PyKMIP, so you will at least need a new package name
15:23:11 <mharley[m]> Where can we *
15:23:55 <dmendiza[m]> basically we would treat it as any other requirement in Global Requirements
15:24:16 <dmendiza[m]> so, we would need it to have a compatible license, which I'm hoping you will keep Apache 2.0
15:24:24 <dmendiza[m]> and then we will need a PyPI release so we can pip install it
15:24:49 <dmendiza[m]> #link https://opendev.org/openstack/requirements
15:25:56 <rajiv> thanks for elaborating, i will check internally and comment on the issue ? hope this is fine ?
15:26:59 <dmendiza[m]> Downstream, my team would likely work on the RPM packaging side of things
15:27:00 <dmendiza[m]> Thank you rajiv!  I would prefer not to have to make a Red Hat fork and just re-use yours if possible.
15:27:12 <rajiv> sure!
15:27:30 <dmendiza[m]> #action rajiv to check with sapcc/PyKMIP maintainers to figure out if this fork could be used in OpenStack
15:28:10 <dmendiza[m]> In the meantime, I'm continuing to work with the existing KMIP plugin to try to get the Gerrit gates working again
15:28:21 <dmendiza[m]> WIP patch is here:
15:28:24 <dmendiza[m]> #link https://review.opendev.org/c/openstack/barbican/+/947760
15:28:36 <dmendiza[m]> That'
15:28:42 <dmendiza[m]> s all I have on KMIP this week
15:28:51 <dmendiza[m]> any questions/comments?
15:29:32 <mharley[m]> Me too, dmendizadespite of the unforeseen period.
15:30:51 <dmendiza[m]> OK, moving on
15:31:09 <dmendiza[m]> #topic Outreachy
15:31:23 <dmendiza[m]> mharley: any updates on this?
15:32:08 <mharley[m]> Yes, but unfortunately we could only select one candidate.  They have received the email already.
15:32:24 <mharley[m]> I need to double check with the organizers this week about this.
15:32:29 <dmendiza[m]> Great news!
15:32:36 <mharley[m]> The project is scheduled to start late this month.
15:32:48 <dmendiza[m]> It will be good to have some fresh collaboration here 😄
15:33:03 <mharley[m]> Yes!
15:33:58 <dmendiza[m]> OK, moving on ...
15:34:03 <dmendiza[m]> #topic Open Discussion
15:34:12 <dmendiza[m]> Any other topics before we move on to bug review?
15:36:07 <dmendiza[m]> OK, moving on ...
15:36:15 <dmendiza[m]> #topic Bug Review
15:37:26 <dmendiza[m]> #link https://bugs.launchpad.net/barbican/+bugs?orderby=-id&start=0
15:37:30 <dmendiza[m]> No new Barbican bugs
15:37:55 <dmendiza[m]> #link https://bugs.launchpad.net/python-barbicanclient/+bugs?orderby=-id&start=0
15:38:00 <dmendiza[m]> No new python-barbicanclient bugs
15:38:15 <dmendiza[m]> #link https://bugs.launchpad.net/castellan/+bugs?orderby=-id&start=0
15:38:26 <dmendiza[m]> No new Castellan bugs
15:38:46 <dmendiza[m]> #link https://bugs.launchpad.net/cursive/+bugs?orderby=-id&start=0
15:38:51 <dmendiza[m]> No new Cursive bugs
15:38:54 <dmendiza[m]> ...
15:38:59 <dmendiza[m]> and that's about it for today
15:39:04 <dmendiza[m]> thanks for joining, everyone!
15:39:07 <dmendiza[m]> #endmeeting