15:01:09 <tmorin> #startmeeting bgpvpn
15:01:10 <openstack> Meeting started Tue Jun 23 15:01:09 2015 UTC and is due to finish in 60 minutes.  The chair is tmorin. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:01:14 <openstack> The meeting name has been set to 'bgpvpn'
15:01:56 <tmorin> hi everyone
15:02:07 <timirnich> hi thomas
15:02:12 <tmorin> hi timirnich, hi Vikram
15:03:11 <Vikram> hi
15:03:31 <Vikram> tmorin: hi
15:03:43 <matrohon> hi
15:03:47 <tmorin> hi matrohon
15:03:53 <tmorin> hi pcarver
15:04:40 <tmorin> I think we can start
15:04:51 <tmorin> svinota told me he would not be present
15:05:06 <tmorin> #topic status on API discussions
15:05:22 <tmorin> I think we are now on a very good track on the API
15:06:13 <timirnich> think so too
15:06:23 <matrohon> +1
15:06:39 <tmorin> we have split the API into an object desrcribing the VPN and separate API calls to bind it to networks and/or to Routers
15:07:25 <tmorin> allowing to associate with Routers seems to make sense from a use case standpoint and will also allow having a Nuage driver until they can support association with networks
15:07:34 <matrohon> we encourage everybody to review the last version since some modification have been done recently to the API
15:07:47 <Vikram> ok
15:08:36 <matrohon> the router association still need some clarifications
15:08:45 <tmorin> yes
15:08:45 <tmorin> we may still have a few adjustments to do down the road, but overall what we have is good enough to start coding API changes
15:09:25 <tmorin> does anyone has an opinion on when we should move this .rst spec out of neutron-spec repo and into the networking-bgpvpn repo ?
15:09:49 <tmorin> if everyone agrees that its got no role in neutron-spec repo, we'll move it soonish
15:10:30 <tmorin> #action move API spec from neutro-specs repo to networking-bgpvpn repo
15:10:49 <timirnich> I guess we will be able to continue Gerrit review also after the move?
15:11:05 <tmorin> yes, the move will be a new gerrit change
15:11:17 <timirnich> +1
15:11:45 <matrohon> I hope we can keep the gerrit change-id and only change the project
15:12:11 <tmorin> that would be nice, but I'm not sure how to do this
15:12:21 <matrohon> in order to keep discussion occured on the current gerrit stream
15:12:29 <tmorin> simply making a commit in networking-bgpvpn and reusing the change id ? would that work ?
15:12:34 <matrohon> I'll investigate
15:12:48 <Vikram> otherwise we can abondon the current and mention new review link
15:12:51 <tmorin> if we can't we can still link to the previous change.
15:12:56 <tmorin> Vikram: yes
15:13:09 <tmorin> #topic work items
15:13:58 <tmorin> let's go through work items
15:14:20 <tmorin> "tmorin to     move spec rst into networking-bgpvpn/doc" --> just discussed
15:14:29 <tmorin> "tmorin to     investigate unit test coverage to db persistency"
15:14:33 <Vikram> Sorry, I couldn't proceed on my part as I was on PTO. Will start this week
15:14:46 <tmorin> I had some time to work on these db unit test
15:14:57 <tmorin> I've pushed a change yesterday
15:15:11 <tmorin> #link https://review.openstack.org/194190
15:15:25 <tmorin> this is a reasonable starting point
15:15:41 <matrohon> +1
15:15:42 <tmorin> it will have to be enriched after we do the API changes
15:16:15 <tmorin> "svinota to work on DB mappings and RD (mostly done)"
15:16:24 <matrohon> I'll investigate how to run UT coverage with tox
15:16:48 <tmorin> svinota joined to me earlier today, and told me he was actually starting to work on it
15:17:11 <tmorin> firts the DB part, then the adaptation in the bagpipe driver so that it will also support specification of the RD
15:18:02 <tmorin> mathieu: ok, is there something missing in the current tox config ?
15:19:05 <tmorin> the current config is already starting the existing unit tests, and the ones I added
15:19:07 <matrohon> I'm not sure, I'll dig into other project (at least neutron) since they are able to have test coverage figure with ./run-tset.sh --coverage
15:19:12 <tmorin> see e.g. http://logs.openstack.org/90/194190/2/check/gate-networking-bgpvpn-python27/8b11226/console.html
15:19:50 <tmorin> correct, coverage info we don't have yet
15:20:12 <tmorin> #action matrohon to investigate unit test tox setup
15:20:26 <tmorin> action item: "vikram to     update  python-neutronclient code"
15:20:31 <Vikram> Sorry, I couldn't proceed on my part as I was on PTO. Will start this week
15:20:35 <tmorin> yes
15:20:37 <tmorin> understood
15:20:44 <Vikram> thanks
15:20:46 <tmorin> #action vikram to update  python-neutronclient code
15:20:53 <tmorin> (to keep it for next time)
15:21:55 <tmorin> have you an idea if you'll work on it before next meeting ?
15:22:05 <Vikram> yes i will finish it
15:22:13 <Vikram> ;)
15:22:30 <tmorin> ok, good :)
15:22:38 <tmorin> I think we're done with action items
15:23:01 <Vikram> can you get me the review link for RD DB changes
15:23:13 <Vikram> so that I can design the CLI accordingly
15:23:39 <tmorin> there is no gerrit change yet for the new code for RDs
15:23:44 <tmorin> svinota is working on it
15:23:45 <Vikram> ok..
15:24:01 <Vikram> i will discuss with svinota
15:24:03 <tmorin> I think you should be able to design the API based on the API spec
15:24:06 <matrohon> Vikram : I don't think it's already under review
15:24:17 <Vikram> ok
15:24:25 <tmorin> #link https://review.openstack.org/177740
15:25:04 <matrohon> I'll wait for the main spec contributors to agree on the split of the API, and create corresponding blueprint
15:25:04 <tmorin> the RD field in the DB is just a string of coma separated values
15:25:05 <matrohon> so that anyone interested can start coding the change
15:25:38 <Vikram> ok got it
15:25:40 <tmorin> code for lists of RTs will provide a useful example for what needs to be done for RDs
15:25:58 <tmorin> this is independent from other API change on how to associate BGP VPNs to networks
15:26:20 <tmorin> Vikram, are you also planning to work on API changes on how to associate BGP VPNs to networks before next meeting ?
15:26:41 <matrohon> however RD are optionals, and so depends on the backend, which has to support it
15:26:52 <matrohon> we have to had this optional framework
15:27:00 <matrohon> had--> add
15:27:19 <Vikram> pythonclient changes i can finish
15:27:36 <Vikram> API changes i can't promise
15:27:55 <tmorin> yes, contrarily to RTs, specifying RDs will have to fail if the backend does not support it
15:28:26 <tmorin> anyways, svinota is planning to do the server-side APi work on RD changes
15:28:32 <Vikram> how we are ensuring the backend support?
15:28:45 <tmorin> Vikram you can focus on python API client code
15:28:49 <Vikram> ok
15:29:24 <tmorin> Vikram: we are not ensuring that, if the backend does not support it, specifying a non empty list of RDs will fail
15:29:43 <Vikram> hmmm..
15:29:59 <Vikram> sounds good
15:31:08 <tmorin> ok, who could plan working on server-side API changes for the BGPVPN/association split ?
15:32:11 <tmorin> ok, we'll see
15:32:44 <tmorin> #topic driver status
15:33:05 * tmorin will have to leave in 5 minutes
15:33:27 <tmorin> on the bagpipe-bgp driver, the status is that it is ready
15:33:37 <tmorin> but not yet adapted to the changes we decided
15:33:47 <tmorin> svinota is planning to add RD support to it
15:34:15 <tmorin> supporting association with routers will be a possible addition
15:34:22 <tmorin> but we haven't prioritized that yet
15:34:28 <tmorin> opinion/volunteers welcome
15:34:31 <tmorin> ...
15:34:37 <tmorin> any update on other drivers ?
15:34:47 <tmorin> maybe on ODL? (timirnich?)
15:35:00 <timirnich> Nothing on ODL unfortunately but I'm working on getting it started
15:35:16 <tmorin> ok, still good to know :)
15:35:58 <timirnich> some difficulties with getting hold of the right people due to holiday season starting
15:36:15 <tmorin> yes, Liberty timeline is hard in this respect
15:36:29 <tmorin> diego not here, we're unlikely to have an update on nuage side
15:36:36 <tmorin> I'll try to get him offline later
15:36:44 <tmorin> any other topic for today ?
15:38:17 <tmorin> ok, if no then we're done
15:38:30 <tmorin> we were just saying we were done
15:38:33 <tmorin> I have to leave
15:38:42 <tmorin> but feel free to pursue the discussion
15:38:52 <tmorin> I'll let you do the endmeeting
15:39:40 <timirnich> i don't have anything in addition
15:40:00 <tmorin> I have to do the endmeeting myself
15:40:07 <tmorin> bye everyone
15:40:11 <Vikram> bye
15:40:13 <timirnich> bye all
15:40:15 <tmorin> #endmeeting