15:05:35 <matrohon> #startmeeting bgpvpn
15:05:37 <openstack> Meeting started Tue Aug  4 15:05:35 2015 UTC and is due to finish in 60 minutes.  The chair is matrohon. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:05:40 <openstack> The meeting name has been set to 'bgpvpn'
15:06:34 <matrohon> ok so no bing annoucement for me today, except taht I'm going to chair the meeting since tmorin is in vacation for 3 weeks
15:07:44 <matrohon> we decided to keep the spec under the neutron-spec repo untill we have our first release
15:08:39 <matrohon> we will move the spec to the bgpvpn repo and we will update it according to what is shipped with the first release
15:08:40 <svinota> hi all
15:08:46 <matrohon> hi svinota
15:09:24 <matrohon> pcarver, svinota : any announcement ?
15:09:36 <svinota> nope.
15:10:09 <pcarver> nothing from me. I think I've reviewed everything I'm aware of.
15:10:51 <matrohon> #info : the implementation of the opencontrail driver has begun : https://review.openstack.org/#/c/202806/
15:11:25 <matrohon> #undo
15:11:25 <openstack> Removing item from minutes: <ircmeeting.items.Info object at 0xa46fe10>
15:11:46 <matrohon> #topic announcement
15:11:58 <matrohon> #info : the implementation of the opencontrail driver has begun : https://review.openstack.org/#/c/202806/
15:12:40 <matrohon> #info : tmorin has started to introduce a policy.json for bgpvpn : https://review.openstack.org/#/c/207914/
15:13:38 <matrohon> #info : matrohon is working on the API split : https://review.openstack.org/#/c/207371/
15:14:34 <matrohon> #info : svinota is working od RD attribute addition : https://review.openstack.org/#/c/206536/
15:14:57 <matrohon> can we discuss this attribute here svinota?
15:15:09 <svinota> matrohon, yep
15:15:23 <matrohon> #topic RD Attribute
15:16:09 <matrohon> so as I reviewed, I'm concerned since not every driver will support this attribute
15:16:30 <svinota> yep. And thus the driver can ignore it
15:17:24 <matrohon> this gone lead to an unexpected behavior if the user specifies a RD : the driver won't use it but the end user expect the driver to use it
15:18:06 <svinota> so we have a simple choice
15:18:31 <svinota> either to raise an exception, or to have a capabilities discovery + exception
15:19:33 <matrohon> the capabilities discovery seems cleaner and such a framework already exists : it is the extension framework
15:19:34 <svinota> the exception is required anyway, since the user (or UI) may ignore the discovery, if I understand this correctly
15:20:32 <matrohon> I think the exception framework will automatically generate an exception if the user want to use an attribute extension that is not supported by the implementation
15:20:46 <svinota> matrohon, so then I'm to implement the discovery
15:21:00 <svinota> should not be too hard, I hope
15:21:09 <matrohon> cool
15:21:48 <matrohon> I don't think it's very hard, we can look at that together
15:22:30 <matrohon> it's just an extension of the bgpvpnconnection object
15:22:41 <svinota> ok, thanks
15:23:10 <svinota> I will try to do it and submit to review.
15:23:35 <matrohon> #action : svinoto to work on an extension concerning the RD attribute
15:23:43 <matrohon> #undo
15:23:44 <openstack> Removing item from minutes: <ircmeeting.items.Action object at 0xa245050>
15:23:48 <matrohon> #action : svinota to work on an extension concerning the RD attribute
15:25:20 <matrohon> this kind of attribute extension may also be used to scan the "technique" parameter
15:26:02 <matrohon> not sure if it's a good idea, but this option is also backend dependent
15:27:13 <matrohon> we'll see once the RD attribute extension will exist
15:27:46 <matrohon> we gone have a better idea of what is possible with the attribute extensions framework
15:28:24 <matrohon> #topic Tests
15:28:48 <matrohon> I really want to improve the test coverage of the bgpvpn code
15:29:12 <matrohon> this will help debugging and CI
15:29:59 <matrohon> I'm trying to learn from existing project (vpnaas, etc...) but the unit test framework in neutron is quite tricky
15:30:32 <matrohon> #action : matrohon to work on test coverage improvment
15:31:26 <matrohon> #topic open discussion
15:31:45 <matrohon> anybody wants to discuss something about bgpvpn
15:31:50 <matrohon> ?
15:32:52 <matrohon> ok, pcarver, svinota, thanks for attending the meeting
15:33:07 <matrohon> #endmeeting