15:09:16 <matrohon> #startmeeting bgpvpn
15:09:17 <openstack> Meeting started Tue Feb  2 15:09:16 2016 UTC and is due to finish in 60 minutes.  The chair is matrohon. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:09:18 <timirnich> We might recap briefly on the discussions we had yesterday on OPNFV C release and its bearing on BGPVPN
15:09:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:09:21 <openstack> The meeting name has been set to 'bgpvpn'
15:09:28 <tmorin> timirnich: you will have to receive the "thank you" for him !  ;)
15:09:39 <timirnich> Sure I'll pass that on
15:09:41 <matrohon> #topic heat plugin
15:09:52 <tmorin> #link https://review.openstack.org/#/c/274089/
15:09:54 <matrohon> so the heat plugin is up for review
15:10:19 <tmorin> so, enicker/timirnich thank you for this contribution  !
15:10:22 <matrohon> does it livein the backport/kilo branch on purpose?
15:10:32 <tmorin> I don't think so
15:10:51 <timirnich> Niko developed it for a Kilo deployment we are supporting, that is why
15:11:03 <matrohon> timirnich, understood
15:11:07 <tmorin> but there is I think nothing kilo-specific in the code
15:11:12 <timirnich> I think lifting it up to Liberty is a quick one
15:11:13 <tmorin> nikolas mentioned that yestreday
15:11:17 <tmorin> yes
15:11:30 <matrohon> timirnich, however we have to follow common practices : first merge in the master, then backport
15:11:34 <tmorin> +1
15:11:36 <timirnich> np
15:11:47 <tmorin> next topic ?
15:11:53 <tmorin> #topic mitaka
15:11:53 <timirnich> Haven't talked to Niko but I think he'll do that asap
15:11:56 <matrohon> timirnich, and of course many thanks for this work
15:12:13 <matrohon> #topic mitaka
15:12:39 <tmorin> I've been going through a few patches to have the code work on mitaka
15:12:50 <tmorin> nothing complex
15:12:56 <matrohon> tmorin, thanks
15:12:59 <tmorin> only minor things in the bagpipe driver
15:13:18 <tmorin> I'm working in parallel to adapt the agent to the L2 agent api
15:13:53 <tmorin> following the work done one the new API, be ready to commit the BGPVPN specific stuff when the rest is ready, and then use it to make the extension
15:14:04 <tmorin> #link https://review.openstack.org/#/c/267591/
15:14:30 <tmorin> we have to follow that closely to make sure we can have a clean agent for mitaka
15:14:54 <matrohon> tmorin, it looks like a good plan
15:15:19 <tmorin> anything else to discuss today ?
15:15:33 <matrohon> timirnich, you wanted to talk about opnfv?
15:16:33 <timirnich> yeah just to mention that one thing we plan there is to consume developments in BGPVPN
15:17:02 <timirnich> I would like to understand the planned releases
15:17:22 <timirnich> I guess we'll make one release to uplift to Mitaka - will that contain functional additions?
15:17:55 <matrohon> timirnich, I would say it's up to us!
15:17:57 <timirnich> Maybe it would be good to do something like a roadmap in case that doesn't exist yet
15:18:26 <tmorin> yes
15:18:33 <timirnich> matrohon: Are there any candidate additions?
15:18:43 <matrohon> timirnich, make sense but what kind of feature do you need first?
15:19:05 <tmorin> as soon as we identify the useful addition, we can track them as RFE bugs
15:19:12 <matrohon> timirnich, there are things to do that was in the initial sepc
15:19:13 <timirnich> Hm, currently there are no officially identified requirements from OPNFV point of view
15:19:15 <tmorin> that would be where the roadmap would be maintained
15:19:57 <matrohon> tmorin, +1, it would be consistent with the neutron way to manage features
15:20:10 <timirnich> I know that ODL intends to add EVPN/L2VPN support so getting that into BGPVPN (not sure how much is left to do) would be one useful addition
15:21:08 <matrohon> timirnich, make sense, bagpipe and contrail should be compatible with the evpn approach
15:22:22 <tmorin> timirnich: not much is needed, most of the Api/framework/DB code is already ready I think
15:22:28 <tmorin> the only thing left is driver/backend
15:23:01 <matrohon> timirnich, there are already some specs on the table about port assoc and static routes, does it have a weaker priority to you?
15:23:15 <timirnich> It's probably worth mentioning that OPNFV will meet 3rd wk March to plan C Release - that is when we need visibility on planned BGPVPN release dates and content, as far as possible
15:23:18 <tmorin> the bagpipe driver does not address E-VPN yet, because bagpipe-bgp hasn't been augmented yet to do E-VPN with OVS
15:23:29 <timirnich> matrohon, no those things are important too
15:23:42 <timirnich> but I think they are comparably small
15:24:04 <tmorin> timirnich: yes, it will be good to have visibility at least at that date in Mach
15:24:21 <matrohon> evpn topic is part of the sdnvpn project?
15:24:40 <tmorin> timirnich: alhough I'll help and review, I think your contributions will be key to move forward the static route evolutions
15:24:41 <timirnich> it depends if we get E2E support in our upstream dependencies
15:25:10 <timirnich> tmoring, that is fine we're prepared to do that
15:26:10 <matrohon> timirnich, tmorin we have to report a RFE bug for evpn support in bgpvpn
15:27:34 <timirnich> +1
15:27:47 <tmorin> +1
15:28:21 <matrohon> #action : matrohon to report a rfe bug in bgpvpn about evpn
15:29:03 <matrohon> doude : do you think that contrail can easily support evpn instantiation?
15:29:13 <timirnich> folks I need to drop out  - sorry can't stay for the full hour today. I'll try to make a step forward on the OPNFV C release planning for Monday
15:29:29 <matrohon> timirnich, np, have a good day
15:29:35 <timirnich> u 2
15:29:51 <doude> matrohon: I don't know
15:30:28 <matrohon> anything else to discuss?
15:31:48 <matrohon> ok let's close the meeting
15:31:51 <matrohon> thanks
15:31:56 <matrohon> #endmeeting