15:03:02 <pafuent> #startmeeting blazar
15:03:03 <openstack> Meeting started Fri Jun 6 15:03:02 2014 UTC and is due to finish in 60 minutes. The chair is pafuent. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
15:03:06 <openstack> The meeting name has been set to 'blazar'
15:03:32 <pafuent> Agenda: https://wiki.openstack.org/wiki/Meetings/Blazar
15:04:48 <cmart> o/
15:05:03 <pafuent> o/
15:05:20 <mspreitz> here
15:07:31 <bauzas> o/
15:07:43 <bauzas> (sorry, was around)
15:08:01 <Nikolay_St> o/
15:08:45 <pafuent> Ok, so let's start
15:08:56 <pafuent> #topic Action items from the last meeting + reviews queries
15:09:42 <pafuent> bauzas and I have the action of define a strategy for the renaming
15:09:45 <bauzas> yey
15:10:02 <bauzas> sorry, was really busy this week due to juno-1 closing
15:10:15 <pafuent> bauzas: No problem
15:10:18 <pafuent> I managed to get a PoC to achieve that
15:10:18 <bauzas> but I saw your pings
15:10:24 <bauzas> great
15:10:33 <bauzas> I see you make use of aliases ?
15:10:45 <bauzas> any PR we could review ?
15:11:15 <pafuent> No, because I want to check with you first, but I could submit some patches to review
15:11:44 <pafuent> The great thing is that we will do the renaming in small patches if we want
15:11:55 <bauzas> pafuent: ok, then let's postpone this task next week
15:12:08 <pafuent> The alias let us to have imports from climate and blazar mixed
15:12:13 <bauzas> but a PR would be helpful
15:12:17 <bauzas> mark it as WIP
15:12:27 <pafuent> bauzas: PR?
15:12:30 <bauzas> a patch
15:12:35 <pafuent> OK
15:12:45 <bauzas> propose a patch, and I'll review it
15:13:02 <bauzas> I'll have very limited access to Internet next week, as I'll be traveling
15:13:18 <pafuent> #action pafuent propose patches for renaming Climate to Blazar
15:13:19 <bauzas> so, that would be great if I could async the review :)
15:13:30 <Nikolay_St> pafuent, bauzas I can help you with review
15:13:34 <bauzas> flag it as WIP for convenience
15:13:42 <bauzas> Nikolay_St: your help is welcome
15:13:46 <pafuent> Nikolay_St: That would be great
15:13:49 <bauzas> hence the patch
15:13:58 <bauzas> so anyone can give his views
15:14:32 <pafuent> Ok, regarding pending reviews
15:14:52 <pafuent> T
15:14:55 <pafuent> Sorry
15:15:22 <pafuent> I have some patches that needs review
15:15:23 <bauzas> yey ?
15:15:57 <Nikolay_St> pafuent: I see them, but was busy. I'll be back to them asap
15:16:13 <pafuent> Nikolay_St: Thanks
15:17:10 <pafuent> Some of that patches are related to agenda items so, if you are OK we can move to the next topic
15:17:30 <Nikolay_St> +
15:17:53 <pafuent> #topic Tempest running on gate jobs status
15:18:12 <bauzas> ok
15:18:18 <pafuent> I think that we really need this in place before we start renaming things on the code
15:18:44 <pafuent> For that reason, I fixed the tests here https://review.openstack.org/#/c/98225/
15:19:20 <pafuent> When that patch is merged, I'll enable Tempest in our gate job
15:19:49 <bauzas> pafuent: cool
15:20:01 <bauzas> pafuent: so I assume this is a top prio patch ?
15:20:04 <bauzas> to review ?
15:20:09 <Nikolay_St> pafuent: how can we prove that it really works?
15:20:13 <pafuent> bauzas: Yes
15:20:44 <pafuent> cmart Wrote a RST that explains how to run the test in Tempest
15:20:47 <bauzas> Nikolay_St: you can run Tempest on your devstack
15:20:58 <bauzas> Nikolay_St: that's really simple
15:21:03 <pafuent> https://github.com/stackforge/blazar/blob/master/contrib/tempest/README.rst
15:21:12 <bauzas> Nikolay_St: like running a tox test with testr
15:21:16 <cmart> Nikolay_St:: probably by following the RST and then running tempest on your dev environment
15:21:26 <bauzas> Nikolay_St: actually testr is used by Tempest
15:21:28 <cmart> bauzas: exactly
15:21:52 <Nikolay_St> oh
15:22:00 <bauzas> Nikolay_St: so the idea is to land the patch on your local Tempest env
15:22:04 <Nikolay_St> sorry, miss this point.
15:22:17 <Nikolay_St> bauzas: yeap, I get it now
15:22:20 <bauzas> Nikolay_St: just make sure you enabled Tempest as a devstack service
15:22:23 <pafuent> bauzas: Yes, that is the idea
15:23:10 <pafuent> BTW, the patch only update some things that changed in Tempest since cmart wrote the tests
15:23:47 <bauzas> pafuent: ok, good to know
15:23:51 <cmart> pafuent: yes. Before end lease events were not there at the time I wrote those tests.
15:24:09 <pafuent> cmart: Yep
15:24:14 <bauzas> pafuent: I'm just wondering if that patch should not be in the tempest repo directly
15:24:15 <cmart> pafuent: could you please put the review link so I can take a look?
15:24:22 <bauzas> in contib/ of course
15:24:42 <cmart> bauzas: it should be there. pafuent?
15:24:48 <pafuent> https://review.openstack.org/#/c/98225/
15:25:04 <pafuent> cmart: bauzas: Sorry, I miss the point
15:25:12 <cmart> pafuent: thanks..
15:25:33 <bauzas> I can see the patch in our repo
15:25:43 <cmart> pafuent: what bauzas is saying that the code is inside the contrib folder
15:25:57 <cmart> *should be inside
15:26:10 <pafuent> cmart: Ahh. OK
15:26:19 <bauzas> yey
15:26:20 <pafuent> Yes the code is in our contrib
15:27:01 <bauzas> no let me explain
15:27:17 <bauzas> directly in the tempest repo under contrib/
15:28:24 <pafuent> bauzas: I can't find that directory in Tempest repo
15:29:01 <bauzas> pafuent: ah ok, my bad then
15:29:08 <bauzas> anyway
15:30:11 <cmart> bauzas: Since Blazar is in incubation, we should code our stuff separately. When Blazar "graduates" and moves to core, then the contrib/tempest folder of our code shoould be adapted to what tempest has.
15:30:28 <cmart> at least, it's what I was being told back then :)
15:30:32 <bauzas> cmart: Blazar is *not* in incubation
15:30:35 <bauzas> :)
15:30:54 <bauzas> cmart: Blazar asked for but we will have to propose again :)
15:30:55 <bauzas> anyway
15:31:05 <bauzas> maybe we can move on ?
15:31:08 <pafuent> OK. Regarding the next topic (Climate -> Blazar renaming status), I think we already covered that so we can skip to the next one.
15:31:11 <cmart> bauzas: sorry! Let's move on then:)
15:31:27 <pafuent> #topic Keystoneclient bug (a new one)
15:31:36 <pafuent> https://review.openstack.org/97565
15:31:59 <pafuent> https://bugs.launchpad.net/blazar/+bug/1326066
15:32:00 <uvirtbot> Launchpad bug 1326066 in blazar "Keystone client fails to authorize during trust creation" [Critical,In progress]
15:32:44 <bauzas> ok, as per the tests, it fixes the problem
15:32:49 <bauzas> I'll +2 it
15:33:05 <pafuent> OK
15:33:29 <pafuent> Nikolay_St: Could you review the bug too?
15:34:22 <Nikolay_St> pafuent: done.
15:34:29 <pafuent> Nikolay_St: Thanks
15:34:36 <pafuent> #topic Blueprints status
15:34:54 <pafuent> I think there are some BP that are finished
15:35:13 <bauzas> let's discuss with DinaBelova about that topic next week
15:35:31 <bauzas> and see if we can consider a new release
15:35:37 <pafuent> OK.
15:35:52 <bauzas> I would wait for Tempest tests and use of trusts in PR to be landed
15:35:55 <bauzas> IMHO
15:36:11 <bauzas> ideally, client for V2 should be there
15:36:21 <bauzas> because if not, V2 has non-sense
15:36:31 <pafuent> That is true
15:36:52 <pafuent> Regarding the trust in PR, I need some core love there
15:36:53 <bauzas> the good thing is that all the patches are there
15:37:00 <Nikolay_St> bauzas: +1
15:37:03 <bauzas> yey, we're missing time :(
15:37:24 <pafuent> I know
15:37:39 <Nikolay_St> bauzas: I'll try to do as much review as I can on weekend. it may solve some problems, I guess
15:38:10 <bauzas> Nikolay_St: nah, no need to urge
15:38:22 <bauzas> Nikolay_St: we're not following Openstack milestones
15:38:28 <bauzas> (yet)
15:38:40 <pafuent> I like the (yet)
15:38:54 <pafuent> Nikolay_St: Please, rest during the weekend
15:39:05 <pafuent> Nikolay_St: :)
15:39:14 <Nikolay_St> bauzas: it's more promise for myself - I know that I'll have time on weekend, and not sure I have it during next week :D
15:39:49 <bauzas> :)
15:39:54 <pafuent> Regarding the V2 on the client, I'll start working on the api version discovery
15:40:02 <bauzas> pafuent: cool great news
15:40:07 <pafuent> https://blueprints.launchpad.net/blazar/+spec/api-version-discovery
15:40:12 <bauzas> awesome
15:40:17 <pafuent> I wrote some examples of other OS projects
15:40:29 <bauzas> cool
15:40:53 <pafuent> So the idea is to look how the do this magic and choose one
15:40:57 * bauzas thinking he has another thing to review... :)
15:41:06 <pafuent> hahaha
15:41:22 <bauzas> ok, that' really cool
15:41:35 <bauzas> ok can we go to opens ?
15:41:43 <bauzas> (I have very limited time left :)
15:41:45 <pafuent> For me, it's OK
15:41:50 <Nikolay_St> +
15:42:01 <pafuent> #topic Open discussion
15:42:19 <cmart> I think that we should start thinking on how to atract more devs to the project
15:42:34 <Nikolay_St> I have thing to discuss in this topic
15:42:39 <pafuent> cmart: +1
15:42:41 <cmart> "atract" not in a sexy-way. I mean.. you kno..
15:42:46 <cmart> *know.
15:42:52 <pafuent> :)
15:43:03 <bauzas> cmart: there is no magic over there :)
15:43:06 <Nikolay_St> cmart: just let use violence :D
15:43:12 <mspreitz> I am not well prepared but would be willing to talk about how my simultaneous scheduling stuff could use Blazar
15:43:22 <cmart> Nikolay_St: LOL
15:43:37 <bauzas> mspreitz: that's something we should discuss on a mailing thread
15:43:43 <mspreitz> OK
15:43:49 <bauzas> mspreitz: that's something manageable
15:44:03 <bauzas> mspreitz: I was at the design session, I have some ideas for you
15:44:19 <mspreitz> Great. I'll start a thread.
15:44:24 <bauzas> mspreitz: cool
15:44:25 <Nikolay_St> I would like to ask question about neutron object reservation.
15:44:39 <bauzas> mspreitz: the ideal is to put use cases
15:44:51 <bauzas> mspreitz: and see what are the missing bits
15:45:04 <mspreitz> yes, good approach
15:45:06 <bauzas> folks I got to go in 2 mins
15:45:13 <Nikolay_St> we have a little conversation with pafuent this week, but haven't any success.
15:45:18 <bauzas> yes ?
15:45:30 <mspreitz> BTW, where would I find a description of the new Blazar API?
15:45:35 <bauzas> Nikolay_St: I'm not that used to Neutron code
15:45:52 <bauzas> mspreitz: grab the code and issue a tox -edocs
15:45:57 <Nikolay_St> bauzas: can't parse this :(
15:45:58 <mspreitz> thanks
15:46:23 <bauzas> mspreitz: we have to put the docs in readthedocs but we had a naming problem, hence the renaming
15:46:41 <bauzas> mspreitz: and API doc is not very suitable for wikis
15:46:50 <mspreitz> got it
15:47:07 <bauzas> Nikolay_St: I mean, I don't exactly know how is Neutron made
15:47:21 <mspreitz> from three quarks?
15:47:22 <bauzas> Nikolay_St: first of all what do we want to reserve ?
15:47:34 <bauzas> mspreitz: good catch ;à
15:47:48 <bauzas> Nikolay_St: do we want to reserve ports or routers ?
15:47:58 <Nikolay_St> bauzas: close to dev-list neutron-guys have some thoughts about fixed-ip reservations.
15:48:05 <bauzas> cool
15:48:16 <pafuent> Floating IP could be interesting too
15:48:18 <bauzas> I have to go folks, I'm really sorry
15:48:23 <Nikolay_St> bauzas: and it is the good point for us to be involved
15:48:32 <Nikolay_St> so
15:48:36 <pafuent> bauzas: NP
15:49:07 <Nikolay_St> pafuent: should we continue discussion or it be better to start dev-list thread about it?
15:49:48 <pafuent> Nikolay_St: The thread will be better. Maybe we can catch the attention of dina and swann
15:49:57 <Nikolay_St> pafuent: yeah
15:50:06 <cmart> +1 to dev-list. bauzas already know about this and it could be great to have more Neutron feedback
15:50:08 <Nikolay_St> pafuent: my message was a little bit longer :D
15:50:09 <cmart> pafuent: +1
15:50:45 <pafuent> Nikolay_St: Sorry I didn't get the last sentence
15:50:55 <Nikolay_St> so, I haven't any topics to discuss
15:51:10 <pafuent> Me neither
15:51:16 <pafuent> cmart?
15:51:17 <cmart> I'll think about violence
15:51:24 <pafuent> hahaha
15:51:27 <cmart> towards Blazar "greatness"
15:51:42 <cmart> :D
15:52:04 <cmart> any help (and fists) will be appreciated
15:52:24 <Nikolay_St> pafuent: I have something like "Maybe we can catch the attention of dina and swann" but it was hard to type :D
15:52:57 <Nikolay_St> cmart: violence is beautiful :D you can use at most developers ;)
15:52:59 <cmart> Nikolay_St: take your time :)
15:53:13 <pafuent> LOL
15:53:18 <Nikolay_St> so, I think we can end the meeting
15:53:22 <pafuent> Yes
15:53:25 <pafuent> Bye
15:53:28 <Nikolay_St> bye
15:53:39 * cmart says "chao"
15:53:46 <pafuent> #endmeeting