09:00:00 <priteau> #startmeeting blazar
09:00:01 <openstack> Meeting started Tue Dec 20 09:00:00 2016 UTC and is due to finish in 60 minutes.  The chair is priteau. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:05 <openstack> The meeting name has been set to 'blazar'
09:00:23 <priteau> #chair masahito
09:00:23 <openstack> Current chairs: masahito priteau
09:00:37 <priteau> Hello
09:00:47 <masahito> hello
09:01:03 <bertys> Hi
09:01:16 <priteau> #topic Roll call
09:01:44 <GeraldK> hi
09:02:22 <masahito> hi
09:02:29 <priteau> pinging bauzas tejaswi janki
09:02:49 <masahito> hkobayashi told me he is out of town this week.
09:02:59 <priteau> OK
09:03:01 <GeraldK> bertys and I are in a parallel meeting today. sorry, we will mainly listen today.
09:03:12 <priteau> r-mibu is on #openstack-blazar but not here
09:03:26 <priteau> anyone else?
09:04:32 <tejaswi> hi
09:04:36 <priteau> Hi tejaswi
09:05:00 <GeraldK> can you pls post the link to the agenda
09:05:09 <priteau> #link https://wiki.openstack.org/wiki/Meetings/Blazar#Agenda_for_December_20_2016
09:05:18 <GeraldK> priteau: thanks
09:05:24 <priteau> this is our agenda for today
09:05:50 <priteau> Let's get started then
09:05:55 <priteau> #topic Action items from last call
09:06:20 <priteau> "Generate WSME doc for v2 API and check for differences with v1"
09:06:29 <priteau> this was assigned to me
09:06:59 <priteau> The WSME doc is generated with tox -e docs, and on each commit
09:07:10 <priteau> e.g. http://docs-draft.openstack.org/66/406666/7/check/gate-blazar-docs-ubuntu-xenial/5ddde5e//doc/build/html/restapi/rest_api_v2.html
09:07:19 <bauzas> yeah
09:07:25 <priteau> while v1 is here: http://docs-draft.openstack.org/66/406666/7/check/gate-blazar-docs-ubuntu-xenial/5ddde5e//doc/build/html/restapi/rest_api_v1.0.html
09:07:38 <bauzas> (sorry, I'm on a gate issue, very unlikely to be present here)
09:07:48 <priteau> bauzas: no problem, thanks
09:07:59 <priteau> I looked at the differences between the REST APIs
09:08:24 <priteau> Just using the doc, I didn't have time to verify data sent on the wire
09:08:32 <priteau> I identified these differences
09:08:39 <priteau> V2: adds support for CRUD operations on "Before end" notifications (before_end_notification field in lease object)
09:08:39 <priteau> v2: host extra capabilities may be handled differently: extra_capas in host object
09:08:39 <priteau> v2: PUT requests have the ID as a parameter rather than in the URL?
09:09:30 <priteau> The last one was unexpected
09:10:00 <priteau> but overall not huge differences
09:10:37 <masahito> it looks like there is only style difference.
09:11:00 <priteau> and actually the last one I need to verify it in the code
09:11:47 <priteau> Next step is to identify what was missing from client v2 patches
09:11:49 <masahito> DELETE also doesn't have id in url, right?
09:12:27 <priteau> masahito: you're right. I wonder if that's a doc issue though
09:12:46 <masahito> I hope so :)
09:13:23 <priteau> #action Verify where id is provided in PUT and DELETE requests for v2 API (priteau)
09:14:24 <priteau> I believe we agreed that we would keep support for v1 API in the next Blazar release
09:15:10 <priteau> If we can trust that v2 is working well and have it supported in the client, we could mark v1 as deprecated for this release
09:15:15 <masahito> yes.
09:15:35 <priteau> the goal being to minimize the amount of code to maintain
09:15:58 <priteau> but I think at some point we will need a new API, probably with microversions
09:16:05 <priteau> to support our new features
09:16:19 <priteau> This brings us to the second action item
09:16:22 <priteau> "investigate microversion support for Blazar API"
09:16:51 <priteau> No one was assigned to this. I thought I could work on it but I didn't have much time for Blazar this past week.
09:17:24 <priteau> Unless someone else has looked into it, I will reregister it
09:17:32 <masahito> we should write down it in priorities after Ocata release
09:17:52 <priteau> masahito: that's a good point
09:18:20 <priteau> I added it at the end of our etherpad
09:18:40 <masahito> we need to choose which version have microversioning, too.
09:18:49 <masahito> like v1.1 or v2.1
09:18:59 <priteau> v2.1 like Nova? ;-)
09:19:19 <masahito> :->
09:19:41 <priteau> We will revisit later then
09:19:49 <priteau> Third item was "masahito translates Promise requirement to blazar feature"
09:19:55 <masahito> but some of us is absent here to discuss it now. let's keep it mind.
09:20:29 <masahito> I'm still working on the item. sorry, not yet done.
09:20:39 <priteau> no problem
09:20:51 <masahito> I try to finish it by next meeting.
09:21:00 <priteau> That's all for last week's action items
09:21:10 <priteau> #topic Feedback on Project Teams Gathering (PTG)
09:21:33 <priteau> masahito: I saw that you sent the email to openstack-dev. Did you get any feedback?
09:22:26 <masahito> Unfortunately, I don't receive any feedback.
09:23:01 <GeraldK> sorry. it is still undecided on our side whether one of us can join
09:23:18 <GeraldK> I hope we can decide on this mid January
09:23:42 <priteau> same for me, it will be clearer next month
09:24:05 <masahito> no problem.
09:25:18 <masahito> I'll be there to join another team meeting. so if we are there, we can meet.
09:25:24 <priteau> OK
09:25:38 <masahito> but I'm not forcing it.
09:26:14 <priteau> And who is planning to be in Boston?
09:26:24 <priteau> I will likely be there
09:27:22 <GeraldK> It's very likely one of us will be there
09:27:23 <masahito> I maybe there
09:28:05 <priteau> For those who can't make the PTG that's another opportunity to meet
09:28:14 <priteau> 2.5 months later
09:28:31 <masahito> good idea
09:29:27 <priteau> Should we skip the next topic? "User story and gap analysis"
09:29:43 <priteau> If it's not ready for discussion
09:29:54 <masahito> somehow, it's good to meet together.
09:30:03 <masahito> nothing from my side for PTG
09:30:33 <r-mibu> I'll join PTG, i havn't get approval yet though
09:32:23 <priteau> Hi r-mibu
09:32:25 <GeraldK> related to the user story: I have drafted a OpenStack persona
09:32:30 <GeraldK> your feedback is welcome on it
09:32:34 <priteau> #topic User story and gap analysis
09:32:39 <GeraldK> #link https://etherpad.openstack.org/p/osux-persona-nocengineer Draft NOC engineer proposal
09:33:01 <priteau> That's great GeraldK
09:33:21 <GeraldK> at the end there is a part that we'd like to propose for the user story update
09:34:38 <priteau> #action Review capacity management use case https://etherpad.openstack.org/p/osux-persona-nocengineer
09:35:52 <priteau> GeraldK: it looks quite detailed, thanks for contributing this
09:37:43 <priteau> Anything else for use cases?
09:38:19 <r-mibu> GeraldK: just quick question
09:38:39 <r-mibu> GeraldK: are you going to add reservation use case into that etherpad page?
09:39:16 <GeraldK> r-mibu: not sure what you mean?
09:39:52 <priteau> r-mibu: make sure you scroll down in the etherpad, there is more content after "The organizational models"
09:39:53 <GeraldK> r-mibu: at the end of the etherpad you have a list of reservation usage examples
09:39:56 <r-mibu> i mean 'key tasks' seems not include reservation use cases
09:40:18 <r-mibu> i see, sorry!
09:40:31 <GeraldK> r-mibu: good point. I may be more specific in the key tasks on reservation
09:40:59 <r-mibu> that includes enough detail! thanks!
09:42:07 <GeraldK> i am not sure about the content for some sections. need feedback from UX team
09:42:38 <GeraldK> this is partically independent from the update to the user story
09:43:00 <GeraldK> we can do the update to the user story even if the NOC engineer persona is not there yet.
09:46:15 <r-mibu> GeraldK: agree
09:46:27 <priteau> GeraldK: are you talking about the capacity management user story?
09:47:28 <r-mibu> GeraldK: what we need is to convince developers in OpenStack project. user story is just one of method
09:47:28 <priteau> or another user story?
09:48:39 <GeraldK> priteau: yes. capacity mgmt user story.
09:49:12 <priteau> OK. Sorry, still haven't been able to review it.
09:49:19 <GeraldK> priteau: I agree this is only one way of convicing developers.
09:50:02 <priteau> #action Review capacity management user story (priteau)
09:50:05 <GeraldK> and in addition this is a quite new method and we cannot know how successful it is. still, I'd like to also try that way.
09:51:01 <priteau> #topic Discussion of new features
09:51:14 <priteau> Anything to discuss about new features since last week?
09:53:01 <priteau> We're mostly focusing on bug fixes and code cleanup at the moment
09:54:09 <priteau> Probably a better topic for next year ;-)
09:54:20 <masahito> ;-)
09:54:26 <priteau> #topic Next meetings
09:54:45 <priteau> It's going to be holiday season
09:55:09 <priteau> I won't be able to join the next two meetings (Dec 27 and Jan 3)
09:55:41 <masahito> me too.
09:55:43 <GeraldK> I am not available Jan 3
09:56:12 <priteau> Feel free to join without me of course
09:56:50 <priteau> But if others have a similar holiday schedule, maybe we should have the next meeting on January 10
09:57:02 <masahito> +1
09:58:04 <priteau> Is that OK for others too?
09:58:54 <GeraldK> +1
09:59:10 <priteau> #agreed Next meeting on January 10
10:00:11 <priteau> That's all for today then
10:00:19 <priteau> #endmeeting