09:02:17 <hiro-kobayashi> #startmeeting blazar
09:02:18 <openstack> Meeting started Tue Jan 10 09:02:17 2017 UTC and is due to finish in 60 minutes.  The chair is hiro-kobayashi. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:02:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:02:21 <openstack> The meeting name has been set to 'blazar'
09:02:34 <hiro-kobayashi> #chair priteau masahito
09:02:36 <openstack> Current chairs: hiro-kobayashi masahito priteau
09:02:44 <hiro-kobayashi> #topic Roll call
09:02:56 <priteau> o/
09:03:02 <masahito> o/
09:03:07 <GeraldK> o/
09:03:12 <tejaswi> hi
09:03:31 <tejaswi> o/
09:03:59 <priteau> Is r-mibu here too?
09:04:44 <hiro-kobayashi> Is bauzas, janki?
09:04:46 <priteau> Maybe not
09:04:54 <janki> o/
09:05:04 <janki> hiro-kobayashi, hi
09:05:06 <hiro-kobayashi> Janki: Hi!
09:05:19 <hiro-kobayashi> A happy new year all!
09:05:27 <GeraldK> happy new year
09:05:28 <hiro-kobayashi> Let's get started the meeting
09:05:29 <priteau> Happy new year!
09:05:40 <masahito> Happy New Year!
09:05:50 <hiro-kobayashi> #topic Action items from last call
09:06:14 <hiro-kobayashi> #link http://eavesdrop.openstack.org/meetings/blazar/2016/blazar.2016-12-20-09.00.html
09:06:42 <hiro-kobayashi> 1. Verify where id is provided in PUT and DELETE requests for v2 API
09:06:52 <priteau> I am sorry, I had several action items from last call which I wasn't able to work on
09:07:26 <hiro-kobayashi> priteau: OK. so no updates for item 1?
09:07:34 <priteau> not at this time
09:07:35 <hiro-kobayashi> and 3?
09:08:02 <priteau> same for 3
09:08:09 <hiro-kobayashi> okay, no problem!
09:08:25 <hiro-kobayashi> 2. Review capacity management use case https://etherpad.openstack.org/p/osux-persona-nocengineer
09:09:10 <hiro-kobayashi> Please write your comments after finishing review
09:10:11 <hiro-kobayashi> #topic Ongoing patch reviews
09:10:24 <hiro-kobayashi> #link https://etherpad.openstack.org/p/Blazar_status_2016
09:10:56 <hiro-kobayashi> I want the nova API plugin related patch (https://review.openstack.org/#/c/406009/) to be Workflow+1ed.
09:11:09 <hiro-kobayashi> Because all other patches for blazar-nova are rebased on it and prevented from being merged.
09:11:43 <hiro-kobayashi> It has already CR+2ed and needs Workflow+1.
09:12:05 <priteau> hiro-kobayashi: I will aim to review it very shortly
09:12:33 <priteau> and I will Workflow+1 if I review +2
09:12:36 <hiro-kobayashi> priteau: Great! Thank you very much!
09:13:17 <hiro-kobayashi> Note that instance reservation should be drastically redesigned in the future.
09:13:53 <priteau> Does instance reservation work after applying your patch?
09:14:28 <hiro-kobayashi> it works if files under blazarnova/api/extensions are copied to nova/api/openstack/compute.
09:15:07 <priteau> I see, this is the note in the commit message
09:15:16 <hiro-kobayashi> yes
09:16:27 <hiro-kobayashi> But I'm not sure it works correctly, and it's better not using instance reservation
09:16:34 <masahito> we want progresses to next release, so go to merge as much as possible if it's ready :-)
09:17:11 <hiro-kobayashi> masahito: +1
09:17:58 <hiro-kobayashi> So, I propose merging the patch 406009 and other prevented patches.
09:18:03 <GeraldK> we have a pile of patches under review. we should aim at merging them in time in order not to grow our pile of work.
09:18:17 <hiro-kobayashi> And drastically redesign instance reservation after that, for a long term.
09:18:36 <GeraldK> hiro-kobayashi: +1
09:18:41 <masahito> +1
09:19:05 <priteau> hiro-kobayashi: Give me a ping if I haven't commented on the patch by tomorrow morning
09:19:22 <hiro-kobayashi> priteau: okay
09:20:16 <hiro-kobayashi> #agreed Merge the patch  406009 not to grow pile of patches and drastically redesign 'instance reservation' after that
09:20:50 <hiro-kobayashi> Any other comments about current topic?
09:21:35 <GeraldK> is the evaluation v1 vs v2 closed? there is still an action item on Pierre in the list line 45
09:22:26 <masahito> IIRC, it's in progress now.
09:23:08 <hiro-kobayashi> Let's discuss about it after priteau's work being finished
09:23:31 <hiro-kobayashi> Can we go next topic?
09:23:37 <masahito> GeraldK: Current status is here. the document in v1 and v2 is different, but anyone isn't sure the doc is correct :-/
09:24:03 <GeraldK> masahito: okay
09:24:04 <priteau> GeraldK: In Etherpad, "Pierre will review this before next meeting" refers to an old meeting
09:24:29 <GeraldK> priteau: yes, I guessed so. let's remove this then
09:24:42 <hiro-kobayashi> GeraldK: +1
09:24:59 <GeraldK> should we also do "migrate namespace climate to blazar" as part of Ocata?
09:24:59 <priteau> We discussed differences between v1 and v2 last month, there is still the way IDs are passed to check, which is my pending action item
09:25:54 <GeraldK> some had commented "it's low priority but we should do it in early stage"
09:25:59 <priteau> GeraldK: If possible, but it shouldn't distract from real fixes
09:26:20 <GeraldK> priteau: sure.
09:26:26 <priteau> I will probably make a lot of patches fail to merge
09:26:27 <masahito> GeraldK: I want to try it. but I guess it needs lot of reviews
09:27:06 <masahito> because a lot change could be needed.
09:27:34 <GeraldK> okay. we need to find a good timing to make that move. and reviewers to be able to merge those patches within a couple of days
09:28:00 <masahito> +1
09:28:13 <hiro-kobayashi> +1
09:28:52 <priteau> +1
09:29:27 <priteau> Good timing may be after all Tempest is running correctly, this way it can catch issues due to the rename
09:31:05 <hiro-kobayashi> There are 2 patches related to Tempest are in review
09:31:49 <hiro-kobayashi> L40 and L41
09:31:59 <GeraldK> okay. let's clean up the current reviews related to 406009 and tempest, then decide on a 1 week to update the namespace
09:32:16 <masahito> yup.
09:32:47 <hiro-kobayashi> ok
09:34:16 <hiro-kobayashi> #agreed Clean up the current reviews related to 406009 and tempest
09:34:33 <hiro-kobayashi> half past, and can we go to next topic?
09:35:15 <hiro-kobayashi> #topic Feedback on Project Teams Gathering (PTG)
09:35:45 <hiro-kobayashi> Any updates about the topic?
09:36:06 <hiro-kobayashi> I and masahito will join the PTG from NTT
09:36:38 <priteau> I most likely won't be able to make it. You can meet without me though :-)
09:36:51 <masahito> I fixed my trip schedule. I'll get to Atlanta on Mon. then leave Sat.
09:37:09 <GeraldK> We have not decided yet. unfortunately, it's parallel to an ETSI NFV meeting.
09:37:18 <hiro-kobayashi> priteau: OK
09:37:43 <janki> I might not come
09:38:36 <hiro-kobayashi> So minimum members may be me, masahito, and r-mibu.
14:28:41 <EmilienM> I'll proceed to branching when we feel confortable with their status so we avoid high # of backports
14:28:51 <EmilienM> I think we have a bot
14:29:00 <EmilienM> #endmeeting