09:00:38 <masahito_> #startmeeting blazar
09:00:39 <hiro-kobayashi> hi
09:00:39 <openstack> Meeting started Tue Jan 24 09:00:38 2017 UTC and is due to finish in 60 minutes.  The chair is masahito_. Information about MeetBot at http://wiki.debian.org/MeetBot.
09:00:40 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
09:00:42 <openstack> The meeting name has been set to 'blazar'
09:01:19 <masahito_> Today's agenda is
09:01:30 <GeraldK> hi
09:01:32 <masahito_> 1. Action items from last call
09:01:35 <bertys__> hi
09:01:41 <masahito_> 2. CFP of the Boston summit
09:01:47 <masahito_> 3. oslo conversion
09:01:54 <masahito_> 4. devstack
09:02:01 <masahito_> 5. Ocata relase
09:02:07 <masahito_> anything else?
09:02:15 <masahito_> hi bertys__
09:02:33 <priteau> PTG?
09:02:48 <priteau> and Pike PTL?
09:02:54 <masahito_> priteau: yes. 6. PTG
09:03:10 <masahito_> 7. Pike PTL
09:03:23 <masahito_> we have lots of agenda :-o
09:03:43 <priteau> we'll have to be quick
09:03:49 <GeraldK> we need two meetings a week :)
09:03:49 <masahito_> priteau: sure
09:04:02 <masahito_> haha
09:04:15 <masahito_> ok, let's move on 1st item
09:04:15 <r-mibu> hi
09:04:21 <masahito_> hi r-mibu
09:04:29 <hiro-kobayashi> action items are listed here: http://eavesdrop.openstack.org/meetings/blazar/2017/blazar.2017-01-17-09.01.html
09:04:39 <masahito_> #topic action items from last meeting
09:04:57 <hiro-kobayashi> link: http://eavesdrop.openstack.org/meetings/blazar/2017/blazar.2017-01-17-09.01.html
09:05:07 <hiro-kobayashi> #link: http://eavesdrop.openstack.org/meetings/blazar/2017/blazar.2017-01-17-09.01.html
09:05:09 <masahito_> we have some action items.
09:05:21 <masahito_> 1. all to review Capacity mgmt story gap analysis: https://etherpad.opnfv.org/p/promise_gap_analysis
09:05:30 <masahito_> 2. priteau to investigate differences between v1 and v2 API
09:05:43 <masahito_> 3. Decide when to update the namespace after current in-review patches are merged
09:05:55 <masahito_> 4. write down the details of the proposed talks, 1. and 2., then check the contents
09:06:17 <masahito_> Does anyone have updates for the items?
09:06:18 <GeraldK> 1. gap analysis of the user story: I don't see any comments - is it okay or you had no time for review?
09:07:11 <priteau> GeraldK: Looked OK to me. Big issues are how to implement reservations other than physical hosts
09:07:37 <GeraldK> we will convert this page to RST format soon and then officially submit to PWG
09:07:38 <masahito_> GeraldK: LGTM. When I write down Blazar new features from it, I have no big comments for it.
09:08:03 <GeraldK> priteau, masahito_: okay. thanks. we will then move forward with it
09:08:46 <priteau> GeraldK: One comment: the acronym RUR needs to be defined explicitly somewhere
09:09:02 <priteau> I inferred that it was resource usage request
09:09:43 <GeraldK> priteau: okay, we can also spell it out once in the gap analysis
09:09:43 <priteau> nevermind I see it in the user story
09:10:32 <masahito_> #agreed Capacity mgmt gap analysis is ready to convert rst for PWG
09:11:00 <bertys__> hiro-kobayashi: thanks again for your work
09:11:20 <masahito_> we have good progress.
09:11:45 <hiro-kobayashi_> Sorry, my connection failed.
09:11:48 <GeraldK> on 4) Proposal 1 seems to be ready. Proposal 2 is still open: no feedback yet from HPE whether they will lead it. have send a reminder to them.
09:12:59 <masahito_> GeraldK: I'll take it over if there is no action by this Thuseday.
09:13:04 <GeraldK> Anyway, I will start drafting a proposal...
09:13:59 <GeraldK> masahito_: thanks, let's put something together and if there is no reply by HPE we make you the lead
09:14:23 <masahito_> GeraldK: yup
09:15:50 <masahito_> #action start drafting the #2 summit proposal if HPE folks has no reaction
09:15:58 <masahito_> another update?
09:16:02 <GeraldK> on proposal #1, please all vote for the right category
09:16:28 <GeraldK> so actions 2 and 3 are still open?
09:16:50 <masahito_> GeraldK: I'll touch action #2 in devstack section.
09:17:09 <GeraldK> masahito_: okay
09:17:32 <GeraldK> then let's move on...
09:17:34 <masahito_> oops, s/action #2/action #3/
09:17:38 <hiro-kobayashi_> #3 should be done after devstack and oslo related patches are merged
09:17:47 <masahito_> To reminder
09:18:03 <masahito_> #action priteau to investigate differences between v1 and v2 API
09:18:11 <priteau> #2 still in progress. When I tried looking into this I had issues with my devstack setup not working anymore.
09:18:30 <priteau> Something might have changed in how Keystone is configured recently
09:18:36 <masahito_> #action Decide when to update the namespace after current in-review patches are merged
09:19:14 <masahito_> priteau: thanks the update
09:19:31 <masahito_> priteau: we're getting closer to devstack working
09:19:46 <masahito_> then, let's move on CFP of the Boston summit
09:19:48 <priteau> devstack install is working on the gate now
09:19:50 <masahito_> #topic CFP of the Boston summit
09:20:40 <hiro-kobayashi_> I will submit proposal 1 by Friday
09:20:55 <hiro-kobayashi_> So please comment on it before Friday
09:22:05 <masahito_> hiro-kobayashi_: great!
09:22:50 <masahito_> we're sure to submit one talk at least now.
09:23:26 <masahito_> proposal #2 will also update by next meeting, as we talked.
09:23:40 <masahito_> any comments or update for CFP?
09:24:19 <r-mibu> hiro-kobayashi_, thanks, i need to check asap
09:24:33 <hiro-kobayashi_> r-mibu: thanks!
09:24:58 <priteau> I will review too
09:25:04 <masahito_> ok, then oslo conversion.
09:25:10 <hiro-kobayashi_> priteau: thanks!
09:25:13 <masahito_> #topic oslo conversion
09:25:32 <masahito_> I see lots of works by hiro-kobayashi_ for oslo conversion.
09:25:55 <priteau> That's great
09:25:58 <masahito_> It's great works. Thank you for the patch.
09:26:10 <priteau> I pushed a patch to use oslo.db, although it doesn't migrate tests yet
09:26:38 <masahito_> priteau: is it ready to review?
09:26:51 <priteau> It is WIP
09:26:55 <hiro-kobayashi_> priteau: Great! migration of oslo.db is heavy
09:26:57 <priteau> and conflicts with hiro's patches
09:27:08 <priteau> but if you want to take a first look
09:27:10 <priteau> feel free
09:27:41 <masahito_> priteau: got it. Thanks the patch.
09:28:19 <hiro-kobayashi_> priteau: thanks
09:28:21 <masahito_> priteau: oslo.db is one of big change we need to do. Thanks again.
09:28:41 <masahito_> any updates about oslo?
09:28:46 <priteau> masahito_: Could you update https://review.openstack.org/#/c/410627/ to include config file changes?
09:29:17 <masahito_> priteau: yes, I'm working on it now.
09:29:28 <hiro-kobayashi_> priteau: I pushed the patch that treat the problem
09:29:30 <priteau> I also have grammar comments on the commit message but I can fix it just before +2 W+1
09:29:49 <hiro-kobayashi_> masahito, priteau: please check https://review.openstack.org/#/c/422969/
09:30:56 <masahito_> Just one question for it. where did you see rabbit_host was changed? If possible, please answer it in the gerrit.
09:31:01 <masahito_> hiro-kobayashi_: got it.
09:31:22 <masahito_> ok, move on to next.
09:31:24 <priteau> hiro-kobayashi_: thanks. I think it needs more work, I will comment on Gerrit
09:31:36 <hiro-kobayashi_> priteau: thanks
09:31:44 <masahito_> #topic devstack
09:32:51 <masahito_> We have had great works for devstack installation. Then tempest is almost working in gate job.
09:32:56 <masahito_> https://review.openstack.org/#/c/409062/
09:33:36 <masahito_> The rest of work is fixing tempest's bug.
09:34:09 <masahito_> I'm working on it and could push it in two days.
09:34:21 <hiro-kobayashi_> masahito_: great!
09:34:25 <bertys__> would be good also to have tempest test for compute host reservation
09:34:28 <priteau> The tempest patch may need https://review.openstack.org/#/c/408079 to have the endpoint created
09:34:43 <priteau> Maybe that's why it's getting a 404
09:35:08 <masahito_> priteau: yup. I rebased tempest job on the patch.
09:35:35 <priteau> so it's something else then :(
09:35:58 <priteau> http://logs.openstack.org/62/409062/4/check/gate-blazar-devstack-dsvm/b8630aa/console.html#_2017-01-24_08_26_50_632820
09:36:00 <masahito_> priteau: np
09:36:32 <masahito_> Anyway, we're getting closer for devstack gate to work.
09:36:47 <priteau> It may be related to the devstack issues I have started to see recently
09:36:57 <priteau> I am trying to figure out what is the problem
09:37:46 <masahito_> priteau: thanks. let's share what is problem for each other. It's fast.
09:38:24 <priteau> devstack installs fine, but climate command shows errors that I didn't see before
09:38:32 <priteau> Maybe your Keystone v3 patch will fix them
09:39:06 <masahito_> priteau: ok, thanks. I'll add dependency.
09:39:13 <masahito_> Then, we can start to update the namespace after current in-review patches are merged.
09:39:46 <priteau> +1, hopefully next week
09:40:02 <hiro-kobayashi_> +1
09:41:11 <masahito_> #agreed start to update the namespace after tempest job works
09:41:21 <masahito_> hopefully, from next week.
09:42:27 <masahito_> I think we need lot of volunteer for the works. so let's review patches as well as push patch.
09:43:06 <masahito_> May I go next agenda?
09:43:25 <priteau> yes
09:43:33 <r-mibu> ok, then let me know if you have problem in tempest jobs
09:43:35 <r-mibu> yes
09:43:47 <masahito_> r-mibu: ok
09:43:53 <masahito_> #topic Ocata relase
09:44:27 <masahito_> ocata-3 release is passed.
09:45:42 <hiro-kobayashi_> masahito_'s connection fails now, so please wait a moment
09:46:20 <masahito> sorry, disconnected
09:47:17 <priteau> masahito_: I think because we are not an official project, we don't have to follow strictly the release cycle with milestones
09:47:30 <masahito> What I wanted to talk is ocata-3 is feature freeze, I think we can merge some patches to move blazar forward.
09:47:36 <masahito> priteau: yes
09:47:56 <priteau> If we need, we would have to postpone namespace migration
09:48:20 <masahito> priteau: nice idea.
09:48:38 <priteau> We are not really in a state of adding any new feature yet
09:49:07 <masahito> right.
09:49:19 <priteau> So I would like to continue merging patches that fix devstack / tempest / bugs
09:49:31 <masahito> +1
09:49:57 <r-mibu> +1 to keep merging
09:50:11 <bertys__> +1
09:50:13 <hiro-kobayashi_> +1
09:50:17 <priteau> It would be great if we can create a stable/ocata branch on release day, but we can even create it a bit later if we're not quite ready yet
09:51:12 <priteau> actually we're probably more of a cycle-trailing model
09:51:34 <priteau> #lin khttps://releases.openstack.org/reference/release_models.html
09:51:37 <priteau> #link https://releases.openstack.org/reference/release_models.html
09:51:38 <masahito> #agreed continue to merging patches
09:51:55 <priteau> In practice we're "independent": completely bypass the 6-month cycle and release independently
09:52:19 <priteau> but for Ocata we can try to be cycle-trailing
09:52:39 <priteau> unofficially
09:53:32 <priteau> probably a discussion for Pike
09:53:43 <masahito> yes
09:54:10 <masahito> any other comments?
09:55:09 <masahito> last 5 mins
09:55:22 <masahito> #topic PTG
09:55:37 <masahito> do you have any update for PTG?
09:55:55 <masahito> IIRC, hiro-kobayashi_, r-mibu, and me will join PTG.
09:56:24 <priteau> I can't go for sure, other commitments at the same date
09:57:32 <masahito> priteau: got it. I'd like to meet you in Forum or other event :-)
09:58:18 <masahito> we should move on open disscusion
09:58:31 <masahito> #topic open disscusion
09:58:43 <masahito> any update or comments for anything?
09:58:54 <masahito> last 2 mins.
09:58:59 <priteau> Pike PTL?
09:59:15 <masahito> oh, yeah.
09:59:44 <masahito> This week is  PTL self-nomination week for Pike cycle.
10:00:04 <GeraldK> let's further exchange via email among active Blazar members?
10:00:21 <GeraldK> just a proposal
10:00:58 <priteau> Sounds good
10:01:28 <masahito> GeraldK: yes. I think if we're interested in it it's good to send nomination mail in openstack-dev.
10:01:58 <GeraldK> +1 to nominate a Pike PTL
10:02:03 <priteau> Can we use the election system if we're not a big tent project?
10:02:14 <masahito> priteau: I'm not sure.
10:02:46 <masahito> btw, we're running out time. if needed, please continue to discuss in #openstack-blazar
10:02:55 <priteau> thanks everyone
10:03:04 <hiro-kobayashi_> thanks!
10:03:06 <masahito> thanks, bye!
10:03:11 <masahito> #endmeeting